Boot up hangs at Mint logo (CLOSED)

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Locked
starflower
Level 3
Level 3
Posts: 125
Joined: Wed Apr 30, 2014 10:59 am

Boot up hangs at Mint logo (CLOSED)

Post by starflower »

the live USB. It seemed to install OK and I got the message at the end saying "installation complete"

When i boot up it seems to get as far a the green Mint logo and then just hangs there with the logo in the center of the screen. Then I have no chice but to kill the power.
Any idea why and how to fix it? I can give you more info if you tell me what you need.

It seems to run from the live USB OK but may take several attempts to boot up (again stalls at the Mint logo). Before installing I went into BIOS setup and disabled UEFI and selected Legacy instead becasue thats what I've done before. I have also used this USB to install Mint on two other PC's so I dont think its the USB at fault.

Any help appreciated. Thanks
Kate
Last edited by starflower on Wed Dec 03, 2014 6:54 pm, edited 5 times in total.

hrturner
Level 1
Level 1
Posts: 33
Joined: Tue Aug 12, 2014 1:07 pm
Location: Indiana

Re: Boot up hangs at Mint logo

Post by hrturner »

Can you switch terminals by hitting "Ctrl" + "alt" + any of the "F" keys (F1, F2, F3, etc)? This could allow you to log in to a text terminal at which point we could potentially do some more troubleshooting.

The other option is when you see the grub screen, press "e". This will allow you to modify kernel parameters at boot. You should see a line that says something along the lines of:
linux /boot/vmlinuz-3.13.0-37-generic root=UUID=2a214213-ac4d-46cf-8405-a9888d9c14d0 ro quiet splash
Go to the end of that line and delete "splash" and put "text". So you should have this instead:
linux /boot/vmlinuz-3.13.0-37-generic root=UUID=2a214213-ac4d-46cf-8405-a9888d9c14d0 ro quiet text
Only change the stuff in red on your machine. The other stuff is machine specific! Then press F10 to boot. This should boot you into a text only mode and then you can log in and we can look at logs to see what may be going on as well.

mzs112000
Level 1
Level 1
Posts: 35
Joined: Mon Jan 27, 2014 3:37 am
Location: Earth(until the SpaceX Mars colony is ready)

Re: Boot up hangs at Mint logo

Post by mzs112000 »

Try switching back to UEFI, then reinstall LM.
IF I have helped you/solved a problem, please add [SOLVED] to your post title, it helps other users looking for help, and keeps the forum clean.
http://www.worldcommunitygrid.org/reg/v ... rId=943129
https://www.lds.org

starflower
Level 3
Level 3
Posts: 125
Joined: Wed Apr 30, 2014 10:59 am

Re: Boot up hangs at Mint logo

Post by starflower »

Thank you both for replies
hrturner wrote:Can you switch terminals by hitting "Ctrl" + "alt" + any of the "F" keys (F1, F2, F3, etc)? This could allow you to log in to a text terminal at which point we could potentially do some more troubleshooting.
No.... it's completely frozen at the logo. Nothing works

(I can only switch to a terminal when booted from the Live USB) (Also it seems a bit reluctant/slow to boot from the Live USB and tend to hang at the logo here as well. However, if I try several times I can get it to boot)
hrturner wrote:
Go to the end of that line and delete "splash" and put "text". So you should have this instead:

linux /boot/vmlinuz-3.13.0-37-generic root=UUID=2a214213-ac4d-46cf-8405-a9888d9c14d0 ro quiet text
{/quote]


Ok have done that. After hitting F10 text scrolls and the last two lines read:

Code: Select all

* Starting signal sysvinit that local files are mounted            [ok]
* stopping load modules from /etc/modules                               [ok]
What next?


(I will try reinstalling with UEFI enabled if we hit a dead end above but prefer to try thihs way first)

Kate

starflower
Level 3
Level 3
Posts: 125
Joined: Wed Apr 30, 2014 10:59 am

Re: Boot up hangs at Mint logo

Post by starflower »

Any ideas on how ro proceed?
should I try UEFI? qnd what are the ramifications of this?

Many Thannks...

starflower
Level 3
Level 3
Posts: 125
Joined: Wed Apr 30, 2014 10:59 am

Re: Boot up hangs at Mint logo

Post by starflower »

OK I tried switching the boot to UEFI. However, it would not recognise the Live USB, "no bootable drive"

Back to Legacy again and a fresh install. What is interesting is even running the Live USB it takes several attempts for it to boot. Again it hangs at the Mint logo. After several tries I managed to get it to boot and then reinstalled again. However, once the install is complete it still hangs at the mint logo every time.
I don't understand what is going on but from the output I described above it seems to not want to load modules.

So please anyone where do I go from here? There must be a way around this isn't there??

Thanks

starflower
Level 3
Level 3
Posts: 125
Joined: Wed Apr 30, 2014 10:59 am

Re: Boot up hangs at Mint logo

Post by starflower »

hrturner wrote: Only change the stuff in red on your machine. The other stuff is machine specific! Then press F10 to boot. This should boot you into a text only mode and then you can log in and we can look at logs to see what may be going on as well.
The last line of the text log actually lists quite a number of starting and then stopping processes before the boot fails. I'm happy to give more specific info or outputs if someone will tell me what you need.

This is most frustrating and I simply dont have the expertise to figure out whats going on that causes the boot to stop at the Mint logo.

Oh and I don't supppose that the fact that i'm using a solid state drive in this machine has any bearing on the problem does it?

Kate

starflower
Level 3
Level 3
Posts: 125
Joined: Wed Apr 30, 2014 10:59 am

Re: Boot up hangs at Mint logo

Post by starflower »

Update:

I'm not a tech head and am fumbling around rather blind here. However, I've been trying a few things to resolve the above probelm and get Mint to boot and function on this new laptop. This is what I have found so far:

1 . At the GRUB menu if I select Compatabilty Mode (Recovery mode?), let that lode and then choose the option to "resume normal boot" it will in fact boot up to the desktop albeit minus a few drivers.

2. I remembered something i read a while back.
I hit "E" at the GRUB menu to get the kernel parameters page. I then added the words "NO_ACPI" after the words "QUIET SPLASH"
Then F10 to resume boot. It then booted up OK!! (WiFi and screen brightness control don't seem to work but we'll sort that later)


What does this mean??? I am not techy enough to interpret what this means exactly but it must tell us something doesn't it?
Please help..............anyone, i'm desperate here!

Kate

hrturner
Level 1
Level 1
Posts: 33
Joined: Tue Aug 12, 2014 1:07 pm
Location: Indiana

Re: Boot up hangs at Mint logo

Post by hrturner »

ACPI is used for power handling. I'm by no means an engineer so I dont know what low level functionality it actually deals with but could lead to explain why your screen diming functionality is gone.

Have you tried this parameter?

Code: Select all

acpi_osi=Linux
Put this in place of where you put

Code: Select all

NO_ACPI
.

Also have you checked to see if there is a bios update for your computer? Some online research seems to point towards a faulty bios.

starflower
Level 3
Level 3
Posts: 125
Joined: Wed Apr 30, 2014 10:59 am

Re: Boot up hangs at Mint logo

Post by starflower »

hrturner wrote:ACPI is used for power handling. I'm by no means an engineer so I dont know what low level functionality it actually deals with but could lead to explain why your screen diming functionality is gone.

Have you tried this parameter?

Code: Select all

acpi_osi=Linux
Put this in place of where you put

Code: Select all

NO_ACPI
.

Also have you checked to see if there is a bios update for your computer? Some online research seems to point towards a faulty bios.
Well that had exactly the same effect as the no_acpi code. It allowed me to boot for that one time only and no brightness functioanlity. TBH I'm less concerned about the brightness issue right now as that can be addressed later. For now though I just wnat to get it to boot and not stall at the logo!

Whats interesting is that editing the kernal parameters at boot up will allow me to boot for the first time only. Subsequent attempts it doesnt work, then my only option is to go via recovery mode and then back to normal boot.

This is very frustrating!

User avatar
gold_finger
Level 9
Level 9
Posts: 2886
Joined: Mon Mar 11, 2013 11:39 pm

Re: Boot up hangs at Mint logo

Post by gold_finger »

starflower wrote:It allowed me to boot for that one time only and no brightness functioanlity.
If adding "noacpi" or "acpi=off" works, you can make the change permanent by editing and saving that change to the file /etc/default/grub. Once you get booted into the installed system open that file with your text editor as root and make the edit. The default text editor differs depending on which desktop environment you're using. Cinnamon and Xfce use the gedit text editor. Mate uses pluma. Directions below depict using gedit. Substitute pluma where you see gedit if you're running the Mate desktop.

* Boot into installed system.

* Open a terminal and enter this command to open the file as root in your text editor:

Code: Select all

gksu gedit /etc/default/grub
* Change this line

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
* To read as

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash noacpi"
* Save the file and close the text editor

* Update grub with following command back in the terminal

Code: Select all

sudo update-grub
* Reboot computer to see if it worked.
Please add [SOLVED] to your thread if a solution is found. Go to your first post in the thread, hit "Edit" button and add [SOLVED] to the title of the post.

How To Format Your Forum Posts.

Try Linux Beginner Search Engine for Linux questions.

starflower
Level 3
Level 3
Posts: 125
Joined: Wed Apr 30, 2014 10:59 am

Re: Boot up hangs at Mint logo

Post by starflower »

[quote="gold_finger"]
If adding "noacpi" or "acpi=off" works, you can make the change permanent by editing and saving that change to the file /etc/default/grub. Once you get booted into the installed system open that

.

Banzai Beagle
Level 3
Level 3
Posts: 108
Joined: Wed Jul 02, 2014 10:48 am

Re: Boot up hangs at Mint logo (CLOSED)

Post by Banzai Beagle »

So what solved the problem?

User avatar
Moem
Level 20
Level 20
Posts: 10116
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: Boot up hangs at Mint logo (CLOSED)

Post by Moem »

Banzai Beagle wrote:
Sun Sep 30, 2018 3:54 pm
So what solved the problem?
Since the OP hasn't been back... how would anyone here know?
If you have a similar question, or in fact any question at all, please start a new thread. This one is years old and should be allowed its eternal rest.
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

Locked

Return to “Installation & Boot”