Page 1 of 1

IBM 600E wont live boot and won't install

Posted: Mon Mar 26, 2007 1:27 am
by shotttgun
Nice works everybody!!!!! wish I could do that.
I'd like to see this bianca work on my 600e. It has like 198mb of mem and a 2 gig hdd which may be the problem. everything is smooth with xp installed.
I boot live with dsl just fine. Lastly the bianca boot cd boots fine on a 1.5ghz gateway.
All I'm trying to get bianca to do is live boot for now.
I get a bianca splash screen so I cntr alt f1 and am able to watch the game action.
Gets into a calling ini 0x1a (f000:fe6e) EAX is 0xB102
continues displaying this for 10 to 12 lines then says:
151.899404 buffer I/O error on device hdc, logical block 97818
151.507734 squashfs error: sb_bread failed reading block 0x2fba1
151.507839 squashfs error: unable to read page. block bee08f2, size 7e4f
then stops

I did try almost all of the boot commands in the bianca help files without much difference. I booted with a 1 gig flash drive in the usb port. Boot reported sda assuming drive cache: write through then stated buffer error on device hdc, logical block 97966 and began a
VFS: brelse: tryging to free free buffer. Did this for 10 to 12 lines and back to the squashfs error and stops.
My thoughts are that the hdc is ramdrive and the size is too big or
the harddrive is giving a problem for some reason.
I bet you guys already know the problem here.
Please assist.

Posted: Mon Mar 26, 2007 7:53 am
by Husse
my 600e. It has like 198mb of mem and a 2 gig hdd which may be the problem. everything is smooth with xp installed.
Sorry, but I don't believe that - XP needs about 300 MB for itself before anything is running. I'd say it's more of a miracle to get XP working at all.
No offence intended :)
Mint is not that hungry for memory, but when you run the live CD everything happens in memory - the harddrives are not mounted at all.
So, sorry, but you are out of memory .
squashfs is the file system used
unable to read page. block b.... could indicate faulty memory, but most likely just lack of it.

memory count

Posted: Mon Mar 26, 2007 9:26 am
by shotttgun
My error, memory is 196032Kb
and thanks for the reply.
How much memory do I need to browse the internet on wireless from CD?
Browse and my kids like to aim plus they edit and upload photos. so that is all I need it to do.
We got hacked too many times from using aim so I'm intent on a live cd at this point. I've been trying to get dsl sound and wireless when I found bianca. wireless set up first boot on the gateway.

Posted: Mon Mar 26, 2007 6:04 pm
by Husse
I don't know for sure but you need around 200MB as a minimum. I managed to run the live CD and later install on a computer with 256 MB but the top 20 MB are faulty.
This means that about 230 MB is sufficient (at least for an old motherboard made for a slot PIII - don't know if it changes depending on other hardware but not to much)
And it's probably hard to protect oneself when the kids use aim, at least if you mean AOL's hopeless messenger service.

Posted: Mon Mar 26, 2007 11:01 pm
by sanguinemoon
When I first read that I was thinking he didn't have enough ram, but those disk errors through me off. Ubuntu, I think, wants at least 256 MB so Mint probably be the same.

But I have run XP slowly in 128 MB. Boy did that ever suck, though :lol: (that was the first edition, before an service packs, so with latter versions it might have much higher requirements?)

Posted: Thu Apr 12, 2007 2:05 am
by jogego
I no longer have my THinkpad 600E but I think the problem might be something apart from memory.

I was never able to run any linux distro on mine without passing a particular code to the kernel when booting and I tried several distros back then, mepis, ubuntu,kanotix,knoppix etc.

When booting, you might try adding

linux acpi=off pnpbios=off

that always worked for me on the 600E and also when booting the thinkpad x21 using the Dock 2

i tried those commands....the error seems to be pointing at

Posted: Thu Apr 19, 2007 8:48 pm
by shotttgun
I tried those commands as well as (pci=noapci) (noapci) (noalpic) (no387)

So I took a different course. I picked up a gateway solo which is 800mhz with over 300mb of ram.
I seem to be having a similaral problem. but getting more clearer errors.
It gets hung at driveseek error on hdb and the cdrom just keeps spinning up and down.
I see errors like
95.089250 hdb: media error (bad sector) status+0x51 (drive ready seek
155.055777 ide-cd: cmd 0x20 timed out
155.'''''''''' dma timeout retry
255.""""""" drive not ready for command.
36.""""""" drive ready seek complete error
199.139562 buffer i/o error on device hdb logical block 97750
150.911139 pci: cannot allocate recource region of devic

Are there any the commands to alter the CDROM command so mint will work with the older cdroms?

Posted: Fri Apr 20, 2007 5:55 am
by Husse
That box can't be too old I think. How old is it?
Older CD players have a problem with home burned disks but they have to be rather old (always exceptions)
If it is around 20X or more it should be "young" enough to cope.
But commands to help the player - no

Posted: Fri Apr 20, 2007 3:13 pm
by shotttgun
I think this laptop is around a 98 to 2000 being a 800mhz.
I'll pull the cd player and do a little research for speed.

Posted: Sun Apr 22, 2007 6:16 am
by Husse
A laptop from that period may have a CD player that can't
cope with home burned CD disks and definitely wont boot from an USB stick

Not a written CD problem

Posted: Fri Apr 27, 2007 10:56 pm
by shotttgun
After some further research and thought. I can run damn small linux burned from ISO's to the same memorex CD's on both the ibm 600e and the compaq 800mhz. I'm thinking it is related to a bus call. And remember I did try the command line bypasses I listed above.
The compaq laptop is a 2001 800mhz Pent III and the CD is a 24 speed cdrom, usb is not high speed.
The IBM is a 366mhz pent II

Posted: Sat Apr 28, 2007 5:47 am
by Husse
damn small linux
is just that :)
How far into boot do you get with Mint?
Have you looked at the troubleshooter int the wiki?
(Un)fortunately I don't get any experience with boot problems generated by the motherboard but there are a few things to use like noapi......

Posted: Sat Apr 28, 2007 6:09 am
by telic
I can run damn small linux
Try Puppy Linux. It's not so damn small, yet runs in 64MB of RAM, and has a setup wizard for virtually everything. Codecs are included to play music etc. Your configuration data can be saved back onto the live CD if you run it on a CD-RW drive (multi-session mode), or to a file on any drive. And your kids could say they have a PC puppy!

Another distro that I'd try on your PCs is Knoppix, which is also geared toward running from CD, and can store your config data in a file on HD or floppy drive.


Posted: Sat May 05, 2007 1:28 am
by shotttgun
Have you had any success with getting the puppy linux working with the wireless cards?
I'm hooked on getting these laptops working on linux wireless.
I have a linksys card wpc54g ver2 works good with windows. I have not got it to work on a linux box yet.

Posted: Sat May 05, 2007 2:49 am
by telic
Have you had any success with getting the puppy linux working with the wireless cards?
I don't have wireless technology to play with.

There looks to be plenty of wireless info at the Puppy Linux Forum.