Page 1 of 1

Upgrade to 17.1 Fail

Posted: Fri Dec 05, 2014 3:23 pm
by jloflin
I attempted the Update Manager upgrade route from 17 to 17.1. When I rebooted the system, Mint stated that it was unable to find my home directory. I have my home directory on a separate disk. It offered to boot as root, but was unable to find a particular file, and aborted that. I ended up restoring my Mint 17 for now.

Is there a problem with using this upgrade if your home directory is on a different disk? Is there a fix or a workaround for this?

Thanks.

Re: Upgrade to 17.1 Fail

Posted: Fri Dec 05, 2014 7:00 pm
by xenopeek
I checked with the developers; one of the developers tried the 17 to 17.1 upgrade on his system with a separate /home. That was a separate partition on the same disk, not a separate disk. That went fine.

Do you perhaps have full disk encryption or home folder encryption? We can't figure how this problem would occur, as the upgrade doesn't touch /etc/fstab file (where your home folder is configured).

Else you may try upgrading by hand, so you can check at each stage if there is some error or it does something unexpected. I recommend you do that from the terminal, and before you start it configure your terminal profile preferences to have unlimited scrollback. Copy the full output of your terminal session after doing these four steps and save it in a file somewhere you can access it if something goes wrong again, so you have something that we can use to pin the problem and help you.
  • Edit /etc/apt/sources.list.d/official-package-repositories.list and replace "qiana" with "rebecca" on the Mint repositories;
  • Run apt update to refresh;
  • Run apt install mint-meta-cinnamon to enable the upgrade to install new features of Mint 17.1 (apt install mint-meta-mate for MATE); (apt install mint-meta-xfce for xfce);
  • Run apt dist-upgrade to do the actual upgrade. This will remove the package libcjs0c, which is expected and okay.

Re: Upgrade to 17.1 Fail

Posted: Sat Dec 06, 2014 12:16 am
by jloflin
I have no encryption on my system.

I will attempt the manual upgrade this weekend and report back here on how it went.

Thanks.

Re: Upgrade to 17.1 Fail

Posted: Sun Dec 28, 2014 8:33 pm
by jaderiver
To jloflin and xenopeek and Mint developers:

I, too, ran into this issue earlier today when updgrading to Rebecca from Qiana. (Since I have dialup at home, each week I get to a WiFi place to do upgrades and other actions requiring speed.) So, a few hours ago, using WiFi, the upgrade attempt to Rebecca also failed in the same way as jloflin described. After upgrading, restarting the computer and signing in again, there was an error message saying my /home/_____ folder did not seem to exist. The option to sign in as /root was offered, so I accepted, (although while reading all the responses to the Rebecca upgrade during the past couple of hours, I noticed Clem strongly advising not to sign in as root).

Anyway, after signing in as /root, and waiting a long while for the computer to do anything, I get another error message: ..."could not update ICEauthority file/.ICEauthority". Also, somewhere during one of the multiple attempts to reload Mint there was a message that one of the ..."clock" files were bad or corrupted and there was an offer to "delete" the file -- so I did.

I tried repairing files and checking disks in "Recovery Mode" but nothing seems to help the issue. When I start up the computer, and sign in using /root (see above), I do get the main splash "Welcome to Mint" screen, but nothing else exists on the desktop except the default Linuxmint "17.1" background.

Now I am home using dialup again, and cannot effectively try what xenopeek suggests for now. So, will reinstall from my Qiana DVD to be able to use Mint again... Very frustrating, but I will try to be patient and continue to be grateful to the Mint team for their wonderful efforts.

Oh - important! Please note: My /home/____ folder is on the same disc but on a separate partition. Also, I do not encrypt my home folder.

Thank you for your time and attention. I am using Windows right now in order to communicate, as I dual boot OS's.

Re: Upgrade to 17.1 Fail

Posted: Sun Jan 04, 2015 7:53 pm
by jaderiver
Hi jloflin...

Just wondering if you have had the opportunity or time to try a manual upgrade ? ... and... ?

I am using Qiana again and would love to use Rebecca, but resisting for now, because going back to Qiana was so time-consuming after the "lost" /home/_____ folder after trying to upgrade to 17.1. When I have time, either I will try xenopeek's suggestions or download a totally new Rebecca and install.

Re: Upgrade to 17.1 Fail

Posted: Wed Jan 07, 2015 5:54 pm
by hhead
This is has slightly concerned me. My home is on a second partition (its more complicated than that since I seem to have somehow set up my swap and home within an extended partition). Any other experiences on upgrade with separate /home and / partitions? The only reason I want to upgrade is this ridiculous wifi won't reconnect after suspend/hibernate bug which I cannot solve. Everything else is fine in 17.