Page 1 of 1

Dual Boot with Windows 8 - Cannot get working [Solved]

Posted: Tue Jan 27, 2015 8:54 pm
by someguy_33
Ok ... where do I start, I am by no means an expert user.. and have looked many places, followed a few instruction sets, here is a summary.

Laptop Acer E15 with Windows 8 (er maybe 8.1?).

What I have done:
1. I have successfully removed security from the bios.
2. I am able to boot to the USB (Using version 17 64 bit of course).
3. I am able to install Linux mint along side of Windows 8 ( I resized windows 8, to not use the complete hard drive, made a EXT with "\" (20gb), a swap partition (5gb) and a Home partition (60gb).
4. When I reboot it only goes to Windows 8.
5. Reading some forums, one person seemed to have luck with using easybcd. I tried that, I can install it and followed what I thought seemed like it made sense. I added a Linux boot option with "grub2". I reboot and nothing. If I point it to the Linux parition (within EASYBCD) it shows 2 Linux ... and will not boot to either from the menu. I hit escape and there is the motherboards' boot options, I can choose there a new listing that looks like the HD name, and linux will boot, but I am unable to boot to windows. and I get errors from both the Linux' that show up. Its weird. I can get better data, and have tried this twice so far, thought maybe i didnt get the instructions correct.

So what I am trying to do is.. have a dual boot Windows 8 and Linux Mint 17 ... I still want windows in case there are some applications I may need from time to time.

Can someone point me to a decent/accurate instruction set?

One alternative way is to boot in legacy and install it that way (have not yet tried that) but wanted the more elegant solution (if possible).

Please advise . . .

Re: Dual Boot with Windows 8 - Cannot get working

Posted: Wed Jan 28, 2015 1:44 am
by kukamuumuka
With some computers you need to (re)change boot order from bios setting after installation. There are choices "windows boot manager" and "ubuntu", so set "ubuntu" as the first bootable system, so that grub menu appears and both of the systems can boot via that menu.

BTW. Did you remember install grub to the efi-partition?

Re: Dual Boot with Windows 8 - Cannot get working

Posted: Wed Jan 28, 2015 9:38 am
by gold_finger
Try what administrollaattori said first.

If that doesn't work, have a look through this tutorial and compare it to what you did during install. Maybe there is something you forgot, or didn't realize you needed to do.

If still stuck, or want us to take a quick look at your current setup before proceeding, boot into your installed Mint, open a terminal and enter the following commands (copy/paste the first one so you don't have to type it out):

Code: Select all

[ -d /sys/firmware/efi ] && echo "EFI boot on HDD" || echo "Legacy boot on HDD"

Code: Select all

sudo blkid -c /dev/null

Code: Select all

cat /etc/fstab

Code: Select all

sudo parted -l
(last character is a lowercase letter "L")

Use mouse to highlight and copy entire output of all commands and paste it back here for us to see. (Use "Code" button on forum interface, then paste between the [ code ] blocks that appear in your reply. That preserves formatting and makes it easier for us to read the output.)

Re: Dual Boot with Windows 8 - Cannot get working

Posted: Fri Jan 30, 2015 8:06 pm
by someguy_33
Thank you all for the quick reply, I got it to work.. but let me share what I did.

1. I followed your instructions (made sure it was EFI, etc..etc.. ) and everything look like it installed fine.
2. Reset, went into windows, there was no boot menu to choose linux.
3. I stumbled on this page: ... -supported
4. the key is boot to windows and point the loader to "bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi" entered from Windows...
5. I reset and it gave me the Grub menu, and I can now choose Windows 8 or Mint (ok it automatically will boot Mint, which is exactly what I wanted).

So the issue (from what I can tell) I was having was the grub was not being pointed to. I have seen other posts that say you can do it in windows (i.e. the Windows boot menu), but I am quite happy with it like this.

to answer the questions below (now that I am on the installed version):

Code: Select all

 me@laptop ~ $ [     -d /sys/firmware/efi ] && echo "EFI boot on HDD" || echo "Legacy boot on HDD"
EFI boot on HDD

Code: Select all

me@laptop ~ $ sudo blkid -c /dev/null
[sudo] password for me: 
/dev/sda1: LABEL="RECOVERY" UUID="EED4EB8FD4EB57FB" TYPE="ntfs" 
/dev/sda2: LABEL="ESP" UUID="10EB-B757" TYPE="vfat" 
/dev/sda4: LABEL="Acer" UUID="30DE8C13DE8BCF90" TYPE="ntfs" 
/dev/sda5: LABEL="Push Button Reset" UUID="1EE0EE16E0EDF3C5" TYPE="ntfs" 
/dev/sda6: UUID="cfc51549-bfe8-43ab-84a0-9044b2b00467" TYPE="ext4" 
/dev/sda7: UUID="980d3686-f075-4055-83f8-6e11124a6c9c" TYPE="ext4" 
/dev/sda8: UUID="045008DE00C34F85" TYPE="ntfs" 
/dev/sda9: UUID="d6b40438-fa74-4068-b47c-ba657a16bd4a" TYPE="swap" 
me@laptop ~ $ 

Code: Select all

me@laptop ~ $ cat /etc/fstab
# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda6 during installation
UUID=cfc51549-bfe8-43ab-84a0-9044b2b00467 /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sda2 during installation
UUID=10EB-B757  /boot/efi       vfat    defaults        0       1
# /home was on /dev/sda7 during installation
UUID=980d3686-f075-4055-83f8-6e11124a6c9c /home           ext4    defaults        0       2
# swap was on /dev/sda9 during installation
UUID=d6b40438-fa74-4068-b47c-ba657a16bd4a none            swap    sw              0       0
me@laptop ~ $ 

Code: Select all

me@laptop ~ $ sudo parted -l
Model: ATA WDC WD5000LPVX-2 (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt

Number  Start   End     Size    File system     Name                          Flags
 1      1049kB  630MB   629MB   ntfs            Basic data partition          hidden, diag
 2      630MB   945MB   315MB   fat32           EFI system partition          boot
 3      945MB   1079MB  134MB                   Microsoft reserved partition  msftres
 4      1079MB  95.5GB  94.4GB  ntfs            Basic data partition          msftdata
 6      95.5GB  116GB   21.0GB  ext4
 7      116GB   169GB   52.4GB  ext4
 8      169GB   478GB   309GB   ntfs                                          msftdata
 9      478GB   485GB   6768MB  linux-swap(v1)
 5      485GB   500GB   15.2GB  ntfs            Basic data partition          hidden, diag

me@laptop ~ $ 
So I am not sure why the bootlaoder didnt load the first way it was installed, mint be something different with my laptop, but again it works so I am happy with it!

If I can provide more information please advise,

Happy I have mint back!!

Re: Dual Boot with Windows 8 - Cannot get working

Posted: Sat Jan 31, 2015 12:23 am
by gold_finger
Glad you got it working. Your output looks good. Keep that Windows command fix handy just in case a Win 8 update reverts the booting on you somewhere along the line.

Go ahead and mark post solved by clicking "Edit" on your first post and adding "Solved" to the title.

Re: Dual Boot with Windows 8 - Cannot get working

Posted: Sat Jan 31, 2015 1:15 am
by Pierre
even better:
- write a short Tutorial on "how you did it".

Re: Dual Boot with Windows 8 - Cannot get working [Solved]

Posted: Mon Feb 02, 2015 11:15 pm
by someguy_33

So in short I looked through several pages... and I will put the links here, versus copying all the data into the forum.

For better suplimental instructions see:

** Assumes you are starting with a Windows 8/8.1 and have no free hard drive space, and Windows is installed in EFI**

These are the instructions I followed your success mary vary, if there is a specific section you are stuck with I can explain better if needed.

1. Prepare hard drive, that is to make space for the Linux install
i. disable pagefile: Control Panel -> System and Security -> System -> Advanced system settings -> Advanced tab -> [Performance] Settings... -> Advanced tab -> [Virtual memory] Change... -> uncheck Automatically manage paging file size for all drives -> select No paging file -> Set -> Yes -> OK...
ii. disable hibernation file (hiberfil.sys): lower left corner rt click -> Command Prompt (Admin) -> powercfg /h off ["powercfg /h on" to turn it back on]
iii. disable system restore: Control Panel -> System and Security -> System -> System protection -> select Local Disk (C:)(System) -> Configure... -> Disable system protection
iv. disable writing debugging information: Control Panel -> System and Security -> System -> Advanced system settings -> Advanced tab -> [Startup and Recovery] Settings -> change Write debugging information from Automatic memory dump to none
v. disk cleanup: Control Panel -> System and Security -> Free up disk space [at bottom] -> check everything -> OK
vi. reboot
vii. defragment: Control Panel -> System and Security -> Defragment and optimize your drives [under Administrative Tools]
viii. reboot
ix. shrink Windows partition to ~100GB with Disk Management
x. reenable pagefile, hibernation file, system restore, and debugging info

2. Prepare a USB or CD with the Mint version you wish, I wont go through that here, there are plenty of instructions and methods for that!
3. Boot from the USB drive. How this varies a little comptuer to computer. Boot computer press F2. Change your boot optoions to allow boot from USB, you can even make it the first option, if you dont you have to press F12, or something like that (depends on your computer) to get the boot menu. Also important is to make sure secure boot is off.
4. Once you boot to USB, you need to make sure you are in EFI mode
5. Install making at least 2 partitions, one for root, and the other for Home
6. Reset, this is where I booted to windows and cannot get into Linux. If you machine boots to windows, and you cant seem to see anything in the boot menu, you can try what I did in the next step.
7. I stumbled on this page: ... -supported
Form the link above: Another issue that could make the system boot directly to Windows (without even showing the GRUB menu) is if either Windows took hold of the boot manager or after installing Ubuntu, the EFI partition was not properly configured for Windows. To solve this, simply go to Windows and open a terminal, then type the following (Need Administrative Privileges):

Command to enter>>>> bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi

8. Reset again, and the Grub menu appeared! Of course I check that both Windows and Mint worked fine.

I hope this helps... not sure what step you are stuck on...

Re: Dual Boot with Windows 8 - Cannot get working [Solved]

Posted: Fri Feb 06, 2015 12:27 am
by electroken
I ran the ubuntu live disk for 14.10 on a hp 2000-2b09 after first getting into bios and changing only the boot list so that it would boot from the dvd drive first in the legacy mode. I think that automatically disabled secure boot if I recall correctly. I installed using the standard method given on the live disk; that is, I did not do any of the disk re-partitioning manually.
After installing linux I could only get to the grub by starting the computer and immediately hitting esc to cause the boot to pause, then hit f10 to get to a menu which would select the hdd as the boot drive (f9). I would then boot right into ubuntu with no trouble.
If I am not quick enough with the esc key, it will boot only into win 8 as before.
I have not tried the efibootmgr yet. i assume is must be in the program repository or possibly on the live disk. Will that or what you are proposign to fix this above work on my install? I am not sure if I can figure out if grub is in the uefi partition or not.

Re: Dual Boot with Windows 8 - Cannot get working [Solved]

Posted: Fri Feb 06, 2015 12:34 am
by electroken
I might add that if i was able to reorder the boot order or find some way to boot from the dvd first then I did that instead of disabling the secure boot. I cant recall now exactly how I got the dvd to boot first.
I know this is probably important to know, but I am just not sure now..

Re: Dual Boot with Windows 8 - Cannot get working [Solved]

Posted: Mon Jun 15, 2015 11:03 pm
by ssthakur
I ran into issue whens installing on "Acer Aspire V 15 Touch V3-572P-326T" that I purchased couple of days back and here is how I resolved it.
Whenever I hit F12 and selected install from the USB it would go blank. Then I read on some post that USB mint comes with UEFI option but somehow it was not appearing in the boot from menu. So this is what I did
1) Hit F2 to get the "Bios" setting and got to Security and provide Supervisor password. At this point you should be able to go to the "select UEFI as trusted" and hit return. From the resulting menu, scroll to the USB related one and then browse till you get to the grub efi file, choose this, it will prompt you to provide a name and then choose Yes.

2) Now when it is booting, at F12, it should give you an option to boot using the "grub uefi" file you added to the trust file.

3) Now after install and reboot, it will go to windows by default.

4) go back and choose the trusted file from the hard drive, you will see a directory called Ubuntu, select the one that has grub in the name, save and exit and not hit f12 upon reboot and you should see this an option.

5) Now go back to the boot menu in the bios and put this option ahead of Windows UEFI file and next time you should take you to grub menu and you do not have to hit f12 to get to it.