[SOLVED] Boot issue on new computer

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
fletcher
Level 3
Level 3
Posts: 179
Joined: Thu Oct 15, 2009 2:11 pm
Contact:

[SOLVED] Boot issue on new computer

Post by fletcher »

Got past the Secure Boot issues that I had when I started, and got Mint 17.1 Cinnamon installed on a new machine. Ran into entirely new problem that I never would have anticipated.

When I turn the computer on, It goes into a black screen with several lines of text. The most important of these seems to be:
Realtek PCIe FE Family Controller Series v1.28
That line comes at the end, then gives several dots, then tells me there is no boot disk detected or the disk has failed.

I set up Mint on a separate 50GB partition, with 5GB of swap at the end. Funny thing is, there is 1MB of empty space before my root partition, and I cannot do anything with it. And cannot get rid of it.

Is the 1MB a problem? Is there something wrong with GRUB? Has anyone heard of this before? I really want to get my new machine working.
Last edited by fletcher on Sun Feb 01, 2015 8:51 am, edited 1 time in total.

fletcher
Level 3
Level 3
Posts: 179
Joined: Thu Oct 15, 2009 2:11 pm
Contact:

Re: Boot issue on new computer

Post by fletcher »

More info:

Looks like I need a driver to preload for Realtek. I have downloaded the tar ball and attempted installation, but I am awful at command line. Hoping for some help. I get these instructions in a readme file:
This is the Linux device driver released for RealTek RTL8101E, RTL8102E(L) and RTL8103E(L), the Fast Ethernet controller with PCI-Express interface.

<Requirements>

- kernel source tree (supported Linux kernel 2.6.x and 2.4.x)
- For linux kernel 2.4.x, this driver supports linux kernel 2.4.20 and latter.
- compiler/binutils for kernel compilation

<Quick install with proper kernel settings>
Unpack the tarball :
# tar vjxf r8101-1.aaa.bb.tar.bz2

Change to the directory:
# cd r8101-1.aaa.bb

If you are running the target kernel, then you should be able to do :

# ./autorun.sh (as root or with sudo)

You can check whether the driver is loaded by using following commands.

# lsmod | grep r8101
# ifconfig -a

If there is a device name, ethX, shown on the monitor, the linux
driver is loaded. Then, you can use the following command to activate
the ethX.

# ifconfig ethX up

,where X=0,1,2,...

<Set the network related information>
1. Set manually
a. Set the IP address of your machine.

# ifconfig ethX "the IP address of your machine"

b. Set the IP address of DNS.

Insert the following configuration in /etc/resolv.conf.

nameserver "the IP address of DNS"

c. Set the IP address of gateway.

# route add default gw "the IP address of gateway"

2. Set by doing configurations in /etc/sysconfig/network-scripts
/ifcfg-ethX for Redhat and Fedora, or /etc/sysconfig/network
/ifcfg-ethX for SuSE. There are two examples to set network
configurations.

a. Fixed IP address:
DEVICE=eth0
BOOTPROTO=static
ONBOOT=yes
TYPE=ethernet
NETMASK=255.255.255.0
IPADDR=192.168.1.1
GATEWAY=192.168.1.254
BROADCAST=192.168.1.255

b. DHCP:
DEVICE=eth0
BOOTPROTO=dhcp
ONBOOT=yes

<Modify the MAC address>
There are two ways to modify the MAC address of the NIC.
1. Use ifconfig:

# ifconfig ethX hw ether YY:YY:YY:YY:YY:YY

,where X is the device number assigned by Linux kernel, and
YY:YY:YY:YY:YY:YY is the MAC address assigned by the user.

2. Use ip:

# ip link set ethX address YY:YY:YY:YY:YY:YY

,where X is the device number assigned by Linux kernel, and
YY:YY:YY:YY:YY:YY is the MAC address assigned by the user.

<Force Link Status>

1. Force the link status when insert the driver.

If the user is in the path ~/r8101, the link status can be forced
to one of the 4 modes as following command.

# insmod ./src/r8101.ko speed=SPEED_MODE duplex=DUPLEX_MODE autoneg=NWAY_OPTION

,where
SPEED_MODE = 100 for 100Mbps
= 10 for 10Mbps
DUPLEX_MODE = 0 for half-duplex
= 1 for full-duplex
NWAY_OPTION = 0 for auto-negotiation off (true force)
= 1 for auto-negotiation on (nway force)
For example:

# insmod ./src/r8101.ko speed=100 duplex=0 autoneg=1

will force PHY to operate in 100Mpbs Half-duplex(nway force).

2. Force the link status by using ethtool.
a. Insert the driver first.
b. Make sure that ethtool exists in /sbin.
c. Force the link status as the following command.

# ethtool -s ethX speed SPEED_MODE duplex DUPLEX_MODE autoneg NWAY_OPTION

,where
SPEED_MODE = 100 for 100Mbps
= 10 for 10Mbps
DUPLEX_MODE = half for half-duplex
= full for full-duplex
NWAY_OPTION = off for auto-negotiation off (true force)
= on for auto-negotiation on (nway force)

For example:

# ethtool -s eth0 speed 100 duplex full autoneg on

will force PHY to operate in 100Mpbs Full-duplex(nway force).

<Jumbo Frame>
RTL8101E, RTL8102E and RTL8103E do not support Jumbo Frame.
I can tell that I need that driver to load before my OS, because that is where it hangs. But I cannot figure out how to get that to happen when I have to work from a live environment.

I can load Mint up from the flash drive, and use it here. But that does not really help me. The point of getting a new computer was to be able to use it.

User avatar
gold_finger
Level 9
Level 9
Posts: 2885
Joined: Mon Mar 11, 2013 11:39 pm

Re: Boot issue on new computer

Post by gold_finger »

Did you install Mint as stand-alone operating system, or did you attempt to setup a dual-boot with Windows 8/8.1?

Does the black screen with text flying by seem to be something from the system itself, or do you get the impression these messages are shown during startup of Mint? Sounds to me like it's not finding Mint (or Windows) and you're seeing messages as computer searches for something to boot from. If that's what is going on, then don't think Realtek drivers are the problem.

When installing to newer computers with UEFI firmware, it's possible to install in either UEFI mode or Legacy/(CSM) mode. Purely as a guess, you may have the firmware set to boot in one mode but have Mint installed in the opposite mode -- so computer can't boot. Try getting into the UEFI settings and change the boot mode from whatever it is now to the other mode, then reboot and see what happens. (I'm guessing that you deleted Windows, installed Mint in Legacy mode by accident, and upon reboot computer is still in UEFI mode so can't find anything to boot from.)

If switching modes didn't get you booted into Mint, check out this tutorial and compare steps to what you did for clues on what might have gone wrong: http://forums.linuxmint.com/viewtopic.php?f=42&t=163126. Just skip over the Windows related steps if you're not dual-booting.
Last edited by gold_finger on Sat Jan 31, 2015 7:00 pm, edited 1 time in total.
Please add [SOLVED] to your thread if a solution is found. Go to your first post in the thread, hit "Edit" button and add [SOLVED] to the title of the post.

How To Format Your Forum Posts.

Try Linux Beginner Search Engine for Linux questions.

fletcher
Level 3
Level 3
Posts: 179
Joined: Thu Oct 15, 2009 2:11 pm
Contact:

Re: Boot issue on new computer

Post by fletcher »

I did delete Windows and install Linux. I have the computer set to Legacy Mode, and I just assumed that Linux woudl install to boot that way. Is there a way to check?

Cause you hit it with the system is not finding anything to boot from.

User avatar
gold_finger
Level 9
Level 9
Posts: 2885
Joined: Mon Mar 11, 2013 11:39 pm

Re: Boot issue on new computer

Post by gold_finger »

fletcher wrote:I did delete Windows and install Linux. I have the computer set to Legacy Mode, and I just assumed that Linux woudl install to boot that way. Is there a way to check?
Yes.

Boot with live Mint again, open the GParted program and look at the drive partitions. If you see a FAT32 formatted partition near the beginning of the drive (probably 100-500MB in size), then it is installed in UEFI mode. If you see a small "unknown" partition (probably only 1MB in size) and no FAT32 partition, then it's installed in Legacy/CSM mode.

Whatever you find out, go into UEFI settings on next reboot and change the boot mode to that. You probably only changed the boot mode for the live medium session before and not the boot mode for normal booting.
Please add [SOLVED] to your thread if a solution is found. Go to your first post in the thread, hit "Edit" button and add [SOLVED] to the title of the post.

How To Format Your Forum Posts.

Try Linux Beginner Search Engine for Linux questions.

User avatar
austin.texas
Level 20
Level 20
Posts: 12048
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: Boot issue on new computer

Post by austin.texas »

fletcher wrote:I set up Mint on a separate 50GB partition, with 5GB of swap at the end. Funny thing is, there is 1MB of empty space before my root partition, and I cannot do anything with it. And cannot get rid of it.
Is the 1MB a problem? Is there something wrong with GRUB? Has anyone heard of this before? I really want to get my new machine working.
No, there is nothing wrong with the 1MB of empty space. It is actually a good practice, in some configurations.

If you would run the Boot Info Script, it would give us a lot of useful information.
You can install it in the live Mint session.
Install boot-info-script:

Code: Select all

sudo apt-get install boot-info-script
Then run the script:

Code: Select all

sudo bootinfoscript
Post the results here - http://pastebin.com/ - and give us the resulting link.
Mint 18.2 Cinnamon, Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Linux Linx 2018

fletcher
Level 3
Level 3
Posts: 179
Joined: Thu Oct 15, 2009 2:11 pm
Contact:

Re: Boot issue on new computer

Post by fletcher »

http://pastebin.com/b3jZpKr5

I really appreciate the help here. I use Linux because it works, but I am not good at working with it.

User avatar
austin.texas
Level 20
Level 20
Posts: 12048
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: Boot issue on new computer

Post by austin.texas »

I think the problem is that you installed Mint in legacy mode to your drive. But your drive is GPT partitioned, so installing in legacy mode is not the best thing to do.
The Boot Report says that Grub is installed to the MBR. But GPT partitioned discs do not have a MBR - so they create a fake MBR to accomodate legacy installations.
The Boot Report says that grub "looks at sector 34224144 of the same hard drive for core.img".
I have never seen anything like that before. Every Boot Report I have seen says "looks at sector 1 of the same hard drive for core.img".

It may be theoretically possible to fix the partitioning after the fact ( see h[url]ttp://www.rodsbooks.com/gdisk/wipegpt.html[/url] ) but your easiest option is to boot the live Mint DVD or USB and use the gparted program to create a msdos partition table to replace the GPT partition table. When you open sda in gparted, click on Device > New Partition Table > msdos
Then you can re-install Mint as before.
Mint 18.2 Cinnamon, Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Linux Linx 2018

fletcher
Level 3
Level 3
Posts: 179
Joined: Thu Oct 15, 2009 2:11 pm
Contact:

Re: Boot issue on new computer

Post by fletcher »

austin.texas wrote:I think the problem is that you installed Mint in legacy mode to your drive. But your drive is GPT partitioned, so installing in legacy mode is not the best thing to do.
The Boot Report says that Grub is installed to the MBR. But GPT partitioned discs do not have a MBR - so they create a fake MBR to accomodate legacy installations.
This would appear to be correct. When I opened GParted in my live Mint, I got a message that the partition was GPT and there was no MSDOS partition.

I am going to try doing partitions in GParted before I do the install, instead of having the installation do the partitions, and see what that does. Mayde I will not have to figure out the whole driver for the network drive issue.

Thank you for the help.

fletcher
Level 3
Level 3
Posts: 179
Joined: Thu Oct 15, 2009 2:11 pm
Contact:

Re: Boot issue on new computer

Post by fletcher »

Got it up and running. Huge thanks to gold_finger and austin.texas for giving a hand to someone who should really still be using Windows, since I cannot seem to do GNU/Linux properly on my own.

User avatar
gold_finger
Level 9
Level 9
Posts: 2885
Joined: Mon Mar 11, 2013 11:39 pm

Re: [SOLVED] Boot issue on new computer

Post by gold_finger »

fletcher,

Good job -- glad to see you got it fixed.

Took a quick look (a bit late now) at your pastebin output. My guess is that you did not run the automatic install and instead chose "Something else" to manually make partitions yourself. I say that because when installing Linux on a GPT disk in Legacy mode, there needs to be a small (1MB) "bios_grub" partition in addition to your Root and Swap partitions. That doesn't appear to be present on the disk and I'm pretty sure the automatic install method would have put it there. Anyway, since you switched the drive to using MBR partitions, that doesn't matter anymore but thought I'd let you know for future reference. (If interested more, here's a tutorial for such an installation: GPT Partitioning for Legacy/CSM mode Linux Installations.)
Please add [SOLVED] to your thread if a solution is found. Go to your first post in the thread, hit "Edit" button and add [SOLVED] to the title of the post.

How To Format Your Forum Posts.

Try Linux Beginner Search Engine for Linux questions.

Post Reply

Return to “Installation & Boot”