Can not change boot order [SOLVED]

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
reeby
Level 1
Level 1
Posts: 23
Joined: Sat Nov 08, 2014 2:44 pm

Can not change boot order [SOLVED]

Post by reeby »

Hi, can someone point me to the right way to change the boot order.
I want Mint to boot first instead of Windows 8 on y my HP Envy but don't seem to be able to do it.
Used efibootmgr and used Grub customizer - does not work. The Windows boots first anyway.

I've tried to change it while on live USB too. The boot order did get changed but windows comes first! It's like the system does not let me set MInt at all.

Code: Select all

BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0004,0000,0003,9999
Boot0000* ubuntu	HD(1,40,81fff,c580bbcb-131a-4d62-bc63-87eec330c336)File(\EFI\ubuntu\shimx64.efi)
Boot0003* Windows Boot Manager	HD(1,40,81fff,c580bbcb-131a-4d62-bc63-87eec330c336)File(\boot\efi\EFI\HP\grubx64.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...a................
Boot0004* Solid State Disk	ACPI(a0341d0,0)PCI(1f,2)03120a000000ffff0000HD(1,40,81fff,c580bbcb-131a-4d62-bc63-87eec330c336)AMBO
Boot9999* USB Drive (UEFI)	ACPI(a0341d0,0)PCI(1d,0)USB(10,0)AMBO
[/quote]

However, if I point efibootmgr to boot Mint next by:

Code: Select all

sudo efibootmgr -n 0000

then if works, but only till the next boot, when it all gets reset again.

What do i do wrong (or don't do right)??
Last edited by reeby on Tue Feb 03, 2015 2:53 am, edited 2 times in total.
reeby
Level 1
Level 1
Posts: 23
Joined: Sat Nov 08, 2014 2:44 pm

Re: Can not change boot order

Post by reeby »

Problem solved.

Solved by fooling computer rather then changing the boot order itself.
Those like me who's suffering with boot preference issues might try this simple trick. It worked for me:

1. Install efibootmgr and see the boot number of your preferred system.
2. Try and see if this command works for you:

Code: Select all

sudo efibootmgr -n 0000
- (where "0000" is your preferred system boot number)
This script forces the computer to boot whatever bootloader you want it to, but only once. Next reboot will overwrite your settings back to previous ones.

3. So, if the command above does the work then the trick is to automate it so it runs every time you reboot your computer. To do that simply put the command line sudo efibootmgr -n 0000 (where "0000" is your preferred system boot number) into this file: /etc/rc.local.

Now, your computer should boot into the OS you need.
Last edited by reeby on Thu Aug 27, 2015 6:46 am, edited 2 times in total.
electroken
Level 1
Level 1
Posts: 21
Joined: Sat Feb 09, 2013 8:57 pm
Location: Minnesota
Contact:

Re: Can not change boot order [SOLVED]

Post by electroken »

I almost understand enough to do this. But how do I know what my preferred system boot number is?
Also first I knew about the efibootmgr. How do I get that program and do I run it from inside my linux install after i manage to boot into it on my hp 2000 computer?
Or is it run from inside of the windows os? I assume not since windows abhors even acknowledging the existance of anything outside of the windows world.

I got into the hp 2000 bios and selected to have it let legacy os boot up. I turned off the secure boot, but it still uses the UEFI boot list first to see if there is a windows os and when it sees one, it boots it istead of going to the boot block on the hdd and finding grub. It is very frustrating and makes me hate Bill Gates even more than before, if that is possible.

So any help here is welcome and i will go look at the other listings here in the forum and see about getting efibootmgr.
Post Reply

Return to “Installation & Boot”