Newbie Alert - No way to dual boot - No GRUB (SOLVED)

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
Kellynch
Level 1
Level 1
Posts: 28
Joined: Wed Feb 11, 2015 6:23 am

Newbie Alert - No way to dual boot - No GRUB (SOLVED)

Post by Kellynch » Wed Feb 11, 2015 8:41 am

I just got my new ASUS laptop yesterday. A seasoned veteran of Linux, especially Mint and various programming languages installed Mint 17.1 (64 bit) for me today. However, there is no Grub or some such to dual boot, it just goes straight to Windows 8.1. My friend spent several hours researching and told me all the different things he's tried, but to be honest my brain is now fried and I couldn't recall most of the jargon he used, What he did say that Mint is definitely installed.
Last edited by Kellynch on Thu Feb 19, 2015 11:52 pm, edited 1 time in total.

User avatar
administrollaattori
Level 15
Level 15
Posts: 5898
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: Newbie Alert - No way to dual boot - No GRUB

Post by administrollaattori » Wed Feb 11, 2015 10:40 am

1. Did you disable Secure boot from BIOS-settings?
2. If yes, did you install Mint on the UEFI mode?
3. If yes, did you install grub to the efi partition?
4. If yes, with some computers you need to (re)set boot order from the BIOS-settings -> if there are options "windows boot manager" and "ubuntu", set "ubuntu" as the first bootable device so that grub menu appears.

User avatar
Pepas
Level 2
Level 2
Posts: 52
Joined: Mon Jan 24, 2011 10:18 am
Contact:

Re: Newbie Alert - No way to dual boot - No GRUB

Post by Pepas » Wed Feb 11, 2015 11:35 am

administrollaattori wrote:1. Did you disable Secure boot from BIOS-settings?
2. If yes, did you install Mint on the UEFI mode?
We started out in CSM, without Secure boot, using the GUI installer, so we didn't see what Grub ended up doing. When we reinstalled grub-pc from the terminal, it refused to use block chains (it is a GPT partition table). I'm supposing that the GUI installer forces it, because we could boot into the install by booting from the CD, and then choosing Boot from harddisk.
We tried Yannubuntu's boot-repair, but it never really wanted to do it's magic in non-secure mode.
administrollaattori wrote:3. If yes, did you install grub to the efi partition?
The GUI installed offered no option, and it didn't, because it was in CSM mode. Later we did try to mount the EFI partition from fstab and install grub-efi-amd64, but we found that we could never boot into it. We even tried a way of directing Windows to our efi-bootfile by doing (in the Windows rescue shell):

Code: Select all

bcdedit.exe /set {bootmgr} path \EFI\Boot\bootx64.efi
administrollaattori wrote:4. If yes, with some computers you need to (re)set boot order from the BIOS-settings -> if there are options "windows boot manager" and "ubuntu", set "ubuntu" as the first bootable device so that grub menu appears.
When we forced the Linux efi-bootfile to be first, it said it was unbootable.

I'm not sure if we should try to get it working from Legacy mode or full Secure mode. The Windows 8.1 install that we want to keep around works in all environments...

User avatar
Pepas
Level 2
Level 2
Posts: 52
Joined: Mon Jan 24, 2011 10:18 am
Contact:

Re: Newbie Alert - No way to dual boot - No GRUB

Post by Pepas » Thu Feb 19, 2015 11:29 pm

For posterity:
We reinstalled on a non-encrypted partition, and with using our original boot partition. I think the installer does some EFI magic that I haven't mastered yet... Anyway, then we just used the grub.conf from the encrypted install instead of the unencrypted one, and in the end we just wiped the unencrypted root-partition. Problem solved! It seems like there is still a problem with installing to LUKS+LVM... (Unless you choose "Wipe the whole disk" which won't work for dual booting with a pre-installed OS.)

Post Reply

Return to “Installation & Boot”