Can not boot! initramfs error!

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
raxial
Level 1
Level 1
Posts: 2
Joined: Wed Feb 11, 2015 6:47 pm

Can not boot! initramfs error!

Post by raxial » Wed Feb 11, 2015 6:57 pm

Hi,

I have Linux Mint Cinnamon 17 installed and it's been fine for ages, but when I tried booting up today it just isn't having it. I get this:

BusyBox v1.17.1 (Ubuntu 1:1.17.1-10ubuntu1) built-in shell (ash)
Enter 'help' for a list of built-in commands

(initramfs)

I got to Grub and tried the Recover option, in fact all the options shown, but everything leads back to the above.

I Googled to try and learn what I can do about it, but to be honest, I'm such I noob I don't understand the responses! Though I have attempted to boot from a CD and from USB. Neither worked, but the USB drive didn't even show as an option in BIOS.

Can anyone please help and explain in the simplest terms possible, please?

Thanks :)

User avatar
karlchen
Level 19
Level 19
Posts: 9513
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Can not boot! initramfs error!

Post by karlchen » Thu Feb 12, 2015 7:50 pm

Hello, raxial.

When you see the Busybox message and prompt, the damage has already been done. :(
What would be helpful in diagnosing why you end up in the busybox would be the lines which will be displayed before you are thrown into the Busybox.
Now normally the Linux Mint splash screen hides away all startup text messages. Plus the boot option "quiet" makes sure most messages will be suppressed anyway.
So what needs to be done is this:
  • Switch on the machine.
  • Keep the shift key pressed till you see the Grub boot menu.
  • On the first menu item, which will be "Linux Mint 17", press the letter "e" for edit.
  • This will take you to a screen that displays all the commands which are behind the menu item.
  • Use the cursor keys to navigate up and down, left and right. Navigate to the line that start with "linux /boot/vmlinuz-..."
    Among other things it will hold the words "splash" and "quiet" (both without the double quotes).
    Remove both words from the line.
    Do not press the <enter> key. It would insert a linebreak, which we do not want.
  • Instead press the function key <F10> to boot now.
  • A lot of boot messages should scroll up through the screen.
    At a certain point in time the Busybox message will appear again.
    The text lines above the Busybox message will hopefully hold useful pieces of information explaining why booting fails and drops to the Busybox.
    Either carefully write down as many messages as you can and post them here.
    Or if you are good at taking excellent photographs of your monitor take a photo of the screen and post it here.
Cheers,
Karl
Image
Linux Mint 18.1 64-bit Cinnamon Desktop, Total Commander 9.21a 64-bit
Ubuntu 18.04.1 32-bit Mate Desktop, Total Commander 9.21a 32-bit
Windows? - 1 window in every room

raxial
Level 1
Level 1
Posts: 2
Joined: Wed Feb 11, 2015 6:47 pm

Re: Can not boot! initramfs error!

Post by raxial » Sat Feb 14, 2015 12:31 pm

Hi Karl,

Thanks so much for your help. I did as you suggested and have taken a photo, hoping it's clear enough to read what might be going on?
IMG_0879600.png

BlackVeils
Level 5
Level 5
Posts: 589
Joined: Wed Nov 06, 2013 9:26 am

Can not boot! initramfs error!

Post by BlackVeils » Sun Feb 15, 2015 1:57 am

for those that are helping, I squinted and saw:

_________________________________________

**** is waiting for root device. common problems:
- boot args (cat /proc/cmdline)
- check rootdelays (did the system wait long enough?)
- check root (did the system wait for the right device?)
- missing modules (cat /proc/modules: ls /dev)
ALERT /dev/mapper/mint --**-root does not exist. dropping to root shell
_________________________________________

asterisks mean I could not read - maybe vg

the first asterisks looks like "Gave" but that doesn't make sense.

--- Sent from my Moto G using Tapatalk ---

User avatar
myk
Level 1
Level 1
Posts: 1
Joined: Mon Apr 23, 2018 2:15 am
Location: Delhi

Re: Can not boot! initramfs error!

Post by myk » Mon Apr 23, 2018 2:19 am

Busybox v1.22.1 (Ubuntu 1:1.22.0-15ubuntu1) built in shell (ash)
Enter 'help' for a list of built-in commands.

(initramfs) _

Solution:

1. Restart ----> Grub Menu ----> Use arrow down key ------> *Advance Option for Linux Mint.
2. choose 2nd line --------> Linux mint .......... (upstream)
3. help (check exec fsck is asking or not)
4. Exit (check partition_name for fsck)
5. Fsck /dev/partition _name (Exa: /dev/sda1)
6. And enter Yes(y) to all errors
7. reboot

Enjoy :D
myk

Mute Ant
Level 13
Level 13
Posts: 4945
Joined: Tue Sep 03, 2013 7:45 pm
Location: Norfolk UK

Re: Can not boot! initramfs error!

Post by Mute Ant » Mon Apr 23, 2018 5:32 am

Hmmm. The mists are clearing... I can see...
"Gave up waiting for root device"
...and...
"/dev/mapper/mint--vg-root does not exist..."

Linux+Busybox is trying to access a LVM installation and can't find the OS root volume. Do you need to type a passphrase to get this far into the boot (LVM-on-LUKS) or does it usually breeze through to a graphic login screen?
Tommy reports the scan of zircon and opal storage is complete. When shall we go today?

User avatar
WharfRat
Level 20
Level 20
Posts: 11834
Joined: Thu Apr 07, 2011 8:15 pm

Re: Can not boot! initramfs error!

Post by WharfRat » Mon Apr 23, 2018 11:52 am

You can run fsck from initramfs with fsck -fvy /dev/sda7 /dev/mapper/mint--vg-root :wink:
ImageImage

olisteadman
Level 1
Level 1
Posts: 4
Joined: Wed Sep 05, 2018 12:07 pm

Re: Can not boot! initramfs error!

Post by olisteadman » Tue Dec 11, 2018 12:30 pm

For me the first command `help` gives a horrible series of 20 or so error messages and then freezes the machine so my only way forward is holding in the power button until it dies: https://dl.airtable.com/oJsmIFGITS64R0i ... .25.21.jpg

Post Reply

Return to “Installation & Boot”