About /etc/fstab

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
quadproc
Level 1
Level 1
Posts: 22
Joined: Sun May 25, 2014 12:12 pm

About /etc/fstab

Post by quadproc »

I have been running Mint 17 for a while and recently decided to go to 17.1. A new problem occurred when I did this, to wit:
/etc/fstab does not seem to be recognized. If i have no partition specified for /home then the system comes up showing mounts for sdc3 and sdc4 my two user partitions.

But if I modify the /etc/fstab file to incude a UUID for sdc3 and a /home then
the system says that it needs S for skip in order to come up, and doing this causes the sdc3 entry to be ignored.
Any ideas? I verified that the md5sum was correct.

quadproc
Mute Ant
Level 14
Level 14
Posts: 5129
Joined: Tue Sep 03, 2013 7:45 pm
Location: Norfolk UK

Re: About /etc/fstab

Post by Mute Ant »

There's something wrong with your entry for sdc3...
While you're waiting, read the free novel we sent you. It's a Spanish story about a guy named "manual".
Cosmo.
Level 23
Level 23
Posts: 17817
Joined: Sat Dec 06, 2014 7:34 am

Re: About /etc/fstab

Post by Cosmo. »

quadproc wrote:I verified that the md5sum was correct.
How did you do this?
I wonder if you probably did mismatch UUID and md5sum, both are very different things. If you should have entered a (how ever you got it) md5sum in your fstab this cannot work.

There are several ways for getting the UUID, in a terminal enter

Code: Select all

sudo blkid -o list -w /dev/null
quadproc
Level 1
Level 1
Posts: 22
Joined: Sun May 25, 2014 12:12 pm

Re: About /etc/fstab

Post by quadproc »

Here is the entire file that I tried to use for 17.1:
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
# / was on /dev/sda17 during installation
UUID=69ee7381-cec9-4e25-9f4e-a5bdad0c3525 / ext3 errors=remount-ro 0 1
UUID=f36c63cc-008c-4547-9d20-2fde9d610731 /home ext3 0 2
# swap was on /dev/sda5 during installation
UUID=1652a31f-4ee8-493d-a8c4-2bec45b3fc2b none swap sw 0 0

Note that my problem is inverse to the file's presence - if the file is valid then the system hangs at S but if the file is invalid then the system starts and mounts both sdc3 and sdc4
without my asking. I checked the md5sum to see if I got a valid transfer; apparently I did because the md5sum matched.

From the tail of the mount command when the /etc/fstab file contains a UUID for /home:
...
none on /sys/fs/pstore type pstore (rw)
systemd on /sys/fs/cgroup/systemd type cgroup (rw,noexec,nosuid,nodev,none,name=systemd)
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,user=bob)
...
quadproc
User avatar
WinterTroubles
Level 6
Level 6
Posts: 1471
Joined: Fri Apr 11, 2014 6:25 am
Location: UK

Re: About /etc/fstab

Post by WinterTroubles »

I'm rather inexperienced with fstab, so my be completely wrong, but...

Have you tried adding an options setting to this line..
UUID=f36c63cc-008c-4547-9d20-2fde9d610731 /home ext3 0 2
For example my seperate data partitiom has 'defaults' (without the ' ) between the ext3 and the 0 in your line.

I'm probably wrong of course :lol:

Regards
WT
17.1Cinn/17.1Xfce

If solved please edit the subject line of your first post to include [Solved] so other users know there's a solution in the topic.

GNU Terry Pratchett
Aristotelian
Level 3
Level 3
Posts: 131
Joined: Tue Dec 24, 2013 7:12 pm

Re: About /etc/fstab

Post by Aristotelian »

Does it not like /home as your mount point? Could you try /media?
Cosmo.
Level 23
Level 23
Posts: 17817
Joined: Sat Dec 06, 2014 7:34 am

Re: About /etc/fstab

Post by Cosmo. »

Before reading the post of WinterTroubles I found the same mistake. Without any option between the file-system and the 2 last parameters they get mis-interpreted.

Another question is, if the UUID in this line is correct. With the terminal-command I already provided that could be cleared up.
Post Reply

Return to “Installation & Boot”