Page 1 of 1

<SOLVED> Dual boot won't boot into linux mint

Posted: Fri Mar 13, 2015 11:31 am
by FridloBaggins
Hard drive Setup:
  • 120GB SSD with windows and a few programs on it.
  • 1TB WD mass storage hard drive with many programs and space left over.


I partitioned the 1TB drive so I could install and use Mint onto it but to no avail. It installs perfectly fine both using the built in "install alongside windows" as well as manually setting partitions to root(/), home(/home) and swap but after the install and reboot into windows to make sure everything is fine (which it is), it just won't boot into linux mint. I set it all up on a logical partitions which I believe combine together into an extended partition? It will always drop into the ash shell and I have tried many different things to fix it though I'm not 100% certain whether I actually did all of them correctly. I set the rootdelay to a couple minutes considering it's a spinning drive, I set the root to /dev/sdXY (X being drive letter, Y being partition #), have tried the boot repair utility from a live usb and finally I tried mounting the drive and editing the fstab. All of which just led to the same error over and over. I can't type in the ash shell once it fails to boot if that's any indicator to what's going wrong. Any help would be appreciated greatly.

Re: Dual boot won't boot into linux mint

Posted: Fri Mar 13, 2015 1:44 pm
by Fornhamfred
Could you provide some more info.

Which version of Windows is installed?

Is the Bios UEFI.

Re: Dual boot won't boot into linux mint

Posted: Fri Mar 13, 2015 5:09 pm
by FridloBaggins
Windows 7 and no the BIOS is Legacy.

Re: Dual boot won't boot into linux mint

Posted: Fri Mar 13, 2015 5:36 pm
by gold_finger
When you installed Mint, did you direct boot loader installation to the Windows drive MBR or the MBR of the drive Mint is on?

If boot loader was installed to the 1TB (Mint) drive, maybe you could go into BIOS settings and change the boot order of the drives so that it looks to the 1TB drive first for booting. Try that to see if it makes any difference first. If doesn't work, boot with live Mint DVD/USB, open a terminal and enter following commands:

Code: Select all

sudo os-prober
sudo parted -l
Copy/Paste the full terminal output back here for us to see.
  • Using mouse, highlight all output in terminal
  • Right-click on the highlighted text and choose "Copy"
  • In forum reply form, click to place cursor on location you want to place the output
  • Then click "Code" button along top of forum interface
  • You'll see two code blocks appear in your reply area that look like this -- [ code ] paste output here [ /code ]
  • Using mouse, right-click between the two blocks and choose "Paste"
  • That preserves the formatting and makes it easier for everyone to read.

Re: Dual boot won't boot into linux mint

Posted: Fri Mar 13, 2015 6:38 pm
by FridloBaggins

Code: Select all

mint@mint ~ $ sudo os-prober
/dev/sda1:Windows 7 (loader):Windows:chain
/dev/sda2:Windows 7 (loader):Windows1:chain
/dev/sdb5:Linux Mint 17.1 Rebecca (17.1):LinuxMint:linux
mint@mint ~ $ sudo parted -l
Model: ATA INTEL SSDSC2BW12 (scsi)
Disk /dev/sda: 120GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End    Size   Type     File system  Flags
 1      1049kB  106MB  105MB  primary  ntfs
 2      106MB   120GB  120GB  primary  ntfs         boot


Model: ATA WDC WD10EZEX-08M (scsi)
Disk /dev/sdb: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos

Number  Start   End     Size    Type      File system     Flags
 1      1049kB  800GB   800GB   primary   ntfs
 2      800GB   1000GB  201GB   extended
 5      800GB   992GB   192GB   logical   ext4
 6      992GB   1000GB  8534MB  logical   linux-swap(v1)

Re: Dual boot won't boot into linux mint

Posted: Sat Mar 14, 2015 5:55 am
by gold_finger
You didn't answer question about where you installed Mint boot loader during installation. I'm assuming that it got installed to the 1TB drive (/dev/sdb); so let's try installing it to the MBR of the other drive and that should fix the problem. (Copy/Paste the commands shown below instead of trying to type them out to avoid possible typos -- especially the first one.)

1. Boot computer with your live Mint DVD/USB.

2. Open a terminal and enter the following command to create a backup copy of the partition table and MBR on the /dev/sda drive:

Code: Select all

dd if=/dev/sda of=/home/mint/Desktop/mbr-backup.image bs=512 count=1
3. A file called "mbr-backup.image" will show up on the Desktop. Copy it to a USB stick for safe keeping.

4. Now enter the following commands one-at-a-time in the terminal to re-install grub to MBR of /dev/sda:

Code: Select all

sudo mount /dev/sdb5 /mnt
sudo grub-install --boot-directory=/mnt/boot /dev/sda
sudo umount /dev/sdb5
5. Close the terminal and reboot computer without the live DVD/USB.

6. If it boots directly into Mint without showing a choice for Windows, open a terminal in Mint and enter the following command to update grub which will add the Windows boot choice.

Code: Select all

sudo update-grub
Everything should boot up properly now.

If somehow everything got messed-up and nothing boots, restore prior MBR of /dev/sda by doing the following:
  • Boot with live Mint DVD/USB again.
  • Plug-in USB stick that you saved "mbr-backup.image" to and copy that file to the live Desktop.
  • Open a terminal and enter this command to restore the MBR of /dev/sda to what it was originally:

    Code: Select all

    dd if=/home/mint/Desktop/mbr-backup.image of=/dev/sda bs=446 count=1

Re: Dual boot won't boot into linux mint

Posted: Sat Mar 14, 2015 11:53 am
by FridloBaggins
I apologize for not answering your question earlier, grub had already been installed to /dev/sda.

Re: Dual boot won't boot into linux mint

Posted: Sat Mar 14, 2015 2:10 pm
by gold_finger
Go ahead with procedure to re-install grub to /dev/sda anyway. Maybe installer didn't get it done right -- that does happen sometimes.

If still doesn't work, boot again with live Mint DVD/USB and post back with the output of following command:

Code: Select all

ls /sys/firmware

Re: Dual boot won't boot into linux mint

Posted: Sat Mar 14, 2015 4:14 pm
by FridloBaggins
The re-installation didn't fix it sadly.

Output of ls /sys/firmware:

Code: Select all

mint@mint ~ $ ls /sys/firmware
acpi  memmap

Re: Dual boot won't boot into linux mint

Posted: Sat Mar 14, 2015 8:44 pm
by gold_finger
Output from last command looks normal, so nothing further to look at from that.

At this point I don't know what is wrong. Everything should work after reinstalling grub. Maybe one of the things you tried originally to fix things messed it up in some other way. Trying to figure that out will be too time consuming. Better bet is to do the installation all over again.

Boot with live Mint and open up GParted.

Right-click on the Swap partition and choose "Swapoff".

Now delete all of the Linux partitions from this failed install attempt. After deleting, you need to go to Edit -> Apply All Operations to finalize the deletions. Close GParted after that.

Start the Installer and choose the "Something else" option so you can set-up partitions manually and direct the boot loader to right location. Follow this tutorial for making the partitions and directing the boot loader. (Note: skip the part about creating a new partition table on the drive. You do not want to do that!) Direct boot loader installation to /dev/sda (assuming that is still the designation of the SSD).

You can make one large Root partition and a Swap partition, like you did on this non-working install; or you can make Root, Home and Swap partitions. It's up to you. If you make a separate Home partition, then make the Root partition only 20GB and use rest of space for Home minus what you need for Swap.

If new install still doesn't work, then I'm fresh out of ideas. It should work.

Re: Dual boot won't boot into linux mint

Posted: Sat Mar 14, 2015 11:45 pm
by FridloBaggins
Still no luck. It still gives me the busybox error after waiting for the device. I'm unable to type into the shell that it provides though. Is that a hardware problem? I tried out two different keyboards and I was still unable to type in "exit".

Re: Dual boot won't boot into linux mint

Posted: Sun Mar 15, 2015 4:08 am
by Fornhamfred
When you run the live dvd does everything work OK?

Re: Dual boot won't boot into linux mint

Posted: Sun Mar 15, 2015 10:43 am
by FridloBaggins
Yes, I have a live usb and everything runs perfectly while I'm on it. I've been using it as a portable storage for learning computer science and the like, nothing's ever acted up.

Re: Dual boot won't boot into linux mint

Posted: Sun Mar 15, 2015 12:56 pm
by Fornhamfred
Can you repeat the following check in the terminal as the boot flag should show in the mbr (msdos 1) not 2

Code: Select all

 sudo parted -l

Re: Dual boot won't boot into linux mint

Posted: Sun Mar 15, 2015 2:26 pm
by FridloBaggins

Code: Select all

mint@mint ~ $ sudo parted -l
Model: ATA INTEL SSDSC2BW12 (scsi)
Disk /dev/sda: 120GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End    Size   Type     File system  Flags
 1      1049kB  106MB  105MB  primary  ntfs
 2      106MB   120GB  120GB  primary  ntfs         boot


Model: ATA WDC WD10EZEX-08M (scsi)
Disk /dev/sdb: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos

Number  Start   End     Size    Type      File system     Flags
 1      1049kB  800GB   800GB   primary   ntfs
 2      800GB   820GB   20.0GB  primary   ext4
 3      820GB   1000GB  181GB   extended
 5      820GB   992GB   172GB   logical   ext4
 6      992GB   1000GB  8189MB  logical   linux-swap(v1)
So it isn't installing correctly?

Re: Dual boot won't boot into linux mint

Posted: Sun Mar 15, 2015 10:38 pm
by FridloBaggins
Okay, I got it to work. I followed a couple different guides on repair and re-installing grub but none of them worked. I ended up using boot repair as a last resort to try and fix it. I went into the advanced options, went to GRUB location, clicked Place GRUB into: and in the drop drown menu I clicked on sda. In GRUB options, I chose to purge GRUB. Finally in Other options, I placed the boot flag on sda1. That was it, now it boots properly but instead of showing linux mint as the name of the OS in grub, it show ubuntu which is kind of funny, but at least it boots correctly. My only other question before I mark the thread as solved is: would anyone be able to point me in the right direction to move everything I've done on my usb to the new partitions?

Thanks for all the help

Re: Dual boot won't boot into linux mint

Posted: Mon Mar 16, 2015 2:17 pm
by Fornhamfred
Glad you got sorted. The reason I asked you to post the output was because the boot flag should have been showing on sda1 ( which is the mbr partition ) not sda2.

What do you want to copy from the USB?

With regard to the grub entry you can change it by editing the grub.cfg file. Which version of Mint have you installed?

Re: Dual boot won't boot into linux mint

Posted: Mon Mar 16, 2015 4:37 pm
by FridloBaggins
Actually I'm all good, I'll just reinstall stuff that I had installed on the usb. Once again, thank you very much for the help both of you.