Page 1 of 1

[SOLVED] No boot from CD-DVD

Posted: Mon Apr 27, 2015 8:49 am
by romualdo
Hi everybody,
I'm quite new in here. Only few months experience with Linux. In particular, i'm using Mint 17.1 on Asus X554LD.

I have a problem with the bios.
Among "Boot Option"s I can choose only Linux or Win but nothing else.
I can remember that few weeks ago I could also choose the CD-DVD option.
Since that time I installed softwares (R, Gretl, Adobe, Texmaker, Wine, Bubleebee etc...) and i did system upgrades from the official upgrade centre.
I need to start from CD cause i would like to try a version of Puppy OS.
Can someone help me to solve?

Thanks

Romualdo

Re: No boot from CD-DVD

Posted: Mon Apr 27, 2015 9:13 am
by karlchen
Hello, Romualdo.

Choosing between different boot devices is a functionality provided by the BIOS. As a rule pressing <F12> or <F11> (details can be found in your Asus hardware manual) right after powering on the machine will bring up an on-demand boot device selection menu.

Cheers,
Karl

Re: No boot from CD-DVD

Posted: Mon Apr 27, 2015 9:41 am
by romualdo
Thanks karlchen,
I have already done what you mean: <F2> just after the PC is turned on and get into the Bios menu
BUT the problem is when I get into the windows where i can choose the boot options there are only 2 option allowed,
start from Linux 17.1 or start from Win 8.1.
There are no option I can choose to start from CD-DVD or USB.
It sounds like the BIOS doesn't recognize the CD and USB devices. I'm guessing...

Re: No boot from CD-DVD

Posted: Mon Apr 27, 2015 9:44 am
by Pierre
are you able to take a photo of that < Bios menu> screen & post that back here?.

Re: No boot from CD-DVD

Posted: Mon Apr 27, 2015 9:53 am
by romualdo
Here the picture

Re: No boot from CD-DVD

Posted: Mon Apr 27, 2015 9:57 am
by Pierre
what device is that fourth option - disabled - supposed to be ?.

Re: No boot from CD-DVD

Posted: Mon Apr 27, 2015 10:03 am
by romualdo
Pierre,
That's not a device, you can choose it if you want to disable a boot option

Re: No boot from CD-DVD

Posted: Mon Apr 27, 2015 10:10 am
by Pierre
okay then - what choice(s) are there in boot options #2 & #3 ??.
- since that screen was for option #1. ..

Re: No boot from CD-DVD

Posted: Mon Apr 27, 2015 10:15 am
by romualdo
For boot options #2 and #3 i have the same choices that in #1

Re: No boot from CD-DVD

Posted: Mon Apr 27, 2015 10:19 am
by Pierre
if you press enter, on one of those other choices - can you change the boot device?.
- the Asus manual is a bit vague about, what you can do on this screen. :|

Re: No boot from CD-DVD

Posted: Mon Apr 27, 2015 10:31 am
by romualdo
Pierre, please.
Answer if you can help me otherwise let other people do it.
Thanks

Re: No boot from CD-DVD

Posted: Mon Apr 27, 2015 10:38 am
by Pierre
romualdo wrote:Pierre, please.
Answer if you can help me otherwise let other people do it.
Thanks
without having direct physical access to your PC, as how you have,
- it is difficult to access just what an issue is on some OPs PC. :o

you can see stuff, that your "helper" cannot see, - without some pictures / photo / etc.

however,
- it appears that your PC had win_8 on it originally, & either yourself,
or a friend has been able to install LinuxMint onto it.

that in itself, is quite an achievement. :D
- and anyone who is "helping" you - can only guess at how that was done. .. ..

Re: No boot from CD-DVD

Posted: Mon Apr 27, 2015 12:02 pm
by waldo
I have an Asus U47A and have had the same problem. I have it dual booting with Windows 8.1 and Mint 17.1. Maybe this will work for you also. It did for me.

In the BIOS, be sure SECURE BOOT CONTROL is DISABLED.

DISABLE FAST BOOT
ENABLE LAUNCH CSM
DISABLE LAUNCH PXE OPROM

You will have to set these last three settings back for Windows to run.

Edit: Actually I had some problems getting Windows to boot after this. Starting Windows in SAFE MODE seems to fix it. Just restart again in regular mode.

Re: No boot from CD-DVD

Posted: Tue Apr 28, 2015 10:39 am
by romualdo
Thanks so much Waldo.
Problem solved.

Re: No boot from CD-DVD

Posted: Tue Apr 28, 2015 5:40 pm
by waldo
Glad it worked for you!

These settings are also needed to boot from a USB stick.

Re: No boot from CD-DVD

Posted: Thu Apr 30, 2015 11:12 am
by romualdo
In my pc
to get the boot option from USB
i need to
ENABLE LAUNCH PXE OPROM