[Solved] No boot from USB after dual boot Win 8.1/mint 17.1

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
Steensen
Level 1
Level 1
Posts: 21
Joined: Tue Jun 30, 2015 11:35 pm

[Solved] No boot from USB after dual boot Win 8.1/mint 17.1

Post by Steensen » Wed Jul 01, 2015 7:05 am

Hey people.
New to this forum, but have been quite active in hardware forums like extremesystems.org and hwt.dk, but now the interest have changed from HW to SW, more specific, Linux. :mrgreen:

HW info: :oops:
Toshiba P850-332 pspkfe 06G00YN5
Intel I5 3230M (2,6GHz)
8GB RAM
nVidia 640M GFX + Intel on board HD4000.
V200 Kingston SSD 256GB
Blue-ray optical drive
Scandinavian keyboard
Ext. hdd: 1TB WD MyPassport USB3.0
Internet connection: Less than 250 kbit :( (I'm a sailor, and I'm at sea right now, witch is where I have the time for playing around with linux)

A few days ago, I managed to reduce my Windows partition by only 25GB in first attempt, due to "unmovable files" and made a 10GB / partition (/dev/sda8), and ~14GB /home (/dev/sda7), and no swap since I have 8GB RAM in my laptop, so rather wanted the space for programs/storage rather than swap.

Mint 17.1 MATE 64bit have got me even more interested and have already started to strip my files out of the dozer to an ext. hard-drive.
After some research, I reduced my dozer partition to 103GB, leaving approximately 100GB free in a block straight after dozer partition (/dev/sda4), and also deleted my recovery partition giving a 12GB free space at the end of my SSD, after /home partition and windows hidden crash analysis partition (/dev/sda5) .

Found a thread in this forum, of how to resize my partitions, and thought: Easy enough, just put in the USB stick that you ran live of initially, and later on installed from, and then get gparted, and fix it from there.
But NOOO :evil:

Grub suppresses my BIOS choice of loading from USB (8GB Kingston Data traveler), and comes up with the "normal" dual boot menu.
Same happens when pushing F12 to get the "one time boot menu", and choosing usb. :-(

So now I have stranded with a half empty SSD, a functional dual boot, both OS' bootable and boot loader functional, unable to merge my vacant space of the ssd to my / and/or /home partitions.
I have tried by means of gparted to make the 12gb to a swap partition at the end of the drive, but mint do not use it when re-starting the system. :?

Some wise guy out there that can give me some hints to how I can fix this, preferably without having to re-install the mint installation?

a) How do I create a bootable USB stick from my mint 17.1 ISO file, that will be able to get gparted integrated to i preferably, and be able to be bootable on all computers I plug it in to? (without having the need for a high speed Internet connection available)

b) How do I get the partitions expanded?

c) Is the 12gb "pocket" at the end of my ssd possible to get included in the / or /home, or should I "just" keep it a swap partition? If the latter, how do I get my mint to use it, automatically?

d) Can I make a common partition, where I can put my music and documents in to, that are accessible from both Windows and Mint?

Here is a screen dump with my gparted informations:
GParted_01-01-2015.png
Last edited by Steensen on Thu Jul 02, 2015 9:12 am, edited 1 time in total.
OS: Linux Mint 18.3-64-bit Cinamon
Laptop: Acer Predator 09-591-726M
CPU: Intel i7-6700HQ (2.6GHz), RAM: 16GB DDR4
GFX-1: Intel, GFX-2: NVIDIA GT 980M
476GB SDD; Win 10~240GB, /~220GB, swap~16GB
2TB HDD, DATA~2TB
Network: Kille AC-1535

Steensen
Level 1
Level 1
Posts: 21
Joined: Tue Jun 30, 2015 11:35 pm

Re: unable to boot from USB after dual boot Win 8.1/mint 17.

Post by Steensen » Thu Jul 02, 2015 6:10 am

Question a) and b) have been fixed now. :D
I installed USB-Creator-gtk, and used it to mount my LM17-1 Mate ISO file on my 8GB stick. :idea:
That way my F12 one time boot menu accepted it as a boot drive, and I could boot on it, use gparted included in it, and move and increase the size of my /dev/sda7 and /dev/sda8 partitions. 8)

Still looking for aswer for c) and d)
Anyone with a usable answer?

Edit:
Answers found for question C and D by enough surfing:
This is the answer to question c)
This is the answer to question d)
/edit
OS: Linux Mint 18.3-64-bit Cinamon
Laptop: Acer Predator 09-591-726M
CPU: Intel i7-6700HQ (2.6GHz), RAM: 16GB DDR4
GFX-1: Intel, GFX-2: NVIDIA GT 980M
476GB SDD; Win 10~240GB, /~220GB, swap~16GB
2TB HDD, DATA~2TB
Network: Kille AC-1535

User avatar
JOPETA
Level 15
Level 15
Posts: 5544
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: [Solved] No boot from USB after dual boot Win 8.1/mint 1

Post by JOPETA » Thu Jul 02, 2015 1:26 pm

Hi Steensen!

c)If you are going to to use hibernation, you will need Swap. I don't use with Mint installed in my SSD RAID0 so have no Swap in there, but use hibernation with Mint installed in my HD. Mint will use Swap "automatically" if detected or created when installing (it seems not to be your case, because Swap is not mounted). You can auto-activate swap using Disks app or adding an entry in etc/fstab.

First option (Menu>Accessories>Disks, select Swap partition, click on double wheels icon> Edit mount options>switch on "auto-mount" ) may fail because it is a special partition (see images bellow).
swap.png
mounting option.png
Adding Swap to fstab is very easy. First need to know UUID of your Swap. Use Disks (click on identify as in the mounting option window above to see UUID)or copy and paste following codes in a terminal to locate it

Code: Select all

sudo blkid
Then, edit fstab typing (replace "gedit" with your default text editor)

Code: Select all

sudo gedit /etc/fstab
Add following lines to the end but replacing UUID with yours (just copy and paste Swap UUID from the terminal or Disk indentify) and save the file.

Code: Select all

# swap was added later: 
UUID=956c6c28-5e88-4030-9df6-ebeb6523e7ce none	swap	 rw	0	0 
d) Yes. You can create a DATA partition but need to use NTFS or FAT file system (format) because Windows can/want not see Ext. file systems. Also you can auto-mount DATA if you want, as described above. :wink:

PS: Sorry, didn't see your "edited". In any case, I had prepared these for you before but need to change from my KDE to Cinnamon because of the images language. :cry:

Post Reply

Return to “Installation & Boot”