Error - Press S to skip mounting

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
EdQld
Level 2
Level 2
Posts: 88
Joined: Fri May 01, 2009 5:35 am

Error - Press S to skip mounting

Post by EdQld »

Having a succession of problems trying to get a Dual Boot of Mint 17.2 & Win 8.1 running on my wife's refurbished Acer AIO PC, I have ditched this PC and purchased a HP Pavilion 23 AIO PC

OK, process of getting this set-up as a Dual Boot PC benefited from the experience with the Acer and proceeded OK

Right, now to get her Mint installation as she wants it, with all her programs & settings. Using a Win Image backup program (Backupper) I made a copy of her recently configured Mint installation on the Acer (which was on D:/) to a Ext HDD

Next I Used Backupper programme in Win on the HP to “Restore” saved D:/ from Ext HDD containing fully configured Mint install from Acer PC (having successfully created a Dual Boot on the HP, with Mint also on D:/)

Result: corrupted Grub > Boot-Repair USB Disk created unstable repair, Mint boot sometimes produces error message “Keys: Continue to wait, or Press S to skip mounting or M for manual recovery” (Waiting not successful, key S loaded Mint successfully, same as on Acer PC) or produces blank frozen screen

Tried running Backupper System Restore image of C:/ restore to prior Dual Boot state, followed by Boot-repair USB Disk, but same result

Note, I did use NTFS-config with Acer Mint installation if that has any impact

Any suggestions for saving the configured Mint install on the HP and fixing Grub boot issues?

User avatar
Derek_S
Level 6
Level 6
Posts: 1279
Joined: Sat Dec 28, 2013 5:36 pm
Location: Long Island, N.Y.

Re: Error - Press S to skip mounting

Post by Derek_S »

Hello EdQld - Don't jump to the conclusion that this is a grub-related issue. When you see this particular error message, “Keys: Continue to wait, or Press S to skip mounting or M for manual recovery”, it indicates that there is a problem related to the file /etc/fstab, which defines the mount points for your Linux disk partitions. Either there is an error involving one or more entries, or an entry is missing altogether. I have a feeling that when you transferred these partitions from one disk to the other, one or more partitions were assigned new UUID's on the new disk, while the entries in /etc/fstab kept the original UUID's from the original disk. Here's how to check your if your UUID's don't match:

Boot into Linux Mint, open the Terminal, and enter " sudo blkid ". Take note: there is a UUID assigned to each disk partition. Leave that Terminal open, and open a second Terminal (yes, you can do that!). In the second Terminal, enter " sudo gedit /etc/fstab ". This will open a new panel showing the contents of /etc/fstab, which you can edit. You should shift these around so you can easily see the contents of both the Terminal and the file /etc/fstab.

Now, to explain: The information displayed by sudo blkid is the actual UUID assigned to the disk partition. The information displayed in /etc/fstab may or may not be correct. What you must do is verify that the UUID for every entry in /etc/fstab for every Linux partition matches what is displayed by sudo blkid. If you find a mis-match, you can very carefully delete just the UUID data string (not the entire line!) in /etc/fstab, then very carefully copy and paste the correct UUID data string from sudo blkid into the entry in fstab. If you take your time, be careful, and make certain you're using the correct UUID for every partition, you shouldn't have a problem.

Once you have done this, you must save the changes in /etc/fstab by doing the following: Go up and click "File", then click "Save" to save your changes. Then click "File" again, and click "Quit" to close the file. After doing this, you can close the two open Terminals, then reboot. If you got everything right, you will no longer see that error message displayed during system boot.

As far as your problem with seeing a blank screen at boot, does this occur when booting Windows, booting Linux Mint, or both? Or does this screen appear before you even see the grub boot menu? Also, is the screen completely blank, or do you see a flashing cursor in the top left corner of the screen?
"Truth is becoming rarer and rarer as time passes. It is only a matter of time before it will cease to exist."

EdQld
Level 2
Level 2
Posts: 88
Joined: Fri May 01, 2009 5:35 am

Re: Error - Press S to skip mounting

Post by EdQld »

Hi Derek_S, thanks very much for the help, I will try what you have suggested :)

re the Blank screen, it occurs only with Mint boot, after making the Grub selection, sometimes I get the error message & sometimes this completely blank screen (no blinking cursor)

Thank again, I will post back after trying your suggestions

EdQld
Level 2
Level 2
Posts: 88
Joined: Fri May 01, 2009 5:35 am

Re: Error - Press S to skip mounting

Post by EdQld »

when I pasted the command sudo gedit /etc/fstab, i get an error message: sudo: gedit: command not found

all41
Level 15
Level 15
Posts: 5751
Joined: Tue Dec 31, 2013 9:12 am
Location: Computer, Car, Cage

Re: Error - Press S to skip mounting

Post by all41 »

Hi EdQld,
After following Derek_S you can check your fstab for errors in a terminal before rebooting:

Code: Select all

 sudo mount -a
If this does not return errors you are good to go.
If it happens to return an error you can re edit the fstab

EdQld
Level 2
Level 2
Posts: 88
Joined: Fri May 01, 2009 5:35 am

Re: Error - Press S to skip mounting

Post by EdQld »

Outcomes

sudo: gedit: command not found

sudo blkid

/dev/sda1: LABEL="Windows RE tools" UUID="B4A48459A484204A" TYPE="ntfs"
/dev/sda2: LABEL="SYSTEM" UUID="B275-D23E" TYPE="vfat"
/dev/sda4: LABEL="Windows" UUID="B8DA5050DA500CCE" TYPE="ntfs"
/dev/sda5: LABEL="DATA" UUID="12DC299BDC297A5D" TYPE="ntfs"
/dev/sda6: UUID="0add6bf8-9fa7-455a-b1f4-9351494b1090" TYPE="swap"
/dev/sda7: UUID="f62300dc-334d-41c7-940b-87b221447453" TYPE="ext4"
/dev/sda8: LABEL="Recovery Image" UUID="3A967F17967ED2BD" TYPE="ntfs"

running: sudo mount -a (to check fstab for errors before rebooting)

ntfs-3g: Failed to access volume 'UUID=7EE41641E415FBD9': No such file or directory

ntfs-3g 2013.1.13AR.1 external FUSE 29 - Third Generation NTFS Driver
Configuration type 7, XATTRS are on, POSIX ACLS are on

Copyright (C) 2005-2007 Yura Pakhuchiy
Copyright (C) 2006-2009 Szabolcs Szakacsits
Copyright (C) 2007-2012 Jean-Pierre Andre
Copyright (C) 2009 Erik Larsson

Usage: ntfs-3g [-o option[,...]] <device|image_file> <mount_point>

Options: ro (read-only mount), windows_names, uid=, gid=,
umask=, fmask=, dmask=, streams_interface=.
Please see the details in the manual (type: man ntfs-3g).

Example: ntfs-3g /dev/sda1 /mnt/windows

News, support and information: http://tuxera.com

So there does seem to be an issue here, now how do I proceed to fix this?

User avatar
Derek_S
Level 6
Level 6
Posts: 1279
Joined: Sat Dec 28, 2013 5:36 pm
Location: Long Island, N.Y.

Re: Error - Press S to skip mounting

Post by Derek_S »

Hello EdQld - It's strange that gedit isn't already installed on your system. To install it from the Terminal:

sudo apt-get install gedit
"Truth is becoming rarer and rarer as time passes. It is only a matter of time before it will cease to exist."

EdQld
Level 2
Level 2
Posts: 88
Joined: Fri May 01, 2009 5:35 am

Re: Error - Press S to skip mounting

Post by EdQld »

Update:

OK, used sudo apt-get install gedit to get gedit

result did not show all sda's but the ones it did had different UUID's and the swap & ext4 were also wrong, corrected these, saved, quit and rebooted

Alas, Mint boot still alternating between frozen dark screen & needing Key S to proceed to load Mint :(

I may just have to start from scratch again and restore Win and then do a fresh install of Mint again :(

Post Reply

Return to “Installation & Boot”