Page 1 of 1

Need grubia32.efi

Posted: Sun Sep 13, 2015 3:38 pm
by Ultratech
Firstly, love Linux Mint! I have installed Linux Mint on numerous uefi systems over the last few years. All were 64-bit uefi systems, so never ran into any problems. But, installing on this Gateway LT41P02h Netbook has been a journey. It is a 64-bit processor with a 32-bit uefi and 32-bit Windows 8.1. I think I'm almost there though. I have managed to:

- resize Win 8.1 partition and ready for Linux install
- extracted Linux Mint 17.2 iso and added bootia32.efi file to boot folder
- converted folder to iso image and installed to usb drive with unetbootin
- boot Linux Mint 17.2 into live mode - works great - installed to free partition - all went perfectly well
- now I need to rework grub2 so that I have a grubia32.efi file, so I can boot Linux Mint

What I have tried so far:
- tried using Yannubuntu boot-repair in live cd to repair grub2 - didn't work, as it is using grubx64.efi instead of grubia32.efi
- If I temporarily enable secure boot in uefi bios, then choose the option to add a trusted OS, I can see Ubuntu listed, but if I choose it, it does not load
- if I try to manually boot the installed Linux Mint from live cd grub, I get cannot find (hd0,gpt8)

Where I'm at:
- My head is spinning, and I do not understand how to go about manually compiling a grubia32.efi from within the live cd and adding it to the correct boot folder. Can someone please lead me through these steps? Thank-you in advance.

Re: Need grubia32.efi

Posted: Sun Sep 13, 2015 5:18 pm
by Ultratech
just tried something else, which did not seem to work

- in live cd, I added yannubuntu repository and update synaptic package manager
- found grub-efi-ia32 in repository and installed it - it removed the grubx64 packages
- then created a mount folder in /mnt and mounted the installed linux partition
- installed yannubuntu boot-repair and ran it
- followed the prompts - it seemed to be installing 32 bit files and removing 64 bit files - seemed to also be updating the linux headers
- boot-repair finished without errors, but when I reboot, still no grub comes up, and it boots directly into windows
- So frustrating!!!!!

Re: Need grubia32.efi

Posted: Sun Sep 13, 2015 5:22 pm
by Ultratech
Also, I'm unable to boot into the installed system manually

I start up live cd, then hit 'c' at the grub menu

type linux (hd2,gpt8) /boot/vmlinuz-3.16.0-38-generic ro quiet splash

this seems to do something, then grub prompt comes up again

when I type initrd /boot/initrd.img-3.16.0-38-generic, it tells me that the image cannot be found

Now, I'm really confused.

Re: Need grubia32.efi

Posted: Sun Sep 13, 2015 9:58 pm
by Ultratech
Solved my issue. Sometimes we look for very complicated answers when the solution is simple.

For anyone else trying to install Linux Mint on a 32-bit UEFI system, here's how it's done.

1. Download the 64-bit Linux Mint ISO (I used the latest 17.2 Rafaela - Cinnamon)
2. Download the bootia32.efi file (I got mine from ... otia32.efi)
3. Add the bootia32.efi file to \EFI\Boot folder. I did this by extracting the ISO with AcetoneIS0, adding the bootia32.efi file, then repackaging the folder into an ISO, again with AcentoneISO
4. Booted back into Windows and used the windows disk partitioner to resize the Windows partition, and give space for the Linux install.
5. Installed the ISO to a flash drive with unetbootin - no special settings
6. Booted into the live cd and installed Linux Mint as normal, with no special considerations - just make sure to choose the option to install the boot loader to the EFI partition (in my case was sda2)
7. When install was finished, I rebooted the LIVE CD. When the grub menu appeared, I hit 'c' to get the grub prompt, then I manually booted into Linux Mint - in my case, I typed: Linux (hd2,gpt8)/boot/vmlinuz-3.16.0-38-generic root=/dev/sda8 ro quiet splash, then ENTER. When the grub prompt appears, I typed: initrd (hd2,gpt8)/boot/initrd.img-3.16.0-38-generic, then ENTER. When the grub prompt appears a third time, I typed: boot
8. When your Linux Mint install boots, install grub-efi-ia32 with the synaptic package manager. It will install the 32-bit binaries and remove the 64-bit binaries.
9. When grub-efi-ia32 is done installing, open a terminal, and type: sudo update-grub.
10. And hooray! When you reboot, the grub menu will be there (with Linux Mint and Windows entries), and you'll be able to boot into your beautiful Linux Mint 17.2 install!