boot process fails to remount root filesystem as read-write

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 8
Joined: Tue Jan 20, 2009 11:05 pm

boot process fails to remount root filesystem as read-write

Postby hapihakr » Thu Jan 22, 2009 2:31 am

I'm running Linux Mint 6 Felicia. I recently upgraded to kernel 2.6.27-9-generic. Subsequently the boot process halted with error messages about the filesystem being read-only. I was able to boot to recovery mode and able to continue the normal boot process from the recovery menu. I discovered that if I remove the splash kernel option from the grub menu.lst file then the boot process continues properly, but with the splash option the kernel fails to remount the filesystem as read-write and I consequently get the read-only filesystem error messages and a halted boot process. I tried a number of different options before stumbling on this discovery, but I have confirmed this behavior on my system repeatedly.

It's not that big of a problem, but I would like to know why this is happening. Any ideas?

Here is the pertinent part of my menu.lst file:

title Linux Mint 6, kernel 2.6.27-9-generic
root (hd0,0)
#kernel /boot/vmlinuz-2.6.27-9-generic root=/dev/sda1 ro quiet splash
#kernel /boot/vmlinuz-2.6.27-9-generic root=/dev/sda1 ro quiet
#kernel /boot/vmlinuz-2.6.27-9-generic root=/dev/sda1 ro splash
kernel /boot/vmlinuz-2.6.27-9-generic root=/dev/sda1 ro
#kernel /boot/vmlinuz-2.6.27-9-generic root=/dev/sda1 rw
initrd /boot/initrd.img-2.6.27-9-generic

title Linux Mint 6, kernel 2.6.27-9-generic (recovery mode)
root (hd0,0)
kernel /boot/vmlinuz-2.6.27-9-generic root=/dev/sda1 ro single
initrd /boot/initrd.img-2.6.27-9-generic

Level 23
Level 23
Posts: 18703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: boot process fails to remount root filesystem as read-write

Postby Husse » Fri Jan 23, 2009 6:58 am

This is odd and hard to find anything out about it
What happens if you have quiet and not splash after ro or splash but not quiet?
Don't fix it if it ain't broken, don't break it if you can't fix it

Level 1
Level 1
Posts: 1
Joined: Thu Mar 12, 2009 7:09 am

Re: boot process fails to remount root filesystem as read-write

Postby molecula21 » Thu Mar 12, 2009 7:16 am

i have a similar problem but i have'nt tried to disable the splashscreen option. it happens on 2 machines (one desktop and one laptop). the filesystem is totally srewed and i have to enter in maintenance mode every time. Plus, the cpu gets to 100% very often and the computer doesn't respond for a few minuts... i haven't find the process responsable for this since "top" seams to be blocked as well... i'm running on linux mint felicia xfce.


User avatar
Level 10
Level 10
Posts: 3339
Joined: Fri Jan 04, 2008 11:59 am
Location: NC USA

Re: boot process fails to remount root filesystem as read-write

Postby Fred » Thu Mar 12, 2009 7:32 am


kernel 2.6.27-9 seems to be a problem child kernel. There are reports of numerous problems related to the boot process. I imagine your best bet would be to either drop back 1 intergeneration or go on to the 2.6.27-11 kernel.

Insanity: Doing the same thing over and over and each time expecting a different result.

Democracy is 2 wolves and a lamb voting on the menu. Liberty is an armed lamb protesting the electoral outcome. A Republic negates the need for an armed protest.

Return to “Installation & Boot”

Who is online

Users browsing this forum: No registered users and 9 guests