no autologin Mint 18 Cinnamon

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
User avatar
ehtron
Level 6
Level 6
Posts: 1000
Joined: Thu Apr 14, 2016 8:15 am
Location: Germany / Baltic Sea
Contact:

no autologin Mint 18 Cinnamon

Post by ehtron » Wed Jun 15, 2016 6:54 am

Hi :)
i have a problem with Mint 18 cinnamon 64bit an auto login..
allways the login screen..
with nouveau also same.
here the system

Code: Select all

inxi -Fz
System:    Host: eslinux-Main Kernel: 4.4.0-24-generic x86_64 (64 bit)
           Desktop: Cinnamon 3.0.5  Distro: Linux Mint 18 Sarah
Machine:   Mobo: ASUSTeK model: P5P41C v: Rev X.0x
           Bios: American Megatrends v: 0604 date: 02/10/2011
CPU:       Dual core Pentium E5400 (-MCP-) cache: 2048 KB 
           clock speeds: max: 2700 MHz 1: 2003 MHz 2: 1603 MHz
Graphics:  Card: NVIDIA G98 [GeForce 9300 GE]
           Display Server: X.Org 1.18.3 driver: nvidia
           Resolution: 1680x1050@59.88hz, 1680x1050@59.88hz
           GLX Renderer: GeForce 9300 GE/PCIe/SSE2
           GLX Version: 3.3.0 NVIDIA 340.96
Audio:     Card Intel NM10/ICH7 Family High Definition Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.4.0-24-generic
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169
           IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter>
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 43.0C mobo: 38.0C gpu: 74C
           Fan Speeds (in rpm): cpu: 1339 sys-1: 0
Info:      Processes: 192 Uptime: 1:06 Memory: 2406.5/3951.2MB
           Client: Shell (bash) inxi: 2.2.35 

all settings in /etc/mdm/mdm.conf seems ok

Code: Select all

[daemon]
AutomaticLoginEnable=true
AutomaticLogin=ehtron
TimedLoginEnable=true
TimedLogin=ehtron
TimedLoginDelay=1

Greeter=/usr/lib/mdm/mdmwebkit

DefaultSession=cinnamon.desktop

[security]

AllowRoot=false

[xdmcp]

[gui]

[greeter]

HTMLTheme=Mint-X

BackgroundType=2

DefaultWelcome=true
also two mdm logs on the same boot /var/log/mdm
0.log

Code: Select all

mdm[2281]: DEBUG: mdm_server_spawn: '/usr/bin/X :0 -audit 0 -auth /var/lib/mdm/:0.Xauth -nolisten tcp vt7'

X.Org X Server 1.18.3
Release Date: 2016-04-04
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.13.0-86-generic x86_64 Ubuntu
Current Operating System: Linux eslinux-Main 4.4.0-24-generic #43-Ubuntu SMP Wed Jun 8 19:27:37 UTC 2016 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.4.0-24-generic root=UUID=ec411e9a-4a28-4091-ad3c-ab4691297961 ro quiet splash
Build Date: 18 May 2016  01:07:07AM
xorg-server 2:1.18.3-1ubuntu2.2 (For technical support please see http://www.ubuntu.com/support) 
Current version of pixman: 0.33.6
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Jun 15 11:29:54 2016
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
>                   Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
>                   Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server
and 0.log1

Code: Select all

mdm[1174]: DEBUG: mdm_server_spawn: '/usr/bin/X :0 -audit 0 -auth /var/lib/mdm/:0.Xauth -nolisten tcp vt7'

X.Org X Server 1.18.3
Release Date: 2016-04-04
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.13.0-86-generic x86_64 Ubuntu
Current Operating System: Linux eslinux-Main 4.4.0-24-generic #43-Ubuntu SMP Wed Jun 8 19:27:37 UTC 2016 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.4.0-24-generic root=UUID=ec411e9a-4a28-4091-ad3c-ab4691297961 ro quiet splash
Build Date: 18 May 2016  01:07:07AM
xorg-server 2:1.18.3-1ubuntu2.2 (For technical support please see http://www.ubuntu.com/support) 
Current version of pixman: 0.33.6
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Jun 15 11:29:35 2016
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
>                   Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server
(II) Server terminated successfully (0). Closing log file.
debug mode of MDM i see starting mdm more times.

here attach mdm-debug.pdf.. can't input the text direct into the post.. to much characters and .txt as attachment also not :(

is this a beta or a mdm problem?
regards ehtron
Attachments
mdm-debug.pdf
(45.93 KiB) Downloaded 110 times
Last edited by ehtron on Tue Jun 21, 2016 10:40 am, edited 1 time in total.
Lg. Ehtron :)
Bitte genutzte Version und Desktop angeben. Ansonsten oft keine Hilfe möglich.
Ich gebe Hilfe zur Selbsthilfe.

Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: no autologin Mint 18 Cinnamon

Post by Cosmo. » Wed Jun 15, 2016 8:16 am

TimedLoginDelay=1 looks bad, The minimum value (via GUI settings) is 10. Probably your low value gives a problem, because 2 auto-login mechanism might interfere (not tested).

This value is anyway out of interest for the first autologin after reboot, but only in case you log out and back in.

User avatar
ehtron
Level 6
Level 6
Posts: 1000
Joined: Thu Apr 14, 2016 8:15 am
Location: Germany / Baltic Sea
Contact:

Re: no autologin Mint 18 Cinnamon

Post by ehtron » Wed Jun 15, 2016 8:19 am

Hi :)
i have set (test for faster autologin on greeter screen)
the TimedLoginDelay=1 ..
with 10 always the same .. get the login greeter show always..
regards ehtron :)
Lg. Ehtron :)
Bitte genutzte Version und Desktop angeben. Ansonsten oft keine Hilfe möglich.
Ich gebe Hilfe zur Selbsthilfe.

Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: no autologin Mint 18 Cinnamon

Post by Cosmo. » Wed Jun 15, 2016 8:32 am

With a second look I see, that you have 2 additional settings in the daemon section, which are at least uncommon. I speak about Greeter and DefaultSession. Remove or comment them out (# in front) and test.

User avatar
ehtron
Level 6
Level 6
Posts: 1000
Joined: Thu Apr 14, 2016 8:15 am
Location: Germany / Baltic Sea
Contact:

Re: no autologin Mint 18 Cinnamon

Post by ehtron » Wed Jun 15, 2016 8:43 am

Hi :)
have test that..
greeter rem #
but no changed.. start with login slideshow
Lg. Ehtron :)
Bitte genutzte Version und Desktop angeben. Ansonsten oft keine Hilfe möglich.
Ich gebe Hilfe zur Selbsthilfe.

Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: no autologin Mint 18 Cinnamon

Post by Cosmo. » Wed Jun 15, 2016 8:50 am

Create a new user account and set this account for autologin.

User avatar
ehtron
Level 6
Level 6
Posts: 1000
Joined: Thu Apr 14, 2016 8:15 am
Location: Germany / Baltic Sea
Contact:

Re: no autologin Mint 18 Cinnamon

Post by ehtron » Wed Jun 15, 2016 10:08 am

Hi :)
have made some tests.
mdm.conf set to default (after a look in my vbox 18 cin installaton, there the autologin works)

Code: Select all

[daemon]
AutomaticLoginEnable=true
AutomaticLogin=ehtron
TimedLoginEnable=true
TimedLogin=ehtron
TimedLoginDelay=10

[security]

[xdmcp]

[gui]

[greeter]

[chooser]

[debug]

[servers]

(some # text in this post remove)

test with a new user... no success.
i think, the xorg / mdm / plymouth startups are before login.

create a xorg.conf in /etc/X11/ with the nvidia-server tool...

all that without success .. :(

i forgot to say, i have a 2 monitor installation. 2*dvi set into screens already. works fine ;)
on my 17.3 installation can set the main monitor in the login-window tool / options,
but on 18 this selector is empty.. possibly is this a point to find the problem.


regards ehtron :)
Lg. Ehtron :)
Bitte genutzte Version und Desktop angeben. Ansonsten oft keine Hilfe möglich.
Ich gebe Hilfe zur Selbsthilfe.

Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: no autologin Mint 18 Cinnamon

Post by Cosmo. » Wed Jun 15, 2016 10:55 am

You should report this 2-monitor-problem here.

User avatar
ehtron
Level 6
Level 6
Posts: 1000
Joined: Thu Apr 14, 2016 8:15 am
Location: Germany / Baltic Sea
Contact:

Re: no autologin Mint 18 Cinnamon

Post by ehtron » Wed Jun 15, 2016 11:07 am

Last edited by ehtron on Thu Jun 16, 2016 12:52 pm, edited 1 time in total.
Lg. Ehtron :)
Bitte genutzte Version und Desktop angeben. Ansonsten oft keine Hilfe möglich.
Ich gebe Hilfe zur Selbsthilfe.

User avatar
ehtron
Level 6
Level 6
Posts: 1000
Joined: Thu Apr 14, 2016 8:15 am
Location: Germany / Baltic Sea
Contact:

Re: no autologin Mint 18 Cinnamon

Post by ehtron » Wed Jun 15, 2016 2:09 pm

Hi :)
new tipps to solve the problem, welcome :)
Lg. Ehtron :)
Bitte genutzte Version und Desktop angeben. Ansonsten oft keine Hilfe möglich.
Ich gebe Hilfe zur Selbsthilfe.

Trapper
Level 4
Level 4
Posts: 352
Joined: Sat Dec 03, 2011 12:21 pm
Location: Sebring, Florida USA

Re: no autologin Mint 18 Cinnamon

Post by Trapper » Wed Jun 15, 2016 4:52 pm

LM18 beta MATE 64

I have the same situation with several LM 18 beta installs. Auto login always fails. The login screen presents and requires me to physically select user even though there is only one user and that user is assigned to auto login. Once I select user no password is required bu it surely is not auto login if I have to select a user to continue login. Have never had this problem from LM 13 onward until 18.

I've yet to find a resolve for the problem. I did mention it in blog comments for the LM 18 beta release so Clem & team could be aware there's a problem.

NOTE:
I have edited out and retract my statements concerning timed logins of less than 10. It was also 10 or more in previous releases.

Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: no autologin Mint 18 Cinnamon

Post by Cosmo. » Wed Jun 15, 2016 5:34 pm

I don't see the problem here - otherwise I would have confirmed the problem. So it seems, that the problem appears only in certain configurations. Give the developers as much information as you can and some time, to go into it. That is the reason, why a beta does exist.

Trapper
Level 4
Level 4
Posts: 352
Joined: Sat Dec 03, 2011 12:21 pm
Location: Sebring, Florida USA

Re: no autologin Mint 18 Cinnamon

Post by Trapper » Wed Jun 15, 2016 6:41 pm

Cosmo. wrote:I don't see the problem here - otherwise I would have confirmed the problem. So it seems, that the problem appears only in certain configurations. Give the developers as much information as you can and some time, to go into it. That is the reason, why a beta does exist.
The problem is simple. We've set up a user to automatically login but the auto login doesn't happen. The login window still comes up and bootup halts until the user that's already configured for auto login is selected at a login screen to continue the boot. Auto login is not suppose to have any login screen or require any user interaction.

Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: no autologin Mint 18 Cinnamon

Post by Cosmo. » Thu Jun 16, 2016 4:56 am

Trapper wrote:The problem is simple. We've set up a user to automatically login but the auto login doesn't happen. The login window still comes up and bootup halts until the user that's already configured for auto login is selected at a login screen to continue the boot.
As I wrote: Not here. On my system autologin works as it always did in previous Mint versions. So there must be some special configuration, which triggers the problem.

Trapper
Level 4
Level 4
Posts: 352
Joined: Sat Dec 03, 2011 12:21 pm
Location: Sebring, Florida USA

Re: no autologin Mint 18 Cinnamon

Post by Trapper » Thu Jun 16, 2016 6:46 am

Cosmo. wrote: On my system autologin works as it always did in previous Mint versions. So there must be some special configuration, which triggers the problem.
Okay, thanks but I don't know what that 'special' configuration could be seeing that it can be the first thing I set after LM 18 installation and it fails without touching anything else on the system. The closest I can get to auto login is the login screen being presented and having timed login also setup. Then, after 10 seconds the bootup continues. But that's not suppose to happen either if auto login is configured.

Most importantly, LM 17.2, LM 17.3 and LMDE 2 on the very same box all have correctly working auto login. Sounds like a bug in LM 18 to me. Whatever, Clem has been clued in on the blog. That's how problem notifications are handled with a beta/RC. If you know of another way, please inform me.
Last edited by Trapper on Thu Jun 16, 2016 12:50 pm, edited 1 time in total.

Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: no autologin Mint 18 Cinnamon

Post by Cosmo. » Thu Jun 16, 2016 7:46 am

Trapper wrote:The closet I can get to auto login is the login screen being presented and having timed login also setup. Then, after 10 seconds the bootup continues.
There are 2 autologin options in Mint: The first one (Autologin enabled) is only relevant in case you boot up and means, that without showing the login screen the selected user gets logged in automatically.

The second option (timed autologin) is relevant primarily in case, that a user logs off and you get back into the login screen. With the second autologin option you see the login screen and a countdown message and you get logged in to the user, which you had set in the settings, when the time has expired.

Your description sounds, as if after bootup the first autologin mechanism does not work and so the timed login mechanism reacts.
As I already wrote, I cannot confirm this problem and I also have no idea, why this behaves for you different for my system. So my only guess is, that this is probably a bug, which only shows in certain configurations.

User avatar
ehtron
Level 6
Level 6
Posts: 1000
Joined: Thu Apr 14, 2016 8:15 am
Location: Germany / Baltic Sea
Contact:

Re: no autologin Mint 18 Cinnamon

Post by ehtron » Thu Jun 16, 2016 9:00 am

Hi :)
i'm not shure.. but i think the bug comes with the update to
mdm 2.0.9 on 2016-May-25.


nonsense.. the beta comes out on 2016-june-07 with 2.0.9 include ;)

regards ehtron :)
Last edited by ehtron on Thu Jun 16, 2016 11:47 am, edited 2 times in total.
Lg. Ehtron :)
Bitte genutzte Version und Desktop angeben. Ansonsten oft keine Hilfe möglich.
Ich gebe Hilfe zur Selbsthilfe.

User avatar
clem
Level 12
Level 12
Posts: 4125
Joined: Wed Nov 15, 2006 8:34 am
Contact:

Re: no autologin Mint 18 Cinnamon

Post by clem » Thu Jun 16, 2016 9:46 am

Hi,

If your home directory is encrypted, you CANNOT autologin (and your name won't appear in the combobox where you choose which user is supposed to be auto-logged in).
Image

User avatar
ehtron
Level 6
Level 6
Posts: 1000
Joined: Thu Apr 14, 2016 8:15 am
Location: Germany / Baltic Sea
Contact:

Re: no autologin Mint 18 Cinnamon

Post by ehtron » Thu Jun 16, 2016 10:31 am

Hi Clem :)
my system is not encrypted ..

do you observed my attachment? mdm debug?

btw.. good job with LM18 cin.. now i work with this as my daily working system.
this is the only problem.. sometimes the icons lost her place on the lower right side on my second screen.. but its only cosmetic at the moment :)

regards ehtron
Lg. Ehtron :)
Bitte genutzte Version und Desktop angeben. Ansonsten oft keine Hilfe möglich.
Ich gebe Hilfe zur Selbsthilfe.

Trapper
Level 4
Level 4
Posts: 352
Joined: Sat Dec 03, 2011 12:21 pm
Location: Sebring, Florida USA

Re: no autologin Mint 18 Cinnamon

Post by Trapper » Thu Jun 16, 2016 12:49 pm

clem wrote:Hi,

If your home directory is encrypted, you CANNOT autologin (and your name won't appear in the combobox where you choose which user is supposed to be auto-logged in).
I do not have encrypted home, per se, Clem. I do have full disk encryption on this drive though but that's unlocked prior to system bootup. I also have my user name available in in the combobox. I still am unable to auto login though. The login window always appears. As I stated previously, I have never experienced this problem with LM 13 thru LM 17.3 on any of my machines. It didn't appear until LM 18.

Post Reply

Return to “Installation & Boot”