no autologin Mint 18 Cinnamon

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: no autologin Mint 18 Cinnamon

Post by Cosmo. » Mon Jun 20, 2016 4:30 pm

Ok. After the 2 replies I did a quick search. It seems, that TTY1 gets a special usage with systemd. I don't consider this as a problem, but I wanted to take the chance to check, if this would be specialty on my system. It is not.

Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: no autologin Mint 18 Cinnamon

Post by Cosmo. » Tue Jun 21, 2016 6:56 am

After having lost the auto-login function today again I updated systemd (it is level 4 update, so not visible by default). After rebooting auto-login worked (without doing anything else except the update). I will wait 1 or 2 days before I consider this as solution. It would be interesting to know, if this helps other affected users.

(What the update did not solve is the terrible longer boot-time in comparison to LM 17.x.)

User avatar
ehtron
Level 6
Level 6
Posts: 1016
Joined: Thu Apr 14, 2016 8:15 am
Location: Germany / Baltic Sea
Contact:

Re: no autologin Mint 18 Cinnamon

Post by ehtron » Tue Jun 21, 2016 8:08 am

Hi :)
@cosmo
I updated systemd
hmm.. i got no systemd update..
i use full-level in updater. all 5 levels on and use the standard server. no mirror.
do you use a special ppa?
Lg. Ehtron :)
Bitte genutzte Version und Desktop angeben. Ansonsten oft keine Hilfe möglich.
Ich gebe Hilfe zur Selbsthilfe.

Trapper
Level 4
Level 4
Posts: 353
Joined: Sat Dec 03, 2011 12:21 pm
Location: North Port, Florida USA

Re: no autologin Mint 18 Cinnamon

Post by Trapper » Tue Jun 21, 2016 8:14 am

[quote="Cosmo."]... I updated systemd (it is level 4 update, so not visible by default). After rebooting auto-login worked (without doing anything else except the update). I will wait 1 or 2 days before I consider this as solution. It would be interesting to know, if this helps other affected users.

Updating to the level 4 systemd does absolutely nothing for us here. Our determination, at this point, is that timed login is functional in LM 18 but auto login is broken. Different machines here substantiate that. We have concluded all investigation and testing that we are willing to do. This is a dev problem and we'll simply wait on the real fix.

Trapper
Level 4
Level 4
Posts: 353
Joined: Sat Dec 03, 2011 12:21 pm
Location: North Port, Florida USA

Re: no autologin Mint 18 Cinnamon

Post by Trapper » Tue Jun 21, 2016 8:24 am

ehtron wrote:Hi :)

hmm.. i got no systemd update..
i use full-level in updater. all 5 levels on and use the standard server. no mirror.
do you use a special ppa?
No special ppa ehtron. It's in level 4 updates. Mine updated to systemd_229-4ubuntu6_amd64.deb Check and see what you have installed.

User avatar
ehtron
Level 6
Level 6
Posts: 1016
Joined: Thu Apr 14, 2016 8:15 am
Location: Germany / Baltic Sea
Contact:

Re: no autologin Mint 18 Cinnamon

Post by ehtron » Tue Jun 21, 2016 8:38 am

Hi :)

229.ubuntu6 also here.
no newer the last days.
i got it on my full dist-upgrade after installation
2016-06-08
Lg. Ehtron :)
Bitte genutzte Version und Desktop angeben. Ansonsten oft keine Hilfe möglich.
Ich gebe Hilfe zur Selbsthilfe.

Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: no autologin Mint 18 Cinnamon

Post by Cosmo. » Tue Jun 21, 2016 8:39 am

ehtron wrote:hmm.. i got no systemd update..
i use full-level in updater. all 5 levels on and use the standard server. no mirror.
do you use a special ppa?
I know that you apply all levels in general. :wink: So obviously the systemd update has been on your system already since some time.
No, I do not use a special PPA. I spoke about the update in the official repos.
Trapper wrote:This is a dev problem
Absolutely. My attempt is to try to break it down, as far as I can.

The situation on my LM 18 system is this: If auto-login stops to work I had made it in the last days with some tricks (which might or might not be related to the origin of the problem, but worked at the end) working again. Than auto-login worked here for the rest of the same day. On the first boot on the following day it stopped to work. So today also. Today no try to revive it was successful, so I tried it with the systemd update and after that auto-login worked again. I am really eager to see, how it behaves tomorrow; but for that I have to wait until tomorrow. (Out of some reasons I do not want to change the system clock manually.) The reason, why I reported and asked you here was to combine the experience of different users about the result. Now that I know them I am not really confident.

To be honest, my hope and my confidence for a quick solution is very limited, because the problem got reported for Ubuntu since 15.04 (that means for a complete year) and it would be a dev job for the Ubuntu devs to solve the problem. How likely is this for the next few weeks, if in the last year no solution has been found?
This and the comparably much longer boot time makes it doubtful, if Sarah will get my next girl-friend. Rosa behaves much more friendly to me. :wink:
As I do my observations and tests in virtual machine I can eliminate the aspect, that this might be something related with my hardware.

User avatar
ehtron
Level 6
Level 6
Posts: 1016
Joined: Thu Apr 14, 2016 8:15 am
Location: Germany / Baltic Sea
Contact:

Re: no autologin Mint 18 Cinnamon

Post by ehtron » Tue Jun 21, 2016 8:47 am

Hi :)
@cosmo
agree :)

in my view, there is a timing problem on systemd bootup..
Lg. Ehtron :)
Bitte genutzte Version und Desktop angeben. Ansonsten oft keine Hilfe möglich.
Ich gebe Hilfe zur Selbsthilfe.

Trapper
Level 4
Level 4
Posts: 353
Joined: Sat Dec 03, 2011 12:21 pm
Location: North Port, Florida USA

Re: no autologin Mint 18 Cinnamon

Post by Trapper » Tue Jun 21, 2016 9:00 am

Cosmo. wrote: This and the comparably much longer boot time makes it doubtful, if Sarah will get my next girl-friend. Rosa behaves much more friendly to me. :wink:
Actually. my main squeeze is still at Rafaela. The kernel(s) in Rosa don't play well with some Logitech wireless keyboards.Form boxes, fill-in-the blanks, etc., text boxes, often fill up with 5's all on their own and will continue filling until it locks everything up. Extremely irritating. That problem rolled over to Sarah. Even the level 5 kernel is affected. However, there's a test patch in a kernel bewtween LM 18's current and it's level 5 that fixes things. They are going to include patches for most current Ubuntu supported kernels shortly. I worked with the auto login without and with the patch and it naturally had no effect or bearing, either way. It did thankfully fix the 55555555555555's problem though.

Trapper
Level 4
Level 4
Posts: 353
Joined: Sat Dec 03, 2011 12:21 pm
Location: North Port, Florida USA

Re: no autologin Mint 18 Cinnamon

Post by Trapper » Tue Jun 21, 2016 12:54 pm

Uh....hum....in the interim...lightdm seems to afford me a real auto login. At least I installed it and after editing lightdm.conf I was able to auto login after reboot/shut down several times. I'll keep using it for a while and see how it does. Maybe it will work as a fill-in until mdm is fixed.

Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: no autologin Mint 18 Cinnamon

Post by Cosmo. » Wed Jun 22, 2016 6:00 am

@Trapper:

I only now saw your comment / question here. (This blog might probably be a usable method for Clem to collect bug reports, but from the standpoint of a user / reader this is horrible. You can never exactly say, what you have read and what not, because moderated comments get inserted after reviewing them (instead of being added at the time of review) and the numbers of the comments from yesterday are not the same today. So it is predictable, that comments / questions get overlooked (except by Clem). Out of this reason I answer you here.)

No, I do not see such a message. Shutting down works here nearly perfectly: In between a few seconds and without any message. The only thing which does not work for me at shutting down is the display of the Mint logo (which also - as already reported - does not show when booting).


BTW:
I rebooted the system yesterday short before midnight for the last time and auto-login still worked. Today it has stopped again to function. It really looks, as if the date change triggers anything, but what and why?

Trapper
Level 4
Level 4
Posts: 353
Joined: Sat Dec 03, 2011 12:21 pm
Location: North Port, Florida USA

Re: no autologin Mint 18 Cinnamon

Post by Trapper » Wed Jun 22, 2016 7:03 am

@Cosmos:

Sorry that I cannot help you with the time/date thing. We get no auto login at any time with mdm other than first bootup after an install.

I agree. In my opinion the blog setup is not being used in the way it should be in regards to commenting. Specifically, I think bug reports, problems encountered, etc. for beta/RC should not be integrated into announcement comments. There should be a specific reporting page for that where rants and raves, etc. do not interfere. Actually, I am in favor of a temporary section being opened in the forum that coincides with beta releases where bugs, problems, etc. can be posted for that release. JMO.

Here we do still note the 'not responding' message from time to time and then delayed shutdown after it. Other times we simply have very slow shutdown as if something is not happening correctly and timeouts are being met prior to shutdown proceeding. Other times shutdown comes quickly. It's difficult to find a common denominator though. Then, of course, there's the lengthy delay in bootup. It generally only varies minimally but occasionally a bootup takes even an extra 30 seconds or so above the already lengthy bootup.

Whatever, this is just beta. It's not going to work like we want it to.

User avatar
don250r
Level 3
Level 3
Posts: 143
Joined: Thu Feb 11, 2016 2:41 pm

Re: no autologin Mint 18 Cinnamon

Post by don250r » Thu Jun 23, 2016 11:46 am

Dont know if this has any bearing on your situations,
http://unix.stackexchange.com/questions ... th-systemd
Mint 18 Cinnamon, 4.6.3 kernel
Intel i5-2500k@4.8GHz
16 Gb DDR3
Nvidia GTX670

User avatar
clem
Level 12
Level 12
Posts: 4128
Joined: Wed Nov 15, 2006 8:34 am
Contact:

Re: no autologin Mint 18 Cinnamon

Post by clem » Thu Jun 23, 2016 1:35 pm

Hi,

I can't reproduce this issue. I tried on 3 different machines, with SSD, with HDD, with a VM... with and without updates. It works always for me.

There's something I'm missing, probably something which is common to you and which I don't have.. a different locale maybe, some driver (I tried with intel, nvidia/with/without prime..)?

I could do with some MDM logs too..

- Enable the log option in mdmsetup
- Reboot
- As soon as autologin fails and you see the login screen, switch to CTRL+ALT+F2
- log in console
- type "grep mdm /var/log/syslog | pastebin"
- paste the link

Move the paste to another service if possible too... our pastebin only keeps text for 2 days.
Image

Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: no autologin Mint 18 Cinnamon

Post by Cosmo. » Thu Jun 23, 2016 2:42 pm

@Clem

as I wrote in my comments in the blog also, in my case this is a virtual machine in VirtualBox. So we can exclude any exotic hardware. No usb-device has been ever added to that machine, no usb filter has been created. My locale is German. (BTW: I happen to know that is also true for ehtron.)

Installed software (all except the guest additions from the official repositories; no PPA has been added):
VirtualBox guest editions for VB 4.3.38 (I use this version). The same gets used of course for all my Mint 17.x machines (totally 6), which all work reliably with auto-login enabled.
ocrfeeder (for checking a problem, which I have already reported; in the meantime removed again)
vlc (for checking a problem, that another user reported; in the meantime removed again)
system-config-samba (for checking a problem, that another user reported)

At first only level 1 to 3 have been applied. Only after I noticed, that auto-login did not work correctly I applied updates for systemd and later also upstart (both without any change regarding of the problem).

No special system changes have been done except adding a second user account. The second user is set on English locale. (I mention this, because you mentioned the keyword locale.)
Furthermore I have removed - following your advice here - btrfs-tools.

The purpose of the machine is bug-hunting in Sarah, nothing else.

I have following your advice activated MDM logs and rebooted. Do you guess, what happened? The same as if you go with some pain to the doctor: If you are there, the pain is gone. I mean, after that auto-login worked. In this case I am unhappy, that it did. :roll:

That is the difference here in contrast to other users: After some (more or less unrelated) tasks in my account auto-login "decides" to work again. That is the case since some days. Once auto-login works, it continues to do so for the rest of the day. Then on the next day (guest and host both properly shut down before I go to bed) auto-login stops to work (that is the only thing, what I can predict reliably).

EDIT: I forgot to mention: No encryption here at all.
Last edited by Cosmo. on Thu Jun 23, 2016 5:46 pm, edited 1 time in total.

Trapper
Level 4
Level 4
Posts: 353
Joined: Sat Dec 03, 2011 12:21 pm
Location: North Port, Florida USA

Re: no autologin Mint 18 Cinnamon

Post by Trapper » Thu Jun 23, 2016 3:48 pm

@ clem

I don't have a /var/log/system so here's my mdm from /var/log/syslog:

http://ledduk.net/paste/syslog-mdm.txt


This was from a totally fresh install. No updates. No nothing. This log is after 2nd bootup. I selected auto login in the installer. I got the login window on first boot and I just let it sit and allowed the timed login (why does the installer activate that?) to do it's thing. Previously, when I did an install and selected auto login I did get a bonifide auto login however, on a reboot I got the login window and had to select my username (without password) to log in.

I have full disk encryption on this machine's HD. In this lvm setup I also have installs of LMDE2 MATE and LM 17.2 MATE. Auto login works correctly with both of those installs.

US English.

Here's my /var/log/mdm log info too:

Code: Select all

mdm[1349]: DEBUG: mdm_server_spawn: '/usr/bin/X :0 -audit 0 -auth /var/lib/mdm/:0.Xauth -nolisten tcp vt8'

X.Org X Server 1.18.3
Release Date: 2016-04-04
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.13.0-85-generic x86_64 Ubuntu
Current Operating System: Linux Shade 4.4.0-21-generic #37-Ubuntu SMP Mon Apr 18 18:33:37 UTC 2016 x86_64
Kernel command line: BOOT_IMAGE=/vmlinuz-4.4.0-21-generic root=/dev/mapper/thrice-root18 ro quiet splash vt.handoff=7
Build Date: 07 April 2016  09:18:50AM
xorg-server 2:1.18.3-1ubuntu2 (For technical support please see http://www.ubuntu.com/support) 
Current version of pixman: 0.33.6
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Jun 23 15:09:37 2016
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(II) [KMS] Kernel modesetting enabled.
(II) AIGLX: Suspending AIGLX clients for VT switch
Last edited by Trapper on Fri Jun 24, 2016 6:51 am, edited 2 times in total.

Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: no autologin Mint 18 Cinnamon

Post by Cosmo. » Fri Jun 24, 2016 5:06 am

Update:

Today I started the LM 18 machine - and this time it did auto-login. That is the first time since several times, that auto-login worked at the first boot on this day.
I did - after enabling the mdm log - apply yesterday only the last provided updates for level 1 to 3. After that I had yesterday shut down this machine until this morning.

But I have another info:
When I installed Sarah 64 bit at June 10th (I installed without codecs and multimedia packs) I did the following:
I installed the guest additions, then I installed all available updates, but only level 1 to 3, then I shut down the VM and created in VB a snapshot. Not the least configuration option has been changed. That means, that the snapshot represents a Sarah Cinnamon, that is as default as it can be (except the guest additions).
Yesterday I created a clone of this very first snapshot. I booted this clone with the only purpose to enable auto-login, than I shut it down.
After I found, that the LM 18 with the current state of updates did surprisingly auto-login today, I booted the clone. The close did not auto-login!
To make it even more clear: The updates, which are applied in the clone have been done on June 10th at 12:47 CET; no update, which has been released later, is applied in the clone. So we can definitely exclude any update from the last 14 days as culprit. As auto-login works in all my VMs with LM 17.x (I have at least 1 machine with every version of the LM 17 tree), I do also exclude the guest additions.
What leaves is Mint 18 with the update state until 14 days ago.

Trapper
Level 4
Level 4
Posts: 353
Joined: Sat Dec 03, 2011 12:21 pm
Location: North Port, Florida USA

Re: no autologin Mint 18 Cinnamon

Post by Trapper » Fri Jun 24, 2016 11:20 am

This AM I booted up the fresh install I did yesterday. I still have done no updates or anything else. The login screen came up and after I selected my user name there was a twist. This time I was required to also provide a password. Yesterday I had to select user but not provide password. Also, the timed login notice was up during all this. Uniquely, yesterday it was a 10 second time. Today it's 30 seconds. A check of mdmsetup showed auto login selected and a timed login of 10 seconds selected.

I also downloaded yet another copy of the LM 18 MATE 64 beta. I installed to an unencrypted IDE HD on this box. Result was the same. Auto login never auto logs in. Will try other boxes with the same routine when they become available.

Here is my inxi -F for this box:

Code: Select all

System:    Host: Shade Kernel: 4.4.0-21-generic x86_64 (64 bit)
           Desktop: MATE 1.14.1  Distro: Linux Mint 18 Sarah
Machine:   Mobo: Gigabyte model: GA-78LMT-S2P v: x.x
           Bios: Award v: F3 date: 10/18/2012
CPU:       Triple core AMD Athlon II X3 455 (-MCP-) cache: 1536 KB 
           clock speeds: max: 3300 MHz 1: 800 MHz 2: 2100 MHz 3: 2100 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] RS780L [Radeon 3000]
           Display Server: X.Org 1.18.3 drivers: ati,radeon (unloaded: fbdev,vesa)
           Resolution: 1600x900@60.00hz
           GLX Renderer: Gallium 0.4 on AMD RS780 (DRM 2.43.0, LLVM 3.8.0)
           GLX Version: 3.0 Mesa 11.2.0
Audio:     Card Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA)
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.4.0-21-generic
Network:   Card: Edimax EW-7711UTn nLite Wireless Adapter [Ralink RT2870]
           driver: rt2800usb
           IF: wlx801f02621b17 state: up mac: 80:1f:02:62:1b:17
Drives:    HDD Total Size: 320.1GB (33.3% used)
           ID-1: /dev/sda model: MAXTOR_STM332062 size: 320.1GB
Partition: ID-1: / size: 36G used: 5.4G (16%) fs: ext3 dev: /dev/dm-4
           ID-2: /boot size: 735M used: 58M (9%) fs: ext3 dev: /dev/sda3
           ID-3: swap-1 size: 4.29GB used: 0.00GB (0%) fs: swap dev: /dev/dm-1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 30.8C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 200 Uptime: 12 min Memory: 783.6/3445.5MB
           Client: Shell (bash) inxi: 2.2.35 

Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: no autologin Mint 18 Cinnamon

Post by Cosmo. » Fri Jun 24, 2016 2:59 pm

Trapper wrote:This time I was required to also provide a password. Yesterday I had to select user but not provide password.
Maybe I do not understand you correctly. If you install the system, you have to set a password during installation - regardless, if you set to auto-login or not. In case the login has to be done manually - because of your setting or because auto-login fails - you always have to enter the password. So I do not understand this problem.
Trapper wrote:Uniquely, yesterday it was a 10 second time. Today it's 30 seconds. A check of mdmsetup showed auto login selected and a timed login of 10 seconds selected.
This is not unusual, but by design. If you have set timed login for 10 seconds as in your case and you press any key on the login screen during this period, the timed autologin gets extended to 30 seconds to give the user more time to enter credentials manually. If a key gets pressed the system thinks, that you want to login with a different account than the one, which is defined for timed login.
This is nothing new for LM 18, but is the case in Mint as long as I can remember.

Trapper
Level 4
Level 4
Posts: 353
Joined: Sat Dec 03, 2011 12:21 pm
Location: North Port, Florida USA

Re: no autologin Mint 18 Cinnamon

Post by Trapper » Fri Jun 24, 2016 3:31 pm

Cosmo. wrote: Maybe I do not understand you correctly. If you install the system, you have to set a password during installation - regardless, if you set to auto-login or not. In case the login has to be done manually - because of your setting or because auto-login fails - you always have to enter the password. So I do not understand this problem.
What I have been saying all along in this thread is that I have auto login set up but 'always' get a login screen and I am forced to select my user name/icon. When I do that login proceeds 'without requiring my password'. But with the install I did yesterday that all changed this morning. Yesterday I did not have to enter the password after selecting my user name, as has happened with all my LM 18 installs that I set up auto login on.. Today I have to on that one install.* **** but as I rattle on here I realize on this box I disabled requiring a password in 'Users and Groups **** So much for that. Auto login is just broke here.

As for the 30 second delay for timed login (timed login is enabled even though I did not enable it). That countdown from 30 began before I touched keyboard or mouse.

I will reiterate that I also have installs of LM 17.2 and LMDE on this same machine and in the same container. I have had as many as 4 LM installs of various flavors on this machine/drive. Auto login has always worked on all of them. Never failed. LM 18 has never worked properly.

Post Reply

Return to “Installation & Boot”