no autologin Mint 18 Cinnamon

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
User avatar
ehtron
Level 6
Level 6
Posts: 1327
Joined: Thu Apr 14, 2016 8:15 am
Location: Germany / Baltic Sea
Contact:

Re: no autologin Mint 18 Cinnamon

Post by ehtron »

Hi :)
after the update to mdm 2.0.10
autologin works here :)
Lg. Ehtron :)
Bitte genutzte Version und Desktop angeben. Ansonsten oft keine Hilfe möglich.
Ich gebe Hilfe zur Selbsthilfe.

User avatar
clem
Level 12
Level 12
Posts: 4170
Joined: Wed Nov 15, 2006 8:34 am
Contact:

Re: no autologin Mint 18 Cinnamon

Post by clem »

The wait-for-plymouth-quit commit (https://github.com/linuxmint/mdm/commits/master) might have impacted it. I'm not sure though... but yes, it has to do with boot sequence, so if it's a race condition with plymouth, it might have helped a bit.

Without a clear identified cause I can't be sure though.
Image

Cosmo.
Level 23
Level 23
Posts: 17817
Joined: Sat Dec 06, 2014 7:34 am

Re: no autologin Mint 18 Cinnamon

Post by Cosmo. »

mdm 2.0.10 arrived here 3 days ago. In the following days auto-login worked and I thought about reporting it, but yesterday I again hat do login manually again. Today auto-login was again successful.

So we are nearer, but not there.

User avatar
ehtron
Level 6
Level 6
Posts: 1327
Joined: Thu Apr 14, 2016 8:15 am
Location: Germany / Baltic Sea
Contact:

Re: no autologin Mint 18 Cinnamon

Post by ehtron »

Hi :)
there is a little bit wrong with mdm / plymouth / systemd

on bootup i see the logo and the 5 dots..
after a moment the logo disaperars and only the dots are visible ..
Lg. Ehtron :)
Bitte genutzte Version und Desktop angeben. Ansonsten oft keine Hilfe möglich.
Ich gebe Hilfe zur Selbsthilfe.

Cosmo.
Level 23
Level 23
Posts: 17817
Joined: Sat Dec 06, 2014 7:34 am

Re: no autologin Mint 18 Cinnamon

Post by Cosmo. »

IN LM 18 I have never seen the Mint logo at startup. Already reported 2 weeks ago.

Trapper
Level 4
Level 4
Posts: 354
Joined: Sat Dec 03, 2011 12:21 pm
Location: North Port, Florida USA

Re: no autologin Mint 18 Cinnamon

Post by Trapper »

After update to mdm 2.0.10 my mdm auto login survived one reboot but has failed every time since.

The mint logo has always shown properly for me.

Cosmo.
Level 23
Level 23
Posts: 17817
Joined: Sat Dec 06, 2014 7:34 am

Re: no autologin Mint 18 Cinnamon

Post by Cosmo. »

Trapper wrote:The mint logo has always shown properly for me.
Hm, might be an issue with VirtualBox. On the other hand, the logo displays fine in all my VMs for any of the LM 17.x versions.

User avatar
ehtron
Level 6
Level 6
Posts: 1327
Joined: Thu Apr 14, 2016 8:15 am
Location: Germany / Baltic Sea
Contact:

Re: no autologin Mint 18 Cinnamon

Post by ehtron »

Hi :)
i have setup my own boot logo in /usr/share/plymouth/themes (different to 17.x)
and setup like this.. german

http://www.ehlertronic.de/linux/tipps-t ... .html#c584

before the desktop starts (autologin on) i see a short login text screen on tty1
Lg. Ehtron :)
Bitte genutzte Version und Desktop angeben. Ansonsten oft keine Hilfe möglich.
Ich gebe Hilfe zur Selbsthilfe.

User avatar
ehtron
Level 6
Level 6
Posts: 1327
Joined: Thu Apr 14, 2016 8:15 am
Location: Germany / Baltic Sea
Contact:

Re: no autologin Mint 18 Cinnamon

Post by ehtron »

Hi :)
now i have test that with my virtualbox lm18 cin 32.. plymouth default.. no own boot logo, no chages on --config default.plymouth

full level dist-upgrade..
logo with dots > logo disapears, only dots.. no text tty screen
autologin works.
Lg. Ehtron :)
Bitte genutzte Version und Desktop angeben. Ansonsten oft keine Hilfe möglich.
Ich gebe Hilfe zur Selbsthilfe.

Trapper
Level 4
Level 4
Posts: 354
Joined: Sat Dec 03, 2011 12:21 pm
Location: North Port, Florida USA

Re: no autologin Mint 18 Cinnamon

Post by Trapper »

Cosmo. wrote:
Trapper wrote:The mint logo has always shown properly for me.
Hm, might be an issue with VirtualBox. On the other hand, the logo displays fine in all my VMs for any of the LM 17.x versions.
With full disk encryption a message indicating a successful unlock is displayed along with the logo. I don't know if that plays into the reason for success on my setup. The logo displays well as do the progress dots. That has not always been my experience with some prior releases. I had to make resolution adjustments in /etc/default/grub to get the splash logo. Here's what I had to enter:

Code: Select all

GRUB_GFXPAYLOAD_LINUX=1024x768x24,1024x768
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

GRUB_GFXMODE=1024x768
I haven't had to make those adjustments with 18.

Cosmo.
Level 23
Level 23
Posts: 17817
Joined: Sat Dec 06, 2014 7:34 am

Re: no autologin Mint 18 Cinnamon

Post by Cosmo. »

ehtron wrote:before the desktop starts (autologin on) i see a short login text screen on tty1
One of the last updates made tty1 available again and since that time I also see this message appearing.
Is this colored for you also? I get in brown letters.
ehtron wrote:autologin works.
Observe it for some days. For me it is like a "Wundertüte": Every day another surprise.

User avatar
ehtron
Level 6
Level 6
Posts: 1327
Joined: Thu Apr 14, 2016 8:15 am
Location: Germany / Baltic Sea
Contact:

Re: no autologin Mint 18 Cinnamon

Post by ehtron »

Hi :)
@cosmo
Is this colored for you also? I get in brown letters.
white on black background
i can see the message on tty1 (strg-alt-F1)
Lg. Ehtron :)
Bitte genutzte Version und Desktop angeben. Ansonsten oft keine Hilfe möglich.
Ich gebe Hilfe zur Selbsthilfe.

Trapper
Level 4
Level 4
Posts: 354
Joined: Sat Dec 03, 2011 12:21 pm
Location: North Port, Florida USA

Re: no autologin Mint 18 Cinnamon

Post by Trapper »

Cosmo. wrote: One of the last updates made tty1 available again and since that time I also see this message appearing.
Yesterday I was getting not 1 but 2 quick text login screens during boot up. First one, it disappeared for several seconds and then a second instance appeared for several seconds. Since I did the mdm update this morning I do not get those white on black login screens. However I do get a steady non-blinking cursor prompt for a number of seconds now.

This is all really bizarre. I am not sure which is more aggravating --- the auto login situation or this absolute PITA that I get often at shutdown/reboot.:
Image
Last edited by Trapper on Wed Jun 29, 2016 10:46 am, edited 2 times in total.

Cosmo.
Level 23
Level 23
Posts: 17817
Joined: Sat Dec 06, 2014 7:34 am

Re: no autologin Mint 18 Cinnamon

Post by Cosmo. »

@Trapper

the link for your image is wrongly formed, but I was anyway able to find it.

I do see this message here also here and then - but not in LM 18, but in LM 17.x.

As far as I investigated into this issue it has something to do with assistive technologies and reports about this issue can be found also for far older Ubuntu version. It appears too seldom for motivating me, to dig into it deeper. The strange thing is that this process does not exist (only at-sp2.registryd) and also this file is nowhere to be found.

Trapper
Level 4
Level 4
Posts: 354
Joined: Sat Dec 03, 2011 12:21 pm
Location: North Port, Florida USA

Re: no autologin Mint 18 Cinnamon

Post by Trapper »

Cosmo. wrote:@Trapper
the link for your image is wrongly formed, but I was anyway able to find it.
I do see this message here also here and then - but not in LM 18, but in LM 17.x.
As far as I investigated into this issue it has something to do with assistive technologies and reports about this issue can be found also for far older Ubuntu version. It appears too seldom for motivating me, to dig into it deeper. The strange thing is that this process does not exist (only at-sp2.registryd) and also this file is nowhere to be found.
Things are so strange. I don't ever see the message in LM 17.x but am seeing it quite frequently in LM 18. I also checked it out recently. Actually it's been an ongoing problem in Ubuntu for several releases and was supposedly fixed more than once. It appears mostly during a session when I do any changes to the panel or the desktop but sometimes just appears when doing not much of anything. It's a do nothing warning. If you lock it simply locks the desktop until you unlock it. If you cancel the only thing that happens is the message goes away. It will always come back to plague once I attempt to shut down. It 'never' rectifies itself here. The only real choice is Reboot Anyway and that may takes a couple of minutes or so. If I am fortunate whatever I was working with/configuring stuck and I won't have to do it again.

There are a number of other little quirks from upstream that plague us but this one is complete nonsense and a major irritant.

I am confused about the 'malformed' image link. It shows properly here. All it is is image code containing the http://ledduk.net/paste/spi.png address. Maybe the site was temporarily not accessible or something?

Cosmo.
Level 23
Level 23
Posts: 17817
Joined: Sat Dec 06, 2014 7:34 am

Re: no autologin Mint 18 Cinnamon

Post by Cosmo. »

@Trapper:

The problem with your image-link is not the server for that link, but your link: I would be astonished, if you see something different in your post than I do: Only the word "Image" (without quotes), but not actually a link. If I open your post as quote, the address can be seen.
As you see, only plain text, not clickable
As you see, only plain text, not clickable
Image.jpg (3.92 KiB) Viewed 985 times
Replace the img-tags with rimg-tags and it should work.

Trapper
Level 4
Level 4
Posts: 354
Joined: Sat Dec 03, 2011 12:21 pm
Location: North Port, Florida USA

Re: no autologin Mint 18 Cinnamon

Post by Trapper »

I was checking through my mdm debug entrys in this AM's syslog and I noted something I did not spot previously. There are numerous lines concerning TimedLoginEnable and TimedLoginDelay. Oddly there are absolutely zero lines for AutomaticLogin or AutomaticLoginEnable. If there's nothing concerning it in the debug info doesn't it mean the AutomaticLogin information isn't even being looked for/parsed in mdm.conf?

I'm including my mdm debug for today in the event Clem wants to take a look.

http://ledduk.net/paste/mdmlog.txt


Here's my mdm.conf daemon info:

Code: Select all

[daemon]

AutomaticLoginEnable=true

AutomaticLogin=curt

Greeter=/usr/lib/mdm/mdmgreeter

TimedLoginEnable=false

TimedLogin=curt

Trapper
Level 4
Level 4
Posts: 354
Joined: Sat Dec 03, 2011 12:21 pm
Location: North Port, Florida USA

Re: no autologin Mint 18 Cinnamon

Post by Trapper »

Cosmo. wrote:@Trapper:

The problem with your image-link is not the server for that link, but your link: I would be astonished, if you see something different in your post than I do: Only the word "Image" (without quotes), but not actually a link. If I open your post as quote, the address can be seen.
Image.jpg
Replace the img-tags with rimg-tags and it should work.
I am confused. Here's a screenshot of what I see and everyone else here sees when they go to this page:

http://ledduk.net/paste/theimage.jpg

Cosmo.
Level 23
Level 23
Posts: 17817
Joined: Sat Dec 06, 2014 7:34 am

Re: no autologin Mint 18 Cinnamon

Post by Cosmo. »

Here is the explanation, why the image-link appears different for me: I let FF consequently block all Mixed Content (content from not secured inside inside a secured connection). Sorry, I forgot to mention this in the previous post.

Trapper
Level 4
Level 4
Posts: 354
Joined: Sat Dec 03, 2011 12:21 pm
Location: North Port, Florida USA

Re: no autologin Mint 18 Cinnamon

Post by Trapper »

Cosmo. wrote:Sorry, I forgot to mention this in the previous post.
Okay. Cool. :)

Post Reply

Return to “Installation & Boot”