Slow to boot on fresh mint 18 install (solved)

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
bushblade
Level 3
Level 3
Posts: 191
Joined: Wed Jan 22, 2014 1:30 pm

Re: Slow to boot on fresh mint 18 install

Post by bushblade » Sun Jul 03, 2016 11:19 am

Pjotr wrote:Well, without NTP the total boot time appears to have improved considerably: NTP *alone* took 3 minutes 45 seconds, whereas the *entire* boot process now takes "only" 1 minute 30 seconds.

yes it has improved I would still like it to be under 30 seconds like on my Mint 17.3 if that's possible?

User avatar
Pjotr
Level 21
Level 21
Posts: 13725
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Slow to boot on fresh mint 18 install

Post by Pjotr » Sun Jul 03, 2016 11:22 am

How did you configure TRIM to happen on your SSD?
Tip: 10 things to do after installing Linux Mint 19.2 Tina
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

bushblade
Level 3
Level 3
Posts: 191
Joined: Wed Jan 22, 2014 1:30 pm

Re: Slow to boot on fresh mint 18 install

Post by bushblade » Sun Jul 03, 2016 11:30 am

Pjotr wrote:How did you configure TRIM to happen on your SSD?
Sorry, I have no idea what that means.

User avatar
Pjotr
Level 21
Level 21
Posts: 13725
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Slow to boot on fresh mint 18 install

Post by Pjotr » Sun Jul 03, 2016 11:34 am

bushblade wrote:
Pjotr wrote:How did you configure TRIM to happen on your SSD?
Sorry, I have no idea what that means.
Then there's no need to examine the TRIM angle any further.... It's just that some TRIM tweaks that you might have done yourself, might influence systemd. As you didn't swerve from the defaults in this respect, it's not relevant to look into this. :)
Tip: 10 things to do after installing Linux Mint 19.2 Tina
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

bushblade
Level 3
Level 3
Posts: 191
Joined: Wed Jan 22, 2014 1:30 pm

Re: Slow to boot on fresh mint 18 install (solved)

Post by bushblade » Sun Jul 03, 2016 11:54 am

Thanks all for the help, I figured it out and learned a lot on the way.

I disabled swap but had not edited my fstab file. I have commented out the swap line and now it boots in 17 seconds.

Thanks again

Will

altair4
Level 19
Level 19
Posts: 9738
Joined: Tue Feb 03, 2009 10:27 am

Re: Slow to boot on fresh mint 18 install (solved)

Post by altair4 » Sun Jul 03, 2016 12:21 pm

Whew! Glad you figured it out.

Just a side note: We actually don't know what affect if any turning off "Network Time" had on all this since we didn't get the total boot time reading from "systemd-analyze critical-chain" before we turned it off. Like I mentioned in my first post:
tester@cmint180mate ~ $ systemd-analyze critical-chain
The time after the unit is active or started is printed after the "@" character.
The time the unit takes to start is printed after the "+" character.

graphical.target @23.444s
└─ntp.service @33.583s +3min 45.028s
└─basic.target @5.061s
└─sockets.target @5.061s
└─cups.socket @5.061s
└─sysinit.target @4.893s
.....
.....
The fact that it took almost 4 minutes for ntp to finish running had no impact on getting to a usable desktop after boot. The only reason I bring this up is that turning off ntp may not be in your best interest
Last edited by altair4 on Sun Jul 03, 2016 12:30 pm, edited 2 times in total.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

bushblade
Level 3
Level 3
Posts: 191
Joined: Wed Jan 22, 2014 1:30 pm

Re: Slow to boot on fresh mint 18 install (solved)

Post by bushblade » Sun Jul 03, 2016 12:26 pm

Thanks, I'll turn it back on.

User avatar
austin.texas
Level 20
Level 20
Posts: 12054
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: Slow to boot on fresh mint 18 install

Post by austin.texas » Sun Feb 19, 2017 3:22 pm

bushblade wrote:Ah is it because I turned swap off then? Should I comment out

Code: Select all

UUID=f92ac476-3d1c-448e-82f7-389b3cbe57d7 none            swap    sw           $
or remove that line?
You should check to see if the UUID number is correct.
Run the command:

Code: Select all

lsblk -f
What did you do to turn swap off?
Mint 18.2 Cinnamon, Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Linux Linx 2018

Post Reply

Return to “Installation & Boot”