[SOLVED]Mint 18 Cinnamon slow boot time 2 min 50 second

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
deepakdeshp
Level 11
Level 11
Posts: 3513
Joined: Sun Aug 09, 2015 10:00 am

[SOLVED]Mint 18 Cinnamon slow boot time 2 min 50 second

Post by deepakdeshp » Mon Jul 18, 2016 5:32 am

Hello,

I upgraded from Mint 17.3 to Mont 18 but there is no noticeable booting time difference. It takes 2 minutes 50 seconds to boot the system.
Is there any way to reduce boot time and tune the system?

Code: Select all

 uma@uma-HP-Notebook ~ $ inxi -Fxz
System:    Host: uma-HP-Notebook Kernel: 4.4.0-31-generic x86_64 (64 bit gcc: 5.3.1)
           Desktop: Cinnamon 3.0.7 (Gtk 3.18.9-1ubuntu3.1) Distro: Linux Mint 18 Sarah
Machine:   System: Hewlett-Packard product: HP Notebook v: Type1ProductConfigId
           Mobo: Hewlett-Packard model: 80CC v: 99.02 Bios: Insyde v: F.02 date: 04/01/2015
CPU:       Quad core AMD A8-7410 APU with AMD Radeon R5 Graphics (-MCP-) cache: 8192 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 17568
           clock speeds: max: 2200 MHz 1: 1600 MHz 2: 1300 MHz 3: 2200 MHz 4: 1800 MHz
Graphics:  Card-1: Advanced Micro Devices [AMD/ATI] Mullins [Radeon R4/R5 Graphics] bus-ID: 00:01.0
           Card-2: Advanced Micro Devices [AMD/ATI] Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330]
           bus-ID: 01:00.0
           Display Server: X.Org 1.18.3 drivers: ati,radeon (unloaded: fbdev,vesa) Resolution: 1366x768@60.32hz
           GLX Renderer: Gallium 0.4 on AMD MULLINS (DRM 2.43.0, LLVM 3.8.0)
           GLX Version: 3.0 Mesa 11.2.0 Direct Rendering: Yes
Audio:     Card-1 Advanced Micro Devices [AMD] FCH Azalia Controller driver: snd_hda_intel bus-ID: 00:14.2
           Card-2 Advanced Micro Devices [AMD/ATI] Kabini HDMI/DP Audio driver: snd_hda_intel bus-ID: 00:01.1
           Sound: Advanced Linux Sound Architecture v: k4.4.0-31-generic
Network:   Card-1: Realtek RTL8723BE PCIe Wireless Network Adapter driver: rtl8723be port: 3000 bus-ID: 02:00.0
           IF: wlan0 state: up mac: <filter>
           Card-2: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
           driver: r8169 v: 2.3LK-NAPI port: 2000 bus-ID: 03:00.0
           IF: eth0 state: down mac: <filter>
Drives:    HDD Total Size: 500.1GB (12.2% used) ID-1: /dev/sda model: HGST_HTS545050A7 size: 500.1GB
Partition: ID-1: / size: 49G used: 40G (86%) fs: ext4 dev: /dev/sda12
           ID-2: swap-1 size: 5.35GB used: 0.00GB (0%) fs: swap dev: /dev/sda8
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 49.4C mobo: 20.0C gpu: 45.0,N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 217 Uptime: 36 min Memory: 1285.1/3393.0MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.421) inxi: 2.2.35 
uma@uma-HP-Notebook ~ $ 




 
Last edited by deepakdeshp on Sun Aug 07, 2016 3:43 pm, edited 4 times in total.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 19 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

deepakdeshp
Level 11
Level 11
Posts: 3513
Joined: Sun Aug 09, 2015 10:00 am

Re: Mint 18 Cinnamon slow boot time 2 min 50 second

Post by deepakdeshp » Tue Jul 19, 2016 3:25 pm

It may be because no Graphics driver is visible in Driver manager for my AMD Radeon Graphics
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 19 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

User avatar
Flemur
Level 15
Level 15
Posts: 5919
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Mint 18 Cinnamon slow boot time 2 min 50 second

Post by Flemur » Tue Jul 19, 2016 4:13 pm

It may be because no Graphics driver is visible in Driver manager for my AMD Radeon Graphics

Code: Select all

Display Server: X.Org 1.18.3 drivers: ati,radeon (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.32hz
Try

Code: Select all

systemd-analyze blame
and

Code: Select all

dmesg
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 18.3 Xfce/fluxbox/pulse-less
Xubuntu 17.10/fluxbox/pulse-less

deepakdeshp
Level 11
Level 11
Posts: 3513
Joined: Sun Aug 09, 2015 10:00 am

Re: Mint 18 Cinnamon slow boot time 2 min 50 second

Post by deepakdeshp » Tue Jul 19, 2016 6:46 pm

Flemur wrote:
It may be because no Graphics driver is visible in Driver manager for my AMD Radeon Graphics

Code: Select all

Display Server: X.Org 1.18.3 drivers: ati,radeon (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.32hz
Try

Code: Select all

systemd-analyze blame
and

Code: Select all

dmesg
dmsg output is attached as the output is too big for a single post

s

Code: Select all

ystemd-analyze blame
      5min 140ms vmware.service
          9.448s NetworkManager-wait-online.service
          9.339s dev-sda12.device
          6.749s systemd-fsck@dev-disk-by\x2duuid-3446\x2d8563.service
          5.179s lvm2-monitor.service
          3.116s vmware-USBArbitrator.service
          3.062s vmware-workstation-server.service
          3.055s nmbd.service
          2.895s samba-ad-dc.service
          2.634s systemd-udevd.service
          2.479s NetworkManager.service
          2.190s keyboard-setup.service
          2.138s systemd-tmpfiles-setup-dev.service
          1.735s gpu-manager.service
          1.703s ModemManager.service
          1.699s systemd-rfkill.service
          1.660s accounts-daemon.service
          1.402s loadcpufreq.service
          1.389s systemd-tmpfiles-setup.service
           891ms networking.service
           851ms mnt-af84e314\x2d67e7\x2d4fd2\x2d966f\x2d1a3965139893.mount
           827ms systemd-journald.service
           794ms systemd-modules-load.service
           725ms console-setup.service
           587ms systemd-backlight@backlight:radeon_bl0.service
           585ms sys-kernel-debug.mount
           582ms dev-mqueue.mount
           580ms dev-hugepages.mount
           568ms smbd.service
           504ms binfmt-support.service
           446ms colord.service
           432ms systemd-logind.service
           431ms kmod-static-nodes.service
           428ms ufw.service
           399ms console-kit-log-system-start.service
           399ms speech-dispatcher.service
           398ms grub-common.service
           343ms rsyslog.service
           326ms upower.service
           295ms bluetooth.service
           284ms systemd-udev-trigger.service
           260ms systemd-hostnamed.service
           237ms udisks2.service
           230ms dev-sda8.swap
           216ms irqbalance.service
           204ms lm-sensors.service
           196ms polkitd.service
           195ms systemd-update-utmp.service
           192ms boot-efi.mount
           180ms setvtrgb.service
           163ms systemd-timesyncd.service
           150ms wpa_supplicant.service
           133ms plymouth-quit.service
           133ms plymouth-quit-wait.service
           130ms dns-clean.service
           127ms ondemand.service
           125ms avahi-daemon.service
           119ms systemd-random-seed.service
           103ms proc-sys-fs-binfmt_misc.mount
            92ms user@1000.service
            90ms systemd-sysctl.service
            88ms systemd-remount-fs.service
            87ms systemd-journal-flush.service
            63ms console-kit-daemon.service
            61ms resolvconf.service
            55ms cpufrequtils.service
            44ms plymouth-read-write.service
            33ms alsa-restore.service
            33ms hddtemp.service
            29ms pppd-dns.service
            25ms systemd-user-sessions.service
            16ms plymouth-start.service
            10ms rc-local.service
             8ms systemd-update-utmp-runlevel.service
             7ms rtkit-daemon.service
             3ms sys-fs-fuse-connections.mount


If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 19 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

deepakdeshp
Level 11
Level 11
Posts: 3513
Joined: Sun Aug 09, 2015 10:00 am

Re: Mint 18 Cinnamon slow boot time 2 min 50 second

Post by deepakdeshp » Tue Jul 19, 2016 7:04 pm

I rarely use vmware and never use samba
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 19 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

User avatar
austin.texas
Level 20
Level 20
Posts: 12055
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: Mint 18 Cinnamon slow boot time 2 min 50 second

Post by austin.texas » Tue Jul 19, 2016 7:26 pm

deepakdeshp wrote:I rarely use vmware and never use samba
The recommendation from Clem was to remove samba to speed up boot time.

Code: Select all

sudo apt-get -y --purge autoremove samba
Mint 18.2 Cinnamon, Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Linux Linx 2018

deepakdeshp
Level 11
Level 11
Posts: 3513
Joined: Sun Aug 09, 2015 10:00 am

Re: Mint 18 Cinnamon slow boot time 2 min 50 second

Post by deepakdeshp » Wed Jul 20, 2016 7:51 am

austin.texas wrote:
deepakdeshp wrote:I rarely use vmware and never use samba
The recommendation from Clem was to remove samba to speed up boot time.

Code: Select all

sudo apt-get -y --purge autoremove samba
I see that the Samba takes very less time to start up as indicated by the

Code: Select all

systemd-analyse blame
output. Rather than remove the package completely is there any way to stop the service at system start up? There will be many services which are not required. Especially vmware,service is taking 9 minutes to start.

Is this the way services are handled in Mint or has it changed?
http://unix.stackexchange.com/questions ... ux-mint-17
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 19 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

altair4
Level 19
Level 19
Posts: 9150
Joined: Tue Feb 03, 2009 10:27 am

Re: Mint 18 Cinnamon slow boot time 2 min 50 second

Post by altair4 » Wed Jul 20, 2016 8:22 am

** systemd-analyze blame tells you how long it took for each service to complete it doesn't tell you how long any of that contributes to getting to the login screen. To find that out use this command:

Code: Select all

systemd-analyze critical-chain
The output is somewhat misleading however since for example nmbd waits for NetworkManager-wait-online.service to finish before it starts and that time is included in critical-chain and blame for nmbd.service.

If you really want to stop nmbd from running at boot:

Code: Select all

sudo systemctl mask nmbd.service
To reinstate it:

Code: Select all

sudo systemctl unmask nmbd.service
If you never use samba and you have nmbd running you must have "upgraded" to Mint 18 from Mint 17.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

deepakdeshp
Level 11
Level 11
Posts: 3513
Joined: Sun Aug 09, 2015 10:00 am

Re: Mint 18 Cinnamon slow boot time 2 min 50 second

Post by deepakdeshp » Wed Jul 20, 2016 8:41 am

you really want to stop nmbd from running at boot:
CODE: SELECT ALL
sudo systemctl mask nmbd.service

To reinstate it:
CODE: SELECT ALL
sudo systemctl unmask nmbd.service


If you never use samba and you have nmbd running you must have "upgraded" to Mint 18 from Mint 17.
Thank you , I did upgrade to Mint 18 from Mint 17.3
I will stop nmbd and smbd and the vmware services listed below. nmbd and smbd both are samba daemons BTW.

Code: Select all

 service --status-all
 [ + ]  acpid
 [ - ]  alsa-utils
 [ - ]  anacron
 [ + ]  avahi-daemon
 [ + ]  binfmt-support
 [ + ]  bluetooth
 [ - ]  bootlogd
 [ - ]  bootmisc.sh
 [ - ]  brltty
 [ - ]  casper
 [ + ]  cgmanager
 [ - ]  cgproxy
 [ - ]  checkfs.sh
 [ - ]  checkroot-bootclean.sh
 [ - ]  checkroot.sh
 [ + ]  console-setup
 [ + ]  cpufrequtils
 [ + ]  cron
 [ - ]  cryptdisks
 [ - ]  cryptdisks-early
 [ + ]  cups
 [ + ]  cups-browsed
 [ + ]  dbus
 [ - ]  dns-clean
 [ + ]  grub-common
 [ + ]  hddtemp
 [ - ]  hostname.sh
 [ - ]  hwclock.sh
 [ + ]  irqbalance
 [ - ]  kerneloops
 [ + ]  keyboard-setup
 [ - ]  killprocs
 [ + ]  kmod
 [ + ]  lm-sensors
 [ + ]  loadcpufreq
 [ - ]  lvm2
 [ + ]  lvm2-lvmetad
 [ + ]  lvm2-lvmpolld
 [ + ]  mdm
 [ - ]  mintsystem
 [ - ]  mountall-bootclean.sh
 [ - ]  mountall.sh
 [ - ]  mountdevsubfs.sh
 [ - ]  mountkernfs.sh
 [ - ]  mountnfs-bootclean.sh
 [ - ]  mountnfs.sh
 [ + ]  network-manager
 [ + ]  networking
 [ + ]  nmbd
 [ + ]  ondemand
 [ - ]  plymouth
 [ - ]  plymouth-log
 [ - ]  pppd-dns
 [ + ]  procps
 [ - ]  pulseaudio
 [ + ]  rc.local
 [ + ]  resolvconf
 [ - ]  rsync
 [ + ]  rsyslog
 [ + ]  samba-ad-dc
 [ + ]  samba.old
 [ - ]  saned
 [ - ]  sendsigs
 [ + ]  smbd
 [ + ]  speech-dispatcher
 [ - ]  stop-bootlogd
 [ - ]  stop-bootlogd-single
 [ + ]  udev
 [ + ]  ufw
 [ - ]  umountfs
 [ - ]  umountnfs.sh
 [ - ]  umountroot
 [ - ]  unattended-upgrades
 [ + ]  urandom
 [ - ]  uuidd
 [ - ]  vmware
 [ - ]  vmware-USBArbitrator
 [ + ]  vmware-workstation-server
 [ - ]  x11-common
uma@uma-HP-Notebook ~ $ 
 
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 19 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

venik212
Level 1
Level 1
Posts: 30
Joined: Thu Aug 25, 2011 12:05 pm

Re: Mint 18 Cinnamon slow boot time 2 min 50 second

Post by venik212 » Fri Jul 22, 2016 1:52 am

I upgraded from 17.3 (Cinnamon) to 18 using the package upgrade (not fresh installed). Boot time is much longer (~3 minutes) than with 17.3, and removing samba did not reduce the long boot time. My computer is a NUC5i5RYK (I5 processor, 16 gb ram, 250 gb SSD).

deepakdeshp
Level 11
Level 11
Posts: 3513
Joined: Sun Aug 09, 2015 10:00 am

Re: Mint 18 Cinnamon slow boot time 2 min 50 second

Post by deepakdeshp » Fri Jul 22, 2016 6:15 am

As discussed in thia thread
systemd-analyze critical-chain command can give which systems are taking more time.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 19 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

deepakdeshp
Level 11
Level 11
Posts: 3513
Joined: Sun Aug 09, 2015 10:00 am

Re: Mint 18 Cinnamon slow boot time 2 min 50 second

Post by deepakdeshp » Fri Jul 22, 2016 6:30 am

As discussed in thia thread
systemd-analyze critical-chain command can give which services are taking more time. You can try stopping some unwanted servicea from starting
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 19 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

srq2625
Level 4
Level 4
Posts: 256
Joined: Tue Jan 08, 2013 11:35 am
Location: State: Constant Confusion, Country: D'oh

Re: Mint 18 Cinnamon slow boot time 2 min 50 second

Post by srq2625 » Fri Jul 22, 2016 7:02 am

My first thought, when I see numbers like that on what is presumed to be a solid install, is I/O - especially when I remember some of the boot times I've seen with noteboot/netbook HDD.

Looking up reviews of the installed HDD, I see that it is quite innovative with respect to physical implementation (very thin, single platter, 500GB - at the time of it's introduction an almost unique configuration). It is, however, lacking in the I/O speed department. Reads are a bit slow, but writes are a bit more disappointing.

Is there any chance of testing with a HDD a bit more performance oriented?

User avatar
Flemur
Level 15
Level 15
Posts: 5919
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Mint 18 Cinnamon slow boot time 2 min 50 second

Post by Flemur » Fri Jul 22, 2016 10:06 am

From your dmesg:

Code: Select all

   23.018256] EXT4-fs (sda9): mounted filesystem with ordered data mode. Opts: (null)
[  101.379454] cgroup: new mount options do not match the existing superblock, will be ignored
Something there took over a minute - I'd check your partition table and partitions with gparted; run from LiveDVD/USB.

Check here:
google ["cgroup: new mount options do not match the existing superblock"] ->

"I had the same error - it was related to the UUIDs in /etc/fstab." :
http://askubuntu.com/questions/612600/1 ... -slow-boot
and maybe
https://lists.ubuntu.com/archives/ubunt ... 30292.html
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 18.3 Xfce/fluxbox/pulse-less
Xubuntu 17.10/fluxbox/pulse-less

venik212
Level 1
Level 1
Posts: 30
Joined: Thu Aug 25, 2011 12:05 pm

Re: Mint 18 Cinnamon slow boot time 2 min 50 second

Post by venik212 » Sat Jul 23, 2016 2:24 am

In trying to understand the exceedingly long boot time of Mint 18 (~3 minutes), I typed in the terminal:
systemd-analyze critical-chain
right after booting. I got back a message: Bootup is not yet finished. Please try again later
After an additional minute or two it ran properly. Sadly, I cannot tell from the output of systemd-analyze what is taking so long.. ;-(

deepakdeshp
Level 11
Level 11
Posts: 3513
Joined: Sun Aug 09, 2015 10:00 am

Re: Mint 18 Cinnamon slow boot time 2 min 50 second

Post by deepakdeshp » Sat Jul 23, 2016 5:44 am

Flemur wrote:From your dmesg:

Code: Select all

   23.018256] EXT4-fs (sda9): mounted filesystem with ordered data mode. Opts: (null)
[  101.379454] cgroup: new mount options do not match the existing superblock, will be ignored
Something there took over a minute - I'd check your partition table and partitions with gparted; run from LiveDVD/USB.
Thank you very much ! The blkid command and the /etc/fstab had different UUIDs for swap. I had deleted some partitions and added some which would have caused this.
The boot time is down to 1.5 minutes from the earlier 3 minute value
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 19 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

User avatar
Rebel450
Level 1
Level 1
Posts: 31
Joined: Wed Aug 20, 2014 9:09 am

Re: [solved] Mint 18 Cinnamon slow boot time 2 min 50 second

Post by Rebel450 » Tue Jul 26, 2016 7:44 am

Even '1,5 minutes' seems to me too long.
I encounter the same problem (with Sarah only)

Will follow up later again
Become a Linux Mint donor today

User avatar
Flemur
Level 15
Level 15
Posts: 5919
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: [solved] Mint 18 Cinnamon slow boot time 2 min 50 second

Post by Flemur » Tue Jul 26, 2016 1:22 pm

Code: Select all

The boot time is down to 1.5 minutes from the earlier 3 minute value
Heh - I mount swap by LABEL, and when I installed Bunsen Hydrogen it erased the swap partition's LABEL...and that caused Mint to complain about the swap partition and spend 1.5 minutes waiting for something.

But I saw it right away during the boot because I DON'T use:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
because it hides error messages. (/etc/defaults/grub file)

But 1.5 minutes boot is still pretty slow**; are you timing from the grub prompt, or from when you turn on the machine?

Suggest you look at dmesg and "systemd-analyze blame" for something else slowing it up.

**mine's about 21 seconds from grub prompt, on a fairly low-end machine with a regular HD (though it also booted Win7 faster than most machines in the win7 forums unless they had SSDs).
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 18.3 Xfce/fluxbox/pulse-less
Xubuntu 17.10/fluxbox/pulse-less

deepakdeshp
Level 11
Level 11
Posts: 3513
Joined: Sun Aug 09, 2015 10:00 am

Re: [solved] Mint 18 Cinnamon slow boot time 2 min 50 second

Post by deepakdeshp » Tue Jul 26, 2016 3:12 pm

Flemur wrote:

Code: Select all

But 1.5 minutes boot is still pretty slow**; are you timing from the grub prompt, or from when you turn on the machine?  

Suggest you look at dmesg and "systemd-analyze blame" for something else slowing it up.

**mine's about 21 seconds from grub prompt, on a fairly low-end machine with a regular HD (though it also booted Win7 faster than most machines in the win7 forums unless they had SSDs).[/quote]

I am timing from the time I choose the Grub entry and hit enter.  This point onward Mint starts booting.That means the boot process has started excluding the PC hardware boot time.

[quote]Suggest you look at dmesg and "systemd-analyze blame" for something else slowing it up.
[/quote]

The error and warning  msgs from dmsg.. UNfortunately I can interpret anything from them.

[code] dmesg --level=err,warn
[    0.000000] ACPI: RSDP 0x00000000AFBFE014 000024 (v02 HPQOEM)
[    0.000000] ACPI: XSDT 0x00000000AFBFE120 0000C4 (v01 HPQOEM SLIC-MPC 00000001      01000013)
[    0.000000] ACPI: FACP 0x00000000AFBFC000 00010C (v05 HPQOEM SLIC-MPC 00000001 HP   00040000)
[    0.000000] ACPI: DSDT 0x00000000AFBE9000 00E381 (v01 HPQOEM SLIC-MPC F0000000 ACPI 00040000)
[    0.000000] ACPI: FACS 0x00000000AFB14000 000040
[    0.000000] ACPI: UEFI 0x00000000AFBFD000 0001B6 (v01 HPQOEM 80CB     00000001 HP   00040000)
[    0.000000] ACPI: HPET 0x00000000AFBFB000 000038 (v01 HPQOEM 80CB     00000001 HP   00040000)
[    0.000000] ACPI: APIC 0x00000000AFBFA000 000090 (v03 HPQOEM SLIC-MPC 00000001 HP   00040000)
[    0.000000] ACPI: MCFG 0x00000000AFBF9000 00003C (v01 HPQOEM 80CB     00000001 HP   00040000)
[    0.000000] ACPI: ASF! 0x00000000AFBF8000 0000A5 (v32 HPQOEM 80CB     00000001 HP   00040000)
[    0.000000] ACPI: BOOT 0x00000000AFBE8000 000028 (v01 HPQOEM 80CB     00000001 HP   00040000)
[    0.000000] ACPI: FPDT 0x00000000AFBE6000 000044 (v01 HPQOEM SLIC-MPC 00000001 HP   00040000)
[    0.000000] ACPI: MSDM 0x00000000AFBE5000 000055 (v03 HPQOEM SLIC-MPC 00000001 HP   00040000)
[    0.000000] ACPI: SSDT 0x00000000AFBE4000 000CB4 (v01 HPQOEM 80CB     00000001 ACPI 00040000)
[    0.000000] ACPI: SSDT 0x00000000AFBDF000 0048A6 (v02 HPQOEM 80CB     00000002 ACPI 00040000)
[    0.000000] ACPI: SSDT 0x00000000AFBDE000 000692 (v01 HPQOEM 80CB     00000001 ACPI 00040000)
[    0.000000] ACPI: SSDT 0x00000000AFBDD000 000170 (v01 HPQOEM 80CB     00000001 ACPI 00040000)
[    0.000000] ACPI: SSDT 0x00000000AFBDC000 000418 (v01 HPQOEM 80CB     00000001 ACPI 00040000)
[    0.000000] ACPI: SSDT 0x00000000AFBDA000 0016B8 (v01 HPQOEM 80CB     00000001 ACPI 00040000)
[    0.000000] ACPI: SSDT 0x00000000AFBD9000 00082B (v01 HPQOEM 80CB     00000001 ACPI 00040000)
[    0.000000] ACPI: SSDT 0x00000000AFBD8000 00008C (v01 HPQOEM 80CB     00000001 ACPI 00040000)
[    0.000000] ACPI: SSDT 0x00000000AFBD6000 001138 (v01 HPQOEM 80CB     00000001 ACPI 00040000)
[    0.000000] ACPI: BGRT 0x00000000AFBD5000 000038 (v01 HPQOEM 80CB     00000001 ACPI 00040000)
[    0.000000] ACPI: SSDT 0x00000000AFBD4000 000F8A (v01 HPQOEM 80CB     00000001 ACPI 00040000)
[    0.027808] ACPI: 11 ACPI AML tables successfully acquired and loaded
[    0.295231] PCCT header not found.
[    0.313389] ACPI: Executed 1 blocks of module-level executable AML code
[    0.324143] ACPI Exception: AE_NOT_FOUND, While evaluating Sleep State [\_S1_] (20150930/hwxface-580)
[    0.324150] ACPI Exception: AE_NOT_FOUND, While evaluating Sleep State [\_S2_] (20150930/hwxface-580)
[    0.325000] [Firmware Bug]: ACPI: No _BQC method, cannot determine initial brightness
[    0.325750] [Firmware Bug]: ACPI: No _BQC method, cannot determine initial brightness
[    0.504591] ACPI: IRQ 7 override to edge, high
[    0.578022] ACPI: Enabled 2 GPEs in block 00 to 1F
[    1.851396] [Firmware Bug]: battery: (dis)charge rate invalid.
[    1.932791] [Firmware Bug]: ACPI: No _BQC method, cannot determine initial brightness
[    1.932818] [Firmware Bug]: ACPI: No _BQC method, cannot determine initial brightness
[    1.933446] ACPI Error: Needed [Buffer/String/Package], found [Integer] ffff880128aebdc8 (20150930/exresop-592)
[    1.933457] ACPI Exception: AE_AML_OPERAND_TYPE, While resolving operands for [OpcodeName unavailable] (20150930/dswexec-461)
[    1.933464] ACPI Error: Method parse/execution failed [\_SB.PCI0.VGA.LCD._BCM] (Node ffff88012a8a6f50), AE_AML_OPERAND_TYPE (20150930/psparse-542)
[    1.933487] ACPI Error: Evaluating _BCM failed (20150930/video-367)
[    1.934142] ACPI Error: Needed [Buffer/String/Package], found [Integer] ffff880128aebe58 (20150930/exresop-592)
[    1.934149] ACPI Exception: AE_AML_OPERAND_TYPE, While resolving operands for [OpcodeName unavailable] (20150930/dswexec-461)
[    1.934155] ACPI Error: Method parse/execution failed [\_SB.PCI0.VGA.LCD._BCM] (Node ffff88012a8a6f50), AE_AML_OPERAND_TYPE (20150930/psparse-542)
[    1.934166] ACPI Error: Method parse/execution failed [\_SB.PCI0.GFX.VGA.LCD._BCM] (Node ffff88012a8aaaf0), AE_AML_OPERAND_TYPE (20150930/psparse-542)
[    1.934174] ACPI Error: Evaluating _BCM failed (20150930/video-367)
[    1.974043] usb 3-2: ep 0x81 - rounding interval to 64 microframes, ep desc says 80 microframes
[    2.010291] r8169 0000:03:00.0: can't disable ASPM; OS doesn't have ASPM control
[    2.088763] CRAT table not found
[    4.172996] ATPX version 1, functions 0x00000003
[    4.683265] radeon 0000:01:00.0: VCE init error (-22).
[    5.102818] [drm:radeon_acpi_init [radeon]] *ERROR* Cannot find a backlight controller
[   17.024689] ACPI Warning: SystemIO range 0x0000000000000B00-0x0000000000000B07 conflicts with OpRegion 0x0000000000000B00-0x0000000000000B0F (\_SB_.PCI0.SMBS.SMB0) (20150930/utaddress-254)
[   17.815101] radeon 0000:01:00.0: VCE init error (-22).
[   28.295210] cgroup: new mount options do not match the existing superblock, will be ignored
[   31.734024] radeon 0000:01:00.0: VCE init error (-22).
[   53.061705] radeon 0000:01:00.0: VCE init error (-22).
[ 5235.507671] atkbd serio0: Unknown key pressed (translated set 2, code 0xd8 on isa0060/serio0).
[ 5235.507686] atkbd serio0: Use 'setkeycodes e058 <keycode>' to make it known.
[ 5235.515901] atkbd serio0: Unknown key released (translated set 2, code 0xd8 on isa0060/serio0).
[ 5235.515912] atkbd serio0: Use 'setkeycodes e058 <keycode>' to make it known.
[ 5239.335520] Suspending console(s) (use no_console_suspend to debug)
[ 5240.267395] radeon 0000:01:00.0: VCE init error (-22).
[ 5242.647843]  cache: parent cpu1 should not be sleeping
[ 5242.675973]  cache: parent cpu2 should not be sleeping
[ 5242.704137]  cache: parent cpu3 should not be sleeping
[ 5244.851450] radeon 0000:01:00.0: VCE init error (-22).
[ 5245.742137] snd_hda_intel 0000:00:14.2: azx_get_response timeout, switching to polling mode: last cmd=0x00970500
Systemd output shows below that 1.33 minutes is spent in userspace. I dont know how to debug that further.

Code: Select all

systemd-analyze time

uma@uma-HP-Notebook ~ $ systemd-analyze blame
         16.327s NetworkManager-wait-online.service
         12.792s apt-daily.service
         12.791s vmware-USBArbitrator.service
          9.576s dev-sda12.device
          5.957s vmware-workstation-server.service
          5.874s systemd-fsck@dev-disk-by\x2duuid-3446\x2d8563.service
          4.675s lvm2-monitor.service
          3.860s NetworkManager.service
          3.817s ModemManager.service
          3.336s samba-ad-dc.service
          3.162s accounts-daemon.service
          3.036s gpu-manager.service
          2.624s vmware.service
          2.549s irqbalance.service
          2.511s keyboard-setup.service
          2.505s systemd-tmpfiles-setup-dev.service
          2.242s systemd-udevd.service
          2.072s loadcpufreq.service
          2.059s rsyslog.service
          2.055s console-kit-log-system-start.service
          1.904s grub-common.service
          1.700s systemd-rfkill.service
          1.389s systemd-user-sessions.service
          1.342s systemd-tmpfiles-setup.service
          1.294s systemd-logind.service
          1.148s networking.service
          1.052s colord.service
           817ms systemd-modules-load.service
           682ms console-setup.service
           656ms avahi-daemon.service
           638ms systemd-journald.service
           546ms binfmt-support.service
           531ms bluetooth.service
           520ms systemd-backlight@backlight:radeon_bl0.service
           507ms polkitd.service
           394ms systemd-tmpfiles-clean.service
           388ms dev-hugepages.mount
           333ms upower.service
           319ms systemd-udev-trigger.service
           316ms wpa_supplicant.service
           312ms ufw.service
           232ms boot-efi.mount
           226ms systemd-update-utmp.service
           221ms sys-kernel-debug.mount
           221ms dev-mqueue.mount
           220ms lm-sensors.service
           210ms udisks2.service
           207ms cpufrequtils.service
           195ms dns-clean.service
           191ms dev-sda8.swap
           186ms ondemand.service
           182ms systemd-random-seed.service
           181ms systemd-timesyncd.service
           174ms kmod-static-nodes.service
           167ms systemd-journal-flush.service
           123ms systemd-sysctl.service
            95ms speech-dispatcher.service
            95ms user@1000.service
            90ms systemd-hostnamed.service
            80ms proc-sys-fs-binfmt_misc.mount
            78ms resolvconf.service
            63ms plymouth-read-write.service
            62ms console-kit-daemon.service
            50ms systemd-remount-fs.service
            45ms plymouth-quit-wait.service
            43ms plymouth-quit.service
            41ms setvtrgb.service
            29ms hddtemp.service
            23ms alsa-restore.service
            16ms plymouth-start.service
            14ms pppd-dns.service
             9ms ureadahead-stop.service
             8ms rtkit-daemon.service
             6ms systemd-update-utmp-runlevel.service
             6ms sys-fs-fuse-connections.mount
             2ms rc-local.service
**mine's about 21 seconds from grub prompt, on a fairly low-end machine with a regular HD (though it also booted Win7 faster than most machines in the win7 forums unless they had SSDs).
Startup finished in 4.432s (firmware) + 23.999s (loader) + 7.416s (kernel) + 1min 33.630s (userspace) = 2min 9.480s
That is really awesome
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 19 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

deepakdeshp
Level 11
Level 11
Posts: 3513
Joined: Sun Aug 09, 2015 10:00 am

Re: [solved] Mint 18 Cinnamon slow boot time 2 min 50 second

Post by deepakdeshp » Tue Jul 26, 2016 3:39 pm

I had installed XFCE when running 17,3 Later I upgraded to Mint 18, hence xfce is still present in the system.CE is taking dome boot up time?

The xfce uninstall process is
viewtopic.php?t=106062

But again removing xfce may bereak Cinnamon, which I can not afford :{
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 19 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

Post Reply

Return to “Installation & Boot”