Very slow boot after upgrade to Mint 18 XFCE

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
oliverjames
Level 4
Level 4
Posts: 290
Joined: Fri Aug 10, 2007 3:00 am
Location: Divonne-les-Bains, France

Very slow boot after upgrade to Mint 18 XFCE

Post by oliverjames » Mon Aug 08, 2016 2:47 am

Upgraded via the Mint upgrade tool. All appeared to go well (although it took a lot longer than a fresh install) except that now, boot takes 2 minutes (SSD) whereas with 17.3 it used to take about 10 seconds.

Edit: Updating the kernel to 4.4.0-31 doesn't improve things - this is the kernel that my Xubuntu OS is using, and that boots quickly.

I note also that after the upgrade the Mint Add-on has gone from Firefox.

xsession errors gives:
initctl: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused
/etc/mdm/Xsession: Beginning session setup...
localuser:richard being added to access control list

I attach the journalctl command output in case that helps

PS if anyone can tell me how to copy and paste text from the XFCE terminal so that the colours are captured it would be much appreciated.

oliverjames
Level 4
Level 4
Posts: 290
Joined: Fri Aug 10, 2007 3:00 am
Location: Divonne-les-Bains, France

Re: Very slow boot after upgrade to Mint 18 XFCE

Post by oliverjames » Thu Aug 11, 2016 6:16 am

Following my initial post I followed the Boot Time Analysis tutorial, thank you Xenopeek.

Having corrected the swap UUID in fstab my system now boots (to usable state) a lot faster. I'd like to attach the systemd-analyze plot before and after for comparison, however attempting this returns "Invalid file extension: plot.svg"

Nonetheless the total boot time is still long:
$ systemd-analyze time
Startup finished in 7.991s (kernel) + 3min 50.635s (userspace) = 3min 58.626s

Any suggestions for improving this would be most welcome.

Otherwise I'm very impressed with Mint 18.

User avatar
Pjotr
Level 20
Level 20
Posts: 10966
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Very slow boot after upgrade to Mint 18 XFCE

Post by Pjotr » Thu Aug 11, 2016 6:18 am

It's easiest to troubleshoot when you've done a clean installation.... So if you can spare the time, I'd do a clean installation of Mint 18. Maybe this in itself is enough to solve your problem. Needless to say: backup your documents first.
Tip: 10 things to do after installing Linux Mint 19 Tara
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

oliverjames
Level 4
Level 4
Posts: 290
Joined: Fri Aug 10, 2007 3:00 am
Location: Divonne-les-Bains, France

Re: Very slow boot after upgrade to Mint 18 XFCE

Post by oliverjames » Thu Aug 11, 2016 6:29 am

Pjotr wrote:It's easiest to troubleshoot when you've done a clean installation.... So if you can spare the time, I'd do a clean installation of Mint 18. Maybe this in itself is enough to solve your problem. Needless to say: backup your documents first.
OK, when I get some time. Meanwhile:
- I note that posting the "plot.svg" file is not possible, and
- if I try to use the inbuilt Backup Tool it crashes.

PS, I don't need the Backup Tool, just an observation.

Thank you.

venik212
Level 1
Level 1
Posts: 30
Joined: Thu Aug 25, 2011 12:05 pm

Re: Very slow boot after upgrade to Mint 18 XFCE

Post by venik212 » Sat Aug 13, 2016 1:48 am

As I mentioned elsewhere, I had the very same problem after an upgrade (not a clean install) from 17.3 to 18.
After days of useless systemd-analyze XXX agony, I discovered that the upgrade has changed the UUID of my swap partition (blkid was producing an UUID that was different from what was in the ]etc]fstab), and the system (NUC5i5RYK) spent about 3 minutes looking for it. I turned SWAPOFF (with gparted) and now my nuc is up in about 8 seconds. Since my system has 16 gb of ram and 250 gb SSD, I shall leave the swap partition off and enjoy the fast boot.
Try it!

Post Reply

Return to “Installation & Boot”