[SOLVED] Linux Mint Not Showing in Grub Boot Menu

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
MCDELTAT
Level 1
Level 1
Posts: 28
Joined: Thu May 26, 2016 11:54 pm
Location: California, US

[SOLVED] Linux Mint Not Showing in Grub Boot Menu

Post by MCDELTAT »

It's probably been asked a million times, but looking through many similar threads, I can't seem to fix my problem. I've been running a Windows 10/Mint 18 Cinnamon (64-Bit) dual boot on /dev/sda/ for a while no problems. I decided to put in another HDD and experiment with other distros there. So I installed elementary 0.4 on /dev/sdc/ and now my Mint partition is longer showing in grub.

Tried the obvious "update-grub" and it doesn't come up.

Looking at gparted and other places, seems everything is intact. Here's the output of blkid and a section from the "Boot Info Script"

Code: Select all

"blkid" output: ________________________________________________________________

Device           UUID                                   TYPE       LABEL

/dev/sda1        6AF4E74EF4E71AD9                       ntfs       
/dev/sda2        a4b64db6-3a81-4cdc-8cdb-dfc14a2eac26   swap       
/dev/sda3        7660A2F760A2BD6D                       ntfs       Recovery
/dev/sda4        96A5-E809                              vfat       
/dev/sda5                                                          
/dev/sda6        cef9660e-259e-42c6-9178-cd4754fa07df   btrfs      
/dev/sdb1        AA54E64354E611BD                       ntfs       Storage
/dev/sdb2        f9075d40-18b2-4628-8213-a007f181a2bd   ext4       MintStorage
/dev/sdc1        b6d4092d-71ac-4fe2-b844-c5de103f897f   btrfs      
/dev/sdc5        62490c76-5687-4224-b5aa-4767b4521f3b   swap       

================================ Mount points: =================================

Device           Mount_Point              Type       Options

/dev/sda4        /boot/efi                vfat       (rw,relatime,fmask=0077,dmask=0077,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro)
/dev/sda6        /mnt                     btrfs      (rw,relatime,ssd,space_cache,subvolid=5,subvol=/)
/dev/sdc1        /home                    btrfs      (rw,relatime,space_cache,subvolid=258,subvol=/@home)
/dev/sdc1        /                        btrfs      (rw,relatime,space_cache,subvolid=257,subvol=/@)
Following the advice of another thread I simply added the following to /etc/grub.d/40_custom

Code: Select all

menuentry "Linux Mint 18" {
	set root=(hd1,6)
	linux /vmlinuz root=(hd1,6) ro quiet splash
	initrd /initrd.img
}
Which gave me no results. I also tried a variation where root=UUID=cef9660e-259e-42c6-9178-cd4754fa07df and didn't get anything.

Options? Also any advice for how to do non-virtual machine testing on my rig without it being so dangerous to my main SSD setup? Thanks.
Last edited by MCDELTAT on Tue Sep 13, 2016 11:22 pm, edited 1 time in total.
User avatar
gold_finger
Level 9
Level 9
Posts: 2885
Joined: Mon Mar 11, 2013 11:39 pm

Re: Linux Mint Not Showing in Grub Boot Menu

Post by gold_finger »

On the grub menu that shows, is there an entry for both Elementary and Windows -- but not for Mint? And do both Elementary and Windows work when selected?

If "yes" to both, boot into Elementary and enter the following command in a terminal:

Code: Select all

sudo update-grub
Reboot and see if Mint now shows in grub menu and works. If yes that means Elementary's grub is now in charge of booting the system instead of Mint. That's fine, but if you decide to get rid of Elementary you'll have to make sure you put Mint back in charge before doing so.

P.s. If you added that Mint entry to /etc/grub.d/40_custom in Elementary, you may wind up with an extra menu choice for Mint. If so, just undo that entry and run sudo update-grub again.
Please add [SOLVED] to your thread if a solution is found. Go to your first post in the thread, hit "Edit" button and add [SOLVED] to the title of the post.

How To Format Your Forum Posts.

Try Linux Beginner Search Engine for Linux questions.
MCDELTAT
Level 1
Level 1
Posts: 28
Joined: Thu May 26, 2016 11:54 pm
Location: California, US

Re: Linux Mint Not Showing in Grub Boot Menu

Post by MCDELTAT »

Thanks for the reply at such a late hour. Night crew.

Grub currently only contains entries for elementary and Windows.

update-grub has resulted in nothing thus far, but following the GRUB manual I tried mounting /dev/sda6 and running "sudo grub install /dev/sda" and it caused my entry rule above "Linux Mint 18" to show up, but alas, it is a bad rule.

Next step: I might try changing that rule to the UUID version.

EDIT: No luck on either of those. When I run the "Linux Mint 18" rule as typed above I get the following error from grub:

Code: Select all

error: no server is specified.
alloc magic is broken at 0x7fd29d80: 7fc3cb20
Aborted. Press any key to exit.
Also of note, in my UEFI/BIOS settings I have an entry for Windows Boot Manager, and another for ADATA(6G_1) but doesn't boot anything.
User avatar
gold_finger
Level 9
Level 9
Posts: 2885
Joined: Mon Mar 11, 2013 11:39 pm

Re: Linux Mint Not Showing in Grub Boot Menu

Post by gold_finger »

Are you able to boot into Windows or not?

Boot into Elementary, open a terminal and post back the output (within code blocks) of the following commands:

Code: Select all

[ -d /sys/firmware/efi ] && echo "EFI boot on HDD" || echo "Legacy boot on HDD"
sudo blkid -o list
cat /boot/grub/grub.cfg | grep "menuentry '"
Also, is /dev/sda6 a Mint or Elementary partition?
Please add [SOLVED] to your thread if a solution is found. Go to your first post in the thread, hit "Edit" button and add [SOLVED] to the title of the post.

How To Format Your Forum Posts.

Try Linux Beginner Search Engine for Linux questions.
itsme4401
Level 3
Level 3
Posts: 168
Joined: Sat Nov 27, 2010 4:12 pm
Location: Netherlands

Re: Linux Mint Not Showing in Grub Boot Menu

Post by itsme4401 »

Re the line marked red:
menuentry "Linux Mint 18" {
set root=(hd1,6)
linux /vmlinuz root=(hd1,6) ro quiet splash
initrd /initrd.img
}
Please check: AFAIK: grub counts diskdrives from 0 ( zero) and partitions from 1 (one)
So sda6 should be: (hd0,6)
MCDELTAT
Level 1
Level 1
Posts: 28
Joined: Thu May 26, 2016 11:54 pm
Location: California, US

Re: Linux Mint Not Showing in Grub Boot Menu

Post by MCDELTAT »

@itsme4401

That's what I'd assume but I found a thread that said that the currently booted drive is always hd0 and then everything is an offset of that. So will try hd0 and the terminal code above.

Yes I can access Windows on sda and my elementary drive on sdc. sdb BTW was only storage for sda so it shouldn't have any boot information. I have a bunch of install USBs so if needed I can boot to those.

The output of [ -d /sys/firmware/efi ] && echo "EFI boot on HDD" || echo "Legacy boot on HDD" returns:

Code: Select all

EFI Boot on HDD
The output of sudo blkid -o list is:

Code: Select all

device     fs_type label    mount point    UUID
-----------------------------------------------------------------------------
/dev/sda1  ntfs             (not mounted)  6AF4E74EF4E71AD9
/dev/sda2  swap             [SWAP]         a4b64db6-3a81-4cdc-8cdb-dfc14a2eac26
/dev/sda3  ntfs    Recovery (not mounted)  7660A2F760A2BD6D
/dev/sda4  vfat             /boot/efi      96A5-E809
/dev/sda6  btrfs            (not mounted)  cef9660e-259e-42c6-9178-cd4754fa07df
/dev/sdb1  ntfs    Storage  (not mounted)  AA54E64354E611BD
/dev/sdb2  ext4    MintStorage (not mounted) f9075d40-18b2-4628-8213-a007f181a2bd
/dev/sdc1  btrfs            (in use)       b6d4092d-71ac-4fe2-b844-c5de103f897f
/dev/sdc5  swap             [SWAP]         62490c76-5687-4224-b5aa-4767b4521f3b
/dev/sdd1  iso9660 Linux Mint 18 Cinnamon 64-bit (not mounted) 2016-06-28-12-50-06-00
/dev/sdd2  vfat             (not mounted)  B1F5-0A13
/dev/sda5                   (not mounted) 
and Finally the output of "cat /boot/grub/grub.cfg | grep "menuentry '"" is:

Code: Select all

menuentry 'elementary' --class elementary --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-b6d4092d-71ac-4fe2-b844-c5de103f897f' {
	menuentry 'elementary, with Linux 4.4.0-36-generic' --class elementary --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.4.0-36-generic-advanced-b6d4092d-71ac-4fe2-b844-c5de103f897f' {
	menuentry 'elementary, with Linux 4.4.0-36-generic (upstart)' --class elementary --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.4.0-36-generic-init-upstart-b6d4092d-71ac-4fe2-b844-c5de103f897f' {
	menuentry 'elementary, with Linux 4.4.0-36-generic (recovery mode)' --class elementary --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.4.0-36-generic-recovery-b6d4092d-71ac-4fe2-b844-c5de103f897f' {
menuentry 'Windows Boot Manager (on /dev/sda4)' --class windows --class os $menuentry_id_option 'osprober-efi-96A5-E809' {
menuentry 'System setup' $menuentry_id_option 'uefi-firmware' {
So as far as I can tell the grub files on only on my HDD? So I just need to add the correct menu entry right?
MCDELTAT
Level 1
Level 1
Posts: 28
Joined: Thu May 26, 2016 11:54 pm
Location: California, US

Re: Linux Mint Not Showing in Grub Boot Menu

Post by MCDELTAT »

Anyone? I'm backing all my stuff and now and getting ready for a clean install cause I have work I have to get back to and can't be just missing my Mint partition.
User avatar
gold_finger
Level 9
Level 9
Posts: 2885
Joined: Mon Mar 11, 2013 11:39 pm

Re: Linux Mint Not Showing in Grub Boot Menu

Post by gold_finger »

Hold on.

When booted into Elementary, post back output from:

Code: Select all

sudo os-prober
ls -l /etc/grub.d
Please add [SOLVED] to your thread if a solution is found. Go to your first post in the thread, hit "Edit" button and add [SOLVED] to the title of the post.

How To Format Your Forum Posts.

Try Linux Beginner Search Engine for Linux questions.
MCDELTAT
Level 1
Level 1
Posts: 28
Joined: Thu May 26, 2016 11:54 pm
Location: California, US

Re: Linux Mint Not Showing in Grub Boot Menu

Post by MCDELTAT »

Yep haven't cleared it yet because I really wanted to learn from this one.

Running sudo os-prober gives:

Code: Select all

/dev/sda4@/EFI/Microsoft/Boot/bootmgfw.efi:Windows Boot Manager:Windows:efi
and running "ls -l /etc/grub.d" gives:

Code: Select all

total 72
-rwxr-xr-x 1 root root  9791 Aug  8 21:59 00_header
-rwxr-xr-x 1 root root  6276 Aug  8 21:31 05_debian_theme
-rwxr-xr-x 1 root root 12251 Aug  8 21:59 10_linux
-rwxr-xr-x 1 root root 11082 Aug  8 21:59 20_linux_xen
-rwxr-xr-x 1 root root 11692 Aug  8 21:59 30_os-prober
-rwxr-xr-x 1 root root  1418 Aug  8 21:59 30_uefi-firmware
-rwxr-xr-x 1 root root   326 Sep 13 10:17 40_custom
-rwxr-xr-x 1 root root   216 Aug  8 21:59 41_custom
-rw-r--r-- 1 root root   483 Aug  8 21:59 README
User avatar
gold_finger
Level 9
Level 9
Posts: 2885
Joined: Mon Mar 11, 2013 11:39 pm

Re: Linux Mint Not Showing in Grub Boot Menu

Post by gold_finger »

Since no Mint menu entry is showing up in your cat /boot/grub/grub.cfg | grep "menuentry '" output, even after you tried sudo update-grub a few posts back, I thought that might mean the 30_os-prober script under /etc/grub.d is not executable.

However, after I posted I realized that if that were not the case then it also would not find Windows ... which it clearly does. So, false hope on that one.

Running out of ideas.

What does sudo efibootmgr -v return?
Please add [SOLVED] to your thread if a solution is found. Go to your first post in the thread, hit "Edit" button and add [SOLVED] to the title of the post.

How To Format Your Forum Posts.

Try Linux Beginner Search Engine for Linux questions.
MCDELTAT
Level 1
Level 1
Posts: 28
Joined: Thu May 26, 2016 11:54 pm
Location: California, US

Re: Linux Mint Not Showing in Grub Boot Menu

Post by MCDELTAT »

Running "sudo efibootmgr -v" gives:

Code: Select all

BootCurrent: 0001
Timeout: 1 seconds
BootOrder: 0001,0006,000A,0008,0000,0002,0003,0004
Boot0000* Windows Boot Manager	HD(4,GPT,333b2204-bc60-4815-8f29-22aa82dcc937,0xf073800,0x32000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...M................
Boot0001* ubuntu	HD(4,GPT,333b2204-bc60-4815-8f29-22aa82dcc937,0xf073800,0x32000)/File(\EFI\UBUNTU\SHIMX64.EFI)
Boot0002* UEFI:CD/DVD Drive	BBS(129,,0x0)
Boot0003* UEFI:Removable Device	BBS(130,,0x0)
Boot0004* UEFI:Network Device	BBS(131,,0x0)
Boot0006* Hard Drive	BBS(HD,,0x0)..GO..NO........o.W.D.C. .W.D.1.0.E.Z.E.X.-.0.0.W.N.4.A.0....................A...........................>..Gd-.;.A..MQ..L. . . . .W. .-.D.C.W.6.C.7.Y.L.Z.L.U.R.J........BO..NO........o.W.D.C. .W.D.1.0.E.A.L.S.-.0.0.Z.8.A.0....................A...........................>..Gd-.;.A..MQ..L. . . . .W. .-.D.C.W.T.A.0.R.1.3.3.3.4.0........BO..NO........o.A.D.A.T.A. .S.P.5.5.0....................A...........................>..Gd-.;.A..MQ..L.G.2.9.2.0.2.4.0.7.1.8.3. . . . . . . . ........BO
Boot0008* UEFI: KingstonDataTraveler 3.0PMAP, Partition 1	PciRoot(0x0)/Pci(0x14,0x0)/USB(19,0)/HD(1,MBR,0x46,0x15470,0x1280)..BO
Boot000A* USB	BBS(HD,,0x0)..GO..NO........s.K.i.n.g.s.t.o.n.D.a.t.a.T.r.a.v.e.l.e.r. .3...0.P.M.A.P....................A.......................F..Gd-.;.A..MQ..L.6.0.A.4.4.C.3.F.A.C.2.D.B.0.4.0.D.9.8.A.0.0.D.7........BO
MCDELTAT
Level 1
Level 1
Posts: 28
Joined: Thu May 26, 2016 11:54 pm
Location: California, US

Re: Linux Mint Not Showing in Grub Boot Menu

Post by MCDELTAT »

How do you ensure that the right grub config is being loaded on boot? As I was backing up my files I realized everything was still intact. Infact, here's the contents of the grub.cfg on in "/sda6/@/boot/grub/grub.cfg" ( I mounted /sda6/ as /mnt). I can see that on line 136 there are the entries I would expect of "Linux Mint 18 Cinnamon 64-Bit" and "Advanced Options for Linux Mint 18 Cinnamon 64-Bit"

Code: Select all

#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s $prefix/grubenv ]; then
  set have_grubenv=true
  load_env
fi
if [ "${next_entry}" ] ; then
   set default="${next_entry}"
   set next_entry=
   save_env next_entry
   set boot_once=true
else
   set default="0"
fi

if [ x"${feature_menuentry_id}" = xy ]; then
  menuentry_id_option="--id"
else
  menuentry_id_option=""
fi

export menuentry_id_option

if [ "${prev_saved_entry}" ]; then
  set saved_entry="${prev_saved_entry}"
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi

function savedefault {
  if [ -z "${boot_once}" ]; then
    saved_entry="${chosen}"
    save_env saved_entry
  fi
}
function recordfail {
  set recordfail=1
  # GRUB lacks write support for btrfs, so recordfail support is disabled.
}
function load_video {
  if [ x$feature_all_video_module = xy ]; then
    insmod all_video
  else
    insmod efi_gop
    insmod efi_uga
    insmod ieee1275_fb
    insmod vbe
    insmod vga
    insmod video_bochs
    insmod video_cirrus
  fi
}

if [ x$feature_default_font_path = xy ] ; then
   font=unicode
else
insmod part_gpt
insmod btrfs
set root='hd0,gpt6'
if [ x$feature_platform_search_hint = xy ]; then
  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt6 --hint-efi=hd0,gpt6 --hint-baremetal=ahci0,gpt6  cef9660e-259e-42c6-9178-cd4754fa07df
else
  search --no-floppy --fs-uuid --set=root cef9660e-259e-42c6-9178-cd4754fa07df
fi
    font="/@/usr/share/grub/unicode.pf2"
fi

if loadfont $font ; then
  set gfxmode=auto
  load_video
  insmod gfxterm
  set locale_dir=$prefix/locale
  set lang=en_US
  insmod gettext
fi
terminal_output gfxterm
if [ "${recordfail}" = 1 ] ; then
  set timeout=30
else
  if [ x$feature_timeout_style = xy ] ; then
    set timeout_style=menu
    set timeout=10
  # Fallback normal timeout code in case the timeout_style feature is
  # unavailable.
  else
    set timeout=10
  fi
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=white/black
set menu_color_highlight=black/light-gray
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/06_mint_theme ###
set menu_color_normal=white/black
set menu_color_highlight=white/light-gray
### END /etc/grub.d/06_mint_theme ###

### BEGIN /etc/grub.d/10_linux ###
function gfxmode {
	set gfxpayload="${1}"
	if [ "${1}" = "keep" ]; then
		set vt_handoff=vt.handoff=7
	else
		set vt_handoff=
	fi
}
if [ "${recordfail}" != 1 ]; then
  if [ -e ${prefix}/gfxblacklist.txt ]; then
    if hwmatch ${prefix}/gfxblacklist.txt 3; then
      if [ ${match} = 0 ]; then
        set linux_gfx_mode=keep
      else
        set linux_gfx_mode=text
      fi
    else
      set linux_gfx_mode=text
    fi
  else
    set linux_gfx_mode=keep
  fi
else
  set linux_gfx_mode=text
fi
export linux_gfx_mode
menuentry 'Linux Mint 18 Cinnamon 64-bit' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-cef9660e-259e-42c6-9178-cd4754fa07df' {
	recordfail
	load_video
	gfxmode $linux_gfx_mode
	insmod gzio
	if [ x$grub_platform = xxen ]; then insmod xzio; insmod lzopio; fi
	insmod part_gpt
	insmod btrfs
	set root='hd0,gpt6'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt6 --hint-efi=hd0,gpt6 --hint-baremetal=ahci0,gpt6  cef9660e-259e-42c6-9178-cd4754fa07df
	else
	  search --no-floppy --fs-uuid --set=root cef9660e-259e-42c6-9178-cd4754fa07df
	fi
	linux	/@/boot/vmlinuz-4.4.0-21-generic root=UUID=cef9660e-259e-42c6-9178-cd4754fa07df ro rootflags=subvol=@  quiet splash $vt_handoff
	initrd	/@/boot/initrd.img-4.4.0-21-generic
}
submenu 'Advanced options for Linux Mint 18 Cinnamon 64-bit' $menuentry_id_option 'gnulinux-advanced-cef9660e-259e-42c6-9178-cd4754fa07df' {
	menuentry 'Linux Mint 18 Cinnamon 64-bit, with Linux 4.4.0-21-generic' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.4.0-21-generic-advanced-cef9660e-259e-42c6-9178-cd4754fa07df' {
		recordfail
		load_video
		gfxmode $linux_gfx_mode
		insmod gzio
		if [ x$grub_platform = xxen ]; then insmod xzio; insmod lzopio; fi
		insmod part_gpt
		insmod btrfs
		set root='hd0,gpt6'
		if [ x$feature_platform_search_hint = xy ]; then
		  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt6 --hint-efi=hd0,gpt6 --hint-baremetal=ahci0,gpt6  cef9660e-259e-42c6-9178-cd4754fa07df
		else
		  search --no-floppy --fs-uuid --set=root cef9660e-259e-42c6-9178-cd4754fa07df
		fi
		echo	'Loading Linux 4.4.0-21-generic ...'
		linux	/@/boot/vmlinuz-4.4.0-21-generic root=UUID=cef9660e-259e-42c6-9178-cd4754fa07df ro rootflags=subvol=@  quiet splash $vt_handoff
		echo	'Loading initial ramdisk ...'
		initrd	/@/boot/initrd.img-4.4.0-21-generic
	}
	menuentry 'Linux Mint 18 Cinnamon 64-bit, with Linux 4.4.0-21-generic (upstart)' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.4.0-21-generic-init-upstart-cef9660e-259e-42c6-9178-cd4754fa07df' {
		recordfail
		load_video
		gfxmode $linux_gfx_mode
		insmod gzio
		if [ x$grub_platform = xxen ]; then insmod xzio; insmod lzopio; fi
		insmod part_gpt
		insmod btrfs
		set root='hd0,gpt6'
		if [ x$feature_platform_search_hint = xy ]; then
		  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt6 --hint-efi=hd0,gpt6 --hint-baremetal=ahci0,gpt6  cef9660e-259e-42c6-9178-cd4754fa07df
		else
		  search --no-floppy --fs-uuid --set=root cef9660e-259e-42c6-9178-cd4754fa07df
		fi
		echo	'Loading Linux 4.4.0-21-generic ...'
		linux	/@/boot/vmlinuz-4.4.0-21-generic root=UUID=cef9660e-259e-42c6-9178-cd4754fa07df ro rootflags=subvol=@  quiet splash $vt_handoff init=/sbin/upstart
		echo	'Loading initial ramdisk ...'
		initrd	/@/boot/initrd.img-4.4.0-21-generic
	}
	menuentry 'Linux Mint 18 Cinnamon 64-bit, with Linux 4.4.0-21-generic (recovery mode)' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.4.0-21-generic-recovery-cef9660e-259e-42c6-9178-cd4754fa07df' {
		recordfail
		load_video
		insmod gzio
		if [ x$grub_platform = xxen ]; then insmod xzio; insmod lzopio; fi
		insmod part_gpt
		insmod btrfs
		set root='hd0,gpt6'
		if [ x$feature_platform_search_hint = xy ]; then
		  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt6 --hint-efi=hd0,gpt6 --hint-baremetal=ahci0,gpt6  cef9660e-259e-42c6-9178-cd4754fa07df
		else
		  search --no-floppy --fs-uuid --set=root cef9660e-259e-42c6-9178-cd4754fa07df
		fi
		echo	'Loading Linux 4.4.0-21-generic ...'
		linux	/@/boot/vmlinuz-4.4.0-21-generic root=UUID=cef9660e-259e-42c6-9178-cd4754fa07df ro recovery nomodeset rootflags=subvol=@ 
		echo	'Loading initial ramdisk ...'
		initrd	/@/boot/initrd.img-4.4.0-21-generic
	}
}

### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/10_lupin ###
### END /etc/grub.d/10_lupin ###

### BEGIN /etc/grub.d/20_linux_xen ###

### END /etc/grub.d/20_linux_xen ###

### BEGIN /etc/grub.d/20_memtest86+ ###
### END /etc/grub.d/20_memtest86+ ###

### BEGIN /etc/grub.d/30_os-prober ###
menuentry 'Windows Boot Manager (on /dev/sda4)' --class windows --class os $menuentry_id_option 'osprober-efi-96A5-E809' {
	insmod part_gpt
	insmod fat
	set root='hd0,gpt4'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt4 --hint-efi=hd0,gpt4 --hint-baremetal=ahci0,gpt4  96A5-E809
	else
	  search --no-floppy --fs-uuid --set=root 96A5-E809
	fi
	chainloader /EFI/Microsoft/Boot/bootmgfw.efi
}
menuentry 'Manjaro Linux (16.08) (on /dev/sdc1)' --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-simple-43429412-0ee0-4a01-947e-093a0ffa9618' {
	insmod part_msdos
	insmod ext2
	set root='hd2,msdos1'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-bios=hd2,msdos1 --hint-efi=hd2,msdos1 --hint-baremetal=ahci2,msdos1  43429412-0ee0-4a01-947e-093a0ffa9618
	else
	  search --no-floppy --fs-uuid --set=root 43429412-0ee0-4a01-947e-093a0ffa9618
	fi
	linux /boot/vmlinuz-4.4-x86_64 root=/dev/sdc1
	initrd /boot/initramfs-4.4-x86_64.img
}
submenu 'Advanced options for Manjaro Linux (16.08) (on /dev/sdc1)' $menuentry_id_option 'osprober-gnulinux-advanced-43429412-0ee0-4a01-947e-093a0ffa9618' {
	menuentry 'Manjaro Linux (16.08) (on /dev/sdc1)' --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-/boot/vmlinuz-4.4-x86_64--43429412-0ee0-4a01-947e-093a0ffa9618' {
		insmod part_msdos
		insmod ext2
		set root='hd2,msdos1'
		if [ x$feature_platform_search_hint = xy ]; then
		  search --no-floppy --fs-uuid --set=root --hint-bios=hd2,msdos1 --hint-efi=hd2,msdos1 --hint-baremetal=ahci2,msdos1  43429412-0ee0-4a01-947e-093a0ffa9618
		else
		  search --no-floppy --fs-uuid --set=root 43429412-0ee0-4a01-947e-093a0ffa9618
		fi
		linux /boot/vmlinuz-4.4-x86_64 root=/dev/sdc1
		initrd /boot/initramfs-4.4-x86_64.img
	}
}

set timeout_style=menu
if [ "${timeout}" = 0 ]; then
  set timeout=10
fi
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/30_uefi-firmware ###
menuentry 'System setup' $menuentry_id_option 'uefi-firmware' {
	fwsetup
}
### END /etc/grub.d/30_uefi-firmware ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

### BEGIN /etc/grub.d/41_custom ###
if [ -f  ${config_directory}/custom.cfg ]; then
  source ${config_directory}/custom.cfg
elif [ -z "${config_directory}" -a -f  $prefix/custom.cfg ]; then
  source $prefix/custom.cfg;
fi
### END /etc/grub.d/41_custom ###
User avatar
gold_finger
Level 9
Level 9
Posts: 2885
Joined: Mon Mar 11, 2013 11:39 pm

Re: Linux Mint Not Showing in Grub Boot Menu

Post by gold_finger »

Don't see a Mint entry there either.

If you've got a live dvd/usb of Mint, maybe try running Boot-Repair from there to see if problem gets fixed. I hesitate to suggest that though, because if fix doesn't work I don't know if it would then mess-up what is still working -- booting Elementary and Windows.

If you feel adventurous and want to try, make sure the Mint dvd/usb is booted in UEFI/EFI mode first. (After booted up, run ls /sys/firmware in a terminal. If you see "efi" listed in output, you are booted in EFI mode.) Then do the following to install and start Boot-Repair:

Code: Select all

sudo add-apt-repository ppa:yannubuntu/boot-repair
sudo apt-get update
sudo apt-get install -y boot-repair && boot-repair
Choose the "Recommended repair" and with any luck that will work. (Post back with the pastebin link it provides if it doesn't work.)


If you don't want to risk ruining ability to boot other OSes, then a re-install of Mint might be the safest way to go. (Make sure Mint dvd/usb gets booted in EFI mode before you try installing.) You'll need to use the "Something else" install option and designate partitions manually. Here's a tutorial that can serve as a general guideline.
Please add [SOLVED] to your thread if a solution is found. Go to your first post in the thread, hit "Edit" button and add [SOLVED] to the title of the post.

How To Format Your Forum Posts.

Try Linux Beginner Search Engine for Linux questions.
User avatar
gold_finger
Level 9
Level 9
Posts: 2885
Joined: Mon Mar 11, 2013 11:39 pm

Re: Linux Mint Not Showing in Grub Boot Menu

Post by gold_finger »

IMPORTANT: I forgot to note on last post that if Boot-Repair asks for what root partition to associate repair with, tell it Mint's.


MCDELTAT wrote:How do you ensure that the right grub config is being loaded on boot? As I was backing up my files I realized everything was still intact.
Elementary is in charge of booting, so it's grub config is the one that counts -- not Mint's.
Please add [SOLVED] to your thread if a solution is found. Go to your first post in the thread, hit "Edit" button and add [SOLVED] to the title of the post.

How To Format Your Forum Posts.

Try Linux Beginner Search Engine for Linux questions.
MCDELTAT
Level 1
Level 1
Posts: 28
Joined: Thu May 26, 2016 11:54 pm
Location: California, US

Re: Linux Mint Not Showing in Grub Boot Menu

Post by MCDELTAT »

Elementary is in charge of booting, so it's grub config is the one that counts -- not Mint's.
That sounds like a horrible idea. ? Shouldn't it have just realized there was already a grub configuration file and just added the entry to it. I'm just saying that there are 2 grub files. Can I just copy the entries from the other one?

Tried boot repair, but it didn't ask for what disk was root. Might try again, but it didn't do anything. Here's the pastebin results:
http://paste2.org/zhIXItvv
User avatar
gold_finger
Level 9
Level 9
Posts: 2885
Joined: Mon Mar 11, 2013 11:39 pm

Re: Linux Mint Not Showing in Grub Boot Menu

Post by gold_finger »

MCDELTAT wrote:That sounds like a horrible idea. ? Shouldn't it have just realized there was already a grub configuration file and just added the entry to it.
I'm not sure how things work on UEFI systems since I don't have one to play around with, but I don't think this is usually an issue on them. You may have a buggy UEFI firmware build -- I don't know.

On standard old Bios-based systems with mbr partitions, the last distro installed will have it's grub code put into the mbr to take control of booting. But that can be avoided if one prefers to keep an already installed OS in charge by pointing the new distro's grub installation to its own root partition instead of the mbr.

I'm afraid I've got no more good ideas. Don't have the experience needed to try analyzing UEFI problems more than we've done. Do have a feeling that problem will be corrected if you re-install Mint, ... but not 100% sure of that. (You may end up with system that boots only Mint and Windows, but no Elementary -- the opposite of what you have now.)


P.s. I did look at the pastebin output, but can't tell much from it. Maybe someone else with more hands-on UEFI experience will have something more constructive to add.
Please add [SOLVED] to your thread if a solution is found. Go to your first post in the thread, hit "Edit" button and add [SOLVED] to the title of the post.

How To Format Your Forum Posts.

Try Linux Beginner Search Engine for Linux questions.
MCDELTAT
Level 1
Level 1
Posts: 28
Joined: Thu May 26, 2016 11:54 pm
Location: California, US

Re: Linux Mint Not Showing in Grub Boot Menu

Post by MCDELTAT »

Thanks for the help gold_finger pointing me in the right direction. I decided to go for broke and experiment a bit. I added a few lines to the grub file located on sdc (elementary) and then run "grub-update". As expected, it over-wrote my changes with what it saw. Since I knew that my file system was still intact however, I decided to simply copy the Linux-Mint menu-entries from /dev/sda6 to the grub that I knew it was loading on boot.

And it worked! All 3 OSes are booting just fine. So my final /boot/grub/grub.cfg file looks like this:

Code: Select all

#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s $prefix/grubenv ]; then
  set have_grubenv=true
  load_env
fi
if [ "${next_entry}" ] ; then
   set default="${next_entry}"
   set next_entry=
   save_env next_entry
   set boot_once=true
else
   set default="0"
fi

if [ x"${feature_menuentry_id}" = xy ]; then
  menuentry_id_option="--id"
else
  menuentry_id_option=""
fi

export menuentry_id_option

if [ "${prev_saved_entry}" ]; then
  set saved_entry="${prev_saved_entry}"
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi

function savedefault {
  if [ -z "${boot_once}" ]; then
    saved_entry="${chosen}"
    save_env saved_entry
  fi
}
function recordfail {
  set recordfail=1
  # GRUB lacks write support for btrfs, so recordfail support is disabled.
}
function load_video {
  if [ x$feature_all_video_module = xy ]; then
    insmod all_video
  else
    insmod efi_gop
    insmod efi_uga
    insmod ieee1275_fb
    insmod vbe
    insmod vga
    insmod video_bochs
    insmod video_cirrus
  fi
}

if [ x$feature_default_font_path = xy ] ; then
   font=unicode
else
insmod part_msdos
insmod btrfs
set root='hd2,msdos1'
if [ x$feature_platform_search_hint = xy ]; then
  search --no-floppy --fs-uuid --set=root --hint-bios=hd2,msdos1 --hint-efi=hd2,msdos1 --hint-baremetal=ahci2,msdos1  b6d4092d-71ac-4fe2-b844-c5de103f897f
else
  search --no-floppy --fs-uuid --set=root b6d4092d-71ac-4fe2-b844-c5de103f897f
fi
    font="/@/usr/share/grub/unicode.pf2"
fi

if loadfont $font ; then
  set gfxmode=auto
  load_video
  insmod gfxterm
  set locale_dir=$prefix/locale
  set lang=en_US
  insmod gettext
fi
terminal_output gfxterm
if [ "${recordfail}" = 1 ] ; then
  set timeout=30
else
  if [ x$feature_timeout_style = xy ] ; then
    set timeout_style=menu
    set timeout=10
  # Fallback normal timeout code in case the timeout_style feature is
  # unavailable.
  else
    set timeout=10
  fi
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=white/black
set menu_color_highlight=black/white
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/10_linux ###
function gfxmode {
	set gfxpayload="${1}"
	if [ "${1}" = "keep" ]; then
		set vt_handoff=vt.handoff=7
	else
		set vt_handoff=
	fi
}
if [ "${recordfail}" != 1 ]; then
  if [ -e ${prefix}/gfxblacklist.txt ]; then
    if hwmatch ${prefix}/gfxblacklist.txt 3; then
      if [ ${match} = 0 ]; then
        set linux_gfx_mode=keep
      else
        set linux_gfx_mode=text
      fi
    else
      set linux_gfx_mode=text
    fi
  else
    set linux_gfx_mode=keep
  fi
else
  set linux_gfx_mode=text
fi
export linux_gfx_mode
menuentry 'elementary' --class elementary --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-b6d4092d-71ac-4fe2-b844-c5de103f897f' {
	recordfail
	load_video
	gfxmode $linux_gfx_mode
	insmod gzio
	if [ x$grub_platform = xxen ]; then insmod xzio; insmod lzopio; fi
	insmod part_msdos
	insmod btrfs
	set root='hd2,msdos1'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-bios=hd2,msdos1 --hint-efi=hd2,msdos1 --hint-baremetal=ahci2,msdos1  b6d4092d-71ac-4fe2-b844-c5de103f897f
	else
	  search --no-floppy --fs-uuid --set=root b6d4092d-71ac-4fe2-b844-c5de103f897f
	fi
	linux	/@/boot/vmlinuz-4.4.0-36-generic.efi.signed root=UUID=b6d4092d-71ac-4fe2-b844-c5de103f897f ro rootflags=subvol=@  quiet splash $vt_handoff
	initrd	/@/boot/initrd.img-4.4.0-36-generic
}
submenu 'Advanced options for elementary' $menuentry_id_option 'gnulinux-advanced-b6d4092d-71ac-4fe2-b844-c5de103f897f' {
	menuentry 'elementary, with Linux 4.4.0-36-generic' --class elementary --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.4.0-36-generic-advanced-b6d4092d-71ac-4fe2-b844-c5de103f897f' {
		recordfail
		load_video
		gfxmode $linux_gfx_mode
		insmod gzio
		if [ x$grub_platform = xxen ]; then insmod xzio; insmod lzopio; fi
		insmod part_msdos
		insmod btrfs
		set root='hd2,msdos1'
		if [ x$feature_platform_search_hint = xy ]; then
		  search --no-floppy --fs-uuid --set=root --hint-bios=hd2,msdos1 --hint-efi=hd2,msdos1 --hint-baremetal=ahci2,msdos1  b6d4092d-71ac-4fe2-b844-c5de103f897f
		else
		  search --no-floppy --fs-uuid --set=root b6d4092d-71ac-4fe2-b844-c5de103f897f
		fi
		echo	'Loading Linux 4.4.0-36-generic ...'
		linux	/@/boot/vmlinuz-4.4.0-36-generic.efi.signed root=UUID=b6d4092d-71ac-4fe2-b844-c5de103f897f ro rootflags=subvol=@  quiet splash $vt_handoff
		echo	'Loading initial ramdisk ...'
		initrd	/@/boot/initrd.img-4.4.0-36-generic
	}
	menuentry 'elementary, with Linux 4.4.0-36-generic (upstart)' --class elementary --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.4.0-36-generic-init-upstart-b6d4092d-71ac-4fe2-b844-c5de103f897f' {
		recordfail
		load_video
		gfxmode $linux_gfx_mode
		insmod gzio
		if [ x$grub_platform = xxen ]; then insmod xzio; insmod lzopio; fi
		insmod part_msdos
		insmod btrfs
		set root='hd2,msdos1'
		if [ x$feature_platform_search_hint = xy ]; then
		  search --no-floppy --fs-uuid --set=root --hint-bios=hd2,msdos1 --hint-efi=hd2,msdos1 --hint-baremetal=ahci2,msdos1  b6d4092d-71ac-4fe2-b844-c5de103f897f
		else
		  search --no-floppy --fs-uuid --set=root b6d4092d-71ac-4fe2-b844-c5de103f897f
		fi
		echo	'Loading Linux 4.4.0-36-generic ...'
		linux	/@/boot/vmlinuz-4.4.0-36-generic.efi.signed root=UUID=b6d4092d-71ac-4fe2-b844-c5de103f897f ro rootflags=subvol=@  quiet splash $vt_handoff init=/sbin/upstart
		echo	'Loading initial ramdisk ...'
		initrd	/@/boot/initrd.img-4.4.0-36-generic
	}
	menuentry 'elementary, with Linux 4.4.0-36-generic (recovery mode)' --class elementary --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.4.0-36-generic-recovery-b6d4092d-71ac-4fe2-b844-c5de103f897f' {
		recordfail
		load_video
		insmod gzio
		if [ x$grub_platform = xxen ]; then insmod xzio; insmod lzopio; fi
		insmod part_msdos
		insmod btrfs
		set root='hd2,msdos1'
		if [ x$feature_platform_search_hint = xy ]; then
		  search --no-floppy --fs-uuid --set=root --hint-bios=hd2,msdos1 --hint-efi=hd2,msdos1 --hint-baremetal=ahci2,msdos1  b6d4092d-71ac-4fe2-b844-c5de103f897f
		else
		  search --no-floppy --fs-uuid --set=root b6d4092d-71ac-4fe2-b844-c5de103f897f
		fi
		echo	'Loading Linux 4.4.0-36-generic ...'
		linux	/@/boot/vmlinuz-4.4.0-36-generic.efi.signed root=UUID=b6d4092d-71ac-4fe2-b844-c5de103f897f ro recovery nomodeset rootflags=subvol=@ 
		echo	'Loading initial ramdisk ...'
		initrd	/@/boot/initrd.img-4.4.0-36-generic
	}
}
menuentry 'Linux Mint 18 Cinnamon 64-bit' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-cef9660e-259e-42c6-9178-cd4754fa07df' {
	recordfail
	load_video
	gfxmode $linux_gfx_mode
	insmod gzio
	if [ x$grub_platform = xxen ]; then insmod xzio; insmod lzopio; fi
	insmod part_gpt
	insmod btrfs
	set root='hd0,gpt6'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt6 --hint-efi=hd0,gpt6 --hint-baremetal=ahci0,gpt6  cef9660e-259e-42c6-9178-cd4754fa07df
	else
	  search --no-floppy --fs-uuid --set=root cef9660e-259e-42c6-9178-cd4754fa07df
	fi
	linux	/@/boot/vmlinuz-4.4.0-21-generic root=UUID=cef9660e-259e-42c6-9178-cd4754fa07df ro rootflags=subvol=@  quiet splash $vt_handoff
	initrd	/@/boot/initrd.img-4.4.0-21-generic
}
submenu 'Advanced options for Linux Mint 18 Cinnamon 64-bit' $menuentry_id_option 'gnulinux-advanced-cef9660e-259e-42c6-9178-cd4754fa07df' {
	menuentry 'Linux Mint 18 Cinnamon 64-bit, with Linux 4.4.0-21-generic' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.4.0-21-generic-advanced-cef9660e-259e-42c6-9178-cd4754fa07df' {
		recordfail
		load_video
		gfxmode $linux_gfx_mode
		insmod gzio
		if [ x$grub_platform = xxen ]; then insmod xzio; insmod lzopio; fi
		insmod part_gpt
		insmod btrfs
		set root='hd0,gpt6'
		if [ x$feature_platform_search_hint = xy ]; then
		  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt6 --hint-efi=hd0,gpt6 --hint-baremetal=ahci0,gpt6  cef9660e-259e-42c6-9178-cd4754fa07df
		else
		  search --no-floppy --fs-uuid --set=root cef9660e-259e-42c6-9178-cd4754fa07df
		fi
		echo	'Loading Linux 4.4.0-21-generic ...'
		linux	/@/boot/vmlinuz-4.4.0-21-generic root=UUID=cef9660e-259e-42c6-9178-cd4754fa07df ro rootflags=subvol=@  quiet splash $vt_handoff
		echo	'Loading initial ramdisk ...'
		initrd	/@/boot/initrd.img-4.4.0-21-generic
	}
	menuentry 'Linux Mint 18 Cinnamon 64-bit, with Linux 4.4.0-21-generic (upstart)' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.4.0-21-generic-init-upstart-cef9660e-259e-42c6-9178-cd4754fa07df' {
		recordfail
		load_video
		gfxmode $linux_gfx_mode
		insmod gzio
		if [ x$grub_platform = xxen ]; then insmod xzio; insmod lzopio; fi
		insmod part_gpt
		insmod btrfs
		set root='hd0,gpt6'
		if [ x$feature_platform_search_hint = xy ]; then
		  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt6 --hint-efi=hd0,gpt6 --hint-baremetal=ahci0,gpt6  cef9660e-259e-42c6-9178-cd4754fa07df
		else
		  search --no-floppy --fs-uuid --set=root cef9660e-259e-42c6-9178-cd4754fa07df
		fi
		echo	'Loading Linux 4.4.0-21-generic ...'
		linux	/@/boot/vmlinuz-4.4.0-21-generic root=UUID=cef9660e-259e-42c6-9178-cd4754fa07df ro rootflags=subvol=@  quiet splash $vt_handoff init=/sbin/upstart
		echo	'Loading initial ramdisk ...'
		initrd	/@/boot/initrd.img-4.4.0-21-generic
	}
	menuentry 'Linux Mint 18 Cinnamon 64-bit, with Linux 4.4.0-21-generic (recovery mode)' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.4.0-21-generic-recovery-cef9660e-259e-42c6-9178-cd4754fa07df' {
		recordfail
		load_video
		insmod gzio
		if [ x$grub_platform = xxen ]; then insmod xzio; insmod lzopio; fi
		insmod part_gpt
		insmod btrfs
		set root='hd0,gpt6'
		if [ x$feature_platform_search_hint = xy ]; then
		  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt6 --hint-efi=hd0,gpt6 --hint-baremetal=ahci0,gpt6  cef9660e-259e-42c6-9178-cd4754fa07df
		else
		  search --no-floppy --fs-uuid --set=root cef9660e-259e-42c6-9178-cd4754fa07df
		fi
		echo	'Loading Linux 4.4.0-21-generic ...'
		linux	/@/boot/vmlinuz-4.4.0-21-generic root=UUID=cef9660e-259e-42c6-9178-cd4754fa07df ro recovery nomodeset rootflags=subvol=@ 
		echo	'Loading initial ramdisk ...'
		initrd	/@/boot/initrd.img-4.4.0-21-generic
	}
}

### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_linux_xen ###

### END /etc/grub.d/20_linux_xen ###

### BEGIN /etc/grub.d/30_os-prober ###
menuentry 'Windows Boot Manager (on /dev/sda4)' --class windows --class os $menuentry_id_option 'osprober-efi-96A5-E809' {
	insmod part_gpt
	insmod fat
	set root='hd0,gpt4'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt4 --hint-efi=hd0,gpt4 --hint-baremetal=ahci0,gpt4  96A5-E809
	else
	  search --no-floppy --fs-uuid --set=root 96A5-E809
	fi
	chainloader /EFI/Microsoft/Boot/bootmgfw.efi
}
set timeout_style=menu
if [ "${timeout}" = 0 ]; then
  set timeout=10
fi
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/30_uefi-firmware ###
menuentry 'System setup' $menuentry_id_option 'uefi-firmware' {
	fwsetup
}
### END /etc/grub.d/30_uefi-firmware ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.### END /etc/grub.d/40_custom ###

### BEGIN /etc/grub.d/41_custom ###
if [ -f  ${config_directory}/custom.cfg ]; then
  source ${config_directory}/custom.cfg
elif [ -z "${config_directory}" -a -f  $prefix/custom.cfg ]; then
  source $prefix/custom.cfg;
fi
### END /etc/grub.d/41_custom ###
This does still raise some questions however but I will mark this as solved.
1) Why is my system not seeing that /dev/sda6 has all the neccessary boot file and adding it grub automatically?
2) I would still like to ask how to switch the grub boot file that's loaded automatically. Even though it's working, it's loading from an HDD, whereas the other file was loading from an SSD. Shouldn't matter in speed anyways since I have to have insecure_boot turned on to run Nvidia drivers on Mint 18.
3) What's the best way to be running a triple boot system like this? (Without it being volatile?) I've been wanting to review distros and test gaming on them, which I can't do in a virtual machine very easily.
User avatar
gold_finger
Level 9
Level 9
Posts: 2885
Joined: Mon Mar 11, 2013 11:39 pm

Re: [SOLVED] Linux Mint Not Showing in Grub Boot Menu

Post by gold_finger »

Well -- good job tinkering and getting something that finally works!

Do yourself a favor right now and make a backup copy of that working config file because it will get overwritten any time grub update happens (either when you run command, or if some system update runs it).

Code: Select all

sudo cp /boot/grub/grub.cfg /boot/grub/grub.cfg.working
If an update comes along and screws-up your grub.cfg, you can just restore the working version running this command:

Code: Select all

sudo cp /boot/grub/grub.cfg.working /boot/grub/grub.cfg
MCDELTAT wrote:3) What's the best way to be running a triple boot system like this? (Without it being volatile?)
Normally there aren't problems like this. I don't know why your system doesn't seem to work properly.

Gotta sign off now. Maybe someone else reading this thread can shed further light on what might be causing Elementary to not automatically pick-up that Mint is there when you run update-grub. It's a mystery to me.
Please add [SOLVED] to your thread if a solution is found. Go to your first post in the thread, hit "Edit" button and add [SOLVED] to the title of the post.

How To Format Your Forum Posts.

Try Linux Beginner Search Engine for Linux questions.
User avatar
austin.texas
Level 20
Level 20
Posts: 12046
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: [SOLVED] Linux Mint Not Showing in Grub Boot Menu

Post by austin.texas »

You did good in copying the Mint menuentry. I have done that in the past in special circumstances.
You might want to check out the rEFInd Boot Manager.
rEFInd boot manager intro
How to use rEFInd - by srs5694
rEFInd tutorial
Mint 18.2 Cinnamon, Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Linux Linx 2018
User avatar
austin.texas
Level 20
Level 20
Posts: 12046
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: [SOLVED] Linux Mint Not Showing in Grub Boot Menu

Post by austin.texas »

In your Boot Repair it shows sda6 and sdc1 as btrfs
I have heard something (sorry I don't remember the details) about Mint 18 having problems with btrfs

Are you booting sda first in the boot order?
Mint 18.2 Cinnamon, Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Linux Linx 2018
Post Reply

Return to “Installation & Boot”