Can't boot; Error 17 -- can any-one help please.

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 2
Joined: Sat Mar 14, 2009 8:28 am

Can't boot; Error 17 -- can any-one help please.

Post by hantsmike » Sat Mar 14, 2009 8:43 am


I'm a Windows refugee to Mint . I have dual boot machine which was running perfectly but had aquired an unwanted partition which I tried to delete using partition editor. This went wrong and when I now turn on the computer to run GRUB all I get is Error 17 and the boot process stops prior to running GRUB. I can get into the bios and I've changed to load from CD but it will not work I've tried various Linux and windows rescue and boot CD / DVD disks ( I have another working computer) and the only thing that works is BG-Rescue Linux. ( ) which loads from two floppys (after I told the BIOS to run from floppy) . BGR then boots from RAM and takes me to the command line


The problem is that I have little idea of what to do next . I think I should try and get it to boot and then reinstall from my Linux Mint DVD but do not know what the correct command is. [b]Can any-one guide me as to how I reload what ever it is I need to reload?[/b][b][/b]

.Unfortunately I do not have any command line experience. I would prefer to keep my windows partition (c drive) because it such a pain to reload and I need it for work related software. There is no data I need to preserve on the machine and obviously reloading linux is easy. The rescue floppys that work contain also the following tools

with lzma support
with inittar support
with cloop 2.01 support
with fuse 2.5.3 support
with NTFS 2.1.6b support
with DVDRW Patch
with SC92031 Ethernet Adapter Patch
with the PocketBoy Patch

uClibc  0.9.29
BusyBox  1.9.2

with losetup-2.4 patch
|[, [[, adjtimex, ar, ash, awk, basename, bunzip2, bzcat, bzip2, cal, cat,|
|chgrp, chmod, chown, chroot, chvt, clear, cmp, cp, cpio, cttyhack, cut, date,|
|dd, deallocvt, devfsd, df, dirname, dmesg, dos2unix, dpkg, dpkg-deb, du,|
|dumpkmap, echo, egrep, env, expr, false, fdflush, fdformat, fdisk, fgrep, find,|
|fold, free, freeramdisk, fsck.minix, ftpget, ftpput, getopt, grep, gunzip,|
|gzip, halt, hd, hdparm, head, hexdump, hostname, hwclock, id, ifconfig, init,|
|insmod, install, kbd_mode, kill, killall, klogd, length, less, ln, loadfont,|
|loadkmap, logger, logname, losetup, ls, lsmod, lzmacat, makedevs, md5sum, mesg,|
|mkdir, mkfifo, mkfs.minix, mknod, mkswap, mktemp, modprobe, more, mount, mv,|
|nameif, nc, netstat, nslookup, od, openvt, pidof, ping, pipe_progress,|
|pivot_root, poweroff, printf, ps, pwd, rdate, readlink, realpath, reboot,|
|renice, reset, rm, rmdir, rmmod, route, rpm, rpm2cpio, sed, setkeycodes, sh,|
|sha1sum, sleep, sort, split, stty, swapoff, swapon, switch_root, sync, sysctl,|
|syslogd, tail, tar, tee, telnet, test, tftp, time, top, touch, tr, traceroute,|
|true, tty, udhcpc, umount, uname, uncompress, uniq, unix2dos, unlzma, unzip,|
|uptime, usleep, uudecode, uuencode, vconfig, vi, watch, wc, wget, which, xargs,|
|yes, zcat |

cramfs  1.1
dosfstools  2.11
e2fsprogs  1.40.7
ntfsprogs  2.0.0
ntfs-3g  1.2310
reiserfsck  3.6.20
umsdos-utils  1.32

cloop  2.05
dd_rescue  1.14
gpart  0.1h    (with support for ReiserFS 3.6)
lilo  22.8
mdadm  2.6.4
ms-sys  2.1.3
syslinux  3.60
fdisk and hdparm are integrated in BusyBox

cabextract  0.6
rzip  2.1
zip  2.32
ar, bzip2, cpio, dpkg, dpkg-deb, gzip, rpm, rpm2cpio, tar, uncompress, unlzma and unzip are integrated in BusyBox

cmdftp  0.7.6
linld  0.97
loadlin  1.6c
pcmcia-cardmgr  3.2.8
regutils  0.10
smbclient  1.9.18p8    (with pipe support)

Supported Filesystems: cramfs, devfs, ext2, ext3, iso9660, minix, msdos, ntfs 2.1.6b, ntfs-3g (rw), proc, ramfs, reiserfs, tmpfs, udf, umsdos, vfat, xfs
Network filesystem: nfs

Many thanks.

Level 4
Level 4
Posts: 211
Joined: Thu Dec 04, 2008 6:35 am
Location: Glasgow Scotland

Re: Can't boot; Error 17 -- can any-one help please.

Post by distoaddict » Sat Mar 14, 2009 4:03 pm

i think it would be a good idea to download the floppy version of supergrub disk if you have not already try it appears you cannot use the cd should be able to boot.

Level 1
Level 1
Posts: 2
Joined: Sat Mar 14, 2009 8:28 am

Re: Can't boot; Error 17 -- can any-one help please.

Post by hantsmike » Thu Mar 19, 2009 5:36 pm

Many thanks , worked a treat . Everything fine now. Turned out the CD drive had broken at the same time.

thanks again,


Post Reply

Return to “Installation & Boot”