"The 'grub-efi-amd64-signed package' failed to install into /target/."

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
SweetBearCub
Level 1
Level 1
Posts: 16
Joined: Sat Aug 15, 2015 12:06 am

"The 'grub-efi-amd64-signed package' failed to install into /target/."

Postby SweetBearCub » Sat Mar 11, 2017 12:56 am

I have googled, and any solutions I found, such as setting up my own partitions by hand, have failed with the same error message. For example, this was recommended in a similar thread. http://www.tecmint.com/install-linux-mint-17/ - It did not work for me.

- Linux Mint 18.1 Cinnamon x64 "Serena".
- Desktop system has 3 drives. One SSD (boot drive), two HDD, data and backups.
- I want to leave the HDDs untouched by the install process.
- Trying to install Mint as the only OS on my SSD. Windows will be virtualized later.
- Secure boot is disabled.
- LiveUSB is on a USB 2.0 drive, plugged into a USB 2.0 port. (My system has two, I tried both, as well as a USB 3.0 port)

Code: Select all

The 'grub-efi-amd64-signed package' failed to install into /target/. Without the GRUB boot loader, the installed system will not boot.


Photos of screen when the error was displayed, with some additional console data is here

Mx2uler
Level 1
Level 1
Posts: 1
Joined: Sat Mar 11, 2017 3:01 am

Re: "The 'grub-efi-amd64-signed package' failed to install into /target/."

Postby Mx2uler » Sat Mar 11, 2017 3:09 am

Hello mate,
I had same problem and fix was easy,go to your boot device menu and pick your liveUSB but not the UEFI (UEFI:Jetflash........)one.

michael louwe
Level 6
Level 6
Posts: 1207
Joined: Sun Sep 11, 2016 11:18 pm

Re: "The 'grub-efi-amd64-signed package' failed to install into /target/."

Postby michael louwe » Sat Mar 11, 2017 3:32 am

@ SweetB

Please refer to ....... https://pctechman.wordpress.com/2016/02 ... with-uefi/
https://sites.google.com/site/easylinuxtipsproject/Home

IOW, you may not need to follow your tecmint link to pre-partition the SSD in GPT mode with GParted, ie the LM 18.1 Installer will automatically do the partitioning in GPT mode for you.

After the install, please refer to ... https://sites.google.com/site/easylinuxtipsproject/ssd

mdd1963
Level 1
Level 1
Posts: 2
Joined: Sat Mar 11, 2017 7:59 am

Re: "The 'grub-efi-amd64-signed package' failed to install into /target/."

Postby mdd1963 » Sat Mar 11, 2017 8:12 am

I worked a similar issue off and on for about 6 hours when time to install MInt18.1 to an M.2 nvme drive; the GRUB simply refused to install unless I created a small FAT32 partition at beginning of drive beforehand (I gave it 1 GB, likely much more than necessary), with "0" space available before start of partition. (The error above in subject always appeared near the very end of the install, all the more frustrating!) Once making the small FAT32 partition at beginning of drive, isntall completed correctly. (No such issue installing to conventional spinning SATA drive last week, however...)

(Same problem occurred using DVD drive or USB install, as a few folks on other forums were thinking the installer might be confused an opting to attempt to install the GRUB to the USB drive, which certainly was not the case with no usb flash drive(s) attached...)


User avatar
xenopeek
Level 24
Level 24
Posts: 21473
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: "The 'grub-efi-amd64-signed package' failed to install into /target/."

Postby xenopeek » Tue Mar 21, 2017 1:01 pm

Try installing without an Internet connection (disable any wifi connection / disconnect the network cable). There is an issue affect some users where GRUB fails to install when connected to the Internet.
Image

User avatar
Ranthe
Level 2
Level 2
Posts: 83
Joined: Fri Sep 05, 2014 9:01 pm
Location: Paraparaumu, New Zealand

Re: "The 'grub-efi-amd64-signed package' failed to install into /target/."

Postby Ranthe » Fri Mar 24, 2017 7:21 pm

xenopeek wrote:Try installing without an Internet connection (disable any wifi connection / disconnect the network cable). There is an issue affect some users where GRUB fails to install when connected to the Internet.


Yes, this works! I did this after umpteen failed attempts at installing with the network in place, and it worked like a charm.

User avatar
scjet45
Level 2
Level 2
Posts: 87
Joined: Sat May 07, 2016 12:50 am

Re: "The 'grub-efi-amd64-signed package' failed to install into /target/."

Postby scjet45 » Sat Mar 25, 2017 11:32 am

xenopeek wrote:Try installing without an Internet connection (disable any wifi connection / disconnect the network cable). There is an issue affect some users where GRUB fails to install when connected to the Internet.


This affects all LM 18.1.
Is there anyway that this "issue" could be fixed at the Linuxmint repo/server end, while connected to network, during installation ?

User avatar
xenopeek
Level 24
Level 24
Posts: 21473
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: "The 'grub-efi-amd64-signed package' failed to install into /target/."

Postby xenopeek » Sat Mar 25, 2017 12:35 pm

The package comes from the Ubuntu repositories. We've had at least one user say the problem affected them on their Ubuntu install as well. We're looking into it.
Image

User avatar
scjet45
Level 2
Level 2
Posts: 87
Joined: Sat May 07, 2016 12:50 am

Re: "The 'grub-efi-amd64-signed package' failed to install into /target/."

Postby scjet45 » Sat Mar 25, 2017 6:37 pm

xenopeek wrote:The package comes from the Ubuntu repositories. We've had at least one user say the problem affected them on their Ubuntu install as well. We're looking into it.


"one user" only, really ?
Have these Forums not counted at all?, let alone google,.... ?

btw, Ubuntu 16.04.*,which is what LM 18.1 is running, is NOT a problem, I tested them all too, or maybe they just "patched" it, as it should be.
So, why is LM 18.1 not fixing this?

anyway fine, there's no point in continuing to argue/discourse an "OBVIOUS" issue that LM want's desperately to make it a diminished non-issue, for whatever reasons.
We'll just wait for 18.2 right ?

michael louwe
Level 6
Level 6
Posts: 1207
Joined: Sun Sep 11, 2016 11:18 pm

Re: "The 'grub-efi-amd64-signed package' failed to install into /target/."

Postby michael louwe » Sat Mar 25, 2017 8:39 pm

@ SweetBear

The 2 HDD should be disconnected from your computer before installing LM18.1, so as not to confuse the LM Installer.

Then the easier install method of "Erase disk and install Linux Mint" can be chosen = the LM 18.1 Installer will auto-partition the SSD, auto-create and auto-install an EFI Boot partition at the beginning of the disk. By default, only a "/" or root and swap partition will be auto-created, ie no /home partition.

The more difficult method is to choose the "Something else" install option = you will have to manually partition the SSD, manually create and install an EFI Boot partition(= should be 550MB in size, in fat32 format, mounted at /boot/efi and have a /boot flag) at the beginning of the disk, as per the tecmint link, ... except that the 'bios grub' partition is no longer needed to be created since LM 18.
....... In this case, GParted may be needed to pre-partition the SSD before doing the install, eg to set GPT mode and the /boot flag(not Legacy-boot flag).

Ensure also that Fast Boot and CSM is disabled in the UEFI/BIOS settings, the Live LM 18.1 USB-stick is booted in UEFI mode and the Internet disconnected during the install.

SweetBearCub
Level 1
Level 1
Posts: 16
Joined: Sat Aug 15, 2015 12:06 am

Re: "The 'grub-efi-amd64-signed package' failed to install into /target/."

Postby SweetBearCub » Tue Mar 28, 2017 2:52 am

Thanks, but way too complex for me. First, I'm confined to a wheelchair, and my computer case sits near the floor in a small carrier. To get it on the table/open it for upgrades, I have to get a friend to come over after we both have free time from work.

Second, I installed Xububtu 16.04.2 LTS with no GRUB issues. It seems that they fixed it.

If Linux Mint wants to succeed, they need to patch stupid issues like this, rather than ask users to do workarounds. Ubuntu has obviously demonstrated that it can be patched. Also, this is a major issue, according to Google. More than just me and 1 other user have been bitten by it.

michael louwe wrote:@ SweetBear

The 2 HDD should be disconnected from your computer before installing LM18.1, so as not to confuse the LM Installer.

Then the easier install method of "Erase disk and install Linux Mint" can be chosen = the LM 18.1 Installer will auto-partition the SSD, auto-create and auto-install an EFI Boot partition at the beginning of the disk. By default, only a "/" or root and swap partition will be auto-created, ie no /home partition.

The more difficult method is to choose the "Something else" install option = you will have to manually partition the SSD, manually create and install an EFI Boot partition(= should be 550MB in size, in fat32 format, mounted at /boot/efi and have a /boot flag) at the beginning of the disk, as per the tecmint link, ... except that the 'bios grub' partition is no longer needed to be created since LM 18.
....... In this case, GParted may be needed to pre-partition the SSD before doing the install, eg to set GPT mode and the /boot flag(not Legacy-boot flag).

Ensure also that Fast Boot and CSM is disabled in the UEFI/BIOS settings, the Live LM 18.1 USB-stick is booted in UEFI mode and the Internet disconnected during the install.

User avatar
xenopeek
Level 24
Level 24
Posts: 21473
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: "The 'grub-efi-amd64-signed package' failed to install into /target/."

Postby xenopeek » Tue Mar 28, 2017 10:34 am

For anybody else finding this topic, for both Linux Mint 18 and 18.1 this issue should be solved now. The workaround to disable your Internet connection is no longer needed. You do not need a new ISO.
Image

davsev
Level 1
Level 1
Posts: 3
Joined: Sun Mar 24, 2013 11:58 am

Re: "The 'grub-efi-amd64-signed package' failed to install into /target/."

Postby davsev » Wed May 03, 2017 8:02 pm

Hi, unfortunately I downloaded the ISO today (18.1 MATE 64bits) and I did have this problem. It seemed to work after I retried without the internet connection, although I was trying to make the partitions manually, and setting the boot partition to the wrong type may have been the actual reason.

User avatar
xenopeek
Level 24
Level 24
Posts: 21473
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: "The 'grub-efi-amd64-signed package' failed to install into /target/."

Postby xenopeek » Thu May 04, 2017 1:22 am

davsev wrote:although I was trying to make the partitions manually, and setting the boot partition to the wrong type may have been the actual reason.

I can confirm that was the actual reason.
Image

julian1
Level 1
Level 1
Posts: 6
Joined: Sun Dec 13, 2015 3:20 am

Re: "The 'grub-efi-amd64-signed package' failed to install into /target/."

Postby julian1 » Sat May 06, 2017 2:14 pm

xenopeek wrote:Try installing without an Internet connection (disable any wifi connection / disconnect the network cable). There is an issue affect some users where GRUB fails to install when connected to the Internet.

I had the same problem and I solved it by turning off the wifi during installation. Now grub displays "Ubuntu" instead of "Linux Mint 18.1 etc". I used Grub Customizer to fix it but no entry with title Ubuntu appeared. All entries (except windows) had the correct title "Linux Mint...". Is there any way to fix this problem?

User avatar
administrollaattori
Level 12
Level 12
Posts: 4391
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: "The 'grub-efi-amd64-signed package' failed to install into /target/."

Postby administrollaattori » Sat May 06, 2017 2:23 pm

julian1 wrote:
xenopeek wrote:Try installing without an Internet connection (disable any wifi connection / disconnect the network cable). There is an issue affect some users where GRUB fails to install when connected to the Internet.

I had the same problem and I solved it by turning off the wifi during installation. Now grub displays "Ubuntu" instead of "Linux Mint 18.1 etc". I used Grub Customizer to fix it but no entry with title Ubuntu appeared. All entries (except windows) had the correct title "Linux Mint...". Is there any way to fix this problem?

Edit /etc/grub.d/10_linux file, changing line(s) in row 42

Code: Select all

case ${GRUB_DISTRIBUTOR} in
    Ubuntu|Kubuntu)
      OS="The name you want"

After editing run

Code: Select all

sudo update-grub

julian1
Level 1
Level 1
Posts: 6
Joined: Sun Dec 13, 2015 3:20 am

Re: "The 'grub-efi-amd64-signed package' failed to install into /target/."

Postby julian1 » Sat May 06, 2017 2:39 pm

administrollaattori wrote:
julian1 wrote:
xenopeek wrote:Try installing without an Internet connection (disable any wifi connection / disconnect the network cable). There is an issue affect some users where GRUB fails to install when connected to the Internet.

I had the same problem and I solved it by turning off the wifi during installation. Now grub displays "Ubuntu" instead of "Linux Mint 18.1 etc". I used Grub Customizer to fix it but no entry with title Ubuntu appeared. All entries (except windows) had the correct title "Linux Mint...". Is there any way to fix this problem?

Edit /etc/grub.d/10_linux file, changing line(s) in row 42

Code: Select all

case ${GRUB_DISTRIBUTOR} in
    Ubuntu|Kubuntu)
      OS="The name you want"

After editing run

Code: Select all

sudo update-grub


Line 42 of /etc/grub.d/10_linux is

Code: Select all

OS="Linux Mint 18.1 Cinnamon 64-bit"

but grub displays Ubuntu in the boot menu. This is the problem I'd like to fix.

User avatar
administrollaattori
Level 12
Level 12
Posts: 4391
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: "The 'grub-efi-amd64-signed package' failed to install into /target/."

Postby administrollaattori » Sun May 07, 2017 4:10 am

julian1 wrote:Line 42 of /etc/grub.d/10_linux is

Code: Select all

OS="Linux Mint 18.1 Cinnamon 64-bit"

but grub displays Ubuntu in the boot menu. This is the problem I'd like to fix.

What tells

Code: Select all

cat /etc/default/grub

Code: Select all

cat /etc/lsb-release

julian1
Level 1
Level 1
Posts: 6
Joined: Sun Dec 13, 2015 3:20 am

Re: "The 'grub-efi-amd64-signed package' failed to install into /target/."

Postby julian1 » Sun May 07, 2017 9:34 am

administrollaattori wrote:
julian1 wrote:Line 42 of /etc/grub.d/10_linux is

Code: Select all

OS="Linux Mint 18.1 Cinnamon 64-bit"

but grub displays Ubuntu in the boot menu. This is the problem I'd like to fix.

What tells

Code: Select all

cat /etc/default/grub

Code: Select all

cat /etc/lsb-release

/etc/default/grub:

Code: Select all

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"


/etc/lsb-release:

Code: Select all

DISTRIB_ID=LinuxMint
DISTRIB_RELEASE=18.1
DISTRIB_CODENAME=serena
DISTRIB_DESCRIPTION="Linux Mint 18.1 Serena"


Return to “Installation & Boot”