USB and LAN problems.

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
neogeo
Level 1
Level 1
Posts: 9
Joined: Thu Mar 30, 2017 1:51 am

USB and LAN problems.

Post by neogeo »

Hi.
I am new but have some weird problems.
I have downloaded Mint 18.1 Cinamon and made an USB installer with UUI. When i boot into Mint Desktop from USB, my USB ports don't working at all and also LAN port, so my keyboard and mouse are dead and i can't use Mint and have no possibillity to install it on my SSD...
My mobo is GA-970A-DS3P... All another o/s-es working fine (Ubuntu and Win)

Any idea how to resolve this with USB and LAN?

TNX
Iacta Alea Est
hallergard
Level 3
Level 3
Posts: 158
Joined: Wed Aug 01, 2012 4:11 am

Re: USB and LAN problems.

Post by hallergard »

Try to enable iommu in bios or try adding "iommu=soft" to the kernel command line
neogeo
Level 1
Level 1
Posts: 9
Joined: Thu Mar 30, 2017 1:51 am

Re: USB and LAN problems.

Post by neogeo »

I disabled AMD-V and enabled IOMMU, all in BIOS and all working like a charm :)

Do i really need AMD-V to be enabled as simple desktop user?

tnx a lot
Iacta Alea Est
hallergard
Level 3
Level 3
Posts: 158
Joined: Wed Aug 01, 2012 4:11 am

Re: USB and LAN problems.

Post by hallergard »

Have no experience of using AMD-V as I am not into virtualization.

To enable USB3 ports when running Linux Mint I have iommu disabled in bios and add "iommu=soft" to the command line (in /etc/default/grub), but for installation I usually enable iommu in bios temporarily.
neogeo
Level 1
Level 1
Posts: 9
Joined: Thu Mar 30, 2017 1:51 am

Re: USB and LAN problems.

Post by neogeo »

I am trying now.
Report later :)

P.S. AMD-V is enabled by default in BIOS, so to leave it On or to Off it?
Iacta Alea Est
neogeo
Level 1
Level 1
Posts: 9
Joined: Thu Mar 30, 2017 1:51 am

Re: USB and LAN problems.

Post by neogeo »

iommu=soft don't work for me at all.
Must set it in BIOS only.
Is there any other value to set it for iommu?

Tnx
Iacta Alea Est
hallergard
Level 3
Level 3
Posts: 158
Joined: Wed Aug 01, 2012 4:11 am

Re: USB and LAN problems.

Post by hallergard »

Do your USB3 ports work in Linux with iommu enabled in bios? Mine don't, that's why I use iommu disabled in bios but add iommu=soft to the kernel command line. I have the same mobo but no settings for AMD-V - different firmware version? - so I cannot have an opinion about it, or other effects of iommu. Googling iommu gives some info, but above my level I am afraid.
neogeo
Level 1
Level 1
Posts: 9
Joined: Thu Mar 30, 2017 1:51 am

Re: USB and LAN problems.

Post by neogeo »

I didn't check USB3.0 ports. For me, USB2.0 don't work nider when iommu set as grub line, so USB3.0 is at higher level :)
Yes You have AMD-V in BIOS but maybe Your CPU dos not support it.
It's an option in CPU frequency settings in BIOS and called SVM !

I'll report what's happening with iommu.

TNX a lot!
Iacta Alea Est
hallergard
Level 3
Level 3
Posts: 158
Joined: Wed Aug 01, 2012 4:11 am

Re: USB and LAN problems.

Post by hallergard »

Found SVM, tnx. Think I will just leave it enabled (unless you can tell me that I will be better off disabled)
neogeo
Level 1
Level 1
Posts: 9
Joined: Thu Mar 30, 2017 1:51 am

Re: USB and LAN problems.

Post by neogeo »

SVM and IOMMU from BIOS do an hardware acceleration of a certain type of a hardware so, let it enabled in BIOS and enabled from a GRUB comnand line as iommu=soft. There are no conflict in between.
Today i will try an usb3.0 flash drive and post a report of a working drive...
Iacta Alea Est
neogeo
Level 1
Level 1
Posts: 9
Joined: Thu Mar 30, 2017 1:51 am

Re: USB and LAN problems.

Post by neogeo »

Just to report i am giving a quit to Mint distro because i have too many strange quirks...
Once system boot-once no boot, random freezes of a system (just power button helping me), etc...
Bye Mint :(
Iacta Alea Est
neogeo
Level 1
Level 1
Posts: 9
Joined: Thu Mar 30, 2017 1:51 am

Re: USB and LAN problems.

Post by neogeo »

THE CURE FOR RANDOM FREEZES:
1. sudo nano /etc/default/grub
2 There is a line in that: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" (like this), replace with: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash intel_idle.max_cstate=1"
3. Save it (CTRL+O)
4. sudo update-grub
5. sudo reboot
Or do it with Grub Customizer app.

ENJOY!
Iacta Alea Est
Post Reply

Return to “Installation & Boot”