Page 1 of 1

trying to replace an older Fedora w/ mint

Posted: Sun Jun 04, 2017 10:05 pm
by harold smith
I have been trying to install the new Mint & Mate on my laptop which has an older fedora distro on it. I burned the ISO to a DVD (using my desktop computer) and checked it. I put it in the laptop's drive and powered up the laptop. It appears to be booting from the DVD drive, as it is set to. It also asks some of the questions I expect to see (language, time zone, etc.) But when all is said and done, all I've got is what appears to be the same fedora, not Mint, but with an empty home folder.

What am I doing wrong?

Re: trying to replace an older Fedora w/ mint

Posted: Mon Jun 05, 2017 1:38 am
by gold_finger
harold smith wrote:What am I doing wrong?
Hard to say without knowing what option you picked to install. If you picked "Something Else" option and tried to manually tell Mint what partitions to use (eg. the old Fedora partitions), you may have forgotten to set the mount point(s). If you picked option to wipe drive and install to whole thing, then it should have replaced Fedora automatically and I'm not sure why it didn't. Maybe best thing would be to boot Mint DVD again and use GParted to delete all current partitions on drive leaving it blank. Then run installer and hopefully that works.

If you're pretty sure you went through install process correctly, another possibility is if computer is newer than 2011-12 it probably has UEFI firmware (vs. older Bios firmware) and could be booting the DVD in a different mode than computer is set to boot from on the hard drive. Boot into the Mint DVD, run these commands and copy/paste output back here for us to see following directions shown here.

Code: Select all

ls /sys/firmware
inxi -Fxz
sudo parted --list
We'll probably be able to tell best way to proceed after seeing that.

Re: trying to replace an older Fedora w/ mint

Posted: Mon Jun 05, 2017 12:41 pm
by harold smith
I booted again from the DVD. (The computer thinks, apparently, that I am trying to install fedora 21, which is what the install pages say.) I tried various stuff, including something that seemed to say I could delete all the partitions already on the disk, but when it finished I still had the old fedora.

I opened a terminal and typed in the commands shown in the reply. The first two came back as unrecognized. The third line, that started with sudo, gave this, after some warnings:

Code: Select all

Model: ATA WDC WD2500BEVT-2 (scsi)
Disk /dev/sda: 250GB
Sector size (logical/physical): 512B/512B
Partition Table:  msdos
Disk Flags:

Number    Start         End           Size           Type          File system          Flags
  1            1049kB     15.0GB      15.0GB       primary      ntfs                      diag
  2             15.0GB    15.1GB      105MB        primary      ntfs                      boot
  3             15.1GB     81.9GB      66.7GB      primary      ntfs
  4             81.9GB     250GB      168GB        extended
  6             82.4GB     82.9GB     524MB        logical       ext4
  7             82.9GB     115GB      31.7GB       logical                                   lvm
  5             115GB      119GB      4020MB      logical
  8             119GB      119GB      524MB        logical      ext4
  9             119GB      250GB      131GB        logical                                   lvm

Warning:  Unable to open /dev/sr0 read-write (read-only file system).  /dev/sr0
has been opened read-only.
Model:  HL-DT-ST DVDRAM GT32N (scsi)
Disk /dev/sr0: 960MB
Sector size (logical/physical): 2048B/2048B
Partition Table: mac
Disk Flags:

Number     Start       End            Size          File System     Name        Flags
  1             2048B     10.2kB       8192B                              Apple
  2             88.1kB    5278kB      5190kB                             EFI
  3             5319kB   26.1MB      20.8MB                             EFI

Re: trying to replace an older Fedora w/ mint

Posted: Mon Jun 05, 2017 7:30 pm
by gold_finger
Somehow you ended up burning another old Fedora DVD instead of Mint. Several things point to that:
  1. You said installer shows as Fedora
  2. The first two commands were not recognized -- they would have been if DVD were Mint.
  3. Size of image on DVD shows as 960MB. If it were Mint Mate 18.1 it would have been around 1.6-1.7GB.
Download either 32-bit or 64-bit version of Mint Mate from links on this page on either desktop or laptop. Burn new DVD using that ISO and try install again with that. Your laptop is using Legacy mode booting and DVD will probably boot that way without you having to do anything special. However, looks like you made last DVD on a MAC machine because DVD shows as "partition table: mac" plus references to "EFI". I have no experience with MACs, so not sure if DVD made that way will work on Legacy boot computer. You might want to download Mint ISO to either Windows or Fedora on laptop and use either of those operating systems to make the DVD just in case. Fedora probably has some kind of CD/DVD burning program on it already. For Windows, you could install something like ImgBurn to it and use that. Make sure you burn as an "image" file and not a normal "data" file.

Assuming parted --list output was from your laptop, it looks like you have a Windows installation and probably two Fedora installs on it now. If you want to only have Mint, tell installer to erase and use the entire drive. It will then wipe out everything and install automatically. If you want to keep Windows, open GParted in live Mint DVD and delete all of the Fedora partitions (/dev/sda5-sda9) first. When done with that, close GParted and start installer. Choose "Alongside Windows" install option when you get to "Installation Type" page. Mint will then use the free space you created by deleting Fedora partitions and install itself there.

Re: trying to replace an older Fedora w/ mint FIXED!

Posted: Mon Jun 05, 2017 9:07 pm
by harold smith
Yup, I'm stupid. I downloaded the Mint iso, and verified it, and then somehow burned the wrong iso to the CD. With the right iso the installation seems to have gone just fine.

Thank you, and sorry for the waste of your time.

Re: trying to replace an older Fedora w/ mint

Posted: Tue Jun 06, 2017 6:01 am
by gold_finger
No worries! Glad everything worked out. Go to your first post on this thread, hit <EDIT> button (pencil icon), then add <SOLVED> to the title of post once you're up and running.