<SOLVED> linux mint 18.2 cinnamon 64-bit (beta) shutdown leads to restart

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
caspardavidfriedrich
Level 1
Level 1
Posts: 16
Joined: Fri Jun 16, 2017 1:20 pm

<SOLVED> linux mint 18.2 cinnamon 64-bit (beta) shutdown leads to restart

Postby caspardavidfriedrich » Fri Jun 16, 2017 3:00 pm

Hi,
I just installed linux mint 18.2 cinnamon 64-bit in place of windows 10 on my laptop. Now every time I press shutdown it will power off but restart in a few seconds. I have tried updating the kernel to 4.8.0-53.1 and disabling the wake-on-lan setting but neither works. Using terminal for `shutdown -h now' doesn't help either. A search online gave me too many different results on modifying the grub file but none of them worked for me so far. Does anyone have any idea how to solve this? I could send further results if you need me to type commands in the terminal. Thanks a lot!
Last edited by caspardavidfriedrich on Mon Jun 19, 2017 3:14 pm, edited 2 times in total.

User avatar
karlchen
Level 17
Level 17
Posts: 7330
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: linux mint 18.2 cinnamon 64-bit (beta) shutdown leads to restart

Postby karlchen » Fri Jun 16, 2017 4:12 pm

Hello, caspardavidfriedrich.

Please, note that problem reports and bug reports about Linux Mint 18.2 Cinnamon (beta) should be posted here:
Linux Mint 18.2 Cinnamon (beta) - section "Bug reports"

Regards,
Karl
Image
Old bugs good, new bugs bad! Updates are evil: might fix old bugs and introduce no new ones.

caspardavidfriedrich
Level 1
Level 1
Posts: 16
Joined: Fri Jun 16, 2017 1:20 pm

Re: linux mint 18.2 cinnamon 64-bit (beta) shutdown leads to restart

Postby caspardavidfriedrich » Fri Jun 16, 2017 11:01 pm

Thanks Karl! I've put it there.

User avatar
Spearmint2
Level 13
Level 13
Posts: 4742
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: linux mint 18.2 cinnamon 64-bit (beta) shutdown leads to restart

Postby Spearmint2 » Sat Jun 17, 2017 12:30 am

Turn off Fast Boot in Windows. With all the new coziness between the UEFI BIOS and Windows, I'd not trust Fast Boot nor the Secure Boot functions, which have to be turned off anyway for most other OS installs.
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

rene
Level 6
Level 6
Posts: 1054
Joined: Sun Mar 27, 2016 6:58 pm

Re: linux mint 18.2 cinnamon 64-bit (beta) shutdown leads to restart

Postby rene » Sat Jun 17, 2017 1:17 pm


caspardavidfriedrich
Level 1
Level 1
Posts: 16
Joined: Fri Jun 16, 2017 1:20 pm

Re: linux mint 18.2 cinnamon 64-bit (beta) shutdown leads to restart

Postby caspardavidfriedrich » Sat Jun 17, 2017 2:37 pm

Spearmint2 wrote:Turn off Fast Boot in Windows. With all the new coziness between the UEFI BIOS and Windows, I'd not trust Fast Boot nor the Secure Boot functions, which have to be turned off anyway for most other OS installs.

Thanks Spearmint2! Upon installing linux mint I've formatted the hard drive and presumably the windows have been uninstalled. Might there be some remnant settings from windows that I need to take care of?

sikejsudjek
Level 3
Level 3
Posts: 188
Joined: Thu Apr 24, 2014 1:53 pm

Re: linux mint 18.2 cinnamon 64-bit (beta) shutdown leads to restart

Postby sikejsudjek » Sat Jun 17, 2017 2:45 pm

Sounds like its suspending rather than shutting down ? What happens if you shut down from the menu instead of pressing a button ?

User avatar
Spearmint2
Level 13
Level 13
Posts: 4742
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: linux mint 18.2 cinnamon 64-bit (beta) shutdown leads to restart

Postby Spearmint2 » Sat Jun 17, 2017 2:48 pm

caspardavidfriedrich wrote:Thanks Spearmint2! Upon installing linux mint I've formatted the hard drive and presumably the windows have been uninstalled. Might there be some remnant settings from windows that I need to take care of?


what windows useds? Is the drive set for GPT or MBR partitions? Was this laptop an UEFI?
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

caspardavidfriedrich
Level 1
Level 1
Posts: 16
Joined: Fri Jun 16, 2017 1:20 pm

Re: linux mint 18.2 cinnamon 64-bit (beta) shutdown leads to restart

Postby caspardavidfriedrich » Sat Jun 17, 2017 2:55 pm

what windows useds? Is the drive set for GPT or MBR partitions? Was this laptop an UEFI?

It's windows 10. It's a Thinkpad s431 and google tells me they are GPT partitions and the laptop was UEFI.

caspardavidfriedrich
Level 1
Level 1
Posts: 16
Joined: Fri Jun 16, 2017 1:20 pm

Re: linux mint 18.2 cinnamon 64-bit (beta) shutdown leads to restart

Postby caspardavidfriedrich » Sat Jun 17, 2017 2:56 pm

sikejsudjek wrote:Sounds like its suspending rather than shutting down ? What happens if you shut down from the menu instead of pressing a button ?

Hi! it's the same whether I use shutdown in terminal, or from the menu, or press the button.

User avatar
Spearmint2
Level 13
Level 13
Posts: 4742
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: linux mint 18.2 cinnamon 64-bit (beta) shutdown leads to restart

Postby Spearmint2 » Sat Jun 17, 2017 3:11 pm

Check the BIOS settings then. There is a setting in many aimed at server use which allows the computer to reboot after a shutdown.
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

caspardavidfriedrich
Level 1
Level 1
Posts: 16
Joined: Fri Jun 16, 2017 1:20 pm

Re: linux mint 18.2 cinnamon 64-bit (beta) shutdown leads to restart

Postby caspardavidfriedrich » Sat Jun 17, 2017 3:43 pm

Spearmint2 wrote:Check the BIOS settings then. There is a setting in many aimed at server use which allows the computer to reboot after a shutdown.

Hi, do you have specific setting in mind? I could find such a thing in BIOS. Some source online says it's the wake-on-lan, but disabling that doesn't help either... Thanks!

User avatar
Spearmint2
Level 13
Level 13
Posts: 4742
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: linux mint 18.2 cinnamon 64-bit (beta) shutdown leads to restart

Postby Spearmint2 » Sat Jun 17, 2017 4:28 pm

All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

caspardavidfriedrich
Level 1
Level 1
Posts: 16
Joined: Fri Jun 16, 2017 1:20 pm

Re: linux mint 18.2 cinnamon 64-bit (beta) shutdown leads to restart

Postby caspardavidfriedrich » Mon Jun 19, 2017 10:57 am

Spearmint2 wrote:http://www.technewsworld.com/story/78930.html

http://www.wintips.org/setup-computer-t ... er-outage/

Hi,
My laptop doesn't have an `advanced settings' or similar tabs in its BIOS and I have explored every option without seeing a setting similar to the one mentioned in the two webpages you gave me. Do you think there might be other possibilities? Thanks a lot!

rene
Level 6
Level 6
Posts: 1054
Joined: Sun Mar 27, 2016 6:58 pm

Re: linux mint 18.2 cinnamon 64-bit (beta) shutdown leads to restart

Postby rene » Mon Jun 19, 2017 11:08 am

One possibility is that "acpi=force" that you didn't reply to; another is indeed WoL, which you said you disabled, but did not specify how/where.

caspardavidfriedrich
Level 1
Level 1
Posts: 16
Joined: Fri Jun 16, 2017 1:20 pm

Re: linux mint 18.2 cinnamon 64-bit (beta) shutdown leads to restart

Postby caspardavidfriedrich » Mon Jun 19, 2017 1:11 pm

rene wrote:One possibility is that "acpi=force" that you didn't reply to; another is indeed WoL, which you said you disabled, but did not specify how/where.


I tried acpi=force but it didn't help. The WoL setting was changed in BIOS. Maybe I got the wrong place?

rene
Level 6
Level 6
Posts: 1054
Joined: Sun Mar 27, 2016 6:58 pm

Re: linux mint 18.2 cinnamon 64-bit (beta) shutdown leads to restart

Postby rene » Mon Jun 19, 2017 1:53 pm

caspardavidfriedrich wrote:I tried acpi=force but it didn't help. The WoL setting was changed in BIOS. Maybe I got the wrong place?

As to the ACPI method, unfortunate. WoL in the BIOS frequenty refers to a dedicated header rather than the modern bus-based method -- but in fact probably only on significantly older machines than yours. Before we go bark up that tree any further therefore: googling for your issue leads to

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1261886

and in turn to

https://www.behnke.io/fedora-17-on-an-aspire-v5-571-reboot-on-shutdown/.

That is, if you run

Code: Select all

sudo bash -c "for i in /sys/bus/usb/devices/*/power/control; do echo on > $i; done"

and shutdown, does it then remain shutdown? If indeed, I'll go find out how to do that best automatically on Mint 18; I'm myself still on Mint 17, use hence upstart rather than systemd.

[EDIT] If it works, this would seem to by the way also indicate that you might be able to tweak a USB wake-up setting somewhere in your BIOS. Maybe that's all you need.

[EDIT] But if it works yet no amount of USB BIOS setting tweaking does, adjusted from the above mentioned sources, create the following as /etc/systemd/system/haltusbpower.service and after doing so run sudo systemctl enable haltusbpower.

Code: Select all

[Unit]
Description=haltusbpower
Before=shutdown.target
DefaultDependencies=no

[Service]
ExecStart=/bin/sh -c "for CONTROL in /sys/bus/usb/devices/*/power/control; do echo on >$CONTROL; done"
Type=oneshot
RemainAfterExit=yes

[Install]
WantedBy=shutdown.target

caspardavidfriedrich
Level 1
Level 1
Posts: 16
Joined: Fri Jun 16, 2017 1:20 pm

Re: linux mint 18.2 cinnamon 64-bit (beta) shutdown leads to restart

Postby caspardavidfriedrich » Mon Jun 19, 2017 3:12 pm

rene wrote:[EDIT] But if it works yet no amount of USB BIOS setting tweaking does, adjusted from the above mentioned sources, create the following as /etc/systemd/system/haltusbpower.service and after doing so run sudo systemctl enable haltusbpower.

Code: Select all

[Unit]
Description=haltusbpower
Before=shutdown.target
DefaultDependencies=no

[Service]
ExecStart=/bin/sh -c "for CONTROL in /sys/bus/usb/devices/*/power/control; do echo on >$CONTROL; done"
Type=oneshot
RemainAfterExit=yes

[Install]
WantedBy=shutdown.target

Wow it worked! You're the best, Rene! Thanks a lot! I'll change the status to `solved' now.


Return to “Installation & Boot”

Who is online

Users browsing this forum: excollier, swati123 and 8 guests