Slow shutdown

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
User avatar
overkill22
Level 4
Level 4
Posts: 282
Joined: Fri Jan 16, 2015 6:09 am
Contact:

Slow shutdown

Postby overkill22 » Thu Oct 12, 2017 12:45 am

Hi guys, I recently installed Linux mint 18.2 cinnamon.
At the beginning everything was OK, but now the shutdown takes minutes.
I don't know what is causing the problem as I didn't mess up with the installation.
I've installed a bunch of stuff using the software manager (like Dropbox, and etc).
In the attachments is where the laptop get stuck for minutes while shutting down.

User avatar
catweazel
Level 10
Level 10
Posts: 3331
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Slow shutdown

Postby catweazel » Thu Oct 12, 2017 1:05 am

In a terminal:

Code: Select all

cat /var/log/kern.log | less


Use the page-up and page-down keys to page through the file. Use the up and down arrows to scroll one line at a time, and type q to quit.

You are looking for messages from the kernel on a date boundary, like this:

Code: Select all

Oct 11 21:53:26 Fenella NetworkManager[1353]: <info>  [1507719206.5542] ModemManager disappeared from bus
Oct 12 06:47:44 Fenella kernel: [    0.000000] random: get_random_bytes called from...
Oct 12 06:47:44 Fenella kernel: [    0.000000] Linux version 4.13.3 (root@Fenella) (gcc...

That might show you what is taking so much time shutting down. In the example above, the Oct 11 date is the shutdown, and the Oct 12 date is the next day startup.
If your problem is fixed, please mark your thread as [SOLVED] by editing the title of the first message in the thread.

User avatar
minitux
Level 5
Level 5
Posts: 587
Joined: Tue Sep 12, 2017 10:05 am

Re: Slow shutdown

Postby minitux » Thu Oct 12, 2017 4:31 am

Sorry for my English, is not my language

When you ask for support, put the output of inxi -Fxz

User avatar
overkill22
Level 4
Level 4
Posts: 282
Joined: Fri Jan 16, 2015 6:09 am
Contact:

Re: Slow shutdown

Postby overkill22 » Mon Oct 16, 2017 3:44 am

catweazel wrote:In a terminal:

Code: Select all

cat /var/log/kern.log | less


Use the page-up and page-down keys to page through the file. Use the up and down arrows to scroll one line at a time, and type q to quit.

You are looking for messages from the kernel on a date boundary, like this:

Code: Select all

Oct 11 21:53:26 Fenella NetworkManager[1353]: <info>  [1507719206.5542] ModemManager disappeared from bus
Oct 12 06:47:44 Fenella kernel: [    0.000000] random: get_random_bytes called from...
Oct 12 06:47:44 Fenella kernel: [    0.000000] Linux version 4.13.3 (root@Fenella) (gcc...

That might show you what is taking so much time shutting down. In the example above, the Oct 11 date is the shutdown, and the Oct 12 date is the next day startup.



Now it is not happening many times. This is what I get after a slow shut down:


Code: Select all

Oct 16 15:38:32 UX305FA NetworkManager[888]: <warn>  [1508139512.5078] error requesting auth for org.freedesktop.NetworkManager.wifi.share.open: Authorization check failed: Message recipient disconnected from message bus without replying
Oct 16 15:38:32 UX305FA NetworkManager[888]: <warn>  [1508139512.5079] error requesting auth for org.freedesktop.NetworkManager.wifi.share.protected: Authorization check failed: Message recipient disconnected from message bus without replying
Oct 16 15:38:32 UX305FA NetworkManager[888]: <warn>  [1508139512.5625] error requesting auth for org.freedesktop.NetworkManager.wifi.share.protected: Authorization check failed: Refusing activation, D-Bus is shutting down.
Oct 16 15:38:32 UX305FA NetworkManager[888]: <warn>  [1508139512.5625] error requesting auth for org.freedesktop.NetworkManager.wifi.share.open: Authorization check failed: Refusing activation, D-Bus is shutting down.
Oct 16 15:38:32 UX305FA NetworkManager[888]: <info>  [1508139512.6023] audit: op="radio-control" arg="wireless-enabled:1" pid=3014 uid=0 result="success"

User avatar
overkill22
Level 4
Level 4
Posts: 282
Joined: Fri Jan 16, 2015 6:09 am
Contact:

Re: Slow shutdown

Postby overkill22 » Tue Oct 17, 2017 11:31 pm

another slow shutdown

Code: Select all

Oct 18 11:13:00 UX305FA NetworkManager[853]: <info>  [1508296380.5312] audit: op="radio-control" arg="wireless-enabled:1" pid=24840 uid=0 result="success"
Oct 18 11:13:00 UX305FA kernel: [ 7172.092902] ahci 0000:00:1f.2: port does not support device sleep

User avatar
catweazel
Level 10
Level 10
Posts: 3331
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Slow shutdown

Postby catweazel » Wed Oct 18, 2017 1:01 am

Please post the output of inxi -Fxz. Note that F is upper case.
If your problem is fixed, please mark your thread as [SOLVED] by editing the title of the first message in the thread.

User avatar
overkill22
Level 4
Level 4
Posts: 282
Joined: Fri Jan 16, 2015 6:09 am
Contact:

Re: Slow shutdown

Postby overkill22 » Wed Oct 18, 2017 3:29 am

catweazel wrote:Please post the output of inxi -Fxz. Note that F is upper case.


Another slow shutdown. Seems something with network manager.

Code: Select all

Oct 18 11:29:34 UX305FA NetworkManager[890]: <info>  [1508297374.5317] manager: WiFi hardware radio set enabled
Oct 18 11:29:34 UX305FA NetworkManager[890]: <info>  [1508297374.5317] manager: WWAN hardware radio set enabled
Oct 18 11:32:15 UX305FA NetworkManager[890]: <warn>  [1508297535.0298] error requesting auth for org.freedesktop.NetworkManager.wifi.share.protected: Authorization check failed: The name :1.9 was not provided by any .service files
Oct 18 11:32:15 UX305FA NetworkManager[890]: <warn>  [1508297535.0300] error requesting auth for org.freedesktop.NetworkManager.wifi.share.open: Authorization check failed: The name :1.9 was not provided by any .service files
Oct 18 11:32:15 UX305FA NetworkManager[890]: <warn>  [1508297535.0902] error requesting auth for org.freedesktop.NetworkManager.wifi.share.protected: Authorization check failed: Refusing activation, D-Bus is shutting down.
Oct 18 11:32:15 UX305FA NetworkManager[890]: <warn>  [1508297535.0903] error requesting auth for org.freedesktop.NetworkManager.wifi.share.open: Authorization check failed: Refusing activation, D-Bus is shutting down.
Oct 18 11:32:15 UX305FA NetworkManager[890]: <info>  [1508297535.1122] audit: op="radio-control" arg="wireless-enabled:1" pid=3258 uid=0 result="success"
Oct 18 11:32:15 UX305FA kernel: [  174.440906] ahci 0000:00:1f.2: port does not support device sleep



Code: Select all

$ inxi -Fxz
System:    Host: UX305FA Kernel: 4.10.0-37-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.4.6 (Gtk 3.18.9) Distro: Linux Mint 18.2 Sonya
Machine:   System: ASUSTeK (portable) product: UX305FA v: 1.0
           Mobo: ASUSTeK model: UX305FA v: 1.0
           Bios: American Megatrends v: UX305FA.213 date: 10/12/2015
CPU:       Dual core Intel Core M-5Y71 (-HT-MCP-) cache: 4096 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 5587
           clock speeds: max: 2900 MHz 1: 800 MHz 2: 1261 MHz 3: 799 MHz
           4: 799 MHz
Graphics:  Card: Intel Broadwell-U Integrated Graphics bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 driver: intel
           Resolution: 1920x1080@60.00hz
           GLX Renderer: Mesa DRI Intel HD Graphics 5300 (Broadwell GT2)
           GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes
Audio:     Card-1 Intel Wildcat Point-LP High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 Intel Broadwell-U Audio Controller
           driver: snd_hda_intel bus-ID: 00:03.0
           Sound: Advanced Linux Sound Architecture v: k4.10.0-37-generic
Network:   Card: Intel Wireless 7265 driver: iwlwifi bus-ID: 02:00.0
           IF: wlp2s0 state: up mac: <filter>
Drives:    HDD Total Size: 256.1GB (29.8% used)
           ID-1: /dev/sda model: SanDisk_SD7SN3Q2 size: 256.1GB
Partition: ID-1: / size: 9.1G used: 5.9G (69%) fs: ext4 dev: /dev/sda2
           ID-2: /home size: 226G used: 66G (31%) fs: ext4 dev: /dev/sda3
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 48.0C mobo: 27.8C
           Fan Speeds (in rpm): cpu: 25500
Info:      Processes: 242 Uptime: 2 min Memory: 1450.4/7884.6MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35

User avatar
catweazel
Level 10
Level 10
Posts: 3331
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Slow shutdown

Postby catweazel » Wed Oct 18, 2017 3:38 am

The only thing I can suggest now is that you move to the 4.11 kernel. Use Update Manager and select Linux Kernels from the View menu.
If your problem is fixed, please mark your thread as [SOLVED] by editing the title of the first message in the thread.

User avatar
overkill22
Level 4
Level 4
Posts: 282
Joined: Fri Jan 16, 2015 6:09 am
Contact:

Re: Slow shutdown

Postby overkill22 » Sun Nov 05, 2017 9:35 pm

I freshly installed mint 18.2.
I'm still having problem of slow shutdown. Here's another log, just to keep track

Code: Select all

Nov  5 14:13:22 UX305FA NetworkManager[978]: <info>  [1509862402.7411] audit: op="radio-control" arg="wireless-enabled:1" pid=12009 uid=0 result="success"



Code: Select all

System:    Host: UX305FA Kernel: 4.10.0-38-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.4.6 (Gtk 3.18.9) Distro: Linux Mint 18.2 Sonya
Machine:   System: ASUSTeK (portable) product: UX305FA v: 1.0
           Mobo: ASUSTeK model: UX305FA v: 1.0 Bios: American Megatrends v: UX305FA.213 date: 10/12/2015
CPU:       Dual core Intel Core M-5Y71 (-HT-MCP-) cache: 4096 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 5587
           clock speeds: max: 2900 MHz 1: 799 MHz 2: 802 MHz 3: 809 MHz 4: 952 MHz
Graphics:  Card: Intel Broadwell-U Integrated Graphics bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: (unloaded: fbdev,vesa) Resolution: 1920x1080@60.00hz
           GLX Renderer: Mesa DRI Intel HD Graphics 5300 (Broadwell GT2)
           GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes
Audio:     Card-1 Intel Wildcat Point-LP High Definition Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 Intel Broadwell-U Audio Controller driver: snd_hda_intel bus-ID: 00:03.0
           Sound: Advanced Linux Sound Architecture v: k4.10.0-38-generic
Network:   Card: Intel Wireless 7265 driver: iwlwifi bus-ID: 02:00.0
           IF: wlp2s0 state: up mac: <filter>
Drives:    HDD Total Size: 256.1GB (26.7% used) ID-1: /dev/sda model: SanDisk_SD7SN3Q2 size: 256.1GB
Partition: ID-1: / size: 9.5G used: 6.3G (71%) fs: ext4 dev: /dev/sda3
           ID-2: /home size: 221G used: 54G (26%) fs: ext4 dev: /dev/sda4
           ID-3: swap-1 size: 4.30GB used: 0.00GB (0%) fs: swap dev: /dev/sda2
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 39.0C mobo: 27.8C
           Fan Speeds (in rpm): cpu: 0
Info:      Processes: 235 Uptime: 9 min Memory: 1378.8/7884.6MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35


I'll now try to upgrade the kernel.


Return to “Installation & Boot”