Page 3 of 3

Re: Linux Mint USB stick boot problems

Posted: Tue Nov 07, 2017 1:25 pm
by p1on
Same thing with a new motherboard :cry:

Re: Linux Mint USB stick boot problems

Posted: Tue Nov 07, 2017 4:38 pm
by ClixTrix
PSU?

Re: Linux Mint USB stick boot problems

Posted: Tue Nov 07, 2017 4:39 pm
by p1on
That or CPU... Nothing else to blame

(really hope it's not the CPU :shock: )

Re: Linux Mint USB stick boot problems

Posted: Tue Nov 07, 2017 5:00 pm
by ClixTrix
A 9 year old PSU is more likely (IMO). They do wear out with age. Depends on use and environment. Also, standards and requirements change over time.

CPU and memory would be the other obvious choices.

Can't say what or which ..... it's just what makes sense. Honestly, I wouldn't base a NEW BUILD on a very old PSU. I keep a few around for bench tests, but not permanent builds.

Re: Linux Mint USB stick boot problems

Posted: Tue Nov 07, 2017 5:06 pm
by p1on
Was planning on a replacement.
Too noisy :/

Re: Linux Mint USB stick boot problems

Posted: Wed Nov 08, 2017 8:30 am
by p1on
Just tried to enable secure boot and disabled it again.
Windows now boots!

Still no luck with my Linux sticks :/

Re: Linux Mint USB stick boot problems

Posted: Wed Nov 08, 2017 9:52 am
by p1on
Aaaand were not booting again!
Updated BIOS (to F4a) and now I can't get Win to boot!
Tried going back to F2... tried everything i could in Secure Boot settings.

What is going on?

Re: Linux Mint USB stick boot problems

Posted: Wed Nov 08, 2017 10:01 am
by ClixTrix
That's interesting. I assume you did "Load Optimized Defaults" In Bios for the replacement board. Which BIOS release came with the board? I've seen some posts at AMD Forum of bad Bios on the X370 boards.

I've seen a few complaints that rocking ON-OFF or OFF-ON on Bios settings is sometimes necessary on Gigabyte boards. Try that on Fast Boot and make sure it's OFF.

Also, are you getting the Gigabyte logo screen at boot with the F-Keys at bottom? If not, enable that. When you see that screen, hit F12, and use that method to boot the flash drive. That's generally how I've used mine to date with install testing.

Are you still getting the same messages from Linux?

Edit: OUCH! Just saw your Bios update post. Hmmmm....... guess those posts at AMD have some relevance.

Re: Linux Mint USB stick boot problems

Posted: Wed Nov 08, 2017 10:11 am
by p1on
Tried the Fast Boot thing.

Getting Gygabyte logo and F-Keys.
Been using F12 the whole time.

Same things happening as before with all my sticks...

Re: Linux Mint USB stick boot problems

Posted: Wed Nov 08, 2017 10:20 am
by ClixTrix
OK.....back to basics.

Did you have any problems flashing back to F2?

If not, Load Optimized Defaults and Save-Exit. (I would also have advised doing that BEFORE flashing BIOS.)

On restart, go back to BIOS setup and try going back and rocking settings....as before. If that doesn't work, try clearing CMOS and start over.

Edit: Oh, and I know you have a Z370 Intel board. Just looking at the problems with NEW processors from both Intel and AMD and BIOS bugs on the various boards. Was going to ask about BIOS and you got ahead of me. Yes, BIOS flash to any new technology board could be a problem. UNLESS there is a problem, I usually don't flash BIOS. My Ryzen needed the latest BIOS. Not sure which processor you have....don't think you posted that.

Re: Linux Mint USB stick boot problems

Posted: Wed Nov 08, 2017 10:47 am
by p1on
8700k

...no problems flashing

Re: Linux Mint USB stick boot problems

Posted: Wed Nov 08, 2017 11:18 am
by p1on
Tried clearing CMOS and fiddling with the settings.. again.
Ready to give up and try a new PSU.
Also have a new CPU in the mail that should be here in 1-2 days :)

Re: Linux Mint USB stick boot problems

Posted: Wed Nov 08, 2017 3:49 pm
by p1on
New PSU and BOOM!
Windows boots!
BOOM! Linux boots!

:lol:

Re: Linux Mint USB stick boot problems

Posted: Wed Nov 08, 2017 4:18 pm
by p1on
Thank you so much for all the help.
Don't think I could've survived without it :)

Re: Linux Mint USB stick boot problems

Posted: Wed Nov 08, 2017 6:19 pm
by ClixTrix
Bridge to Engineering ..... More Power Scotty! :lol: