Cannot see Mint on BOOT Menu (Can't Disable Secure Boot)

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
gcsydney
Level 1
Level 1
Posts: 12
Joined: Sun Nov 05, 2017 6:28 am

Cannot see Mint on BOOT Menu (Can't Disable Secure Boot)

Postby gcsydney » Sun Nov 05, 2017 6:36 am

Please help a newbie out. I have searched a hundred forums and I haven't had any luck.

I have a HP Envy desktop and I have tried installing Mint a few times but every time I do, it seems to be successful but I can never see it when I manually go into the BOOT menu. I installed on ext5.

Note: I am unable to see the option in the BIOS menu to access the Secure Boot option to disable it (I know where it should be but it isn't there). So this means I won't get a grub menu I can live with that if I need to.

Please help. Thank you in advance!

P.S. this is a persistent problem for me. I have been working on it for a few months with no luck.

michael louwe
Level 6
Level 6
Posts: 1066
Joined: Sun Sep 11, 2016 11:18 pm

Re: Cannot see Mint on BOOT Menu (Can't Disable Secure Boot)

Postby michael louwe » Sun Nov 05, 2017 8:13 am

gcsydney wrote: .

.
Please provide info on your HP desktop's model and specifications or the Live LM Terminal output for inxi -Fxz .

HP UEFI computers are known to be difficult to boot and install Linux.

gcsydney
Level 1
Level 1
Posts: 12
Joined: Sun Nov 05, 2017 6:28 am

Re: Cannot see Mint on BOOT Menu (Can't Disable Secure Boot)

Postby gcsydney » Sun Nov 05, 2017 9:12 am

Thanks for replying. It’s a HP Envy H8-1425A.
Intel Core i7-3770 @ 3.4GHz 8GB RAM 64 bit

michael louwe
Level 6
Level 6
Posts: 1066
Joined: Sun Sep 11, 2016 11:18 pm

Re: Cannot see Mint on BOOT Menu (Can't Disable Secure Boot)

Postby michael louwe » Sun Nov 05, 2017 10:06 am

gcsydney wrote: .


Please try the tech-geeky fix for HP computers at ... viewtopic.php?f=42&t=243338

Certain high-end OEM Win 8.x/10 computers, eg Acer, Asus and HP, have an obstructive or pro-M$ BIOS setting for "select an UEFI file as trusted for executing", .......
https://itsfoss.com/no-bootable-device-found-ubuntu/
viewtopic.php?t=236560
... The above latest(= 2017) OEM laptops may have even removed this BIOS setting(= cannot even boot a Live Linux USB/DVD), but may be restored by a new BIOS firmware update from the OEMs.

gcsydney
Level 1
Level 1
Posts: 12
Joined: Sun Nov 05, 2017 6:28 am

Re: Cannot see Mint on BOOT Menu (Can't Disable Secure Boot)

Postby gcsydney » Mon Nov 06, 2017 12:42 am

Thank you for this.

Unfortunately, there is no option anywhere in my BIOS for "select an UEFI file as trusted for executing...". Also I cannot even get into Linux to run any commands in Konsole/Bash as Mint will not appear in my BOOT menu at all.

I'm still stuck.

User avatar
pbear
Level 4
Level 4
Posts: 240
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: Cannot see Mint on BOOT Menu (Can't Disable Secure Boot)

Postby pbear » Mon Nov 06, 2017 2:11 am

gcsydney wrote:I have tried installing Mint a few times but every time I do, it seems to be successful but I can never see it

Are you able to get a live session to boot? (In Linux lingo, install is what you do after that, but maybe you're using the word differently.) Which is to say, you downloaded an ISO, then burned it to DVD or USB. Are you able to get that to boot?
Time flies like an arrow. Fruit flies like a banana.
Running Mint 18.2 Mate 64 bit

michael louwe
Level 6
Level 6
Posts: 1066
Joined: Sun Sep 11, 2016 11:18 pm

Re: Cannot see Mint on BOOT Menu (Can't Disable Secure Boot)

Postby michael louwe » Mon Nov 06, 2017 2:31 am

@ gcsydney, .......

gcsydney wrote: I installed on ext5.


Did you install on ext4 or ext5 file system.?

What procedures did you use for the install, eg single-boot or dual-boot, UEFI or Legacy BIOS mode, "Install LM alongside Windows" or "Erase disk and install LM" or "Something else"(which "Device for boot loader installation" did you select.?), etc.?

Does your HP H8 desktop has dual graphics cards, ie integrated Intel and discrete HVidia cards.? Please run the Live LM USB/DVD and provide the Terminal output for inxi -Fxz
Last edited by michael louwe on Mon Nov 06, 2017 2:34 am, edited 1 time in total.

gcsydney
Level 1
Level 1
Posts: 12
Joined: Sun Nov 05, 2017 6:28 am

Re: Cannot see Mint on BOOT Menu (Can't Disable Secure Boot)

Postby gcsydney » Mon Nov 06, 2017 2:33 am

Yes I can get into that from the ISO on the USB but that’s all.

User avatar
pbear
Level 4
Level 4
Posts: 240
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: Cannot see Mint on BOOT Menu (Can't Disable Secure Boot)

Postby pbear » Mon Nov 06, 2017 3:22 am

While we're at it, what version of Windows came on the machine originally? I ask because when I look for your model on HP's website, the quick setup guide says it was Win7. Is that right?

By the way, as you can boot the ISO, there's an alternate solution (call it Plan B) where you install to an external hard drive. So, you have options.
Last edited by pbear on Mon Nov 06, 2017 3:25 am, edited 1 time in total.
Time flies like an arrow. Fruit flies like a banana.
Running Mint 18.2 Mate 64 bit

Laurent85
Level 13
Level 13
Posts: 4762
Joined: Tue May 26, 2015 10:11 am

Re: Cannot see Mint on BOOT Menu (Can't Disable Secure Boot)

Postby Laurent85 » Mon Nov 06, 2017 3:25 am

If you installed LM in EFI mode you can use my Live EFI Boot Disk to install rEFInd Boot Manager in Fallback mode.

Download iso image live-efi-boot-disk-amd64-171028.iso, boot a live session from it, then on the desktop double click the rEFInd installation icon.

Run the installation twice so that it reads "rEFInd Boot Manager set in Fallback mode..."

First installation rEFInd will be setup in Prioritity mode. Re-running installation will change rEFInd setup to Fallback mode. In this mode any EFI computer, even computers with buggy EFI firmware will load rEFInd Boot Manager at startup.
Last edited by Laurent85 on Mon Nov 06, 2017 3:32 am, edited 1 time in total.
Image

gcsydney
Level 1
Level 1
Posts: 12
Joined: Sun Nov 05, 2017 6:28 am

Re: Cannot see Mint on BOOT Menu (Can't Disable Secure Boot)

Postby gcsydney » Mon Nov 06, 2017 3:29 am

Here is the Terminal output for inxo -Fxz:

Code: Select all

System:    Host: mint Kernel: 4.8.0-53-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.4.3 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.2 Sonya
Machine:   System: Hewlett-Packard product: H8-1425A v: 1.00
           Mobo: PEGATRON model: 2AD5 v: 1.03
           Bios: AMI v: 7.15 date: 07/02/2012
CPU:       Quad core Intel Core i7-3770 (-HT-MCP-) cache: 8192 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 27139
           clock speeds: max: 3800 MHz 1: 1599 MHz 2: 1599 MHz 3: 1599 MHz
           4: 1605 MHz 5: 1599 MHz 6: 1601 MHz 7: 1799 MHz 8: 1600 MHz
Graphics:  Card: NVIDIA GF116 [GeForce GT 640 OEM] bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 drivers: nouveau (unloaded: fbdev,vesa)
           Resolution: 1680x1050@59.88hz
           GLX Renderer: Gallium 0.4 on NVCF
           GLX Version: 3.0 Mesa 12.0.6 Direct Rendering: Yes
Audio:     Card-1 Intel 7 Series/C210 Series Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 NVIDIA GF116 High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 01:00.1
           Sound: Advanced Linux Sound Architecture v: k4.8.0-53-generic
Network:   Card-1: Broadcom BCM43228 802.11a/b/g/n
           driver: bcma-pci-bridge bus-ID: 03:00.0
           IF: N/A state: N/A mac: N/A
           Card-2: Qualcomm Atheros AR8161 Gigabit Ethernet
           driver: alx port: d000 bus-ID: 04:00.0
           IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 1008.0GB (13.8% used)
           ID-1: /dev/sda model: WDC_WD10EZEX size: 1000.2GB temp: 0C
           ID-2: USB /dev/sdf model: TransMemory size: 7.8GB temp: 0C
           ID-1: swap-1 size: 8.54GB used: 0.00GB (0%) fs: swap dev: /dev/sda12
           ID-2: swap-2 size: 135.17GB used: 0.00GB (0%) fs: swap dev: /dev/sda13
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C gpu: 61.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 252 Uptime: 1 min Memory: 606.7/7940.3MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35


It was Windows 8 that my PC had originally installed.

gcsydney
Level 1
Level 1
Posts: 12
Joined: Sun Nov 05, 2017 6:28 am

Re: Cannot see Mint on BOOT Menu (Can't Disable Secure Boot)

Postby gcsydney » Mon Nov 06, 2017 3:32 am

michael louwe wrote:@ gcsydney, .......

gcsydney wrote: I installed on ext5.


Did you install on ext4 or ext5 file system.?

What procedures did you use for the install, eg single-boot or dual-boot, UEFI or Legacy BIOS mode, "Install LM alongside Windows" or "Erase disk and install LM" or "Something else"(which "Device for boot loader installation" did you select.?), etc.?


I just loaded from the USB and selected to install alongside windows (which is I assume how to install for a dual boot). Not sure about the UEFI/Legacy BIOS question though.

michael louwe
Level 6
Level 6
Posts: 1066
Joined: Sun Sep 11, 2016 11:18 pm

Re: Cannot see Mint on BOOT Menu (Can't Disable Secure Boot)

Postby michael louwe » Mon Nov 06, 2017 4:17 am

@ gcsydney, .......

gcsydney wrote:.

.
Looks like you have a wrongly installed Linux system using the 'swap dev' file-system or ext5 fs. The ext5 file-system is still in experimental development stage or alpha-testing.
... Where did you download the LM 18.2 ISO file.? Try to download the ISO file from another mirror website near your country, instead of a torrent website, and verify the ISO file.

If you encounter booting problem, refer to the NVidia fix at ... https://linuxmint.com/rel_sonya_cinnamon.php
.
.
P S - Your HP H8 desktop is a UEFI Win 8-era computer. By default, the OS is installed in UEFI mode. There is a BIOS setting to change from UEFI to Legacy BIOS mode, eg CSM or Legacy BIOS enabled.
... UEFI mode usually has to use GPT disks and 64bit OS; and has Secure Boot and TPM1.2. Legacy BIOS usually use MBR/ms-dos disks and 32bit or 64bit OS. The install procedures for LM are different for the 2 modes.
Last edited by michael louwe on Mon Nov 06, 2017 4:25 am, edited 1 time in total.

gcsydney
Level 1
Level 1
Posts: 12
Joined: Sun Nov 05, 2017 6:28 am

Re: Cannot see Mint on BOOT Menu (Can't Disable Secure Boot)

Postby gcsydney » Mon Nov 06, 2017 4:23 am

michael louwe wrote:@ gcsydney, .......

gcsydney wrote:.

.
Looks like you have a wrongly installed Linux system using the 'swap dev' file-system or ext5 fs. The ext5 file-system is still in experimental development stage or alpha-testing.
... Where did you download the LM 18.2 ISO file.? Try to download the ISO file from another mirror website near your country, instead of a torrent website, and verify the ISO file.

If you encounter booting problem, refer to the NVidia fix at ... https://linuxmint.com/rel_sonya_cinnamon.php


I downloaded it from the official Linux Mint website using my local mirror. Okay thanks, sounds like I stuffed something up. I don't know the different between ext1,2,3,4,5 etc. or the swap.dev. Which one should I have been using?

michael louwe
Level 6
Level 6
Posts: 1066
Joined: Sun Sep 11, 2016 11:18 pm

Re: Cannot see Mint on BOOT Menu (Can't Disable Secure Boot)

Postby michael louwe » Mon Nov 06, 2017 4:28 am

gcsydney wrote: I don't know the different between ext1,2,3,4,5 etc. or the swap.dev. Which one should I have been using?

.
Ext4.

For reference ... viewtopic.php?f=42&t=122276 (manual partitioning in Legacy BIOS mode)

At which install step did you select ext5 or swap dev.?
Last edited by michael louwe on Mon Nov 06, 2017 4:30 am, edited 1 time in total.

gcsydney
Level 1
Level 1
Posts: 12
Joined: Sun Nov 05, 2017 6:28 am

Re: Cannot see Mint on BOOT Menu (Can't Disable Secure Boot)

Postby gcsydney » Mon Nov 06, 2017 4:30 am

michael louwe wrote:@ gcsydney, .......

gcsydney wrote:.


P S - Your HP H8 desktop is a UEFI Win 8-era computer. By default, the OS is installed in UEFI mode. There is a BIOS setting to change from UEFI to Legacy BIOS mode, eg CSM or Legacy BIOS enabled.
... UEFI mode usually has to use GPT disks and 64bit OS; and has Secure Boot and TPM1.2. Legacy BIOS usually use MBR/ms-dos disks and 32bit or 64bit OS. The install procedures for LM are different for the 2 modes.


I have looked everywhere in the BIOS menu and there is absolutely nothing to change any BOOT settings, nothing which even has says UEFI or MBR. Must be restricted or something.

gcsydney
Level 1
Level 1
Posts: 12
Joined: Sun Nov 05, 2017 6:28 am

Re: Cannot see Mint on BOOT Menu (Can't Disable Secure Boot)

Postby gcsydney » Mon Nov 06, 2017 4:32 am

michael louwe wrote:
gcsydney wrote: I don't know the different between ext1,2,3,4,5 etc. or the swap.dev. Which one should I have been using?

.
Ext4.

For reference ... viewtopic.php?f=42&t=122276 (manual partitioning in Legacy BIOS mode)

At which install step did you select ext5 or swap dev.?


Thank you, I'll try again. It was the second/third time I tried installing, I selected the option to change the settings and was trying various ext options and most were just saying it wouldnt install, one finally would let it install. But no change, it still wouldnt appear in the BOOT menu.

Laurent85
Level 13
Level 13
Posts: 4762
Joined: Tue May 26, 2015 10:11 am

Re: Cannot see Mint on BOOT Menu (Can't Disable Secure Boot)

Postby Laurent85 » Mon Nov 06, 2017 4:33 am

Hi gcsydney, did you read my above post ?
Image

gcsydney
Level 1
Level 1
Posts: 12
Joined: Sun Nov 05, 2017 6:28 am

Re: Cannot see Mint on BOOT Menu (Can't Disable Secure Boot)

Postby gcsydney » Mon Nov 06, 2017 4:34 am

Laurent85 wrote:Hi gcsydney, did you read my above post ?


Yes, thanks. I am downloading the ISO now.

gcsydney
Level 1
Level 1
Posts: 12
Joined: Sun Nov 05, 2017 6:28 am

Re: Cannot see Mint on BOOT Menu (Can't Disable Secure Boot)

Postby gcsydney » Mon Nov 06, 2017 5:36 am

Laurent85 wrote:If you installed LM in EFI mode you can use my Live EFI Boot Disk to install rEFInd Boot Manager in Fallback mode.

Download iso image live-efi-boot-disk-amd64-171028.iso, boot a live session from it, then on the desktop double click the rEFInd installation icon.

Run the installation twice so that it reads "rEFInd Boot Manager set in Fallback mode..."

First installation rEFInd will be setup in Prioritity mode. Re-running installation will change rEFInd setup to Fallback mode. In this mode any EFI computer, even computers with buggy EFI firmware will load rEFInd Boot Manager at startup.


I tried to install this but it says: Cannot proceed. You need to boot the Live USB/DVD in EFI mode


Return to “Installation & Boot”