Secondary drives will not mount on boot

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
JamesK386
Level 1
Level 1
Posts: 2
Joined: Sun Nov 05, 2017 8:59 pm

Secondary drives will not mount on boot

Postby JamesK386 » Sun Nov 05, 2017 9:31 pm

Having a lingering problem I can't seem to resolve. Using Linux Mint 18.2 (Cinnamon). I have a boot drive, two other drives, and two CD drives. Problem: after boot, I can't access the two other drives unless I take a very specific (though simple) action. Starting a program that accesses either one of the other drives produces the following error message, "Unable to mount location, No object for D-Bus interface." However, if I click on the "Computer" icon and then click the two devices (drives) it will yield the appropriate file structure and I can access the drives from that point forward (until I reboot). I have found no other way to cause access. Would appreciate any clues on how to fix this. I'm generally comfortable with the command line. Thanks.

Laurent85
Level 13
Level 13
Posts: 4851
Joined: Tue May 26, 2015 10:11 am

Re: Secondary drives will not mount on boot

Postby Laurent85 » Mon Nov 06, 2017 4:03 am

You can change mounting options of the drives to "Mount at startup" in the Disk application utility.
Image

JamesK386
Level 1
Level 1
Posts: 2
Joined: Sun Nov 05, 2017 8:59 pm

<SOLVED> Secondary drives will not mount on boot

Postby JamesK386 » Fri Nov 10, 2017 5:01 pm

Thank you for the help. That was the clue I needed.

Using "Disks" highlighted the partition, clicked the tools icon (additional partition options), selected "edit mount options", turned on "automatic mount options" (you want the state that permits you to edit the mount options; it will reflect off, think of it like an old school light switch), ensure the "mount at startup" option is selected (I also selected "show in user interface"). Applied action to each of the partitions I was having difficulty with; solved the issue -- partitions now mount at boot. There are some fields that are auto filled at the bottom of the mount options screen -- did not mess with these.


Return to “Installation & Boot”