[Solved] Can not boot from Samsung pc with Win 8

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
deepakdeshp
Level 8
Level 8
Posts: 2370
Joined: Sun Aug 09, 2015 10:00 am

[Solved] Can not boot from Samsung pc with Win 8

Postby deepakdeshp » Mon Nov 06, 2017 12:04 am

Hello,
I got a convert who is ready to try Mint with some efforts. I was trying to set up dual boot on this machine from a single disk. I installed 64 bit Mint on an i3 processor in s8 partition. The install went ahead without a problem, but I am not getting the grub boot menu. Machine has Windows 8.
In the BIOS for boot option I get 3 entries for Windows Booting but there is no entry for Mint booting in the Bios after installing Mint. (In another HP machine I do get the entry for Mint booting in bios.

Please advise. I am trying for 2 days to solve the problem
Last edited by deepakdeshp on Sat Nov 11, 2017 11:36 am, edited 1 time in total.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 18 Cinnamon 64 bit with AMD processor .

Laurent85
Level 13
Level 13
Posts: 4746
Joined: Tue May 26, 2015 10:11 am

Re: Can not boot from Samsung pc with Win 8

Postby Laurent85 » Mon Nov 06, 2017 3:50 am

From a live session generate a bisnext summary, that will detail current installation setup :

Code: Select all

sudo add-apt-repository ppa:cematinla/bisnext
apt update
apt install bisnext inxi --install-recommends
bisnext --pastebin

See first line of summary, only provide the URL link, do not copy paste the entire summary to the forum it's too large.
Image

User avatar
administrollaattori
Level 12
Level 12
Posts: 4280
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: Can not boot from Samsung pc with Win 8

Postby administrollaattori » Mon Nov 06, 2017 4:56 am

I think that you need to make fake-windows-boot-files like in the next topic.
viewtopic.php?f=42&t=243338&p=1300722#p1300722

deepakdeshp
Level 8
Level 8
Posts: 2370
Joined: Sun Aug 09, 2015 10:00 am

Re: Can not boot from Samsung pc with Win 8

Postby deepakdeshp » Mon Nov 06, 2017 9:23 am

administrollaattori wrote:I think that you need to make fake-windows-boot-files like in the next topic.
viewtopic.php?f=42&t=243338&p=1300722#p1300722

Is sda8 same as gpt8?
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 18 Cinnamon 64 bit with AMD processor .

User avatar
austin.texas
Level 20
Level 20
Posts: 11696
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: Can not boot from Samsung pc with Win 8

Postby austin.texas » Mon Nov 06, 2017 10:56 am

deepakdeshp wrote:Is sda8 same as gpt8?
Same partition, yes. In the Grub configuration, sda8 is referred to as gpt8.
Mint 18.2 Cinnamon, Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Linux Linx 2017

User avatar
administrollaattori
Level 12
Level 12
Posts: 4280
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: Can not boot from Samsung pc with Win 8

Postby administrollaattori » Mon Nov 06, 2017 1:17 pm

deepakdeshp wrote:
administrollaattori wrote:I think that you need to make fake-windows-boot-files like in the next topic.
viewtopic.php?f=42&t=243338&p=1300722#p1300722

Is sda8 same as gpt8?

If you are editing /etc/grub.d/40_custom file, you can copy windows-entry from grub.cfg file, but if your windows boot-files are located in /EFI/Microsoft.orig/Boot, you need to add the same path to the /etc/grub.d/40_custom file.

deepakdeshp
Level 8
Level 8
Posts: 2370
Joined: Sun Aug 09, 2015 10:00 am

Re: Can not boot from Samsung pc with Win 8

Postby deepakdeshp » Tue Nov 07, 2017 1:20 pm

administrollaattori wrote:
deepakdeshp wrote:
administrollaattori wrote:I think that you need to make fake-windows-boot-files like in the next topic.
viewtopic.php?f=42&t=243338&p=1300722#p1300722

Is sda8 same as gpt8?

If you are editing /etc/grub.d/40_custom file, you can copy windows-entry from grub.cfg file, but if your windows boot-files are located in /EFI/Microsoft.orig/Boot, you need to add the same path to the /etc/grub.d/40_custom file.


Thank you for your note but there is no joy, I made the changes in 40_custom . Bios gives boot option as boot from Windows and another option is boot from hdd. I chose boot from hdd. It would not let me run update-grub so I chrooted to sda8 and ran update-grub
[url]http://karuppuswamy.com/wordpress/2010/06/02/how-to-chroot-to-ubuntu-using-live-cd-to-fix-grub-rescue-prompt/
[/url]
I added entry as per your advise in 40_custom. It automatically reflected in grub.cfg.
The log is enclosed.

Code: Select all

   nt@mint ~ $ cat /mnt//test
 mount --bind /dev /mnt/dev
mint mint # mount --bind /proc /mnt/proc
mint mint # mount --bind /sys /mnt/sys
mint mint # sudo chroot /mnt
mint / # update-grub
Generating grub configuration file ...
Warning: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported.
Found linux image: /boot/vmlinuz-4.8.0-53-generic
Found initrd image: /boot/initrd.img-4.8.0-53-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
  /run/lvm/lvmetad.socket: connect failed: No such file or directory
  WARNING: Failed to connect to lvmetad. Falling back to internal scanning.
done
   
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 18 Cinnamon 64 bit with AMD processor .

deepakdeshp
Level 8
Level 8
Posts: 2370
Joined: Sun Aug 09, 2015 10:00 am

Re: Can not boot from Samsung pc with Win 8

Postby deepakdeshp » Tue Nov 07, 2017 1:25 pm

Laurent85 wrote:From a live session generate a bisnext summary, that will detail current installation setup :

Code: Select all

sudo add-apt-repository ppa:cematinla/bisnext
apt update
apt install bisnext inxi --install-recommends
bisnext --pastebin

See first line of summary, only provide the URL link, do not copy paste the entire summary to the forum it's too large.


Pastebin link https://paste.debian.net/994560/
Nov 7, 2017, bisnext summary id f5d2
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 18 Cinnamon 64 bit with AMD processor .

Laurent85
Level 13
Level 13
Posts: 4746
Joined: Tue May 26, 2015 10:11 am

Re: Can not boot from Samsung pc with Win 8

Postby Laurent85 » Tue Nov 07, 2017 2:46 pm

LM was installed in Legacy mode. No grub boot loader in the ESP (EFI System Partition) and no /boot/efi in fstab:
================================== UEFI ===================================
...
EFI files in /dev/sda2:
0b9894b9cf5d469617ec8346f48ce601 /EFI/Microsoft/Boot/bootmgr.efi
87d5111db80f3b1dba0c44b4af2257f1 /EFI/Boot/bootx64.efi
87d5111db80f3b1dba0c44b4af2257f1 /EFI/Microsoft/Boot/bootmgfw.efi
b97bca0a4cc28f274b5e1414014bcbac /EFI/Microsoft/Boot/memtest.efi


=================== Linux Mint 18.2 Sonya in /dev/sda8 ====================
...
_______________________________ /etc/fstab ________________________________

UUID=4a026d53-aa72-41da-810e-c05a670af9eb / ext4 errors=remount-ro 0 1


Boot your LM installation media in EFI mode and reinstall LM. As Windows was installed in EFI mode, you need to install LM in the same mode Windows was installed, hence in EFI mode. Also disable Secure Boot in the Bios settings.

Before proceeding with installation check the active boot mode using this command:

Code: Select all

[ -d /sys/firmware/efi ] && echo "UEFI mode active" || echo "Legacy mode active"
Image

deepakdeshp
Level 8
Level 8
Posts: 2370
Joined: Sun Aug 09, 2015 10:00 am

Re: Can not boot from Samsung pc with Win 8

Postby deepakdeshp » Wed Nov 08, 2017 2:22 am

Laurent85 wrote:LM was installed in Legacy mode. No grub boot loader in the ESP (EFI System Partition) and no /boot/efi in fstab:
================================== UEFI ===================================
...
EFI files in /dev/sda2:
0b9894b9cf5d469617ec8346f48ce601 /EFI/Microsoft/Boot/bootmgr.efi
87d5111db80f3b1dba0c44b4af2257f1 /EFI/Boot/bootx64.efi
87d5111db80f3b1dba0c44b4af2257f1 /EFI/Microsoft/Boot/bootmgfw.efi
b97bca0a4cc28f274b5e1414014bcbac /EFI/Microsoft/Boot/memtest.efi


=================== Linux Mint 18.2 Sonya in /dev/sda8 ====================
...
_______________________________ /etc/fstab ________________________________

UUID=4a026d53-aa72-41da-810e-c05a670af9eb / ext4 errors=remount-ro 0 1


Boot your LM installation media in EFI mode and reinstall LM. As Windows was installed in EFI mode, you need to install LM in the same mode Windows was installed, hence in EFI mode. Also disable Secure Boot in the Bios settings.

Before proceeding with installation check the active boot mode using this command:

Code: Select all

[ -d /sys/firmware/efi ] && echo "UEFI mode active" || echo "Legacy mode active"


I cant boot from the usb unless I set BIOS parameter to UEFI+CSM
AT another place there is UEFI in Bios but it is greyed out and I cant change it.
I reset the boot parameters to factory default , and still the UEFI entry is disabled , and remains greyed out.
The command above always gives Legacy mode active and there is no /sys/firmware/efi directory in the usb or sda8
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 18 Cinnamon 64 bit with AMD processor .

User avatar
administrollaattori
Level 12
Level 12
Posts: 4280
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: Can not boot from Samsung pc with Win 8

Postby administrollaattori » Wed Nov 08, 2017 3:30 am

deepakdeshp wrote:I cant boot from the usb unless I set BIOS parameter to UEFI+CSM
AT another place there is UEFI in Bios but it is greyed out and I cant change it.
I reset the boot parameters to factory default , and still the UEFI entry is disabled , and remains greyed out.
The command above always gives Legacy mode active and there is no /sys/firmware/efi directory in the usb or sda8

You need to convert Legacy boot to UEFI boot. An example can find from the next topic.
viewtopic.php?f=46&t=256244#p1383522

1. Add efi-partition to the /etc/fstab file (if not added)
2. mount efi-partition

Code: Select all

sudo mount -a

3. Install grub

Code: Select all

sudo -i
mkdir -p /boot/efi/EFI/ubuntu
apt-get install grub-efi grub-efi-amd64
update-grub
sync
reboot

fabien85
Level 6
Level 6
Posts: 1023
Joined: Tue Mar 11, 2014 4:30 pm

Re: Can not boot from Samsung pc with Win 8

Postby fabien85 » Wed Nov 08, 2017 5:38 am

Will the apt-get install grub-efi grub-efi-amd64 part work if you are booted in Legacy mode ?
I always understood that if you are booted in Legacy mode, the linux system does not have the capability to communicate with the firmware to create a UEFI boot entry in the NVRAM.

I would think you first need to install refind from windows (instructions here), then you will be able to boot into Mint in UEFI mode. And then, if you want, you can install grub in UEFI mode (although for me it's cleaner to just keep refind).

deepakdeshp
Level 8
Level 8
Posts: 2370
Joined: Sun Aug 09, 2015 10:00 am

Re: Can not boot from Samsung pc with Win 8

Postby deepakdeshp » Wed Nov 08, 2017 6:29 am

fabien85 wrote:Will the apt-get install grub-efi grub-efi-amd64 part work if you are booted in Legacy mode ?
I always understood that if you are booted in Legacy mode, the linux system does not have the capability to communicate with the firmware to create a UEFI boot entry in the NVRAM.

I would think you first need to install refind from windows (instructions here), then you will be able to boot into Mint in UEFI mode. And then, if you want, you can install grub in UEFI mode (although for me it's cleaner to just keep refind).

This is an Intel i3 machine.And the Mint version I am installing is 32 bit. Hope it is ok.
So should I install something else for grub-efi-amd64?

Thank you for quick response.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 18 Cinnamon 64 bit with AMD processor .

deepakdeshp
Level 8
Level 8
Posts: 2370
Joined: Sun Aug 09, 2015 10:00 am

Re: Can not boot from Samsung pc with Win 8

Postby deepakdeshp » Wed Nov 08, 2017 7:26 am

I will download 64 bit version of LM and try dual boot instead of the earlier 32 bit LM
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 18 Cinnamon 64 bit with AMD processor .

Laurent85
Level 13
Level 13
Posts: 4746
Joined: Tue May 26, 2015 10:11 am

Re: Can not boot from Samsung pc with Win 8

Postby Laurent85 » Wed Nov 08, 2017 7:36 am

deepakdeshp wrote:I will download 64 bit version of LM and try dual boot instead of the earlier 32 bit LM

Didn't notice your were trying to install LM 32 bit. Installing LM in EFI mode must be 64 bit, For further references see [TUTORIAL] Installing Mint on a Windows 8/8.1/10 Computer
Image

deepakdeshp
Level 8
Level 8
Posts: 2370
Joined: Sun Aug 09, 2015 10:00 am

Re: Can not boot from Samsung pc with Win 8

Postby deepakdeshp » Wed Nov 08, 2017 7:45 am

I will download 64 bit version of LM and try dual boot instead of the earlier 32 bit LM.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 18 Cinnamon 64 bit with AMD processor .

deepakdeshp
Level 8
Level 8
Posts: 2370
Joined: Sun Aug 09, 2015 10:00 am

Re: Can not boot from Samsung pc with Win 8

Postby deepakdeshp » Wed Nov 08, 2017 11:04 am

fabien85 wrote:Will the apt-get install grub-efi grub-efi-amd64 part work if you are booted in Legacy mode ?
I always understood that if you are booted in Legacy mode, the linux system does not have the capability to communicate with the firmware to create a UEFI boot entry in the NVRAM.

I would think you first need to install refind from windows (instructions here), then you will be able to boot into Mint in UEFI mode. And then, if you want, you can install grub in UEFI mode (although for me it's cleaner to just keep refind).

Thank you. The grub commands given by you didnt work.
Now I am able to boot Mint which is installed in Legacy mode, but there is no option for Windows. Update-grub can not find Window.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 18 Cinnamon 64 bit with AMD processor .

deepakdeshp
Level 8
Level 8
Posts: 2370
Joined: Sun Aug 09, 2015 10:00 am

Re: Can not boot from Samsung pc with Win 8

Postby deepakdeshp » Wed Nov 08, 2017 12:02 pm

Hello ,
In BIOS CSM mode, I can boot only LM and in BIOS UEFI mode I can boot only windows.
But grub still does not detect windows and I do not get a choice to boot either LM or Window$,
Please advise
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 18 Cinnamon 64 bit with AMD processor .

fabien85
Level 6
Level 6
Posts: 1023
Joined: Tue Mar 11, 2014 4:30 pm

Re: Can not boot from Samsung pc with Win 8

Postby fabien85 » Wed Nov 08, 2017 1:21 pm

Indeed, you cannot dual-boot systems in different boot modes. Also support for 32-bit is crumbling, so as Laurent said you need to install with the 64-bit ISO which is UEFI-capable.
If there are still troubles in 64-bit (like you still cant install UEFI mode) then we can give further advices, but the first step is a 64-bit reinstall.

deepakdeshp
Level 8
Level 8
Posts: 2370
Joined: Sun Aug 09, 2015 10:00 am

Re: Can not boot from Samsung pc with Win 8

Postby deepakdeshp » Wed Nov 08, 2017 2:11 pm

fabien85 wrote:Indeed, you cannot dual-boot systems in different boot modes. Also support for 32-bit is crumbling, so as Laurent said you need to install with the 64-bit ISO which is UEFI-capable.
If there are still troubles in 64-bit (like you still cant install UEFI mode) then we can give further advices, but the first step is a 64-bit reinstall.

I did install the 64 bit LM as indicated in my previous post.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 18 Cinnamon 64 bit with AMD processor .


Return to “Installation & Boot”

Who is online

Users browsing this forum: dwatrous, Joe2Shoe, Laurent85 and 18 guests