Acer Aspire S7 No bootable device

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
dwatrous
Level 1
Level 1
Posts: 1
Joined: Fri Nov 17, 2017 6:45 pm

Acer Aspire S7 No bootable device

Postby dwatrous » Fri Nov 17, 2017 7:10 pm

I want to use Linux Mint on my Acer Aspire S7 391. Linux mint boots fine from the USB and I can run the install. The files are on the disk, but when I reboot, it says "No bootable device -- Please restart system".

I found this article with a similar problem: https://itsfoss.com/no-bootable-device-found-ubuntu/
When I get to the section where I would “Select an UEFI file as trusted for executing”, none are listed. I would expect HDD0 to be in the list, but it's empty.

I have tried to install with Legacy Mode in the BIOS, but it fails to install telling me that "Unable to install GRUB in /dev/sda"

Any ideas to help me get this working?

michael louwe
Level 6
Level 6
Posts: 1207
Joined: Sun Sep 11, 2016 11:18 pm

Re: Acer Aspire S7 No bootable device

Postby michael louwe » Sat Nov 18, 2017 2:33 am

@ dwatrous, .......

dwatrous wrote:.

.
You should have an SSD or EMMC, instead of a HDD. Is it listed in BIOS setup as SSD or EMMC.? Please refer also to ... viewtopic.php?t=236560

Maybe, you need to check your BIOS settings and install procedures properly for the Legacy BIOS install. It is not normal for a Legacy BIOS install to fail.

Jedinovice
Level 5
Level 5
Posts: 948
Joined: Sun Aug 18, 2013 9:09 pm

Re: Acer Aspire S7 No bootable device

Postby Jedinovice » Sat Nov 18, 2017 3:23 am

The answer is in this thread!
viewtopic.php?f=46&t=254948&p=1374459&hilit=no+bootable+device+acer#p1374459

I have been there recently. Acer blew the BIOS in their S and E series laptops. You cannot insert a trusted key in the BIOS no matter what! One option is to get the BIOS updated... but that can only be done in Windows. I think you would have to get Acer to do it for you. Once updated you can then add a trusted key.

In the absence of that, you HAVE to use rEFInd! I did and it worked! I am typing on this laptop which i was able to install Mint and then Neon after it with no grief since. But note that you must FORCE a table entry.

It's easy when you know how and I give instructions as I expected this problem to re-appear. Read the whole thread to see my troubles!!
I swear, there is no other way if you do not get the BIOS updated to 1.10. But it's no so bad if you follow the instructions given.
Mint Linux 18.0 64 bit KDE edition.
Video editing (AMV's mainly) on a dual core n2840 atom!
Results here: https://www.youtube.com/channel/UC5Dw91 ... yVKS7X1Rlg
LOOK HERE FOR MY DEMO OF MINT LINUX KDE - https://www.youtube.com/watch?v=Q8hDYiGprWs


Return to “Installation & Boot”