Page 1 of 1

New PC, can't run from live CD with video card installed

Posted: Mon Nov 20, 2017 11:56 am
by eyeball
All, I'm looking for some help getting Mint up and running on my new PC.


Hardware I'm including:

I7 8700k
32GB ram
Samsung M.2 SSD
ASROCK z370 motherboard
AMD Vega 64 graphics card

I'm trying to use the beta 18.3 iso. I created a bootable USB from windows using yumi.

If I leave the AMD graphics card uninstalled in the new machine, I can boot from the USB drive and install just fine using the integrated graphics.

If I start over and install the graphics card, and then try to boot from the USB drive, I get nothing. I start the machine, get my bios splash screen, tell it to boot from USB and then the screen goes black.

The card is seated properly and working (For example I was able to install Fedora 27 on it before changing my mind about trying that and deciding to stick with Mint).


I also tried installing with the integrated graphics and then installing the card and trying to boot into the installed mint, same problem. Nothing after the bios splash.

Any suggestions on how to debug this / get it running?


Thanks!

Re: New PC, can't run from live CD with video card installed

Posted: Mon Nov 20, 2017 2:02 pm
by administrollaattori
What tells a command

Code: Select all

inxi -G

Re: New PC, can't run from live CD with video card installed

Posted: Mon Nov 20, 2017 2:07 pm
by Spearmint2
Are booting from a 32 bit or 64 bit ISO?

Have you tried any other version of the distro? Like 18.2 or 17.3 ?

Re: New PC, can't run from live CD with video card installed

Posted: Mon Nov 20, 2017 2:18 pm
by eyeball
I'll run the inxi command when I get home from work tonight.

I'm using the 64 bit version.

I did not try 18.2 yet, I will also do that when I get home. I did also try Ubuntu 17.04 and had the same problem. I had been trying the newer releases thinking they would be more likely to work with the fairly new hardware. Maybe bad assumption?

Re: New PC, can't run from live CD with video card installed

Posted: Mon Nov 20, 2017 8:37 pm
by eyeball
administrollaattori wrote:What tells a command

Code: Select all

inxi -G
Here's how it looks when booted into the installed mint 18.3 running the integrated graphics:

Graphics: Card-1: Intel Device 3e92
Card-2: Advanced Micro Devices [AMD/ATI] Device 687f
Display Server: X.Org 1.18.4 drivers: vesa,intel (unloaded: fbdev)
Resolution: 1720x1440@0.00hz
GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 4.0, 256 bits)
GLX Version: 3.0 Mesa 17.0.7

Re: New PC, can't run from live CD with video card installed

Posted: Mon Nov 20, 2017 9:59 pm
by Mattyboy
Now that you've installed Mint to your hard drive try dropping the res down to 720p, shut down, plugg the card back in, run the video cable out the back of it and boot back up.

I solved a similar issue with a NIVIDA card, install with integrated, switch to card after installation.

I'll point out that you may have better results using Mint 17.3 as that fully supports AMD's Radeon catalyst drivers.

Re: New PC, can't run from live CD with video card installed

Posted: Tue Nov 21, 2017 2:22 pm
by Spearmint2
Mattyboy wrote:Now that you've installed Mint to your hard drive try dropping the res down to 720p, shut down, plugg the card back in, run the video cable out the back of it and boot back up.

I solved a similar issue with a NIVIDA card, install with integrated, switch to card after installation.

I'll point out that you may have better results using Mint 17.3 as that fully supports AMD's Radeon catalyst drivers.
Agree. He has the wrong drivers loaded for that video card, although that was probably a reading from his onboard video, which is Intel. Maybe if he uses JUST the video card and has the onboard video disabled in his BIOS.

Re: New PC, can't run from live CD with video card installed

Posted: Wed Nov 22, 2017 8:19 am
by eyeball
Ok, I tried 18.2 and 17.3 and same thing with both.

Regarding disabling the on-board graphics ... I'm not super clear on how to do that in my uefi ... there's a toggle for primary graphics device or something like that and it sets to PCIE automatically when the gpu is installed. There's a toggle for enabling both of them all the time that is set to disabled.

IT seems like they're both there to the os though. Like when I ran that inxi command it shows both yet I had the primary graphics device toggled to the integrated graphics.

Re: New PC, can't run from live CD with video card installed

Posted: Wed Nov 22, 2017 8:21 am
by eyeball
Mattyboy wrote:Now that you've installed Mint to your hard drive try dropping the res down to 720p, shut down, plugg the card back in, run the video cable out the back of it and boot back up.
If I try to boot mint with the gpu installed, I just get a black screen once the bios splash screen is passed. It doesn't even show the grub menu for choosing which os to boot.

Re: New PC, can't run from live CD with video card installed

Posted: Wed Nov 22, 2017 11:32 am
by Mattyboy
eyeball wrote:
If I try to boot mint with the gpu installed, I just get a black screen once the bios splash screen is passed. It doesn't even show the grub menu for choosing which os to boot.
Mattyboy wrote:I'll point out that you may have better results using Mint 17.3 as that fully supports AMD's Radeon catalyst drivers.
Spearmint2 wrote: Maybe if he uses JUST the video card and has the onboard video disabled in his BIOS.
Maybe?