[SOLVED]Hibernate doesn't work

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
parotta36
Level 1
Level 1
Posts: 8
Joined: Fri Mar 24, 2017 3:11 pm

[SOLVED]Hibernate doesn't work

Postby parotta36 » Tue Nov 21, 2017 2:30 pm

I'm using Linux Mint 18.2 Sonya and hibernate doesn't work. It worked perfectly when i used Serena.
I searched the web a lot and tried modified, even after which it doesn't seem to work. This really bugs me as I used to hibernate a lot.
Kernel: 4.8.0-53-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.4.3 (Gtk 3.18.9-1ubuntu3.3)
Distro: Linux Mint 18.2 Sonya

The output of free is,

Code: Select all

free
              total        used        free      shared  buff/cache   available
Mem:        8056880     1178952     5847384      131152     1030544     6455664
Swap:       8294396           0     8294396

I added the line to /etc/fstab

Code: Select all

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda2 during installation
UUID=8b6086fa-f963-4e85-bfb9-d3282510e2cb /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sda1 during installation
UUID=FEA2-E9FB  /boot/efi       vfat    umask=0077      0       1
#swap partition
UUID=ef5f7645-b3c9-4fe8-876d-c125e5fb84ca       none    swap    sw      0       0


I also added the UUID at /etc/default/grub in the GRUB_CMDLINE_LINUX line

Code: Select all

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX="resume=UUID=/dev/disk/by-uuid/ef5f7645-b3c9-4fe8-876d-c125e5fb84ca"

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
GRUB_INIT_TUNE="480 440 1"

I also updated using update-grub after changing the line at /etc/default/grub.
Last edited by parotta36 on Wed Nov 22, 2017 1:27 am, edited 1 time in total.

Mute Ant
Level 12
Level 12
Posts: 4192
Joined: Tue Sep 03, 2013 7:45 pm

Re: Hibernate doesn't work

Postby Mute Ant » Tue Nov 21, 2017 6:41 pm

This bit looks wrong to me...
GRUB_CMDLINE_LINUX="resume=UUID=/dev/disk/by-uuid/ef5f7645-b3c9-4fe8-876d-c125e5fb84ca"
...the kernel "root=" equivalent would be...
root=UUID=ef5f7645-b3c9-4fe8-876d-c125e5fb84ca
...or...
root=LABEL=rootski
..or...
root=/dev/sdb7
...so I am guessing your GRUB line should be...
GRUB_CMDLINE_LINUX="resume=UUID=ef5f7645-b3c9-4fe8-876d-c125e5fb84ca"
...or...
GRUB_CMDLINE_LINUX="resume=/dev/disk/by-uuid/ef5f7645-b3c9-4fe8-876d-c125e5fb84ca"
Strange women lying in ponds distributing swords is no basis for a system of government.

FreedomTruth
Level 4
Level 4
Posts: 326
Joined: Fri Sep 23, 2016 10:19 am

Re: Hibernate doesn't work

Postby FreedomTruth » Tue Nov 21, 2017 11:48 pm

parotta36 wrote:I'm using Linux Mint 18.2 Sonya and hibernate doesn't work. It worked perfectly when i used Serena.
I searched the web a lot and tried modified, even after which it doesn't seem to work. This really bugs me as I used to hibernate a lot.
Kernel: 4.8.0-53-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.4.3 (Gtk 3.18.9-1ubuntu3.3)
Distro: Linux Mint 18.2 Sonya

(Serena used 4.4 kernel by default) Seems like I had an issue with suspend with some of the 4.8 kernels; try either a later kernel (4.10 worked for me) or go back to 4.4 (what I eventually switched back to). That is, assuming your resume settings are correct. Also, check the file /etc/initramfs-tools/conf.d/resume
If you abide in My word, you are My disciples indeed. And you shall know the truth, and the truth shall make you free... Most assuredly, I say to you, whoever commits sin is a slave of sin... Therefore if the Son makes you free, you shall be free indeed.

parotta36
Level 1
Level 1
Posts: 8
Joined: Fri Mar 24, 2017 3:11 pm

Re: Hibernate doesn't work

Postby parotta36 » Wed Nov 22, 2017 1:26 am

@Mute Ant. Thanks, it worked for me.
This bit looks wrong to me...
...so I am guessing your GRUB line should be...
GRUB_CMDLINE_LINUX="resume=UUID=ef5f7645-b3c9-4fe8-876d-c125e5fb84ca"


Return to “Installation & Boot”