Memtest does not run

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
deepakdeshp
Level 10
Level 10
Posts: 3427
Joined: Sun Aug 09, 2015 10:00 am

Memtest does not run

Post by deepakdeshp » Sun Dec 03, 2017 1:35 pm

When I try running memtest, I get error message that "cant run memtest on sda13"
I dont have SDA partition at all. I am running Mint 18.3 Cinnamon.
Please advise
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 19 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

User avatar
ClixTrix
Level 5
Level 5
Posts: 723
Joined: Wed Dec 09, 2015 11:40 am
Location: Columbus, Ohio, USA

Re: Memtest does not run

Post by ClixTrix » Sun Dec 03, 2017 2:13 pm

No SDA hard drive partitions? SDA is the 1st physical hard drive with 13 as the 13th partition.

How do you have Mint installed? Multiple OSes? What device?

Is that error coming from Grub when you select Memtest86+ from Grub boot menu?

Could you please run the following command from Terminal and post back the results:

Code: Select all

inxi -Fxz
Linux Mint 18.3 x64 Cinnamon Kernel 4.15.0-29-generic
Gigabyte GA-AB350M-D3H (F20) / Ryzen 5 1600 / Micron Ballistix Sport DDR4 2400 2x8GB / XFX HD5450-1GB
NVMe-SSD Samsung EVO 960 250GB / SATA-HDD WD1600BEKT 160GB / SATA-SSD Toshiba OCZ VX500 512GB

User avatar
Pjotr
Level 20
Level 20
Posts: 10462
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Memtest does not run

Post by Pjotr » Sun Dec 03, 2017 2:26 pm

If I recall correctly, memtest can only be run on a conventional BIOS. Not on UEFI in UEFI mode.
Tip: 10 things to do after installing Linux Mint 19 Tara
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

deepakdeshp
Level 10
Level 10
Posts: 3427
Joined: Sun Aug 09, 2015 10:00 am

Re: Memtest does not run

Post by deepakdeshp » Mon Dec 04, 2017 2:48 am

ClixTrix wrote:No SDA hard drive partitions? SDA is the 1st physical hard drive with 13 as the 13th partition.

How do you have Mint installed? Multiple OSes? What device?

Is that error coming from Grub when you select Memtest86+ from Grub boot menu?

Could you please run the following command from Terminal and post back the results:

Code: Select all

inxi -Fxz
Sorry, I meant I didnt have sda13 but partitions only till sda11
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 19 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

User avatar
ClixTrix
Level 5
Level 5
Posts: 723
Joined: Wed Dec 09, 2015 11:40 am
Location: Columbus, Ohio, USA

Re: Memtest does not run

Post by ClixTrix » Mon Dec 04, 2017 8:09 am

deepakdeshp wrote:Sorry, I meant I didnt have sda13 but partitions only till sda11
That suggests you deleted some partitions or did some rearrangement of partitions/folders on the sda drive, so that Grub is no longer pointing to the correct location of Memtest86+. However, I'm thinking you may have more than one copy of Grub and other installs of Linux. I can see the possibility of complications with either EFI or MBR boot methods, so not absolutely certain what has happened to create the problem. As Pjotr mentioned, Memtest86+ won't work on EFI installs.

I'm assuming you installed Mint on SDA and /boot contains the Grub folder and Memtest86+ files as well as Kernel. Is that correct or do you have some other arrangement? I asked for the inxi info to check locations of devices and partitions.

Normally, I would recommend running Grub Update, but not understanding exactly what's happened and what you have installed is making me step back from that suggestion. I really need more info on your configuration and what might have created the problem.

Edit: Are you running any Grub utilities, like Grub Customizer?
Linux Mint 18.3 x64 Cinnamon Kernel 4.15.0-29-generic
Gigabyte GA-AB350M-D3H (F20) / Ryzen 5 1600 / Micron Ballistix Sport DDR4 2400 2x8GB / XFX HD5450-1GB
NVMe-SSD Samsung EVO 960 250GB / SATA-HDD WD1600BEKT 160GB / SATA-SSD Toshiba OCZ VX500 512GB

deepakdeshp
Level 10
Level 10
Posts: 3427
Joined: Sun Aug 09, 2015 10:00 am

Re: Memtest does not run

Post by deepakdeshp » Tue Dec 05, 2017 10:23 am

ClixTrix wrote:
deepakdeshp wrote:Sorry, I meant I didnt have sda13 but partitions only till sda11
Edit: Are you running any Grub utilities, like Grub Customizer?
I am running customizer. But gparted shows only 11 partitions and never deleted sda13.
Last edited by deepakdeshp on Tue Dec 05, 2017 2:30 pm, edited 1 time in total.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 19 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

deepakdeshp
Level 10
Level 10
Posts: 3427
Joined: Sun Aug 09, 2015 10:00 am

Re: Memtest does not run

Post by deepakdeshp » Tue Dec 05, 2017 10:25 am

Pjotr wrote:If I recall correctly, memtest can only be run on a conventional BIOS. Not on UEFI in UEFI mode.
Let me try booting in Non efi mode and test
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 19 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

User avatar
trytip
Level 7
Level 7
Posts: 1677
Joined: Tue Jul 05, 2016 1:20 pm

Re: Memtest does not run

Post by trytip » Tue Dec 05, 2017 1:28 pm

did you try to completely remove and then install again?
Image

Post Reply

Return to “Installation & Boot”