Wireless connection on Mint 18.3 (solved)

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
beacon
Level 3
Level 3
Posts: 184
Joined: Thu Oct 20, 2011 8:40 am

Wireless connection on Mint 18.3 (solved)

Postby beacon » Wed Dec 06, 2017 1:59 pm

I had a similar problem last year that was solved by help I received on this forum. (Thanks especially to Jeremy B.) I have since upgraded to 18.3 and find that, like last year, I can't get a wireless connection. I have gone through all the procedures suggested in the previous topic with no luck. I have also checked nearly all the advice I can find in this forum and elsewhere.

The puzzling thing is that, following the suggestion made in another site, I logged in with the DVD I originally used to install 18.0, and there is no problem at all. My connection appears at once. When I go back to network settings on the installed version (18.3), only wired connection shows.

I have twice installed 18.3 and don't fancy another installation, but is my only option to go back to 18.0?
Last edited by beacon on Sun Dec 10, 2017 5:48 am, edited 1 time in total.

User avatar
kc1di
Level 10
Level 10
Posts: 3480
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Can no longer use Linux Mint

Postby kc1di » Fri Dec 08, 2017 11:18 am

Hi beacon,
Why give up so easily?
Give us the information we need to help you.
As for the wireless connection we need to know what your wireless card is.
you can find out by exicuting this command in a terminal

Code: Select all

inxi -nn

also this one would be helpful.

Code: Select all

rfkill list

give us the outputs of these commands.
This is often caused by the drivers being propitiatory and available to be ship with the distro. because of legal things.
but there are usually alternatives available.
It's not always Linux's fault hardware doesn't work out of the box.

as for playing videos it's often the same story Linux can not always ship the codecs for free so it will need to be downloaded by the user.
In any event 18.3 is a very good release. But you may have to do a little work to get it where you want it to be.
What ever you choose to do, good luck to you.
Last edited by karlchen on Sat Dec 09, 2017 9:24 am, edited 3 times in total.
Reason: Moved some technical posts directly related to the "Wireless problem experienced on Linux Mint 18.3" here from that thread: https://forums.linuxmint.com/viewtopic.php?f=60&t=259018

beacon
Level 3
Level 3
Posts: 184
Joined: Thu Oct 20, 2011 8:40 am

Re: Can no longer use Linux Mint

Postby beacon » Fri Dec 08, 2017 12:42 pm

Thank you kc1 for your suggestions. Before carrying on may I reply to Mute Ant who makes me sound like sullen child throwing his toys out of the pram. Replies such as his (or hers) can put off users who are seeking help and don't need attacks from people lacking any kind of empathy or understanding. I only noted that I had had no replies; that was a fact and not a complaint. I don't know what is an 'acceptable rate' for replies, but when ones goes several weeks without help, then surely an alternative has to be sought. And I shall not be leaving in a huff, so there is no need to slam the door. I also want to say that I have used Linux since I started using a computer almost as soon as they appeared on the market. I have never in my life used Windows or Mac, so please don't accuse me of wanting the simplicity of those systems. I frankly find this kind of reply arrogant and quite unacceptable.

To the more reasonable Kc1 may I thank you once again The codecs have been installed, and I list the results of the two commands suggested:

Code: Select all

inxi -nn
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169
           IF: enp2s0 state: up speed: 100 Mbps duplex: full
           mac: 50:e5:49:69:42:
 ~ $ rfkill list

Note nothing appeared when I put in the second command.

The main thing I find odd is that I have never before had problems such as this with Mint; only after the installation of 18.3

I shall be grateful if you can think of anything I might do to resolve the problem.

User avatar
kc1di
Level 10
Level 10
Posts: 3480
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Can no longer use Linux Mint

Postby kc1di » Fri Dec 08, 2017 5:20 pm

Hi Beacon,
The commands I gave you show no wireless card, are you using a usb wireless dongle? If so give us the make model and chip set if you know them.
If not it points towards a card that is switch off in bios. Since it shows not output on rfkill that usually means the card has not be detected at all.

Post the output of

Code: Select all

inxi -Fxz

Thanks.

User avatar
karlchen
Level 18
Level 18
Posts: 8175
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Wireless connection on Mint 18.3

Postby karlchen » Sat Dec 09, 2017 11:15 am

Hi, beacon.

Please, post the requested inxi -Fxz screen output, so that we have a concise overview on how Linux Mint 18.3 "sees" your hardware.
The same inxi report would come in handy in your other ongoing thread, Play videos, as well. - Run inxi once, use it twice. :wink:

Regards,
Karl
Image
Old bugs good, new bugs bad! Updates are evil: might fix old bugs and introduce no new ones.

beacon
Level 3
Level 3
Posts: 184
Joined: Thu Oct 20, 2011 8:40 am

Re: Wireless connection on Mint 18.3

Postby beacon » Sun Dec 10, 2017 5:46 am

Thank you Karl. I shall give the screen shot information below, but I should say that I am going to mark this as solved. I spent countless hours over several weeks trying to deal with the issue. Finally, I did a fresh install of LM18.3, then put my router back to factory settings. I thought then that I would be starting afresh and went back to the immeasurably helpful help that Jeremy B provided in dealing with the matter a year ago. I went through all of his suggestions until I succeeded. I now have wireless connection.

The video problem remains, but I'll keep at it.

The information from inxi -Fxz:

Code: Select all

Kernel: 4.10.0-42-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.6 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   Mobo: Gigabyte model: GA-MA78LMT-US2H v: x.x
           Bios: Award v: F10 date: 03/10/2011
CPU:       Triple core AMD Athlon II X3 455 (-MCP-) cache: 1536 KB
           flags: (lm nx sse sse2 sse3 sse4a svm) bmips: 19888
           clock speeds: max: 3300 MHz 1: 2100 MHz 2: 2600 MHz 3: 800 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] RS780L [Radeon 3000]
           bus-ID: 01:05.0
           Display Server: X.Org 1.18.4 drivers: ati,radeon (unloaded: fbdev,vesa)
           Resolution: 1920x1080@60.00hz
           GLX Renderer: Gallium 0.4 on AMD RS780 (DRM 2.49.0 / 4.10.0-42-generic, LLVM 4.0.0)
           GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes
Audio:     Card-1 Advanced Micro Devices [AMD/ATI] RS780 HDMI Audio [Radeon (HD) 3000 Series]
           driver: snd_hda_intel bus-ID: 01:05.1
           Card-2 Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA)
           driver: snd_hda_intel bus-ID: 00:14.2
           Sound: Advanced Linux Sound Architecture v: k4.10.0-42-generic
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: de00 bus-ID: 02:00.0
           IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 240.1GB (10.0% used)
           ID-1: /dev/sda model: KINGSTON_SV300S3 size: 240.1GB
Partition: ID-1: / size: 213G used: 16G (8%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 8.05GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 29.1C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 188 Uptime: 1:16 Memory: 1091.4/7474.1MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35

Thank you again for your help.

User avatar
Pjotr
Level 19
Level 19
Posts: 9330
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Wireless connection on Mint 18.3 (solved)

Postby Pjotr » Sun Dec 10, 2017 6:59 am

Also post the output of the following three commands:

Code: Select all

rfkill list all

and:

Code: Select all

iwconfig

and:

Code: Select all

inxi -Nn
Tip: 10 things to do after installing Linux Mint 18.3 Sylvia
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

User avatar
karlchen
Level 18
Level 18
Posts: 8175
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Wireless connection on Mint 18.3

Postby karlchen » Sun Dec 10, 2017 8:14 am

Hi, beacon.

Great you have solved the wireless problem, resorting to JeremyB's advice from 2016.

beacon wrote:[...] Finally, I did a fresh install of LM18.3 [...] and went back to the immeasurably helpful help that Jeremy B provided in dealing with the matter a year ago. I went through all of his suggestions until I succeeded. I now have wireless connection.

May I assume that the thread from 2016 is this one here: no wifi connection linux mint 18
Correct?
Reason for asking is not pure curiosity; in case this is the helpful thread, linking back to it might prove useful for other Mint 18.x users who experience the same wireless trouble with the same hardware as you. :)

Cheers,
Karl
Image
Old bugs good, new bugs bad! Updates are evil: might fix old bugs and introduce no new ones.

beacon
Level 3
Level 3
Posts: 184
Joined: Thu Oct 20, 2011 8:40 am

Re: Wireless connection on Mint 18.3 (solved)

Postby beacon » Sun Dec 10, 2017 11:30 am

First, Karl, you are correct in thinking that I found the solution in returning to the 2016 post you cite, and I would be glad to point out the connection for others if I knew how to do it.

Second, Ptjor, thanks also to you who also have helped me in the past. Since I had marked the thread as 'solved', I'm not certain that the information you requested is still relevant, but just in case:

rfkill list all does nothing

iwconfig produces the following:

enp2s0 no wireless extensions.

wlx801f02b35c9d IEEE 802.11bgn ESSID:"NETGEAR36" Nickname:"rtl_wifi"
Mode:Managed Frequency:2.412 GHz Access Point: 20:0C:C8:21:39:AC
Bit Rate:150 Mb/s Sensitivity:0/0
Retry:off RTS thr:off Fragment thr:off
Power Management:off
Link Quality=100/100 Signal level=100/100 Noise level=0/100
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

lo no wireless extensions.

inxi -Nn:

Machine: Mobo: Gigabyte model: GA-MA78LMT-US2H v: x.x
Bios: Award v: F10 date: 03/10/2011
Network: Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
driver: r8169
IF: enp2s0 state: down mac: 50:e5:49:69:42:94

User avatar
karlchen
Level 18
Level 18
Posts: 8175
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Wireless connection on Mint 18.3 (solved)

Postby karlchen » Sun Dec 10, 2017 1:38 pm

Hello, beacon.
beacon wrote:I found the solution in returning to the 2016 post you cite, and I would be glad to point out the connection for others if I knew how to do it.
Actually, linking to the thread is easy.
You open the thread from 2016. In the browser addressbar there is the complete URL to the thread.
You mark it Right click and select "copy link address". You paste it into the post where you want to point to it.

  1. way (very simple): viewtopic.php?f=150&t=227392
    Browsers will be smart enough to recognize the string which has been inserted into the line above as a URL and mark it as a clickable URL.
    or
  2. way: You click on the [url] button on top of the forum editor pane. This will insert [url][/url] into your post. You click in the empty space between the 2 tags and paste the URL. Result: https://forums.linuxmint.com/viewtopic.php?f=150&t=227392
    or
  3. way (more complex): Insert as link plus thread title.
    This is a bit more work, because URL and thread title will have to copied and pasted separately.
    1. Mark and copy the URL.
    2. In your post click the [url] button which inserts [url][/url]
      Instead of pasting the address in the middle between [url] and [/url], add a = character to the [URL], yielding [ url= ]
    3. Now paste the URL between = and ], looks like this:

      Code: Select all

       [url=https://forums.linuxmint.com/viewtopic.php?f=150&t=227392] [/url]
    4. Go back to the other thread. Mark the title. Right click and select "Copy".
    5. Come back to your post and paste the title right in front of the [/url]. Will look like this:

      Code: Select all

       [url=https://forums.linuxmint.com/viewtopic.php?f=150&t=227392]no wifi connection linux mint 18[/url]
    6. Displayed result: no wifi connection linux mint 18
To be honest:
Almost all forum users simply post links in the first way.
Only snobs take the time to post links following the 3rd way. :wink:

Cheers,
Karl
Image
Old bugs good, new bugs bad! Updates are evil: might fix old bugs and introduce no new ones.

beacon
Level 3
Level 3
Posts: 184
Joined: Thu Oct 20, 2011 8:40 am

Re: Wireless connection on Mint 18.3 (solved)

Postby beacon » Tue Dec 12, 2017 9:56 am

The solution was found in the suggestions made in the following link:
viewtopic.php?f=150&t=227392

User avatar
JerryF
Level 7
Level 7
Posts: 1887
Joined: Mon Jun 08, 2015 1:23 pm
Location: Rhode Island, USA

Re: Wireless connection on Mint 18.3 (solved)

Postby JerryF » Tue Dec 12, 2017 10:35 am

karlchen wrote:...
To be honest:
Almost all forum users simply post links in the first way.
Only snobs take the time to post links following the 3rd way. :wink:

Cheers,
Karl

I resemble that remark. :lol:
Don't forget to edit your original post and add [SOLVED] to the beginning of the Subject line if your problem has been fixed.
My main language is English. I speak very little Portuguese, and a whole lot of gibberish.


Return to “Installation & Boot”