Lenovo Ideapad 120s - Mint 18 - WiFi Connection Problems

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Eduardo103
Level 1
Level 1
Posts: 17
Joined: Tue Aug 23, 2016 6:51 pm

Lenovo Ideapad 120s - Mint 18 - WiFi Connection Problems

Postby Eduardo103 » Wed Dec 06, 2017 3:01 pm

As you know the 120s is a simple soldered board, comes with 2gb RAM and 32gb emms, delivered with Win10. My goal was to install a good Mint 18.3 ONLY (no dual boot due to minimal memory). Many people have had problems installing 18.1 to 18.3. Several solutions have been posted, but this one worked fine for me:

viewtopic.php?f=46&t=258658&p=1396533&hilit=lenovo+120s#p1396533

Good so far, but a number of people complained about difficulties making Wi-Fi connections. In many cases, available networks were not showing up. This also happened to me after my otherwise successful Mint 18.3 install to my Lenovo 120s. Please recall the setting needed for the original install:

Settings (via F2):
Secure boot disabled
Legacy enabled
Legacy first
USB boot enabled
USB inserted, power up, F12 to boot from USB.
Fast Start had been disabled earlier via Windows 10 settings


However, now found that the network connector was not seeing all available networks. After much messing around, the solution was this: Went back into the bios via F2, and changed settings to:

USB Legacy enabled, then
Boot Mode Legacy Support
Boot Priority UEFI first

Easy peasy... worked for me. But there's a catch: my friend's 120s (we bought them together) installed 18.3 just as above, but left hers at Legacy first - and - it works as well. Thus a solution is not clear so I've decided to leave this up as "unsolved" for a bit, to allow others to comment with their own solutions.

Eduardo103
Level 1
Level 1
Posts: 17
Joined: Tue Aug 23, 2016 6:51 pm

Re: Lenovo Ideapad 120s - Mint 18 - WiFi Connection Problems

Postby Eduardo103 » Fri Dec 08, 2017 9:26 am

Last call for alcohol... although I don't consider this "solved" in full, in honor of the website, I'll keep it open for two days, then mark it "solved - maybe". I'm fine, don't need your help, but others may, your move...


Return to “Installation & Boot”