Long delay before Mint boot - SOLVED

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
bushyiii
Level 2
Level 2
Posts: 68
Joined: Thu Apr 07, 2016 12:42 am

Long delay before Mint boot - SOLVED

Postby bushyiii » Thu Dec 07, 2017 9:50 pm

Intalled mint18.3 on a new Lonovo low end laptop. Had to change bios to legacy boot and disable Intel security boot. Mint works well but there is a very long delay on power up before the mint boot starts around 90 seconds, then the normal Mint boot is fast. The laptop has a 32g eMMC drive.

Any suggestion on how to eliminate or minimize the startup delay?
Last edited by bushyiii on Fri Dec 08, 2017 7:03 pm, edited 1 time in total.

User avatar
MrEen
Level 3
Level 3
Posts: 178
Joined: Mon Jun 12, 2017 8:39 pm

Re: Long delay before Mint boot

Postby MrEen » Thu Dec 07, 2017 9:57 pm

My first suspicion, especially with 90 seconds mentioned is incorrect UUID for swap in fstab. Please paste back here the results from entering the following in the terminal:

Code: Select all

blkid

and

Code: Select all

cat /etc/fstab

bushyiii
Level 2
Level 2
Posts: 68
Joined: Thu Apr 07, 2016 12:42 am

Re: Long delay before Mint boot

Postby bushyiii » Thu Dec 07, 2017 10:28 pm

richard@richard-Lenovo-ideapad-120S-14IAP ~ $ blkid
/dev/mmcblk0p1: UUID="0FF6-F664" TYPE="vfat" PARTLABEL="EFI System Partition" PARTUUID="f104243d-25b9-46db-9adf-678462b4198c"
/dev/mmcblk0p2: UUID="b4ce2baf-73e5-4cd2-9808-099cb850e85c" TYPE="ext4" PARTUUID="8a501dc5-c004-461c-8442-cd75db05ec65"
/dev/mmcblk0p3: UUID="09d721a0-d822-43fd-90bc-2ce3319c1e1d" TYPE="swap" PARTUUID="498d07ea-92a2-4456-86b9-0864f45dbb55"

richard@richard-Lenovo-ideapad-120S-14IAP ~ $ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
# / was on /dev/mmcblk0p2 during installation
UUID=b4ce2baf-73e5-4cd2-9808-099cb850e85c / ext4 errors=remount-ro 0 1
# /boot/efi was on /dev/mmcblk0p1 during installation
UUID=0FF6-F664 /boot/efi vfat umask=0077 0 1
# swap was on /dev/mmcblk0p3 during installation
UUID=09d721a0-d822-43fd-90bc-2ce3319c1e1d none swap sw 0 0

User avatar
MrEen
Level 3
Level 3
Posts: 178
Joined: Mon Jun 12, 2017 8:39 pm

Re: Long delay before Mint boot

Postby MrEen » Thu Dec 07, 2017 10:36 pm

Ok. It wasn't that. Try, again in terminal:

Code: Select all

systemd-analyze blame

bushyiii
Level 2
Level 2
Posts: 68
Joined: Thu Apr 07, 2016 12:42 am

Re: Long delay before Mint boot

Postby bushyiii » Thu Dec 07, 2017 10:43 pm

It was a very long listing, thought it best to add it in pastebin: https://pastebin.com/UQ2E8gi6

User avatar
MrEen
Level 3
Level 3
Posts: 178
Joined: Mon Jun 12, 2017 8:39 pm

Re: Long delay before Mint boot

Postby MrEen » Thu Dec 07, 2017 10:51 pm

I should have said only the first few lines were really necessary. In the future, you can use the Code blocks for long pastes. (If you've already copied something, press the Code button above the box you're typing in and paste away.)

Unfortunately, we seem to have hit the limit of my knowledge.

I'm sure others will have better ideas. Good luck!

User avatar
thx-1138
Level 4
Level 4
Posts: 347
Joined: Fri Mar 10, 2017 12:15 pm
Location: Athens, Greece

Re: Long delay before Mint boot

Postby thx-1138 » Fri Dec 08, 2017 6:45 am

Had to change bios to legacy boot and disable Intel security boot.

Is there a setting called 'Fast Boot' enabled in your bios? If yes, try disabling it...

Also, try pressing ESC while booting, to reveal the text messages, and try finding where / why the bottleneck appears. You can alternatively check dmesg for such...

Code: Select all

dmesg | less

bushyiii
Level 2
Level 2
Posts: 68
Joined: Thu Apr 07, 2016 12:42 am

Re: Long delay before Mint boot

Postby bushyiii » Fri Dec 08, 2017 7:41 am

No Fast Boot in BIOS. The screen remained blank when pushing ESC key during the 90 second delay period. Once the Mint logo appeared text briefly did display but Mint boots extremely fast from that point. Did not see anything in DMESG that identified a problem.

It seems at this point that there isn't any boot issue with Mint but rather something is delaying Mint from starting it's boot process.

User avatar
thx-1138
Level 4
Level 4
Posts: 347
Joined: Fri Mar 10, 2017 12:15 pm
Location: Athens, Greece

Re: Long delay before Mint boot

Postby thx-1138 » Fri Dec 08, 2017 9:32 am

...Post the results from:

Code: Select all

systemd-analyze critical-chain
and

Code: Select all

sudo systemctl --failed
I'm also out of ideas, but those may help people around to diagnose further...

PS: Also, maybe:

Code: Select all

journalctl --disk-usage
Say maybe in case too many logs are kept / not flushed them properly?...systemd-analyze should have shown such already...

bushyiii
Level 2
Level 2
Posts: 68
Joined: Thu Apr 07, 2016 12:42 am

Re: Long delay before Mint boot

Postby bushyiii » Fri Dec 08, 2017 10:33 am

I changed the boot order in the bios, this seemed to help a bit.


systemd-analyze critical-chain
The time after the unit is active or started is printed after the "@" character.
The time the unit takes to start is printed after the "+" character.

graphical.target @3.664s
└─multi-user.target @3.664s
└─ntp.service @3.511s +152ms
└─network-online.target @3.506s
└─NetworkManager-wait-online.service @3.007s +498ms
└─NetworkManager.service @2.599s +399ms
└─dbus.service @2.552s
└─basic.target @2.550s
└─sockets.target @2.550s
└─avahi-daemon.socket @2.550s
└─sysinit.target @2.537s
└─apparmor.service @2.302s +234ms
└─local-fs.target @2.293s
└─run-cgmanager-fs.mount @2.689s
└─local-fs-pre.target @2.155s
└─lvm2-monitor.service @642ms +1.513s
└─lvm2-lvmetad.service @771ms
└─system.slice @627ms
└─-.slice @601ms

sudo systemctl --failed
[sudo] password for richard:
0 loaded units listed. Pass --all to see loaded but inactive units, too.
To show all installed unit files use 'systemctl list-unit-files'.

journalctl --disk-usage
Archived and active journals take up 4.5M on disk.

fabien85
Level 6
Level 6
Posts: 1096
Joined: Tue Mar 11, 2014 4:30 pm

Re: Long delay before Mint boot

Postby fabien85 » Fri Dec 08, 2017 10:45 am

The systemd outputs looks normal and fast.
I am guessing that the problem is not at the stage of loading Mint, but before that, at the bootloading stage.
It's possible that the computer's firmware takes a long time to find the bootloader (grub), and/or it's first trying to boot a non-existent boot entry before going to the next entry.

The fact that you have an EFI partition (/dev/mmcblk0p1) is in contradiction with your saying of having installed in BIOS mode.
If you do not have any data to lose, or have backups, I would go for a reinstall after formatting the hard drive with gparted (Device > create partition table).
If you install in BIOS mode, format in msdos/mbr. If you install in UEFI mode, format in gpt. Then the installer will take care of the partitions and everything.

bushyiii
Level 2
Level 2
Posts: 68
Joined: Thu Apr 07, 2016 12:42 am

Re: Long delay before Mint boot

Postby bushyiii » Fri Dec 08, 2017 11:37 am

I am going to leave things as there are, at least the system works. I tried rebooting from a USB to re-install Mint, the laptop won't boot from the it. this was my original problem which corrected when I changed the bios to legacy. Since it's not booting from the USB thumb drive I give up and accept what I have. Thanks to everyone for their help.

User avatar
prestonR
Level 5
Level 5
Posts: 802
Joined: Wed Jan 07, 2015 12:24 pm
Location: Harare

Re: Long delay before Mint boot

Postby prestonR » Fri Dec 08, 2017 1:21 pm

Looks like it's first trying to boot something that doesn't respond. If you call up your boot menu and you pick your linux hdd as boot device does it speed up the process?

In your Bios check your Legacy boot options and either disable 'Network boot' or 'PXE boot' or at least make sure that it's below your linux hdd in your boot sequence. If you never boot from DVD but use LiveUSB your boot order should be:

- USB
- linux hdd
- other hdds
- cd/dvd
- Network boot/PXE

If you're not planning to boot a Live USB or if booting a LiveUSB is possible from the boot menu, you could even put the linux hdd first, like:

- linux hdd
- other hdds
- USB
- cd/dvd
- Network boot/PXE

Also check that, in case your Bios has 2 legacy related settings ('CMS' and 'Boot Mode'), both are set correctly; 'CMS'=Enabled and below 'Boot Mode'= Legacy only'.

bushyiii
Level 2
Level 2
Posts: 68
Joined: Thu Apr 07, 2016 12:42 am

Re: Long delay before Mint boot

Postby bushyiii » Fri Dec 08, 2017 7:03 pm

@fablen85, finally got the laptop to boot again off the live USB of Mint 18.3, I did as you suggested using gparted and created a new partition table formatted for DOS. Re-installed MINT and it worked perfectly, boot times are great. Oddly it takes a while to shut down but I'm a happy camper. Thanks for the suggestion.

fabien85
Level 6
Level 6
Posts: 1096
Joined: Tue Mar 11, 2014 4:30 pm

Re: Long delay before Mint boot - SOLVED

Postby fabien85 » Sat Dec 09, 2017 10:17 am

Nice it worked out.
For the shutdown time, you can press esc when the splash screen with the Mint logo is shown, to view kernel messages and see what's taking so long.
I have had long shutdown in my machine and they were due to a 1'30" countdown for a cups printer service. Once I solved this, the shutdown went to a few seconds.


Return to “Installation & Boot”