Two Swap Partitions: one not activ.

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
foersu
Level 2
Level 2
Posts: 88
Joined: Thu Mar 18, 2010 6:52 pm
Location: Kaarst, Germany
Contact:

Two Swap Partitions: one not activ.

Post by foersu » Wed Dec 13, 2017 10:36 am

Hello,

looking at the application "Laufwerke" (I use Mint in the German language), the swap partition /dev/mint-vg/swap_1 is shown under "Inhalt" (Content) as not activ:
Auslagerungsspeicher (Version 1) – Nicht aktiv

Another swap partition /dev/mapper/cryptswap1 is shown as active: Auslagerungsspeicher (Version 1) – Aktiv

Questions:
  • why two of them?
  • why is the one not activ?
Thanks in advance for an explanation.

Regards

My system:
Linux Mint 18.2 "Sonya"
Xfce 64-bit

User avatar
JerryF
Level 9
Level 9
Posts: 2882
Joined: Mon Jun 08, 2015 1:23 pm
Location: Rhode Island, USA

Re: Two Swap Partitions: one not activ.

Post by JerryF » Wed Dec 13, 2017 2:51 pm

My shot-in-the-dark question: Do you have your data encrypted?
IF your problem has been solved, please edit your original post and add [SOLVED] to the beginning of the Subject Line. It helps other members.

User avatar
WharfRat
Level 20
Level 20
Posts: 11464
Joined: Thu Apr 07, 2011 8:15 pm

Re: Two Swap Partitions: one not activ.

Post by WharfRat » Wed Dec 13, 2017 3:10 pm

If you have an encrypted home then swap is also encrypted, with /dev/mint-vg/swap_1 being the unencrypted swap.

swapon -s should show /dev/mint-vg/swap_1
ImageImage

foersu
Level 2
Level 2
Posts: 88
Joined: Thu Mar 18, 2010 6:52 pm
Location: Kaarst, Germany
Contact:

Re: Two Swap Partitions: one not activ.

Post by foersu » Thu Dec 14, 2017 5:08 am

Hello,

yes, my whole installation, not only home, is encrypted.

The result of swapon -s is>:

Code: Select all

Filename				Type		Size	Used	Priority
/dev/dm-3           partition 8277500   0   -1
I wonder why during the installation if full encryption is selected still the not encrypted swap partition is created.

Regards

fabien85
Level 6
Level 6
Posts: 1342
Joined: Tue Mar 11, 2014 4:30 pm

Re: Two Swap Partitions: one not activ.

Post by fabien85 » Thu Dec 14, 2017 11:17 am

I have few expertise on encryption, but here are my 2 cents :
/dev/mint-vg/swap_1 is really encrypted, as it's a part in the LUKS container.

On a computer that I have with full disk encryption, both /dev/mint-vg/swap_1 and /dev/mapper/mint--vg-swap_1 are symbolic links to /dev/dm-2

Did you select both full disk encryption, and home encryption on top of it ?
That could explain it.

Please post the output of

Code: Select all

cat /etc/fstab

foersu
Level 2
Level 2
Posts: 88
Joined: Thu Mar 18, 2010 6:52 pm
Location: Kaarst, Germany
Contact:

Re: Two Swap Partitions: one not activ.

Post by foersu » Thu Dec 14, 2017 11:58 am

Hello,

well, as far as I remember, if I select full encryption - a choice presented at the very beginning of the installation - I was not asked any more for a dedicated home encryption later. In my understandind this one would be included, but I am not really sure if I got the choice to select both.

I am only sure that I selected the full encryption.

Output of cat /etc/fstab:

Code: Select all

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
/dev/mapper/mint--vg-root /               ext4    errors=remount-ro 0       1
# /boot was on /dev/sda2 during installation
UUID=6f954c86-3a07-408c-b13a-e969acb991ce /boot           ext2    defaults        0       2
# /boot/efi was on /dev/sda1 during installation
UUID=8A7E-C357  /boot/efi       vfat    umask=0077      0       1
#/dev/mapper/mint--vg-swap_1 none            swap    sw              0       0
/dev/mapper/cryptswap1 none swap sw 0 0
Regards

fabien85
Level 6
Level 6
Posts: 1342
Joined: Tue Mar 11, 2014 4:30 pm

Re: Two Swap Partitions: one not activ.

Post by fabien85 » Fri Dec 15, 2017 12:44 pm

Hum yeah something commented out the standard swap created by full disk encryption, and then added an additional encrypted swap.
It looks beyond my expertise, sorry.

Post Reply

Return to “Installation & Boot”