[solved] Not so trouble-free upgrade

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
Level 4
Level 4
Posts: 267
Joined: Thu Apr 19, 2012 9:59 am

[solved] Not so trouble-free upgrade

Post by dclement » Thu Dec 28, 2017 6:53 am


A while back I upgraded my daughter's PC from LM 17.3 to 18.1. Everything seemed to work OK after the upgrade so for some time I left this PC untouched.

But last week, I tried to upgrade to LM 18.3. There was no "Edit-Upgrade to..." option in menu. Instead I saw that the update manager showed an "apt cache corrupted" warning (red cross). I began to wonder:

Code: Select all

cat /etc/linuxmint/info
DESCRIPTION="Linux Mint 18.1 Serena"
GRUB_TITLE=Linux Mint 18.1 MATE 64-bit
looks good.

But some time into the session, the red cross disappears and the green check mark appears. If I refresh, I get another warning:
W: The repository 'http://extra.linuxmint.com rosa Release' is not signed.
and the red cross is eventually back.

Moreover, in Synaptic I see a mintupgrade package with 17.3.11 version :?

I'd like to sort this out without reinstalling everything! Perhaps reset the repos? Or manually update the mintupgrade package, if that makes any sense?

TIA for any advice. BR, Daniel
Last edited by dclement on Thu Dec 28, 2017 1:20 pm, edited 1 time in total.

User avatar
Level 5
Level 5
Posts: 843
Joined: Wed Jan 07, 2015 12:24 pm
Location: Harare

Re: Not so trouble-free upgrade

Post by prestonR » Thu Dec 28, 2017 9:15 am

Disable the http://extra.linuxmint.com repo, it's the wrong one (for 17), for 18 this has a different name. Then proceed with the update (the installed software that relies on the 'extra' won't be uninstalled only not updated until the new repo appears in sources). That should then fix the problem by adding the correct new name (I think it's packages.linuxmint)

This is not the only way to fix this, maybe wait 'till someone else chimes in who can give you instructions to change your sources via command line.
Last edited by prestonR on Thu Dec 28, 2017 9:41 am, edited 1 time in total.

Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: Not so trouble-free upgrade

Post by Cosmo. » Thu Dec 28, 2017 9:34 am

Open software sources and click on the first page near the bottom to reset to default; after that you have to click the button on the top right to refresh the cache.

Level 4
Level 4
Posts: 267
Joined: Thu Apr 19, 2012 9:59 am

Re: Not so trouble-free upgrade

Post by dclement » Thu Dec 28, 2017 1:20 pm

Thanks, prestonR and Cosmo, for the replies.

It appears that one of the repositories (probably "extra") was preventing the update. After resetting to default, I was able to update the system.

Even better, after all the updates I could upgrade to Linux Mint 18.3.

Everything went well, so I guess my daughter's PC is now fully up to date.

I'm marking the thread solved. Thanks again - Daniel

Post Reply

Return to “Installation & Boot”