You should choose NOT to force UEFI installation here

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
KGL
Level 1
Level 1
Posts: 1
Joined: Sun Jan 21, 2018 3:27 pm

You should choose NOT to force UEFI installation here

Post by KGL » Sun Jan 21, 2018 3:59 pm

I want to install Linux Mint but arrive at a screen that I don’t understand the implications of.

The box is as follows: W-10 OS, 32GB RAM, i3 Processor, four HD’s. The empty HD I want to install Mint on is known by Linux as sda1, a 500GB SATA drive. W-10 is on a 3TB drive partitioned as 2TB/1TB with the W-10 OS on the 2TB partition. There are a couple of storage HD’s and a USB external 3TB backup drive.
Linux Mint v-18.3 works superbly on this box as a live-boot OS simply operating in RAM. So I decided to load it on the empty HD designated sda1 by LinuxMint.

All goes well until I get to what must be close to the final launch-pad, and I get this notice, which I don’t understand the ramifications of. So I aborted the load until I can find out what the devil it means. I would prefer to not have to recover W-10 from backup, although I’m certainly not in love with it. It may well be the eventual victim of my total upgrade to Linux. Windows-10 has cost MS a lifelong fan, I started with DOS in 1990 and attended every MS gathering within a hundred miles.

But back to loading LinuxMint v-18.3 on this box:

[The choices on the Mint warning screen are: “Go Back”, or, “Continue in UEFI mode”.]

This machine's firmware has started the installer in UEFI mode but it looks like there may be existing operating systems already installed using "BIOS compatibility mode". If you continue to install Debian in UEFI mode, it might be difficult to reboot the machine into any BIOS-mode operating systems later.

If you wish to install in UEFI mode and don't care about keeping the ability to boot one of the existing systems, you have the option to force that here. If you wish to keep the option to boot an existing operating system, you should choose NOT to force UEFI installation here.


So can anyone here please enlighten me as to what to do, using plain English, not tech-speak?
Thanks, Ken.

[Note: One time I tried to dual-boot MS Vista with W-10 but W-10 threw a fit and wouldn’t allow it. “But”, the Boot Sector still thinks there is a Vista choice for dual boot. There is no Vista HD, so maybe that is the missing OS that would have used a “BIOS compatibility mode”, and it is still embedded into the existing W-10 Boot Sector, IDK...]

User avatar
catweazel
Level 16
Level 16
Posts: 6230
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: You should choose NOT to force UEFI installation here

Post by catweazel » Mon Jan 22, 2018 1:05 am

Deleted. My reply was wrong.
Last edited by catweazel on Mon Jan 22, 2018 3:14 am, edited 1 time in total.
Only a life lived for others is a life worthwhile - Albert Einstein

User avatar
michael louwe
Level 9
Level 9
Posts: 2596
Joined: Sun Sep 11, 2016 11:18 pm

Re: You should choose NOT to force UEFI installation here

Post by michael louwe » Mon Jan 22, 2018 3:09 am

@ KGL, .......
KGL wrote:...
.
If Win 10 is installed in UEFI mode, then proceed to install LM 18.3 also in UEFI mode and ignore the message. UEFI mode requires an EFI System Partition for the installation of bootloaders = fat32/104MB/flagged as boot/efi. Check if this partition is present in the Win 10 drive(= 3TB drive)

If so, ensure that Fast Startup in Win 10 is disabled(>Control Panel >Power options), Secure Boot, Fast Boot and CSM(Legacy BIOS) are disabled, and the Live LM 18.3 USB/DVD is booted in UEFI mode in UEFI/BIOS setup.
... For a multi-drives computer setup, the manual "Something else" install method have to be used. Ensure that the "Device for boot loader installation" is the Win 10 EFI System Partition. After installation has completed, configure the computer to boot first from the LM 18.3 drive(= 500GB SATA drive), in order to see the Grub menu.

Post Reply

Return to “Installation & Boot”