[SOLVED] Linux stops after Grub

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
Irakus
Level 1
Level 1
Posts: 11
Joined: Tue Mar 28, 2017 8:46 am

[SOLVED] Linux stops after Grub

Post by Irakus » Wed Jan 31, 2018 5:26 pm

Hi, I cannot install Linux Mint( and other Linux Distributions as well ) on my notebook. I get the Grub screen, but after I press Enter, I'm getting blackscreen. It looks like notebook stops working, because if I use Live USB, the pendrive's light turns off, and when I use external DVD, it becomes silent, like nothing is happening. I'm 100% sure my USB/DVD are ok, because I tested them on another PC, and installed Linux succesfully. I had Linux installed on my notebook before, but after I send it to support ( they had to repair my disk ) , I can't install Linux anymore. I made sure to update my BIOS to latest version, tested both Legacy and UEFI boot. I've also tried "nomodeset" and similar commands to check if it's problem with graphics.
Last edited by Irakus on Sun Feb 11, 2018 7:28 pm, edited 1 time in total.

jglen490
Level 3
Level 3
Posts: 169
Joined: Sat Jul 15, 2017 9:57 pm

Re: Linux stops after Grub

Post by jglen490 » Wed Jan 31, 2018 5:52 pm

Notebook specs?

Please the following in a terminal and post the output to a code box.

Code: Select all

inxi -Fxz
I feel more like I do than I did when I got here.
Toshiba A135-S2386, Intel T2080, ATI Radeon® Xpress 200M Chipset, 2GB RAM, 500GB

Irakus
Level 1
Level 1
Posts: 11
Joined: Tue Mar 28, 2017 8:46 am

Re: Linux stops after Grub

Post by Irakus » Thu Feb 01, 2018 8:14 am

Since I can't get to the terminal because I don't have Linux, I'll write what I know:
Notebook Model: HP Pavilion 13-x360.
CPU: Intel Core i5-5200U
BIOS version: Insyde F.39
GPU: Intel HD 5500
Motherboard: HP 2341(U3E1)
If you need more specs, tell me which and eventually how to get them in Windows(I used speccy to get those).

User avatar
kc1di
Level 13
Level 13
Posts: 4569
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Linux stops after Grub

Post by kc1di » Thu Feb 01, 2018 8:30 am

Hello Irakus and Welcome to Linux Mint Forums,

I've had problems with hp laptop before so maybe we can figure it out.
First what graphics card is in your machine?

Did a little further searching and found this page which may be helpful. It's a bit dated but may still work.
Seems the hp UEFI only like to boot windows. any way give it a read :
https://laundryisrandom.wordpress.com/2 ... ndows-8-1/
Last edited by kc1di on Thu Feb 01, 2018 8:41 am, edited 1 time in total.
Easy tips : https://sites.google.com/site/easylinuxtipsproject/
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608

Irakus
Level 1
Level 1
Posts: 11
Joined: Tue Mar 28, 2017 8:46 am

Re: Linux stops after Grub

Post by Irakus » Thu Feb 01, 2018 8:33 am

Like I wrote, Intel HD 5500. I tried all stuff from this page: https://community.linuxmint.com/tutorial/view/842

User avatar
kc1di
Level 13
Level 13
Posts: 4569
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Linux stops after Grub

Post by kc1di » Thu Feb 01, 2018 9:33 am

Irakus wrote:Like I wrote, Intel HD 5500. I tried all stuff from this page: https://community.linuxmint.com/tutorial/view/842
The problem I think is HP's UEFI boot. (see web page in my last post. )
Easy tips : https://sites.google.com/site/easylinuxtipsproject/
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608

Irakus
Level 1
Level 1
Posts: 11
Joined: Tue Mar 28, 2017 8:46 am

Re: Linux stops after Grub

Post by Irakus » Thu Feb 01, 2018 9:45 am

Well, the solution on site you posted is to get to the grub. I can get to the Grub, but it freezes after Grub, so I think the problem lies somewhere else.
"I’ll assume from now and on that you have disabled secure boot and fast boot in Windows and that you have installed Linux on your hard drive. Install efibootmgr and grub." - the thing is, I cannot install Linux, since I cannot get to the Live mode/installation screen.

User avatar
michael louwe
Level 9
Level 9
Posts: 2591
Joined: Sun Sep 11, 2016 11:18 pm

Re: Linux stops after Grub

Post by michael louwe » Thu Feb 01, 2018 10:24 am

@ Irakus, .......
Irakus wrote:...
Try this link, ie use Rufus, ... https://h30434.www3.hp.com/t5/Notebook- ... -p/2552097

Irakus
Level 1
Level 1
Posts: 11
Joined: Tue Mar 28, 2017 8:46 am

Re: Linux stops after Grub

Post by Irakus » Thu Feb 01, 2018 10:30 am

I'm new on this forum and I didn't know that I had to use quote to quote things other than forum posts. My problem is different than in most of your links. People usually can't boot from USB at all. I can get to GRUB, but I have problems after that, so my notebook can start booting from USB.

User avatar
Moem
Level 16
Level 16
Posts: 6226
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: Linux stops after Grub

Post by Moem » Thu Feb 01, 2018 10:58 am

Irakus wrote:I'm new on this forum and I didn't know that I had to use quote to quote things other than forum posts.
I've been here for a while and it's the first time I hear that. People sometimes use it when they're quoting articles found elsewhere, and that makes things nice and clear, but it's not a rule. No worries, you're doing fine.
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

User avatar
michael louwe
Level 9
Level 9
Posts: 2591
Joined: Sun Sep 11, 2016 11:18 pm

Re: Linux stops after Grub

Post by michael louwe » Thu Feb 01, 2018 1:01 pm

@ Irakus, .......
Irakus wrote:...
.
Have a look at this link ... viewtopic.php?f=46&t=233654

Irakus
Level 1
Level 1
Posts: 11
Joined: Tue Mar 28, 2017 8:46 am

Re: Linux stops after Grub

Post by Irakus » Fri Feb 09, 2018 3:59 pm

jglen490 wrote:
Wed Jan 31, 2018 5:52 pm
Notebook specs?

Please the following in a terminal and post the output to a code box.

Code: Select all

inxi -Fxz
I wrote it. Any ideas?

jglen490
Level 3
Level 3
Posts: 169
Joined: Sat Jul 15, 2017 9:57 pm

Re: Linux stops after Grub

Post by jglen490 » Fri Feb 09, 2018 6:06 pm

Irakus wrote:
Thu Feb 01, 2018 9:45 am
Well, the solution on site you posted is to get to the grub. I can get to the Grub, but it freezes after Grub, so I think the problem lies somewhere else.
"I’ll assume from now and on that you have disabled secure boot and fast boot in Windows and that you have installed Linux on your hard drive. Install efibootmgr and grub." - the thing is, I cannot install Linux, since I cannot get to the Live mode/installation screen.
O.K., so you are having problems with the Live media (DVD/USB). My bad, I thought you had already installed it to your notebook.

You have gone into your BIOS and done all the settings for UEFI, Legacy, and Fast Boot. You shutdown your machine, then restarted with the Live media (DVD/USB) attached, and you never see the initial screen with the choices such as proceed to install, verify the media, or edit the boot string for the installer. Is that pretty much your situation?
I feel more like I do than I did when I got here.
Toshiba A135-S2386, Intel T2080, ATI Radeon® Xpress 200M Chipset, 2GB RAM, 500GB

Irakus
Level 1
Level 1
Posts: 11
Joined: Tue Mar 28, 2017 8:46 am

Re: Linux stops after Grub

Post by Irakus » Fri Feb 09, 2018 6:22 pm

jglen490 wrote:
Fri Feb 09, 2018 6:06 pm
You have gone into your BIOS and done all the settings for UEFI, Legacy, and Fast Boot. You shutdown your machine, then restarted with the Live media (DVD/USB) attached, and you never see the initial screen with the choices such as proceed to install, verify the media, or edit the boot string for the installer. Is that pretty much your situation?
No, I actually get the GRUB screen with options such as proceeding to Live Mode, etc.
I tried new thing. I used WUBI to install Ubuntu on virtual disk, but during boot, I get black(purple) screen same as if I was running Live mode. Maybe this will help to understand my problem

jglen490
Level 3
Level 3
Posts: 169
Joined: Sat Jul 15, 2017 9:57 pm

Re: Linux stops after Grub

Post by jglen490 » Sat Feb 10, 2018 1:59 am

That's the screen where you can edit the boot string for getting to the Live media install screen. This sounds like a video card problem, but from what I can see the Intel HD 5500 should be well supported, so the only way around this display problem that I know is to add the "nomodeset" to the boot string and you can remove the "quiet" parameter to see all the responses from the boot process. There may be something else that can be edited into the boot string, but I sure don't know.

I hope someone else can figure out a solution for you.
I feel more like I do than I did when I got here.
Toshiba A135-S2386, Intel T2080, ATI Radeon® Xpress 200M Chipset, 2GB RAM, 500GB

User avatar
michael louwe
Level 9
Level 9
Posts: 2591
Joined: Sun Sep 11, 2016 11:18 pm

Re: Linux stops after Grub

Post by michael louwe » Sat Feb 10, 2018 2:33 am

@ Irakus, .......
Irakus wrote:...
.
Please refer to this link ... https://askubuntu.com/questions/765506/ ... t-acpi-off (hp bios update screwes stuff - black screen without acpi=off)

Irakus
Level 1
Level 1
Posts: 11
Joined: Tue Mar 28, 2017 8:46 am

Re: Linux stops after Grub

Post by Irakus » Sun Feb 11, 2018 4:16 pm

Is there a method to check where my booting process stops?

fabien85
Level 6
Level 6
Posts: 1328
Joined: Tue Mar 11, 2014 4:30 pm

Re: Linux stops after Grub

Post by fabien85 » Sun Feb 11, 2018 4:42 pm

Irakus wrote:
Sun Feb 11, 2018 4:16 pm
Is there a method to check where my booting process stops?
Yes. When you are editing the grub entry with 'e' to add 'acpi=off' as suggested by michael, also remove the 'quiet splash'.
To be perfectly clear, the procedure to edit the entry is given in the section "Solving freezes during the boot sequence" in https://www.linuxmint.com/rel_sylvia_cinnamon.php. This is most probably what you already did to add 'nomodeset' as you report.

Irakus
Level 1
Level 1
Posts: 11
Joined: Tue Mar 28, 2017 8:46 am

Re: Linux stops after Grub

Post by Irakus » Sun Feb 11, 2018 7:29 pm

Okay, so what my problem was... bad typing. I was always writing "apic" instead of "acpi". Deleting quiet splash and adding acpi=off solved everything on both Mint and Ubuntu. Thank you all for help.

Post Reply

Return to “Installation & Boot”