Switching off power management[Solved]

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
AnalogueMan
Level 3
Level 3
Posts: 120
Joined: Mon Dec 15, 2014 6:34 am

Switching off power management[Solved]

Post by AnalogueMan » Sat Feb 03, 2018 10:45 am

I am currently running Linux Mint 18.2 Sonya and switched off the power management via Preferences > Power Management and choosing for both Actions and Display (the On AC Power tab) "never".
But Mint is still activating this feature and I have to supply my password to get into my desktop again.
Very annoying.
What did I forget to do more to get rid of this feature?
Last edited by AnalogueMan on Wed Feb 07, 2018 5:02 am, edited 1 time in total.
Analogue man in a digital world

Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: Switching of power management

Post by Cosmo. » Sat Feb 03, 2018 10:49 am

What is your version of Mint and what is the desktop environment? If you don't know open a terminal and enter:

Code: Select all

inxi -Sz
Paste the output here.

Which feature do you mean? Possibly it is the screensaver, which locks the desktop.

AnalogueMan
Level 3
Level 3
Posts: 120
Joined: Mon Dec 15, 2014 6:34 am

Re: Switching of power management

Post by AnalogueMan » Sat Feb 03, 2018 11:11 am

Sorry, I forgot that to do and also failed in supplying the correct info. :oops:
here the correct data:

Code: Select all

analogueman@Alpha-PC ~ $ inxi -Sz
System:    Host: Alpha-PC Kernel: 4.13.0-32-generic x86_64 (64 bit)
           Desktop: MATE 1.18.0  Distro: Linux Mint 18.3 Sylvia
Also looked into the "Control Center" without discovering any clue.
Analogue man in a digital world

AnalogueMan
Level 3
Level 3
Posts: 120
Joined: Mon Dec 15, 2014 6:34 am

Re: Switching of power management

Post by AnalogueMan » Sat Feb 03, 2018 11:28 am

Think I found it :D

Personal > Startup Applications and I unchecked "Screensaver"
Hope this is the solution.
Analogue man in a digital world

AnalogueMan
Level 3
Level 3
Posts: 120
Joined: Mon Dec 15, 2014 6:34 am

Re: Switching of power management

Post by AnalogueMan » Sat Feb 03, 2018 11:42 am

No it was not the solution :(
Analogue man in a digital world

Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: Switching of power management

Post by Cosmo. » Sat Feb 03, 2018 6:43 pm

Screensaver was only a guess, because I had and still have no idea, which "feature" you mean.

User avatar
CaptainKirksChair
Level 4
Level 4
Posts: 288
Joined: Sat Feb 18, 2017 9:29 pm

Re: Switching of power management

Post by CaptainKirksChair » Sat Feb 03, 2018 7:26 pm

It's not the screen saver as much as it is the suspend feature. This is under the power management and, in Cinnamon, is called Suspend when inactive for. Mine is set to Never but it was actually entering the suspend mode when I locked the computer. The problem is that it won't recover from suspend mode. The entire system is frozen and the only answer is to hard boot. After having had to do that a few times, the system wouldn't boot at all. Not even to a LiveUSB. I thought I'd lost the hard drive. I have a backup but that's still a bit scary. I still have no answer for the freezes. I've rebuilt the computer and I hope this problem is solved. I had updated the kernel as approved for the recent malware concerns but am back to the default Mint 18.3 Cinnamon kernel after the rebuild. I'll just have to see if the system freezes when I let it sit for a few hours.

Post rebuild:

Code: Select all

System:    Host: Linux-iMac Kernel: 4.10.0-38-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.6 (Gtk 3.18.9-1ubuntu3.3) Distro: Linux Mint 18.3 Sylvia
Machine:   System: Apple product: iMac9 1 v: 1.0
           Mobo: Apple model: Mac-F2218EA9 Bios: Apple v: IM91.88Z.008D.B08.0904271717 date: 04/27/09
CPU:       Dual core Intel Core2 Duo E8135 (-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 ssse3 vmx) bmips: 10612
           clock speeds: max: 2660 MHz 1: 1862 MHz 2: 1596 MHz
Graphics:  Card: NVIDIA C79 [GeForce 9400] bus-ID: 03:00.0
           Display Server: X.Org 1.18.4 drivers: nouveau (unloaded: fbdev,vesa) Resolution: 1680x1050@60.00hz
           GLX Renderer: Gallium 0.4 on NVAC GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes
Audio:     Card NVIDIA MCP79 High Definition Audio driver: snd_hda_intel bus-ID: 00:08.0
           Sound: Advanced Linux Sound Architecture v: k4.10.0-38-generic
Network:   Card-1: NVIDIA MCP79 Ethernet driver: forcedeth port: 21e0 bus-ID: 00:0a.0
           IF: enp0s10 state: down mac: <filter>
           Card-2: Broadcom BCM4322 802.11a/b/g/n Wireless LAN Controller driver: wl bus-ID: 04:00.0
           IF: wlp4s0 state: up mac: <filter>
Drives:    HDD Total Size: 320.1GB (32.6% used) ID-1: /dev/sda model: WDC_WD3200AAJS size: 320.1GB
Partition: ID-1: / size: 38G used: 5.8G (17%) fs: ext4 dev: /dev/sda2
           ID-2: /home size: 239G used: 76G (34%) fs: ext4 dev: /dev/sda6
           ID-3: swap-1 size: 17.83GB used: 0.00GB (0%) fs: swap dev: /dev/sda7
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 41.0C mobo: N/A gpu: 72.0
           Fan Speeds (in rpm): cpu: 1197
Info:      Processes: 213 Uptime: 2:32 Memory: 1417.4/7726.5MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 

Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: Switching of power management

Post by Cosmo. » Sat Feb 03, 2018 7:40 pm

CaptainKirksChair wrote:the only answer is to hard boot. After having had to do that a few times, the system wouldn't boot at all.
This will sooner or later damage your file system, which can only be solved by installing new and formatting the drive.

In general: If the system does not react on anything, there is in 95 % of all cases still a way to go: Press and hold both the alt key and the print key; while still holding them press those keys: r e i s u b (with a little break after each letter); after the last letter the system will reboot.

AnalogueMan
Level 3
Level 3
Posts: 120
Joined: Mon Dec 15, 2014 6:34 am

Re: Switching of power management

Post by AnalogueMan » Sun Feb 04, 2018 9:06 am

Well it seems that I have to live with this feature?
After a minute of five or so of inactivity, the display starts to "slowly die" into a black screen.
Whatever I try, setting for instance "Put display to sleep when inactive for" to 1 hour, this doesn't have
any effect. The display starts to slowly die after 5 or 10 minutes or so.
And I think this has nothing to do with my hardware because other (linux) o.s.es do not show this problem
on this particular computer.
Analogue man in a digital world

Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: Switching of power management

Post by Cosmo. » Sun Feb 04, 2018 10:20 am

AnalogueMan wrote:the display starts to "slowly die" into a black screen.
This sounds very strongly for the screensaver. There should be a screensaver setting in the system (but I use Cinnamon, not Mate).

AnalogueMan
Level 3
Level 3
Posts: 120
Joined: Mon Dec 15, 2014 6:34 am

Re: Switching of power management

Post by AnalogueMan » Sun Feb 04, 2018 12:02 pm

Cosmo. wrote:
AnalogueMan wrote:the display starts to "slowly die" into a black screen.
This sounds very strongly for the screensaver. There should be a screensaver setting in the system (but I use Cinnamon, not Mate).
Well, then AGAIN I did take a look at those settings and to my very,very surprise both the "Activate screensaver....." and "Lock screen......" were set,
although I was pretty sure that in the past I DID uncheck both.

At this moment it looks like the problem is solved but I did wrote this earlier......
Analogue man in a digital world

Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: Switching of power management

Post by Cosmo. » Mon Feb 05, 2018 6:22 am

If you change these (or any other) settings and they revert after rebooting, than you have near to sure a problem with ownership of your home. You can investigate into this by doing the following:
Mark the following command and press ctrl-c

Code: Select all

find $HOME ! -user $USER -type f
open a terminal and press ctrl-shift-V
Mark the complete result inclusive the command with the mouse and press ctrl-shift-C
In the forum click the Code-button above the text box, than press ctrl-v.

Report in case, that there is no output.

AnalogueMan
Level 3
Level 3
Posts: 120
Joined: Mon Dec 15, 2014 6:34 am

Re: Switching of power management

Post by AnalogueMan » Tue Feb 06, 2018 5:14 am

Cosmo. wrote:If you change these (or any other) settings and they revert after rebooting, than you have near to sure a problem with ownership of your home. You can investigate into this by doing the following:
Mark the following command and press ctrl-c

Code: Select all

find $HOME ! -user $USER -type f
open a terminal and press ctrl-shift-V
Mark the complete result inclusive the command with the mouse and press ctrl-shift-C
In the forum click the Code-button above the text box, than press ctrl-v.

Report in case, that there is no output.
Hope I did understand your advice correctly:

Code: Select all

analogueman@Alpha-PC ~ $ sudo find $HOME ! -user $USER -type f
[sudo] password for analogueman: 
/home/analogueman/.cache/dconf/user
analogueman@Alpha-PC ~ $
The problem is still not solved although both the "Active screensaver....." and "Lock screen....." are unchecked. :(
Is perhaps the problem lying in the way I have my computer organized?
My main O.S. is PCLinuxOS and the Linux Mint Mate O.S. is chainloaded. So I am starting Linux Mint Mate by choosing it during boot.
But I can understand that it has nothing to do with it.
Analogue man in a digital world

Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: Switching of power management

Post by Cosmo. » Tue Feb 06, 2018 6:03 am

General notice:
Don't use sudo as a kind of Swiss army knife, but only for a reason, otherwise you might create problems, which had not yet been there.
In this case there is no reason for sudo. I gave you the command without sudo and you should use it exactly as given.
But on the other side: The output is usable and in this case harmless.

There is one thing,, where I am unsure: Do those screensaver settings still get reverted after rebooting?

If so create a fresh new user account. Log out of the main account and into the test account. Do no changes except changing those screensaver settings. Reboot and log again into the test account. Do the settings persist in this case? Do they get honored?

AnalogueMan
Level 3
Level 3
Posts: 120
Joined: Mon Dec 15, 2014 6:34 am

Re: Switching of power management

Post by AnalogueMan » Tue Feb 06, 2018 6:39 am

"Don't use sudo as a kind of Swiss army knife,...."

I am absolutely aware of the risks but........
I was forced to do it with sudo because "permission denied" was the first response :?:

"There is one thing,, where I am unsure: Do those screensaver settings still get reverted after rebooting?"

As I wrote in my last response : " Both the "Active screensaver....." and "Lock screen....." are unchecked."
And this situation is also after boot. So everything is as it should be when one wants no screensaver active.
But, as a test, I will create a new user account to see if the problem occurs also with that new user account.
Analogue man in a digital world

Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: Switching of power management

Post by Cosmo. » Tue Feb 06, 2018 6:45 am

AnalogueMan wrote:I was forced to do it with sudo because "permission denied" was the first response :?:
If you mean, that this message came in context with the the folder /home/analogueman/.cache/dconf: This message was expected. This special problem is the result of a long standing bug in the update manager (since LM 18), but luckily it is harmless. (I do anyway not understand, why this bug pertains from Mint version to Mint version.)

AnalogueMan
Level 3
Level 3
Posts: 120
Joined: Mon Dec 15, 2014 6:34 am

Re: Switching off power management

Post by AnalogueMan » Tue Feb 06, 2018 10:39 am

"If so create a fresh new user account. Log out of the main account and into the test account. Do no changes except changing those screensaver settings. Reboot and log again into the test account. Do the settings persist in this case? Do they get honored?"

Made a new account and changed only the screen saver settings. The result is exactly what I want : NO screen saver.
So this leaves me quite puzzled :?
What more can I do (test)?
Analogue man in a digital world

Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: Switching off power management

Post by Cosmo. » Tue Feb 06, 2018 4:57 pm

So we know, that the culprit is in your main account. As we know already, that it is not a permission problem it must be some misconfiguration.

Try this (in the main account):
Open the file manager and make hidden files visible (ctrl-h).
Rename inside of your home the folder .config to .config.bck. Rename the folder .local accordingly.
Immediately after that lock out and back in. Both folders get recreated with default values and get deleted, if you want to revert. Does this help?

Those 2 folders are the most suspicious places for misconfiguration.

AnalogueMan
Level 3
Level 3
Posts: 120
Joined: Mon Dec 15, 2014 6:34 am

Re: Switching off power management

Post by AnalogueMan » Wed Feb 07, 2018 5:02 am

Cosmo. wrote:So we know, that the culprit is in your main account. As we know already, that it is not a permission problem it must be some misconfiguration.

Try this (in the main account):
Open the file manager and make hidden files visible (ctrl-h).
Rename inside of your home the folder .config to .config.bck. Rename the folder .local accordingly.
Immediately after that lock out and back in. Both folders get recreated with default values and get deleted, if you want to revert. Does this help?

Those 2 folders are the most suspicious places for misconfiguration.
That's it!!
At last I got rid of this "feature" (between quotes is a strictly personal opinion).
Although I don't understand what went wrong during the installation of Mint-Mate, I will take a note of this solution "in case of".
Thanks Cosmo for your valuable help. :D
AM
Analogue man in a digital world

Post Reply

Return to “Installation & Boot”