Changed my uefi boot options, can't boot anymore

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
PatriceB
Level 1
Level 1
Posts: 7
Joined: Tue Feb 06, 2018 3:57 am

Changed my uefi boot options, can't boot anymore

Post by PatriceB » Tue Feb 06, 2018 5:00 am

Hi everybody,

I have a laptop Toshiba (Portege) with Linux mint (sylvia) installed. I have no dual boot as I overwrote over the windows OS that was installed.
Up to now everything was ok.
Yesterday a friend came cause he couldn't installed a new version of mint on his HP laptop with uefi boot. The pen drive couldn't be detected (we are sure of the pen drive. I tested it on my desktop which doesn't have uefi boot)

I have three boot mode on my laptop:
UEFI Boot
UEFI Boot (Legacy)
CSM Boot

My friend told me to change the boot mode to CSM boot to check if we can boot with the pen drive. We could fallback to the UEFI Boot if it doesn't work (never trust your friend -:)).

Now my laptop doesn't boot anymore.
I have the following message:

Insert system disk in drive.
Press any key when ready...
Please check if the Boot Mode is correct in the Bios settings.
The BIOS settings menu is launched by pressing the [F2] key after you reboot.

I then tried every Boot Mode, set the BIOs to default mode. I can't boot anymore.

It seems that the grub options have been modified but I have no idea how to check this.
Somebody could give me a hand (as mine are worthless)

Thanks,

Patrice

User avatar
michael louwe
Level 9
Level 9
Posts: 2616
Joined: Sun Sep 11, 2016 11:18 pm

Re: Changed my uefi boot options, can't boot anymore

Post by michael louwe » Tue Feb 06, 2018 7:14 am

@ PatriceB, .......
PatriceB wrote:...
.
Try reinstalling Grub.EFI ... https://sites.google.com/site/easylinuxtipsproject/6

PatriceB
Level 1
Level 1
Posts: 7
Joined: Tue Feb 06, 2018 3:57 am

Re: Changed my uefi boot options, can't boot anymore

Post by PatriceB » Tue Feb 06, 2018 7:47 am

Thanks for your reply.
The problem is that I can't even boot on a pendrive.
The live USB is Okay cause when I boot my desktop computer with it, it works.

My BIOS configuration up to now is this one:

Security:
Secure Boot: Disabled

Advanced:
USB Legacy Emulation: Cold boot only
Boot priority Options: USB Memory, HDD/SSD, USB ODD, FDD, LAN1, LAN2
Boot Mode: UEFI Boot

I tried the two other Boot mode (UEFI Boot (Legacy) and CSM Boot) but always have the same message:

Insert system disk in drive.
Press any key when ready...
Please check if the Boot Mode is correct in the Bios settings.
The BIOS settings menu is launched by pressing the [F2] key after you reboot.

It seems to be something stupid in my BIOS configuration to have a access to the USB live CD but I don't find out what is going on.

BTW: the USB live has been create with Linux Mint Sylvia

User avatar
Lucap
Level 5
Level 5
Posts: 913
Joined: Tue May 24, 2016 1:40 am

Re: Changed my uefi boot options, can't boot anymore

Post by Lucap » Tue Feb 06, 2018 7:53 am

Does pressing [F12] bring up the boot options?

PatriceB
Level 1
Level 1
Posts: 7
Joined: Tue Feb 06, 2018 3:57 am

Re: Changed my uefi boot options, can't boot anymore

Post by PatriceB » Tue Feb 06, 2018 8:25 am

Sorry to answer that late (was doing dishes)
Pressing the [F12] brings me effectively to the boot options in this order:

USB Memory
HDD/SSD
USB ODD
FDD
LAN1
LAN2
Enter Setup (which leads me to the BIOS)

User avatar
Pierre
Level 17
Level 17
Posts: 7142
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: Changed my uefi boot options, can't boot anymore

Post by Pierre » Tue Feb 06, 2018 9:38 am

if you change the BIOS to UEFI Boot (Legacy)
- does that work ?.
use the F12 to check that the HDD/SSD option will work.
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.

PatriceB
Level 1
Level 1
Posts: 7
Joined: Tue Feb 06, 2018 3:57 am

Re: Changed my uefi boot options, can't boot anymore

Post by PatriceB » Tue Feb 06, 2018 9:56 am

Hi,
Actually, I tried the three modes with or without the USB inserted but without any results...

PatriceB
Level 1
Level 1
Posts: 7
Joined: Tue Feb 06, 2018 3:57 am

Re: Changed my uefi boot options, can't boot anymore

Post by PatriceB » Tue Feb 06, 2018 12:31 pm

I finally make another USB live and I have access to the computer again with the linux live. Don't understand why the live USB worked on my desktop and not on my laptop but anyway...

I am following the step of the following link given by Michael: https://sites.google.com/site/easylinuxtipsproject/6

the Gparted says for the laptop:

/dev/sda1 EFI sytem Partition FAT32
/dev/sda2 ext4
/dev/sda3 (phone icon) Linux-swap

the pen drive is on sdb

I tried the mount the ext4 partition with "sudo mount dev/sda2/ /mnt just as it is written on the post but the terminal response is "mount: special device dev/sda1 does not exist2.
Same message for sda1.

Any idea?
Thanks in advance

PatriceB
Level 1
Level 1
Posts: 7
Joined: Tue Feb 06, 2018 3:57 am

Re: Changed my uefi boot options, can't boot anymore

Post by PatriceB » Tue Feb 06, 2018 12:54 pm

Another tip.
When I start Gparted, I have a libparted warning saying that: "The driver descriptor says the physical block size is 2048 bytes, but linux says it is 512 bytes....??

fabien85
Level 6
Level 6
Posts: 1331
Joined: Tue Mar 11, 2014 4:30 pm

Re: Changed my uefi boot options, can't boot anymore

Post by fabien85 » Tue Feb 06, 2018 2:47 pm

PatriceB wrote:When I start Gparted, I have a libparted warning saying that: "The driver descriptor says the physical block size is 2048 bytes, but linux says it is 512 bytes....??
That's a harmless warning about the USB. It happens because a live USB has to be formatted in an exotic way to be able to boot on all computers (both Legacy and UEFI), but you dont need to care about it.
PatriceB wrote:sudo mount dev/sda2/ /mnt
there is a typo : that should be sudo mount /dev/sda2 /mnt. Note the positions of the path separator "/".
Useful tip : one way to check that a path is valid is to use the bash autocompletion. It also saves a lot of time in the long run. The autocompletion is trigerred by the tab key. So you start typing "/de" and hit tab, bash will autocomplete into "/dev/" (because the only path on the filesystem starting with /de is /dev. If there were several possibilities you would get an error sound, and hitting tab a second time would list the possibilities), then type "sd" hit tab twice and the possibilities will be listed, eg on my computer

Code: Select all

$ ls /dev/sd
sda   sda1  sda2  sda3  sda4  sda5  sdb   sdb1  sdb2  sdb3  sdb4

PatriceB
Level 1
Level 1
Posts: 7
Joined: Tue Feb 06, 2018 3:57 am

Re: Changed my uefi boot options, can't boot anymore

Post by PatriceB » Wed Feb 07, 2018 5:46 am

I don't get why typing "sudo mount dev/sda2/ /mnt" gives me an error while doing the same command with completion works.

But anyway, the tuto worked and I have my laptop back.

Thank you very much to all.
Today it's a day off. it snowed 9 cm yesterday in Paris and the train, metro traffic is stuck.
Have a good day (or afternoon or night)

Patrice

fabien85
Level 6
Level 6
Posts: 1331
Joined: Tue Mar 11, 2014 4:30 pm

Re: Changed my uefi boot options, can't boot anymore

Post by fabien85 » Wed Feb 07, 2018 11:10 am

Hi,
it's not a question of autocompletion, you would have the same result by typing, the thing is to use the correct path which is "/dev/sda2" and not "dev/sda2/".
In Unix (comprising Linux and macOS), "/" is the path separator. In windows it's "\".
/dev/sda2 is an absolute path and means the following :
- go to the root of the filesystem, i.e. the start of the directory tree.
- there, find the directory "dev"
- there, find the device sda2

By contrast dev/sda2/ would be a relative path, relative to the current directory you are in. When you open a terminal, by default the working directory is your home (/home/username/). So in that case, dev/sda2/ would mean the following :
- in the current directory (/home/username/ by default), find a directory called dev
- inside that directory, find another directory called sda2
why a directory ? because leaving a / at the end implies so

Compare the following :

Code: Select all

$ ls /dev/sda2
/dev/sda2
$ ls /dev/sda2/
ls: cannot access '/dev/sda2/': Not a directory
The first command is valid. The second is not because /dev/sda2 is a device (here a partition on a disk) and not a directory.
Now if I forget the first /, the path are going to be interpreted relative to my home folder, and as I have no directory called dev there, the shell is just going to tell me that such path does not exist :

Code: Select all

$ ls dev/sda2
ls: cannot access 'dev/sda2': No such file or directory
$ ls dev/sda2/
ls: cannot access 'dev/sda2/': No such file or directory
Bon après-midi :)

Post Reply

Return to “Installation & Boot”