Grub multiboot on 2 drives

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 3
Joined: Fri Feb 09, 2018 11:50 am

Grub multiboot on 2 drives

Post by GoodOldJack12 » Fri Feb 09, 2018 12:08 pm

Hello mint guru's and enthousiasts,

I've recently tried switching to Mint KDE from Manjaro
for that little bit extra user friendlyness and compatibility.

however, I've encountered some issues.
I have a laptop with an ssd and hdd,
with windows and my old grub on the ssd.

now i'm trying to get Mint installed on the hdd (to have an OS on each drive for recovery and such), but the bootloader on the ssd, since thats where my windows bootloader is.
Whichever way I try, grub always breaks saying 'unknown filesystem... (if I recall correctly)

my temporary solution is to have manjaro installed on the ssd, and thus installing grub correctly.
but this is hardly ideal. I think that if I would delete the manjaro partition now, my grub would break, right?

so how do I set up grub in such a way (preferably without reinstalling Mint again) that I dont have 100 bits of OS and bootloader scattered over my hard drive?

bonus question: my bios boot device menu still shows old bootloader entries like my old ubuntu installation, any way to get rid of those?

User avatar
Level 5
Level 5
Posts: 843
Joined: Wed Jan 07, 2015 12:24 pm
Location: Harare

Re: Grub multiboot on 2 drives

Post by prestonR » Fri Feb 09, 2018 3:22 pm

With Manjaro comes an odd quirk concerning multi-boot setups with other Linux distros. More, plus the fixes here: viewtopic.php?p=1421027#p1421027

Basically, Manjaros needs to be in charge of grub. If due to a kernel update Mint takes over, the Manjaro entries won't work. Easy to fix but a little annoying. Due to Mint's rare kernel updates this isn't normally a big deal (and the Manjaro grub is nice :D ) but you should be aware of it.

The actual issue here seems to be that error. To get more info about your system can you give us the output of:

Code: Select all

inxi -Fzx

Code: Select all

PS: You are aware that Mint is dropping the KDE edition from its upcoming Mint19 version, right?

Level 1
Level 1
Posts: 3
Joined: Fri Feb 09, 2018 11:50 am

Re: Grub multiboot on 2 drives

Post by GoodOldJack12 » Sun Feb 11, 2018 10:46 am

Yeah I dont want manjaro anymore, but I used it to install grub properly. anyways, here are the command outputs:

Code: Select all

jack@jack-Mint ~ $ inxi -Fzx
System:    Host: jack-Mint Kernel: 4.10.0-38-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: KDE Plasma 5.8.8 (Qt 5.6.1) Distro: Linux Mint 18.3 Sylvia
Machine:   Mobo: Micro-Star model: MS-16GD v: REV:1.0 Bios: American Megatrends v: E16GDIMS.30B date: 08/23/2013
CPU:       Quad core Intel Core i7-4700MQ (-HT-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 19156
           clock speeds: max: 3400 MHz 1: 1103 MHz 2: 1198 MHz 3: 1201 MHz 4: 1064 MHz 5: 1053 MHz 6: 1293 MHz
           7: 1090 MHz 8: 1030 MHz
Graphics:  Card-1: Intel 4th Gen Core Processor Integrated Graphics Controller bus-ID: 00:02.0
           Card-2: NVIDIA GK208M [GeForce GT 740M] bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 driver: nvidia Resolution: 1920x1080@59.93hz
           GLX Renderer: GeForce GT 740M/PCIe/SSE2 GLX Version: 4.5.0 NVIDIA 384.111 Direct Rendering: Yes
Audio:     Card-1 Intel 8 Series/C220 Series High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:03.0
           Sound: Advanced Linux Sound Architecture v: k4.10.0-38-generic
Network:   Card-1: Qualcomm Atheros AR8161 Gigabit Ethernet driver: alx port: d000 bus-ID: 04:00.0
           IF: enp4s0 state: up speed: 100 Mbps duplex: full mac: <filter>
           Card-2: Realtek RTL8723AE PCIe Wireless Network Adapter driver: rtl8723ae port: c000 bus-ID: 05:00.0
           IF: wlp5s0 state: down mac: <filter>
Drives:    HDD Total Size: 2000.4GB (0.6% used) ID-1: /dev/sda model: TOSHIBA_MQ01ABD1 size: 1000.2GB temp: 20C
           ID-2: /dev/sdb model: Samsung_SSD_850 size: 1000.2GB temp: 0C
Partition: ID-1: / size: 20G used: 12G (66%) fs: ext4 dev: /dev/sda1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 53.0C mobo: N/A gpu: 0.0:47C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 244 Uptime: 8 min Memory: 2260.5/7901.2MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 
(really fancy command btw, I'll remember that)

Code: Select all

sdb    931,5G    #primary ssd               
├─sdb4 195,3G            ntfs   OldStorage #old cross-OS storage from before I got a second drive
├─sdb2   128M                                #I have no idea what this is
├─sdb5  15,4G            ext4   	      #Manjaro linux
├─sdb3 675,4G            ntfs   Windows   
└─sdb1   100M /boot/efi  vfat                 #obviously the efi partition
sda    931,5G      #secondary hdd
├─sda2   912G            ntfs   HDDStorage #my new storage partition for cross-OS stuff
└─sda1  19,5G /          ext4  	              #Mint
added some comments for your convenience.

User avatar
Level 20
Level 20
Posts: 12055
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: Grub multiboot on 2 drives

Post by austin.texas » Sun Feb 11, 2018 11:10 am

When you tried to install Mint on the hdd, where did you try to install Grub?
Did you chose /dev/sdb1 - the efi partition?

But beyond that, from what I have seen about Mint UEFI installations, the default is to install Grub to the ESP (EFI System Partition) on /dev/sda always. If no ESP exists on /dev/sda, that could be the cause of the failure. And I have gotten the impression from various posts that trying to install Grub to a ESP on /dev/sdb will fail - even when you chose /devsdb1 as the bootloader location in the Mint installation program. It insists on looking for a ESP on /dev/sda.

Maybe rEFInd can handle what you want to do.
Mint 18.2 Cinnamon, Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Linux Linx 2018

Level 1
Level 1
Posts: 3
Joined: Fri Feb 09, 2018 11:50 am

Re: Grub multiboot on 2 drives

Post by GoodOldJack12 » Tue Feb 13, 2018 12:41 pm

Yes exactly, I cant seem to get it to install to my EFI partition in any way. I tried manually installing it via grub-install, but im not very proficient in the details of that.
I suppose I could just leave manjaro linux with the few GB's it needs just for grub.

User avatar
Level 16
Level 16
Posts: 6412
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Grub multiboot on 2 drives

Post by Flemur » Tue Feb 13, 2018 1:02 pm

prestonR wrote:
Fri Feb 09, 2018 3:22 pm
Basically, Manjaros needs to be in charge of grub. If due to a kernel update Mint takes over, the Manjaro entries won't work.
I dual boot Mint and Ubuntu; Ubuntu controls booting; the MBR on /dev/sda uses ubuntu's /boot/grub/grub.cfg file.

Kernel updates to Mint change Mint's /boot/grub/grub.cfg file, but it's not used in booting.

IOW, Mint never takes over booting, even from a kernel update. (unless I were to do a "grub-install /dev/sda", but that never happens automagically in a software update).

After a Mint kernel upgrade I edit the grub.cfg file on ubuntu so as to include the new kernel. (others would run update-grub on ubuntu to do the same thing).
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Manjaro openbox/fluxbox/pulse-less
Lubuntu LXDE/fluxbox/pulse-less

Post Reply

Return to “Installation & Boot”