Issue with Linux Mint 18.3 Cinnamon with Nvidia driver 384

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
zorin1
Level 1
Level 1
Posts: 9
Joined: Mon Feb 12, 2018 11:38 am

Issue with Linux Mint 18.3 Cinnamon with Nvidia driver 384

Post by zorin1 » Mon Feb 12, 2018 11:40 am

I having an issue with Linux Mint 18.3 Cinnamon with Nvidia driver 384 (recommend).
Machine specs:
I7-4790K
Asus Z97-pro motherboard
Nvidia GTX 970

Steps:
1) Created a fresh install of Linux Mint 18.3 Cinnamon onto a USB stick
2) Machine when booting from the USB stick would show just a black screen. Work around, remove the GTX 970 and use the onboard graphics.
3) Installed LM 18.3 onto a hard drive erasing everything.
4) reboot
5) Installed all the updates
6) shutdown
7) Reinstalled the GTX 970
8) Machine boots up using the Open source Nvidia drivers (nouveau).
9) From the Driver Manager install the Recommend Nvidia 384 driver.
10) Reboot
11) I can’t remember but I would either get a Cinnamon error and a message that told me that I was using CPU graphics or something like that.
12) Issues is that the 384 drivers won’t load. AT this point everything is up to date.
Things that I have tried:
1) Going back to the (nouveau) driver from the Driver Manager, reboot, things work.
2) Removing all of the Nvidia drivers (sudo apt-get purge nvidia*), reboot, try to reinstall different Nvidia drivers. Nothing working
I also tried this on another machine with a GTX 660TI and same type of issues where the driver won’t load.

Anyone know the solution? I think an update broke the Nvidia drivers. The reason why I was trying to install in that my Linux Mint crashed and I was getting a black screen at boot up. I thought it was something that I did to the system so I thought that it might be best to just do a clean install again. But no, the install won’t work. Help please!!

deepakdeshp
Level 11
Level 11
Posts: 3707
Joined: Sun Aug 09, 2015 10:00 am

Re: Issue with Linux Mint 18.3 Cinnamon with Nvidia driver 384

Post by deepakdeshp » Mon Feb 12, 2018 12:28 pm

If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 19 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

zorin1
Level 1
Level 1
Posts: 9
Joined: Mon Feb 12, 2018 11:38 am

Re: Issue with Linux Mint 18.3 Cinnamon with Nvidia driver 384

Post by zorin1 » Mon Feb 12, 2018 1:34 pm

deepakdeshp,
I have tried all that, still does not work. Either the Kernel or an update to the Window Manager has caused an issue. I have tried going back to an old video driver and that does not work as well. At this point, I'm stuck.

User avatar
greerd
Level 5
Level 5
Posts: 978
Joined: Sat Jul 31, 2010 10:58 am
Location: Nova Scotia, Canada

Re: Issue with Linux Mint 18.3 Cinnamon with Nvidia driver 384

Post by greerd » Mon Feb 12, 2018 1:46 pm

Have you tried using nomodeset? From linuxmint-installation-guide.

zorin1
Level 1
Level 1
Posts: 9
Joined: Mon Feb 12, 2018 11:38 am

Re: Issue with Linux Mint 18.3 Cinnamon with Nvidia driver 384

Post by zorin1 » Mon Feb 12, 2018 4:08 pm

greerd wrote:
Mon Feb 12, 2018 1:46 pm
Have you tried using nomodeset? From linuxmint-installation-guide.
greerd,
Thanks, but I was able to get the USB stick to boot. The issue now is to get the Nvidia drivers to load.

User avatar
greerd
Level 5
Level 5
Posts: 978
Joined: Sat Jul 31, 2010 10:58 am
Location: Nova Scotia, Canada

Re: Issue with Linux Mint 18.3 Cinnamon with Nvidia driver 384

Post by greerd » Mon Feb 12, 2018 4:36 pm

The installation guide says to try the same thing post-install, did you at least give it a go?

zorin1
Level 1
Level 1
Posts: 9
Joined: Mon Feb 12, 2018 11:38 am

Re: Issue with Linux Mint 18.3 Cinnamon with Nvidia driver 384

Post by zorin1 » Mon Feb 12, 2018 7:51 pm

greerd wrote:
Mon Feb 12, 2018 4:36 pm
The installation guide says to try the same thing post-install, did you at least give it a go?
No luck. Going to try and load an older kernel and see if that solves the problem. Linux Mint was working on this machine just fine until and update came out. I'm just not sure what update caused the issue.

zorin1
Level 1
Level 1
Posts: 9
Joined: Mon Feb 12, 2018 11:38 am

Re: Issue with Linux Mint 18.3 Cinnamon with Nvidia driver 384

Post by zorin1 » Tue Feb 13, 2018 10:25 am

I fixed my issue but then broke it again. I know what I did to break it but did not write down the steps on how to fix the issue.

I think this is what I did. The issue is that the Nvidia drivers were not loading at boot time.

1) I changed grub to give me the boot menu
2) I installed kernel 4.4
3) booted the 4.4 kernel
4) removed the latest kernel, don't remember what the version number is at the moment.
5) rebooted
6) sudo apt-get purge nvidia
7) sudo apt-get install nvidia-prime nvidia-settings
8) installed the nouveau from the Driver Manager
9) rebooted
10) install the 384 drivers by the way of Driver Manager
11) install the latest kernel
12) reboot
11) Nvidia drivers were now loaded!!!!

So everything was working and I was setting up everything else. I happened to issue the command sudo apt-get upgrade After this, I rebooted got the grub menu hit enter and then I get a black screen, it is locked I can't do a ctrl-alt-1 to get another console. The one thing that I noticed is a mesa update. Not sure if that caused the issue, I'm not sure what mesa is.

I might just reload from scratch again so that I can document all the steps to get the Nvidia drivers to load. I just find it weird that I'm the only one reporting this issue. Some update is breaking the Nvidia drivers from loading. I need to find out a way to list out what 'apt-get upgrade' without doing the update.

zorin1
Level 1
Level 1
Posts: 9
Joined: Mon Feb 12, 2018 11:38 am

Re: Issue with Linux Mint 18.3 Cinnamon with Nvidia driver 384

Post by zorin1 » Tue Feb 13, 2018 9:38 pm

I finally figured out my problem after spending days reinstall kernels, nvidia drivers. The issue is if there is anything in the /etc/X11/xorg.conf then the Nvidia driver won't load. I found this by trying to add the coolbits by doing the following command:
sudo nvidia-xconfig -a --cool-bits=31

which created this file: /etc/X11/xorg.conf:

Code: Select all

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 384.111  (buildmeister@swio-display-x86-rhel47-01)  Wed Dec 20 00:05:28 PST 2017

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 970"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Coolbits" "31"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
Maybe my issue is that I have two monitors hooked up? I have one on HDMI and the other on a display port.

xrandr --query

Code: Select all

creen 0: minimum 8 x 8, current 4480 x 1440, maximum 16384 x 16384
DVI-I-0 disconnected (normal left inverted right x axis y axis)
DVI-I-1 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 597mm x 336mm
   1920x1080     60.00*+ 120.00    60.00    59.94    50.00    60.05    60.00    50.04  
   1680x1050    119.99    59.95  
   1600x900     120.00    60.00  
   1280x1024    119.96    75.02    60.02  
   1280x720      60.00    59.94    50.00  
   1024x768     119.99    75.03    60.00  
   800x600      119.97    75.00    60.32  
   720x576       50.00  
   720x480       59.94  
   640x480       75.00    59.94    59.93  
DP-0 connected 2560x1440+1920+0 (normal left inverted right x axis y axis) 598mm x 336mm
   2560x1440     59.95*+ 143.96   120.00    99.95    84.98    23.97  
   1024x768      60.00  
   800x600       60.32  
   640x480       59.94  
DP-1 disconnected (normal left inverted right x axis y axis)
DVI-D-0 disconnected (normal left inverted right x axis y axis)
I just wanted to thank everyone who has tried to give me some help. I really appreciate it.

User avatar
greerd
Level 5
Level 5
Posts: 978
Joined: Sat Jul 31, 2010 10:58 am
Location: Nova Scotia, Canada

Re: Issue with Linux Mint 18.3 Cinnamon with Nvidia driver 384

Post by greerd » Tue Feb 13, 2018 10:00 pm

Good job, I couldn't understand why it wasn't working for you, my gtx 970 works great.

I have a question about your coolbits, why coolbits= 31 ?? I think it's an illegal number and is probably why you don't see it listed in your xorg.conf file.

Here's some notes I have on them:
When “2” (Bit 1) is set in the “Coolbits” option value, the NVIDIA driver will attempt to initialize SLI when using GPUs with different amounts of video memory.

When “4” (Bit 2) is set in the “Coolbits” option value, the nvidia-settings Thermal Monitor page will allow configuration of GPU fan speed, on graphics boards with programmable fan capability.

When “8” (Bit 3) is set in the “Coolbits” option value, the PowerMizer page in the nvidia-settings control panel will display a table that allows setting per-clock domain and per-performance level offsets to apply to clock values. This is allowed on certain GeForce GPUs. Not all clock domains or performance levels may be modified.

When “16” (Bit 4) is set in the “Coolbits” option value, the nvidia-settings command line interface allows setting GPU overvoltage. This is allowed on certain GeForce GPUs.

When this option is set for an X screen, it will be applied to all X screens running on the same GPU.

The default for this option is 0 (unsupported features are disabled).
So for example, if you wanted both fan control and over clocking, your Section "Device" would show Option "Coolbits" "12"

Cheers

User avatar
catweazel
Level 17
Level 17
Posts: 7078
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Issue with Linux Mint 18.3 Cinnamon with Nvidia driver 384

Post by catweazel » Wed Feb 14, 2018 1:52 am

zorin1 wrote:
Tue Feb 13, 2018 10:25 am
sudo apt-get upgrade
A guaranteed way to b0rk your system. But of course, you've learned that now. What gets me is that the devs don't live in userland so they don't see the problem, so they don't put in a warning or ask if you're absolutely certain that you want to execute that command.
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

zorin1
Level 1
Level 1
Posts: 9
Joined: Mon Feb 12, 2018 11:38 am

Re: Issue with Linux Mint 18.3 Cinnamon with Nvidia driver 384

Post by zorin1 » Wed Feb 14, 2018 11:49 am

greerd wrote:
Tue Feb 13, 2018 10:00 pm
Good job, I couldn't understand why it wasn't working for you, my gtx 970 works great.

I have a question about your coolbits, why coolbits= 31 ?? I think it's an illegal number and is probably why you don't see it listed in your xorg.conf file.

Here's some notes I have on them:
When “2” (Bit 1) is set in the “Coolbits” option value, the NVIDIA driver will attempt to initialize SLI when using GPUs with different amounts of video memory.

When “4” (Bit 2) is set in the “Coolbits” option value, the nvidia-settings Thermal Monitor page will allow configuration of GPU fan speed, on graphics boards with programmable fan capability.

When “8” (Bit 3) is set in the “Coolbits” option value, the PowerMizer page in the nvidia-settings control panel will display a table that allows setting per-clock domain and per-performance level offsets to apply to clock values. This is allowed on certain GeForce GPUs. Not all clock domains or performance levels may be modified.

When “16” (Bit 4) is set in the “Coolbits” option value, the nvidia-settings command line interface allows setting GPU overvoltage. This is allowed on certain GeForce GPUs.

When this option is set for an X screen, it will be applied to all X screens running on the same GPU.

The default for this option is 0 (unsupported features are disabled).
So for example, if you wanted both fan control and over clocking, your Section "Device" would show Option "Coolbits" "12"

Cheers
The problem is that I can't create a xorg.conf file otherwise the driver does not load or I get a black screen and can't do anything. Can you post your xorg.con file?

zorin1
Level 1
Level 1
Posts: 9
Joined: Mon Feb 12, 2018 11:38 am

Re: Issue with Linux Mint 18.3 Cinnamon with Nvidia driver 384

Post by zorin1 » Wed Feb 14, 2018 11:51 am

catweazel wrote:
Wed Feb 14, 2018 1:52 am
zorin1 wrote:
Tue Feb 13, 2018 10:25 am
sudo apt-get upgrade
A guaranteed way to b0rk your system. But of course, you've learned that now. What gets me is that the devs don't live in userland so they don't see the problem, so they don't put in a warning or ask if you're absolutely certain that you want to execute that command.
It is hard going from the command line to using the GUI interface. Old habbits I guess. Never had a problem doing an upgrade until now.

User avatar
greerd
Level 5
Level 5
Posts: 978
Joined: Sat Jul 31, 2010 10:58 am
Location: Nova Scotia, Canada

Re: Issue with Linux Mint 18.3 Cinnamon with Nvidia driver 384

Post by greerd » Wed Feb 14, 2018 2:47 pm

zorin1 wrote:
Wed Feb 14, 2018 11:49 am
The problem is that I can't create a xorg.conf file otherwise the driver does not load or I get a black screen and can't do anything. Can you post your xorg.con file?
I can when I get home from work. Have you tried creating your xorg.conf file from within nvidia-settings? There should be a 'Save to Xconfig file' button in the 'X server config' section, maybe that'll work for you.

User avatar
greerd
Level 5
Level 5
Posts: 978
Joined: Sat Jul 31, 2010 10:58 am
Location: Nova Scotia, Canada

Re: Issue with Linux Mint 18.3 Cinnamon with Nvidia driver 384

Post by greerd » Wed Feb 14, 2018 5:56 pm

zorin1 wrote:
Wed Feb 14, 2018 11:49 am
Can you post your xorg.con file?
Here it is, note I only have one monitor:

Code: Select all

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 367.18  (buildd@lgw01-52)  Thu May 19 23:33:33 UTC 2016


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"

    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "DELL U2410"
    HorizSync       30.0 - 81.0
    VertRefresh     56.0 - 76.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 970"
    Option         "Coolbits" "12"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-4"
    Option         "metamodes" "nvidia-auto-select +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

User avatar
catweazel
Level 17
Level 17
Posts: 7078
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Issue with Linux Mint 18.3 Cinnamon with Nvidia driver 384

Post by catweazel » Thu Feb 15, 2018 12:36 am

zorin1 wrote:
Wed Feb 14, 2018 11:51 am
It is hard going from the command line to using the GUI interface. Old habbits I guess. Never had a problem doing an upgrade until now.
Yes. The recommended approach nowadays is to restrict doing upgrades by using the update manager. The Mint devs have put a lot of work into it.

Cheers.
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

zorin1
Level 1
Level 1
Posts: 9
Joined: Mon Feb 12, 2018 11:38 am

Re: Issue with Linux Mint 18.3 Cinnamon with Nvidia driver 384

Post by zorin1 » Thu Feb 15, 2018 8:59 pm

greerd wrote:
Wed Feb 14, 2018 5:56 pm
zorin1 wrote:
Wed Feb 14, 2018 11:49 am
Can you post your xorg.con file?
Here it is, note I only have one monitor:

Code: Select all

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 367.18  (buildd@lgw01-52)  Thu May 19 23:33:33 UTC 2016


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"

    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "DELL U2410"
    HorizSync       30.0 - 81.0
    VertRefresh     56.0 - 76.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 970"
    Option         "Coolbits" "12"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-4"
    Option         "metamodes" "nvidia-auto-select +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
greerd,
Thanks for posting your xorg.conf. I was able to create the xorg file by using the Nvidia X server Setting program. I did what you said and did a save. I then went in and set the coolbits to 12. Thanks for your advice.

Post Reply

Return to “Installation & Boot”