Dual-boot, can't boot into safe mode

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
kharrisma
Level 1
Level 1
Posts: 6
Joined: Fri Dec 15, 2017 6:35 pm

Dual-boot, can't boot into safe mode

Post by kharrisma » Tue Feb 20, 2018 4:22 pm

Hi Forum Folk

Wow, the search function here is pretty rudimentary, isn't it? I mean, how do you search for posts discussing Dual-boot systems that won't boot into Windows Safe Mode using just a few words? Maybe it's my lack of imagination, but I couldn't do it. So that's why I'm starting a new topic... couldn't find anything using search (such as it is....)

Dell Inspiron 5755, set up as dual-boot Linux Mint and Windows 10 (for gaming only, I promise!). I'm trying to install an old game (Need for Speed 2), where the actual game should run okay, but the installer is a 16-bit app and won't run in a 64-bit OS. So much for Windows 10 being the most "advanced' version of Windows yet... can't even run a measly old game app.

Anyway, one of the suggestions was to boot Windows into Safe Mode and try installing it that way... if it works, I should be able to play the game in subsequent normal boots.

That's the problem I'm having. I pick "Windows boot manager" from the grub menu, then start hitting F8 as fast as I can... and it just boots straight into Windows. I'm worried that I may trash things if I start hitting F8 before grub comes up... just not sure what to do here. Is Windows Safe Mode no longer accessible now that it's set up to dual-boot?

Thanks for dispelling the confusion!

User avatar
Flemur
Level 15
Level 15
Posts: 5661
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Dual-boot, can't boot into safe mode

Post by Flemur » Tue Feb 20, 2018 5:04 pm

kharrisma wrote:
Tue Feb 20, 2018 4:22 pm
Wow, the search function here is pretty rudimentary, isn't it?
It is.
So try an internet search like this:

Code: Select all

site:forums.linuxmint.com "Windows" "Safe Mode" "grub"
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 18.3 Xfce/fluxbox/pulse-less
Xubuntu 17.10/fluxbox/pulse-less

User avatar
gld59
Level 2
Level 2
Posts: 61
Joined: Thu Nov 30, 2017 11:05 pm
Location: Australia

Re: Dual-boot, can't boot into safe mode

Post by gld59 » Tue Feb 20, 2018 9:09 pm

Safe Mode has been changed in Win10 - you have to do it from within Windows by setting some reboot option. (Makes it real useful for critical hardware issues, eh? :roll: )
I'd be a little surprised if it allows you to run the installer anyway - 64-bit Windows run 32-bit stuff using WoW64 (Windows On Windows), just as 32-bit Windows runs 16 bit stuff using WoW.

Mattyboy
Level 6
Level 6
Posts: 1038
Joined: Thu Mar 26, 2015 2:17 pm

Re: Dual-boot, can't boot into safe mode

Post by Mattyboy » Tue Feb 20, 2018 11:08 pm

From the Windows 10 desktop press and hold shift then click re-start from start menu. The next time Windows 10 boots, regardless of when or what you do in Grub you will have the option to boot into 'safe mode', plus a whole other bunch of options, most of them useless :lol:

I would try to install the program in 'compatibility mode' 'works in earlier versions'.

kharrisma
Level 1
Level 1
Posts: 6
Joined: Fri Dec 15, 2017 6:35 pm

Re: Dual-boot, can't boot into safe mode

Post by kharrisma » Wed Feb 21, 2018 3:34 pm

Thanks for the replies,

So if I hit F8 (advanced boot options) right at the Dell splash screen, I'll be able to boot into Windows safe mode? Effectively bypassing grub altogether? Good, if I understand that correctly.

Tried the compatibility mode change... no good. Still "won't run on this PC."

Actually hadn't heard of WoW64... I knew there were 'virtual machines' out there, just never had to use one before. I'll give it a whirl!

User avatar
gld59
Level 2
Level 2
Posts: 61
Joined: Thu Nov 30, 2017 11:05 pm
Location: Australia

Re: Dual-boot, can't boot into safe mode

Post by gld59 » Wed Feb 21, 2018 10:21 pm

No, forget everything you ever learned with earlier versions about how to start in safe mode. You can't get into it that way. It can only be done by telling Windows on exit that when it restarts it should allow you the option to choose safe mode. The actual procedure is as in Mattyboy's first sentence. (The second sentence just points out that it doesn't matter whether you restart back into Windows immediately, or go and do other things in Linux and then back to Windows - the safe mode has been enabled for the next time you restart Windows.)

WoW64 (for running 32-bit programs) isn't something you download and choose to use. It's part of 64-bit Windows, just as the original WoW (for running 16-bit programs) is part of 32-bit Windows. In both cases, they simply allow the OS to run the huge legacy of programs written for the previous architecture. I suspect you'll need some other compatibility layer or VM, or 32-bit Windows.

kharrisma
Level 1
Level 1
Posts: 6
Joined: Fri Dec 15, 2017 6:35 pm

Re: Dual-boot, can't boot into safe mode

Post by kharrisma » Thu Feb 22, 2018 3:44 pm

I just love the way Microsoft just arbitrarily changes things like that... leaves me floundering every time I have to "upgrade" trying to find out how things are done now... not like it comes with a manual or changelog or anything (or maybe it does, but I haven't found that yet either....)

Anyway, thanks again for setting me straight. I appreciate the time taken.

I'm looking into setting up a VM now... it's looking like the simplest option.

Post Reply

Return to “Installation & Boot”