Reboot after hibernation

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
havon
Level 1
Level 1
Posts: 13
Joined: Sun Jul 31, 2016 6:11 am

Reboot after hibernation

Post by havon » Thu Mar 01, 2018 3:24 am

My laptop reboots while waking up after hibernation. I click Menu -> Quit -> Hibernate. It hibernates properly. Later I press on/off button and the computer seems to wake up, it shows Linux Mint logo, but in 3-5 sec the screen gets black, the laptop reboots, and GRUB shows different boot parameters like after reset.

I've tried to:
  • boot with kernel parameter acpi_sleep=nonvs
  • save "10" to /proc/sys/vm/swappiness file
  • use proprietary NVidia driver
  • use kernel 4.13.0
I also tried to use kernel 4.4.0 but the computer didn't boot up.

Code: Select all

~ $ inxi -Fxz
System:    Host: book Kernel: 4.10.0-38-generic i686 (32 bit gcc: 5.4.0)
           Desktop: MATE 1.18.0 (Gtk 3.18.9-1ubuntu3.3) Distro: Linux Mint 18.3 Sylvia
Machine:   System: Acer product: Aspire 6935 v: V1.04
           Mobo: Acer model: Aspire 6935 v: PSMBOU-1234567 Bios: Acer v: V1.04 date: 07/25/2008
CPU:       Dual core Intel Core2 Duo P7350 (-MCP-) cache: 3072 KB
           flags: (lm nx pae sse sse2 sse3 sse4_1 ssse3) bmips: 7979
           clock speeds: max: 2000 MHz 1: 1600 MHz 2: 800 MHz
Graphics:  Card: NVIDIA G96M [GeForce 9600M GT] bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 drivers: nouveau (unloaded: fbdev,vesa)
           Resolution: 1920x1080@60.00hz
           GLX Renderer: NV96 GLX Version: 3.0 Mesa 17.2.8 Direct Rendering: Yes
Audio:     Card Intel 82801I (ICH9 Family) HD Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.10.0-38-generic
Network:   Card-1: Qualcomm Atheros AR8121/AR8113/AR8114 Gigabit or Fast Ethernet
           driver: ATL1E port: 4000 bus-ID: 02:00.0
           IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter>
           Card-2: Intel WiFi Link 5100 driver: iwlwifi bus-ID: 05:00.0
           IF: wlp5s0 state: down mac: <filter>
Drives:    HDD Total Size: 120.0GB (59.2% used) ID-1: /dev/sda model: KINGSTON_SA400S3 size: 120.0GB
Partition: ID-1: / size: 19G used: 9.1G (52%) fs: ext4 dev: /dev/sda1
           ID-2: /home size: 88G used: 54G (65%) fs: ext4 dev: /dev/sda3
           ID-3: swap-1 size: 4.29GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 41.0C mobo: 35.0C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 175 Uptime: 2:37 Memory: 1714.9/4038.1MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35

fabien85
Level 6
Level 6
Posts: 1343
Joined: Tue Mar 11, 2014 4:30 pm

Re: Reboot after hibernation

Post by fabien85 » Thu Mar 01, 2018 5:51 am

Can you show the boot options you pass currently pass to the kernel :

Code: Select all

cat /proc/cmdline
?

Personally to get hibernation to work, I have to pass the option resume=UUID=swap-uuid where 'swap-uuid' is the UUID of the swap partition, which you can find with blkid. That said, hibernate doesnt work for me with the latest kernels these days. And it's often not compatible with nvidia drivers or other things so that people recommend to turn it off, see e.g. https://sites.google.com/site/easylinux ... d-to-disk- by forum member Pjotr.

havon
Level 1
Level 1
Posts: 13
Joined: Sun Jul 31, 2016 6:11 am

Re: Reboot after hibernation

Post by havon » Thu Mar 01, 2018 3:00 pm

Code: Select all

~ $ cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-4.10.0-38-generic root=UUID=df3ddb2c-0ea1-483f-a6fb-ae72ff9fdb30 ro quiet splash vt.handoff=7
I used Linux Mint 17 on this machine and hibernation worked properly then.

Mute Ant
Level 13
Level 13
Posts: 4918
Joined: Tue Sep 03, 2013 7:45 pm

Re: Reboot after hibernation

Post by Mute Ant » Thu Mar 01, 2018 4:47 pm

"I used Linux Mint 17 on this machine and hibernation worked properly then." Mint 18 made the switch to systemd and it is different, yes. You have to tell the boot process which volume holds the system-resume image.
Data stored in an encrypted volume will only be accessible with the original password. Without this key, all the data will remain scrambled beyond hope of recovery.

havon
Level 1
Level 1
Posts: 13
Joined: Sun Jul 31, 2016 6:11 am

Re: Reboot after hibernation

Post by havon » Fri Mar 02, 2018 5:08 am

Code: Select all

$ sudo blkid /dev/sda5
/dev/sda5: UUID="aaceeb81-4651-470b-8e73-9f7d58fc0bc8" TYPE="swap" PARTUUID="cf7dadf5-05"
I replaced GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" line in /etc/default/grub file with this one GRUB_CMDLINE_LINUX_DEFAULT="quiet splash resume=UUID=aaceeb81-4651-470b-8e73-9f7d58fc0bc8" then

Code: Select all

$ sudo update-grub
and rebooted.
And unfortunately it didn't help. Behaviour is the same, except for Resuming from /dev/disk/by-uuid/aaceeb81-4651-470b-8e73-9f7d58fc0bc8/ label under Linux Mint logo while trying to wake up.

Code: Select all

$ cat /etc/default/grub
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash resume=UUID=aaceeb81-4651-470b-8e73-9f7d58fc0bc8"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
$ cat /proc/cmdline 
BOOT_IMAGE=/boot/vmlinuz-4.10.0-38-generic root=UUID=df3ddb2c-0ea1-483f-a6fb-ae72ff9fdb30 ro quiet splash resume=UUID=aaceeb81-4651-470b-8e73-9f7d58fc0bc8

User avatar
Pjotr
Level 20
Level 20
Posts: 10780
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Reboot after hibernation

Post by Pjotr » Fri Mar 02, 2018 6:04 am

Try if it helps when you roll back your kernel to the latest kernel of the 4.4 series (currently 4.4.0-116).
Update Manager - panel: View - Linux kernels

After installing it, reboot and make sure you boot from it (it's under the header Advanced in the Grub bootloader menu). If it works well: remove every installed kernel from all higher series.
Tip: 10 things to do after installing Linux Mint 19 Tara
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

Mute Ant
Level 13
Level 13
Posts: 4918
Joined: Tue Sep 03, 2013 7:45 pm

Re: Reboot after hibernation

Post by Mute Ant » Fri Mar 02, 2018 7:40 am

"...and rebooted..." Using the hibernation volume as swap will trash any hibernated state. Try a full cycle of 'hibernate' to write a new state then 'boot' to use it.
Data stored in an encrypted volume will only be accessible with the original password. Without this key, all the data will remain scrambled beyond hope of recovery.

havon
Level 1
Level 1
Posts: 13
Joined: Sun Jul 31, 2016 6:11 am

Re: Reboot after hibernation

Post by havon » Fri Mar 02, 2018 10:32 am

Pjotr wrote:
Fri Mar 02, 2018 6:04 am
Try if it helps when you roll back your kernel to the latest kernel of the 4.4 series (currently 4.4.0-116).
havon wrote:
Thu Mar 01, 2018 3:24 am
I also tried to use kernel 4.4.0 but the computer didn't boot up.

havon
Level 1
Level 1
Posts: 13
Joined: Sun Jul 31, 2016 6:11 am

Re: Reboot after hibernation

Post by havon » Fri Mar 02, 2018 10:48 am

Mute Ant wrote:
Fri Mar 02, 2018 7:40 am
"...and rebooted..." Using the hibernation volume as swap will trash any hibernated state. Try a full cycle of 'hibernate' to write a new state then 'boot' to use it.
I don't understand what exactly do you mean. Could you explain me step by step what I have to do? Should I use another partition for hibernation, other than swap? Of course I had to reboot in order to apply new kernel parameters, but then I did these steps again
havon wrote:
Thu Mar 01, 2018 3:24 am
I click Menu -> Quit -> Hibernate. It hibernates properly. Later I press on/off button and the computer seems to wake up, it shows Linux Mint logo, but in 3-5 sec the screen gets black, the laptop reboots, and GRUB shows different boot parameters like after reset.
And ...
havon wrote:
Fri Mar 02, 2018 5:08 am
Behaviour is the same, except for Resuming from /dev/disk/by-uuid/aaceeb81-4651-470b-8e73-9f7d58fc0bc8/ label under Linux Mint logo while trying to wake up.

havon
Level 1
Level 1
Posts: 13
Joined: Sun Jul 31, 2016 6:11 am

Re: Reboot after hibernation

Post by havon » Mon Mar 05, 2018 5:19 am

Pjotr wrote:
Fri Mar 02, 2018 6:04 am
Try if it helps when you roll back your kernel to the latest kernel of the 4.4 series (currently 4.4.0-116).
Update Manager - panel: View - Linux kernels

After installing it, reboot and make sure you boot from it (it's under the header Advanced in the Grub bootloader menu). If it works well: remove every installed kernel from all higher series.
havon wrote:
Thu Mar 01, 2018 3:24 am
the computer didn't boot up.
Sorry, I was wrong, I managed to boot with kernel 4.4.0-116 and hibernation works fine with it, but my second HDMI monitor doesn't work with this kernel, it just shows black screen. It's presented in the menu and I can set some it's options and even move some windows to external monitor, but it doesn't show them. Kernel 4.8.0 has the same behaviour as 4.10.0.

havon
Level 1
Level 1
Posts: 13
Joined: Sun Jul 31, 2016 6:11 am

Re: Reboot after hibernation

Post by havon » Wed Mar 07, 2018 4:37 am

However the same monitor connected via VGA does work.

Is this problem with hibernation a kernel bug?

User avatar
Pjotr
Level 20
Level 20
Posts: 10780
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Reboot after hibernation

Post by Pjotr » Wed Mar 07, 2018 5:13 am

havon wrote:
Wed Mar 07, 2018 4:37 am
Is this problem with hibernation a kernel bug?
Probably, yes...
Tip: 10 things to do after installing Linux Mint 19 Tara
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

Post Reply

Return to “Installation & Boot”