Asus VivoBook E403NA

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
User avatar
Level 2
Level 2
Posts: 50
Joined: Thu Feb 22, 2018 6:29 pm
Location: Sweden

Asus VivoBook E403NA

Post by premier69 » Sun Mar 04, 2018 9:07 am

A mess of a computer...

Hello all :)

So, I don't know how to explain this very clearly but the computer I have says in the BIOS that there is no SATA drive installed. I figured out it has eMMC
I will not detect any USB stick I plug in, so I can't chose boot device other then "ubuntu" which I somehow managed to install, no idea how. I can boot Linux Mint.

Here is the funny thing, it will show a boot option when I plug in my android phone which has Drivedroid installed, Drivedroid functions as an emulator of a usb stick and I have several ISO images on for it. I can connect the phone, mount let's say the Ubuntu ISO and boot it on the laptop.

I cannot however start the windows installer successfully, during the booting of the install it gives some driver error. This laptop was shipped with windows 10 but when I bought the computer, used, windows was broken and I didn't manage to use any recovery process. This is why I started with Linux Mint.

I will show you a series of pictures I took of the BIOS and maybe you can help me explain what the hell is going on because I have never seen a BIOS like this during the 20 years I've been tinkering with PC's. ... 145231.png
You're a load in my pants Al - Officer Dan

User avatar
Lord Boltar
Level 4
Level 4
Posts: 386
Joined: Mon Jan 09, 2017 7:24 pm

Re: Asus VivoBook E403NA

Post by Lord Boltar » Wed Mar 07, 2018 7:42 pm

In order for the system to recognized the installed OS, you must ensure the system is using UEFI boot mode as well as enabling Firmware TPM BEFORE installation. Secure boot MUST be off for installation and after installation. Legacy Option ROM should be disabled. After install, the system will recognize the OS and boot properly after the TPM check which will only occur at the very first bootup

disable secure boot
disable fastboot
disable legacy boot

keep UEFI

now install F12 then select your USB
IF your problem has been solved, please edit your original post and add [SOLVED] to the beginning of the Subject Line. It helps other members

The only way for evil to prosper is for good men to do nothing

User avatar
michael louwe
Level 9
Level 9
Posts: 2993
Joined: Sun Sep 11, 2016 11:18 pm

Re: Asus VivoBook E403NA

Post by michael louwe » Thu Mar 08, 2018 3:57 am

@ premier69, .......
premier69 wrote:.
AFAIK, basically, because of UEFI's Secure Boot feature, only M$-certified or signed or approved EFI bootloader files can be loaded into the UEFI-BIOS firmware and then be allowed to boot.
....... LM is based on Ubuntu. The Live LM USB has the signed EFI-Grub bootloader file, eg grubx64.efi, shimx64.efi(Secure Boot enabled), elilo.efi, etc = can be booted and installed on UEFI computers.
....... Win 10 could not be booted on your computer likely because the EFI-bootmanager file is missing or has been deleted from the UEFI-BIOS firmware. So, to boot Win 10, you need to enter this signed Windows Boot Manager file, ie bootx64.efi , eg by just booting a Win 10 Recovery or Install USB/DVD, then unboot - check whether there is a Boot entry for Windows Boot Manager in UEFI-BIOS setup.

About UEFI and bootloaders, please refer to ... ... work-then/ ... and-linux/ ... ew-machine (One possible workaround to this problem is to copy GRUB from EFI/ubuntu/grubx64.efi to EFI/BOOT/bootx64.efi = create a new folder, BOOT, in the EFI folder and rename grubx64.efi to bootx64.efi. Restart.) ... gr-4028027 ... r-examples

Post Reply

Return to “Installation & Boot”